[jitsi-dev] [jitsi-videobridge] Jigasi media error with latest videobridge builds (#124)


#1

I was struggeling the last few days with the following error in jigasi:

Jan 21 10:47:41 bl17-15internaluzgentbe jigasish[22134]: 2016-01-21 10:47:41735 INFO: [109] orgjitsijigasiGatewaySessionhandleCallState()628 SIP call format used: rtpmap:0 PCMU/8000
Jan 21 10:47:41 bl17-15internaluzgentbe jigasish[22134]: 2016-01-21 10:47:41735 INFO: [109] orgjitsijigasiGatewaySessionpeerStateChanged()692 15263950d86@callcontrolbl17-15uzgentbe SIP peer state: Connected
Jan 21 10:47:41 bl17-15internaluzgentbe jigasish[22134]: 2016-01-21 10:47:41736 INFO: [109] serviceprotocolmediaCallPeerMediaHandlerstart()1932 Starting
Jan 21 10:47:42 bl17-15internaluzgentbe jigasish[22134]: 2016-01-21 10:47:42245 SEVERE: [148] netsffmjmediaLogerror() Unable to handle format: LINEAR, 480000 Hz, 16-bit, Mono, LittleEndian, Signed

It seems that this occurs in the latest builds of videobridge (621, 620, ) The latest compatible version is build 618 Anyone who has the same problem?

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124


#2

What is the error that you face, what is not working? Last time I was using jigasi I have seen this error and the calls were successful. The thing was that for some reason DTLS is not working for jigasi. You need to make sure jvb is not dropping non-dtls packets. There is a property for that: org.jitsi.impl.neomedia.transform.dtls.DtlsPacketTransformer.dropUnencryptedPkts=false

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173582917


#3

The error is the one in the post above, jigasi successfully makes the call but no audio is received at all. The property you suggested unfortunately doesn't fix that.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173587841


#4

You put the property in video bridge and restarted it?

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173609665


#5

Yes, I tried adding it to logging.properties (since there was already a org.jitsi.impl.neomedia entry there) and restarted the videobridge but the problem remains.

I see a lot of these warnings:
jvb.sh[10863]: 2016-01-21 20:28:37.593 WARNING: [86] org.jitsi.impl.neomedia.rtp.translator.OutputDataStreamImpl.warn() Will not translate RTP packet.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173682976


#6

You need to add it to sip-communicator.properties for videobridge and
restart it.

···

On Thu, Jan 21, 2016 at 1:29 PM, Dries De Gendt <notifications@github.com> wrote:

Yes, I tried adding it to logging.properties (since there was already a
org.jitsi.impl.neomedia entry there) and restarted the videobridge but the
problem remains.

I see a lot of these warnings:
jvb.sh[10863]: 2016-01-21 20:28:37.593 WARNING: [86]
org.jitsi.impl.neomedia.rtp.translator.OutputDataStreamImpl.warn() Will not
translate RTP packet.


Reply to this email directly or view it on GitHub
<https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173682976>
.

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173686054


#7

I believe I don't have a sip-communicator.properties in the videobridge directory? I took one of the builds listed at https://download.jitsi.org/jitsi-videobridge/linux/.

I only have such a file for jigasi...

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173687269


#8

Well if you install it from package the the file is in /etc/jitsi/videobridge/sip-communicator.properties. From the archive folder, I think it uses the home to be the folder where it is extracted. So you need to create .sip-communicator folder and place the file there. Information about that should be written in the beginning of the logs or console output.
For installed from deb package it is:
net.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi
net.java.sip.communicator.SC_HOME_DIR_NAME=videobridge
Which forms /etc/jitsi/videobridge/sip-communicator.properties.
You need to make sure jvb founds your config file.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173691361


#9

Thanks, found the file. I've added the parameter and did a restart, videobridge enabled it:
jvb.sh[15182]: 2016-01-21 21:04:43.832 INFO: [1] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() org.jitsi.impl.neomedia.transform.dtls.DtlsPacketTransformer.dropUnencryptedPkts=false

However, the warnings still appear and jigasi doesn't produce any audio. It throws the same errors as in my first post. Is it possible that it tries to use opus (haven't installed it on the server, nor on the SIP server). When I used a previous version like 618, it immediately works again.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173694211


#10

I don't see any change after 618 that can break it, it must use opus. But there is nothing extra to install. I remembered a problem I faced, I didn't make it working with asterisk and jigasi on one machine, if that is the case try moving asterisk on different machine. I didn't had time to investigate the problem. But this doesn't explain how it is working with 618.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173697958


#11

Indeed, very weird since the only thing I do is replacing the original videobridge directory (618 build) with the 621 build and restarting the videobridge.

The Asterisk runs on a different server so that shouldn't be the cause of it. For now I'll stick with build 618 and try again in a few weeks. Thanks for the effort though!

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-173699331


#12

Hi, any news here? I have not working jigasi too https://github.com/jitsi/jigasi/issues/26 . But I am not sure if 618 version will work for me. Can you give me deb or link for your videobridge please?

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-190192803


#13

For now I'm still stuck at 618 (haven't tried anything else since). It seems that the older builds are no longer available for download using the link above. You can still grab build 618 over here: http://raspi.degendt.com/jitsi-videobridge-linux-x64-618.zip
(Please send a reply when you've got the file)

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-190196417


#14

Got it. thx! I will check it later

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-190212932


#15

Checked. Unfortunately, there is also problem with new jicofo too. For example: if I use videobridge 618 , jicofo 1.0-68-1, jigasi 1.0-99 then all work as expected; If I use videobridge 618 , jicofo 1.0-211-1, jigasi 1.0-99 then sip calls not work. Too bad that new jitsi-meet is not compatible with old jicofo. So now I have to choose between Firefox support and SIP calls

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-191257154


#16

I'm experiencing the same issue. No audio on incoming/outgoing calls between Asterisk and Jigasi/Jitsi-Videobridge when using Jitsi-Videobridge version 659. When I revert back to 513, with no configuration changes, it starts working again immediately.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-191964204


#17

Hi driesken,

I'm facing same issue, could you please upload videobridge 618 again.
I want to try it maybe it will solve mine.

BR

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-193166750


#18

@hisham1402
I've uploaded the file again.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-193178825


#19

Got it, Thanks a lot.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-193188205


#20

OK I tired it and the audio start working, unfortunately the video not working.

I got this message:

jvb,log:
2016-03-07 13:40:24.045 WARNING: [286] org.ice4j.stack.Connector.run() Connector died: x.x.x.x:10002/udp -> null
java.net.SocketException: Socket closed

and this error keep repeating
java.util.prefs.checkLockFile0ErrorCode() Could not lock User prefs. Unix error code 2.

jigasi.log:
"No ICE media stream for media: video - ignored candidates"

Thanks a lot

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/124#issuecomment-193202908