[jitsi-dev] Jitsi videobridge Docker image


#1

Hi Nicholas,

I don't try to solve the port mapping issue on jisti videobridge since I had wasted too much time during the opencmu dockerization with
the same issue for no solution.

To avoid the docker issue with large range port publishing, it could consist to reduce the port number to publish ( but I've never tried with jitsi videobridge ).

So to match with my use cases, I'm resigned to use the host mode in all my docker images for media servers involving rtp (openmcu and jitsi videobridge for instance).

Maybe things will be different in future docker releases.

Cheers,
Franck

Hi Franck,

how did you solve the port mapping? We are currently having issues getting a connection from a Jitsi Meet client to the

videobridge. I can’t/don’t want to use the host mode. What ports did you expose? Thanks!

···

Best

Nicholas


#2

Hello guys,

Hi Nicholas,

I don't try to solve the port mapping issue on jisti videobridge since I
had wasted too much time during the opencmu dockerization with
the same issue for no solution.

To avoid the docker issue with large range port publishing, it could
consist to reduce the port number to publish ( but I've never tried with
jitsi videobridge ).

Just a note that we now support a mode with UDP on a single port. To enable it set:
org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT=12345

The drawback is that it doesn't work with jigasi and jirecon (it requires bundle and rtcp-mux, which we haven't yet implemented there).

Regards,
Boris

···

On 25/05/15 08:54, Franck Rupin wrote:


#3

*Boris Grozev*boris at jitsi.org<mailto:dev%40jitsi.org?Subject=Re%3A%20[jitsi-dev]%20Jitsi%20videobridge%20Docker%20image&In-Reply-To=<5562F97C.3070508%40jitsi.org>>
/Mon May 25 12:29:16 CEST 2015/

···

------------------------------------------------------------------------

Hello guys,

On 25/05/15 08:54, Franck Rupin wrote:

/ Hi Nicholas,

/>>/
/>>/ I don't try to solve the port mapping issue on jisti videobridge since I
/>>/ had wasted too much time during the opencmu dockerization with
/>>/ the same issue for no solution.
/>>/
/>>/ To avoid the docker issue with large range port publishing, it could
/>>/ consist to reduce the port number to publish ( but I've never tried with
/>>/ jitsi videobridge ).
/>

Just a note that we now support a mode with UDP on a single port. To
enable it set:
org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT=12345

The drawback is that it doesn't work with jigasi and jirecon (it
requires bundle and rtcp-mux, which we haven't yet implemented there).

Regards,
Boris

Hey Boris,

That's very interesting, I will try this option to validate if it's now
possible to run the docker image with publish option.

regards,
Franck