[jitsi-dev] [jitsi-videobridge] Default simulcast target order can be set with receive-simulcast-layer (#179)


#1

You can view, comment on, or merge this pull request online at:

  https://github.com/jitsi/jitsi-videobridge/pull/179

-- Commit Summary --

  * Default simulcast target order can be set with receive-simulcast-layer
  * Update doc with receive-simulcast-layer

-- File Changes --

    M doc/simulcast.md (6)
    M src/main/java/org/jitsi/videobridge/Content.java (6)
    M src/main/java/org/jitsi/videobridge/VideoChannel.java (30)
    M src/main/java/org/jitsi/videobridge/Videobridge.java (3)
    M src/main/java/org/jitsi/videobridge/health/Health.java (1)
    M src/main/java/org/jitsi/videobridge/simulcast/SimulcastSender.java (15)
    M src/main/java/org/jitsi/videobridge/simulcast/SimulcastSenderManager.java (10)

-- Patch Links --

https://github.com/jitsi/jitsi-videobridge/pull/179.patch
https://github.com/jitsi/jitsi-videobridge/pull/179.diff

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179


#2

Hi, thanks for your contribution!
If you haven't already done so, could you please make sure you sign our CLA (https://jitsi.org/icla for individuals and https://jitsi.org/ccla for corporations)? We would unfortunately be unable to merge your patch unless we have that piece :(.

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179#issuecomment-199296466


#3

@@ -255,7 +255,8 @@ void askForKeyframes(Collection<Endpoint> endpoints)
     public RtpChannel createRtpChannel(String channelBundleId,
                                        String transportNamespace,
                                        Boolean initiator,
- RTPLevelRelayType rtpLevelRelayType)
+ RTPLevelRelayType rtpLevelRelayType,
+ Integer receiveSimulcastLayer)

Hi @lluczo, thank you very much for this! :+1:

One minor note, I would like to avoid modifying the create `createRtpChannel` method. Could you please create a setter for the `receiveSimulcastLayer` parameter in the `VideoChannel` and use that in Videobridge.java?\

Thank you very much :slight_smile:

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179/files/08ed32b9cee94e7fa62b6a7ef3ed22e1f4c19d1f#r57009350


#4

Also, please ignore the CLA message, i's an automated message.. We're still fine tuning this.. :slight_smile: We have a CLA for you.

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179#issuecomment-199872777


#5

Jenkins: add to whitelist

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179#issuecomment-199873349


#6

thank you @damencho :slight_smile:

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179#issuecomment-199875255


#7

@@ -743,6 +743,13 @@ else if (authorizedSourcePattern != null
                                         transportNamespace,
                                         channelIQ.isInitiator(),
                                         channelIQ.getRTPLevelRelayType());
+
+ if (channel instanceof VideoChannel)
+ {
+ VideoChannel videoChannel = (VideoChannel)channel;
+ videoChannel.setReceiveSimulcastLayer(channelIQ.getReceivingSimulcastLayer());

Awesome, thank you @lluczo! Yet another (very) minor thing, could you please make sure this line doesn't exceed 80 chars? Thank you very much!

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179/files/fd346e82871ca3e06df5ef8632e9879099cba467#r57027354


#8

There was a problem with the script that do the merges before testing, it is fixed now. Jenkins: it's ok to test.

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179#issuecomment-199939872


#9

Jenkins: it's ok to test.

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179#issuecomment-199978155


#10

Sorry for the noise, but Jenkins: it's ok to test.

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179#issuecomment-200004987


#11

Merged #179.

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179#event-599352521


#12

Thank you @lluczo for your contribution!

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/179#issuecomment-200017490