[jitsi-dev] [jitsi-videobridge] ComponentException : Not authorized (#41)


#1

I'm trying to run jitsi videobridge 361 in Ubuntu 12.04, configured ejabberd 14.07 in port 5275, the next error is shown :
```
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
09:45:28.646 GRAVE: [1] util.UtilActivator.uncaughtException().108 An uncaught exception occurred in thread=Thread[main,5,main] and message was: not-authorized
org.xmpp.component.ComponentException: not-authorized
  at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)
  at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
  at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
  at org.jitsi.videobridge.Main.main(Main.java:273)
´´´
Thank you in advance and good work

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/41


#2

This can typically happen if the password the bridge is using to connect to the XMPP server isn't the one the XMPP is expecting. If you haven't done so, can you please double check that?

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/41#issuecomment-65377065


#3

Thank you for your quick response , in my ejabberd.yml and in the command i use the same pass:

    port: 5275
    module: ejabberd_service
    host: "jitsi-videobridge.[EJABBERDDOMAIN]"
    password:
        -"XXXX"

then i run :

./jvb.sh --host=localhost --domain=[EJABBERDDOMAIN] --port=5275 --secret=XXXX
···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/41#issuecomment-65381374


#4

gpolitis it was a problem of my yml translation of thew documentation to connect jitsi videobridge with ejabberd , the correct way to add the service to ejabberd is :

    port: 5275
    module: ejabberd_service
    hosts:
      "jitsi-videobridge.[EJABBERDDOMAIN]":
        password: "YOURSECRET"

IMHO, add this to the documentation could help ohter people!
thank you again,

LTJ

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/41#issuecomment-65388170


#5

Closed #41.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/41#event-201860584


#6

Cool, I'm glad you solved your problem and I agree that this is something useful to have in the documentation. Please feel free to submit a pull request for that.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/41#issuecomment-65390379


#7

Thanks, LTJ. Just added a note to the doc, hopefully I got the syntax right.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/41#issuecomment-65390587


#8

I used the same configuration still getting error.. hmm:

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/41#issuecomment-84009961


#9

please help me:
:11:30.350 SEVERE: [1] util.UtilActivator.uncaughtException().108 An uncaught exception occurred in thread=Thread[main,5,main] and message was: not-authorized
org.xmpp.component.ComponentException: not-authorized
        at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)
        at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
        at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
        at org.jitsi.videobridge.Main.main(Main.java:273)

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/issues/41#issuecomment-84010296