[jitsi-dev] Jitsi unstable repos not working right in Debian


#1

Hello,
Lately the plain http debian/unstable repos dont seem to work. The error message:

W: Failed to fetch http://download.jitsi.org/deb/unstable/Packages: Undetermined Error [IP: 130.79.200.22 80]

Now i did replace them with https in the sources.list+installed the https transport package and it seems to work ok, but the problem is that with every upgrade Jitsi places the /etc/apt/sources.list.d/jitsi.list file that contains the link to the http repo. This means long waits when updating because of Jitsi's repos that dont seem to work and you have to wait until they time out.

Now a solution would be either: - adjusting the jitsi list (this means that users will be forced to install apt's https transport package, probably most will say something is broken in Jitsi)
            - fixing the http repos.

···

--
O zi buna,
Kertesz Laszlo


#2

I too am mixed... Love the responsiveness! Hate the broken updates...

Now a solution would be either: - adjusting the jitsi list (this means
that users will be forced to install apt's https transport package,
probably most will say something is broken in Jitsi)
- fixing the http repos.

My I sugest a page based redirect to https as opposed to a global one. That way for the repos, you can choose https if you want to and know how, but can use http if you are a non-tech user...

As to changing the source to https and forcing install of the apt https transport, what does this do to apt cacher, and other centralized apt repos. (So my office only downloads it once...)

      Lee

···

On 05/23/2012 10:12 AM, Kertesz Laszlo wrote:


#3

Got a cousin, B Flat... :wink:

      Lee

···

On 05/23/2012 11:02 AM, Buddy Butterfly wrote:

Hi Lee,

are you the brother of C Sharp?


#4

Hi Lee,

are you the brother of C Sharp?

P.S.: Just a joke, sry :slight_smile:

Best regards,
Matt

···

Am 23.05.2012 17:52, schrieb Lee Sharp:

I too am mixed... Love the responsiveness! Hate the broken updates...

On 05/23/2012 10:12 AM, Kertesz Laszlo wrote:

Now a solution would be either: - adjusting the jitsi list (this means
that users will be forced to install apt's https transport package,
probably most will say something is broken in Jitsi)
- fixing the http repos.

My I sugest a page based redirect to https as opposed to a global one.
That way for the repos, you can choose https if you want to and know
how, but can use http if you are a non-tech user...

As to changing the source to https and forcing install of the apt
https transport, what does this do to apt cacher, and other
centralized apt repos. (So my office only downloads it once...)

            Lee


#5

Hey folks,

This was discussed in on the users list in this message and thread:

http://goo.gl/6r5Fv

Here's a quote:

"Just wanted to let you know that we've temporarily disabled the https
forwarding so download.jitsi.org is now accessible in both http and
https. This should resolve the apt issues until we find a more permanent
solution."

Cheers,
Emil

···

On 23.05.12 17:12, Kertesz Laszlo wrote:

Hello,
Lately the plain http debian/unstable repos dont seem to work. The error
message:

W: Failed to fetch http://download.jitsi.org/deb/unstable/Packages:
Undetermined Error [IP: 130.79.200.22 80]

Now i did replace them with https in the sources.list+installed the
https transport package and it seems to work ok, but the problem is that
with every upgrade Jitsi places the /etc/apt/sources.list.d/jitsi.list
file that contains the link to the http repo. This means long waits when
updating because of Jitsi's repos that dont seem to work and you have to
wait until they time out.

Now a solution would be either: - adjusting the jitsi list (this means
that users will be forced to install apt's https transport package,
probably most will say something is broken in Jitsi)
            - fixing the http repos.
        
--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31