[jitsi-dev] Jitsi still receives calls when in DND status


#1

I have been testing Jitsi with an Asterisk system and have found that when
the SIP account is set to a status of DND I still receive calls to Jitsi
and get the incoming call screen. In looking at how others handle DND it
appears that there are a few ways it is handled, one of them is by replying
with a 486 Busy Here message. I did a packet capture and Jitsi sends the
486 message if you click the decline button on the incoming call screen. My
question is, would it be difficult to have that message sent automatically
if the status is set to DND?

Nate


#2

Hi Nate,

to enable this you must add a property to your configuration file:
net.java.sip.communicator.impl.protocol.RejectIncomingCallsWhenDnD=true
Currently there is no setting in the UI to set it.

Hope this helps
damencho

ยทยทยท

On Tue, Jun 11, 2013 at 9:31 PM, Nate Renbarger <nate.renbarger@gmail.com>wrote:

I have been testing Jitsi with an Asterisk system and have found that when
the SIP account is set to a status of DND I still receive calls to Jitsi
and get the incoming call screen. In looking at how others handle DND it
appears that there are a few ways it is handled, one of them is by replying
with a 486 Busy Here message. I did a packet capture and Jitsi sends the
486 message if you click the decline button on the incoming call screen. My
question is, would it be difficult to have that message sent automatically
if the status is set to DND?

Nate

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev