[jitsi-dev] Jitsi provisioning


#1

Hi,

I am building a jitsi provisioning app and I noticed that some of the
settings are not provisionable
Example:

org.jitsi.impl.neomedia.codec.video.h264.preset=
org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=
org.jitsi.impl.neomedia.codec.video.h264.keyint=

These are part of the menu: Tools/Options/Advanced/H264

Is this the case, or maybe I have to do something specific

I have this in the .properties file that is served by my app:
org.jitsi.impl.neomedia.codec.video.h264.preset=slow
org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=true
org.jitsi.impl.neomedia.codec.video.h264.keyint=180

However, the changes are not applied at Jitsi client level

Thanks,
Mircea


#2

I am building a jitsi provisioning app and I noticed that some of the
settings are not provisionable
Example:

org.jitsi.impl.neomedia.codec.video.h264.preset=
org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=
org.jitsi.impl.neomedia.codec.video.h264.keyint=

These are part of the menu: Tools/Options/Advanced/H264

Is this the case, or maybe I have to do something specific

I have this in the .properties file that is served by my app:
org.jitsi.impl.neomedia.codec.video.h264.preset=slow
org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=true
org.jitsi.impl.neomedia.codec.video.h264.keyint=180

However, the changes are not applied at Jitsi client level

They're just like any other property. How do you conclude that they didn't get
applied? Are your values not shown in the config page? Do they end up in the
created .properties file?

Thanks,
Mircea

Ingo


#3

Hi,
Thanks for your response.

Yes, they do not end up in the created .properties file... And as a result
they are not shown in the config page

Mircea

Mircea

···

On Oct 5, 2015 20:40, "Ingo Bauersachs" <ingo@jitsi.org> wrote:

> I am building a jitsi provisioning app and I noticed that some of the
> settings are not provisionable
> Example:
>
> org.jitsi.impl.neomedia.codec.video.h264.preset=
> org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=
> org.jitsi.impl.neomedia.codec.video.h264.keyint=
>
> These are part of the menu: Tools/Options/Advanced/H264
>
> Is this the case, or maybe I have to do something specific
>
> I have this in the .properties file that is served by my app:
> org.jitsi.impl.neomedia.codec.video.h264.preset=slow
> org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=true
> org.jitsi.impl.neomedia.codec.video.h264.keyint=180
>
> However, the changes are not applied at Jitsi client level

They're just like any other property. How do you conclude that they didn't
get
applied? Are your values not shown in the config page? Do they end up in
the
created .properties file?

> Thanks,
> Mircea

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Yes, they do not end up in the created .properties file... And as a result
they are not shown in the config page

And other properties actually do make it into the properties file? Are you using the ${null} operator somewhere and overwriting an already sent configuration?

Ingo


#5

Yes, all of the account settings and most of the phone generic
settings(except one or two from general tab) end up in the properties file
just fine and are correctly provisionable. I am using ${null} on top of the
generated .properties file, to erase all of the existing values and put the
new ones...so it works fine for almost all other settings as explained
above.
Thank you,
Mircea

···

On Oct 5, 2015 23:07, "Ingo Bauersachs" <ingo@jitsi.org> wrote:

> Yes, they do not end up in the created .properties file... And as a
result
> they are not shown in the config page

And other properties actually do make it into the properties file? Are you
using the ${null} operator somewhere and overwriting an already sent
configuration?

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

I noticed that only settings that start with: "net.java.sip.communicator"
are provisionable

Having the below set of settings only the first two are provisionable, the
last three won't show up in .jitsi/sip-communicator.properties
If I change the prefix for the last three into net.java.sip.communicator,
all will show up in sip-communicator.properties, but the values for the
last three won't show ui in jitsi UI...because the prefix is wrong.

net.java.sip.communicator.impl.neomedia.codec.video.h264.defaultProfile=baseline
net.java.sip.communicator.impl.neomedia.codec.video.h264.preferredKeyFrameRequester=signaling
org.jitsi.impl.neomedia.codec.video.h264.preset=fast
org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=false
org.jitsi.impl.neomedia.codec.video.h264.keyint=225

I am using jitsi build: 2.8.5426

Mircea

···

On Tue, Oct 6, 2015 at 7:41 AM, Mircea Carasel <mirceac@ezuce.com> wrote:

Yes, all of the account settings and most of the phone generic
settings(except one or two from general tab) end up in the properties file
just fine and are correctly provisionable. I am using ${null} on top of the
generated .properties file, to erase all of the existing values and put the
new ones...so it works fine for almost all other settings as explained
above.
Thank you,
Mircea
On Oct 5, 2015 23:07, "Ingo Bauersachs" <ingo@jitsi.org> wrote:

> Yes, they do not end up in the created .properties file... And as a
result
> they are not shown in the config page

And other properties actually do make it into the properties file? Are
you using the ${null} operator somewhere and overwriting an already sent
configuration?

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

I noticed that only settings that start with:
"net.java.sip.communicator" are provisionable

Having the below set of settings only the first two are provisionable, the
last three won't show up in .jitsi/sip-communicator.properties
If I change the prefix for the last three into net.java.sip.communicator, all
will show up in sip-communicator.properties, but the values for the last
three won't show ui in jitsi UI...because the prefix is wrong.

net.java.sip.communicator.impl.neomedia.codec.video.h264.defaultProfile=b
asel ine
net.java.sip.communicator.impl.neomedia.codec.video.h264.preferredKeyFram
eReq uester=signaling
org.jitsi.impl.neomedia.codec.video.h264.preset=fast
org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=false
org.jitsi.impl.neomedia.codec.video.h264.keyint=225

I am using jitsi build: 2.8.5426

I just tried provisioning the keyint property and it worked just fine. It appeared in the config and the UI as expected. Did you play around with the provisioning.ALLOW_PREFIX property at beginning of your served config?

Mircea

Ingo


#8

Thanks for your response.

Yes, I am playing with ALLOW_PREFIX in the following way:

        builder.append("provisioning.ALLOW_PREFIX=net.java|org.ice4j|
java.net\n");
        builder.append(content);
        builder.append('\n');

        builder.append("provisioning.ENFORCE_PREFIX=net.java|org.ice4j|
java.net\n");

I think I should change ALLOW_PREFIX to use org.jitsi, something like:
provisioning.ALLOW_PREFIX=net.java|org.jitsi|org.ice4j|java.net\n

I will try and let you know
thanks
Mircea

···

On Thu, Oct 22, 2015 at 2:33 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

> I noticed that only settings that start with:
> "net.java.sip.communicator" are provisionable
>
> Having the below set of settings only the first two are provisionable,
the
> last three won't show up in .jitsi/sip-communicator.properties
> If I change the prefix for the last three into
net.java.sip.communicator, all
> will show up in sip-communicator.properties, but the values for the last
> three won't show ui in jitsi UI...because the prefix is wrong.
>
>
> net.java.sip.communicator.impl.neomedia.codec.video.h264.defaultProfile=b
> asel ine
> net.java.sip.communicator.impl.neomedia.codec.video.h264.preferredKeyFram
> eReq uester=signaling
> org.jitsi.impl.neomedia.codec.video.h264.preset=fast
> org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=false
> org.jitsi.impl.neomedia.codec.video.h264.keyint=225
>
> I am using jitsi build: 2.8.5426

I just tried provisioning the keyint property and it worked just fine. It
appeared in the config and the UI as expected. Did you play around with the
provisioning.ALLOW_PREFIX property at beginning of your served config?

> Mircea

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

That was the trick, forgot about ALLOW_PREFIX... works for me now too

Thank you so much for the deads up
Mircea

···

On Thu, Oct 22, 2015 at 3:01 PM, Mircea Carasel <mirceac@ezuce.com> wrote:

Thanks for your response.

Yes, I am playing with ALLOW_PREFIX in the following way:

        builder.append("provisioning.ALLOW_PREFIX=net.java|org.ice4j|
java.net\n");
        builder.append(content);
        builder.append('\n');

        builder.append("provisioning.ENFORCE_PREFIX=net.java|org.ice4j|
java.net\n");

I think I should change ALLOW_PREFIX to use org.jitsi, something like:
provisioning.ALLOW_PREFIX=net.java|org.jitsi|org.ice4j|java.net\n

I will try and let you know
thanks
Mircea

On Thu, Oct 22, 2015 at 2:33 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

> I noticed that only settings that start with:
> "net.java.sip.communicator" are provisionable
>
> Having the below set of settings only the first two are provisionable,
the
> last three won't show up in .jitsi/sip-communicator.properties
> If I change the prefix for the last three into
net.java.sip.communicator, all
> will show up in sip-communicator.properties, but the values for the last
> three won't show ui in jitsi UI...because the prefix is wrong.
>
>
>
net.java.sip.communicator.impl.neomedia.codec.video.h264.defaultProfile=b
> asel ine
>
net.java.sip.communicator.impl.neomedia.codec.video.h264.preferredKeyFram
> eReq uester=signaling
> org.jitsi.impl.neomedia.codec.video.h264.preset=fast
> org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=false
> org.jitsi.impl.neomedia.codec.video.h264.keyint=225
>
> I am using jitsi build: 2.8.5426

I just tried provisioning the keyint property and it worked just fine. It
appeared in the config and the UI as expected. Did you play around with the
provisioning.ALLOW_PREFIX property at beginning of your served config?

> Mircea

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

Hi,

I still found a setting that despite the fact that it gets sent properly,
in the UI it is not shown:

service.gui.SEND_MESSAGE_COMMAND=Ctrl-Enter
or
service.gui.SEND_MESSAGE_COMMAND=Enter

If I manually set it on jitsi client it is replicated in
sip-communicator.properties in the same format

please see the attached screenshot.

Thanks,
Mircea

···

On Thu, Oct 22, 2015 at 3:39 PM, Mircea Carasel <mirceac@ezuce.com> wrote:

That was the trick, forgot about ALLOW_PREFIX... works for me now too

Thank you so much for the deads up
Mircea

On Thu, Oct 22, 2015 at 3:01 PM, Mircea Carasel <mirceac@ezuce.com> wrote:

Thanks for your response.

Yes, I am playing with ALLOW_PREFIX in the following way:

        builder.append("provisioning.ALLOW_PREFIX=net.java|org.ice4j|
java.net\n");
        builder.append(content);
        builder.append('\n');

        builder.append("provisioning.ENFORCE_PREFIX=net.java|org.ice4j|
java.net\n");

I think I should change ALLOW_PREFIX to use org.jitsi, something like:
provisioning.ALLOW_PREFIX=net.java|org.jitsi|org.ice4j|java.net\n

I will try and let you know
thanks
Mircea

On Thu, Oct 22, 2015 at 2:33 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

> I noticed that only settings that start with:
> "net.java.sip.communicator" are provisionable
>
> Having the below set of settings only the first two are provisionable,
the
> last three won't show up in .jitsi/sip-communicator.properties
> If I change the prefix for the last three into
net.java.sip.communicator, all
> will show up in sip-communicator.properties, but the values for the
last
> three won't show ui in jitsi UI...because the prefix is wrong.
>
>
>
net.java.sip.communicator.impl.neomedia.codec.video.h264.defaultProfile=b
> asel ine
>
net.java.sip.communicator.impl.neomedia.codec.video.h264.preferredKeyFram
> eReq uester=signaling
> org.jitsi.impl.neomedia.codec.video.h264.preset=fast
> org.jitsi.impl.neomedia.codec.video.h264.defaultIntraRefresh=false
> org.jitsi.impl.neomedia.codec.video.h264.keyint=225
>
> I am using jitsi build: 2.8.5426

I just tried provisioning the keyint property and it worked just fine.
It appeared in the config and the UI as expected. Did you play around with
the provisioning.ALLOW_PREFIX property at beginning of your served config?

> Mircea

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#11

I still found a setting that despite the fact that it gets sent properly, in
the UI it is not shown:

service.gui.SEND_MESSAGE_COMMAND=Ctrl-Enter
or
service.gui.SEND_MESSAGE_COMMAND=Enter

If I manually set it on jitsi client it is replicated in sip-
communicator.properties in the same format

please see the attached screenshot.

There's a problem with that combobox anyway, it's not related to provisioning. You can enter an issue for that at Github if you want.

Thanks,
Mircea

Ingo