[jitsi-dev] Jitsi over Tor


#1

Hello Jitsi Developer Folks :slight_smile:

I'm having a live event in San Francisco for the Third Annual Aaron Swartz
Day and International Hackathon, at the Internet Archive, on November 7,
2015.

On of my remote guests, Jacob Applebaum, has requested that we use Jitsi
over Tor for his appearance.

I have Jitsi running but am unsure about what the server configuration
settings should be to successfully run over Tor. This would be preferable
as a proof of concept, during the event. (Much of the event will be
featuring Tor.)

Any assistance would be very much appreciated.

Thanks!

lisa

Lisa Rein

http://www.aaronswartzday.org


#2

Hi,

Enabling socks proxy on your tor client and then configure Jitsi
Options -> Advanced -> Global proxy and set 127.0.0.1, port 9050,
restart Jitsi. And it should be working, just give it a little more
time to connect.
This should work.
There is also a setting for proxying DNS, where DNS queries also goes
through tor. Setting there 127.0.0.1 should also work if enabled in
the tor client. If I remember correct this DNS stuff was not working
on windows, but when I tested it this was few years ago.

Regards
damencho

路路路

On Thu, Sep 24, 2015 at 12:33 AM, Lisa Rein <lisa@lisarein.com> wrote:

Hello Jitsi Developer Folks :slight_smile:

I'm having a live event in San Francisco for the Third Annual Aaron Swartz
Day and International Hackathon, at the Internet Archive, on November 7,
2015.

On of my remote guests, Jacob Applebaum, has requested that we use Jitsi
over Tor for his appearance.

I have Jitsi running but am unsure about what the server configuration
settings should be to successfully run over Tor. This would be preferable
as a proof of concept, during the event. (Much of the event will be
featuring Tor.)

Any assistance would be very much appreciated.

Thanks!

lisa

Lisa Rein

http://www.aaronswartzday.org

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi Damencho,

So it looks like there are *two* different techniques to try.

1. Enabling socks proxy on your tor client and then configure Jitsi

Options -> Advanced -> Global proxy and set 127.0.0.1, port 9050,
restart Jitsi. And it should be working, just give it a little more
time to connect.
This should work.

and

2. There is also a setting for proxying DNS, where DNS queries also goes

through tor. Setting there 127.0.0.1 should also work if enabled in
the tor client. If I remember correct this DNS stuff was not working
on windows, but when I tested it this was few years ago.

I will let you know if I have any questions :slight_smile:

thanks so much! Will be testing soon! :slight_smile:

lisa

Regards
damencho

Hello Jitsi Developer Folks :slight_smile:

I'm having a live event in San Francisco for the Third Annual Aaron
Swartz
Day and International Hackathon, at the Internet Archive, on November 7,
2015.

On of my remote guests, Jacob Applebaum, has requested that we use Jitsi
over Tor for his appearance.

I have Jitsi running but am unsure about what the server configuration
settings should be to successfully run over Tor. This would be
preferable
as a proof of concept, during the event. (Much of the event will be
featuring Tor.)

Any assistance would be very much appreciated.

Thanks!

lisa

Lisa Rein

http://www.aaronswartzday.org

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

Lisa Rein

http://www.aaronswartzday.org

路路路

On Thu, Sep 24, 2015 at 12:33 AM, Lisa Rein <lisa@lisarein.com> wrote:


#4

Hi Damencho,
Please let me know if this is really working (e.g. with Mac) or how to
get it to work
... anonymous chatting seem to work fine with these setting using Adium
(Mac) or Pidgin (Linux, Win) but not with Jitsi...

any feedback welcome!

br MS

路路路

On 9/24/15 11:40 PM, Damian Minkov wrote:

Hi,

Enabling socks proxy on your tor client and then configure Jitsi
Options -> Advanced -> Global proxy and set 127.0.0.1, port 9050,
restart Jitsi. And it should be working, just give it a little more
time to connect.
This should work.
There is also a setting for proxying DNS, where DNS queries also goes
through tor. Setting there 127.0.0.1 should also work if enabled in
the tor client. If I remember correct this DNS stuff was not working
on windows, but when I tested it this was few years ago.

Regards
damencho

On Thu, Sep 24, 2015 at 12:33 AM, Lisa Rein <lisa@lisarein.com> wrote:

Hello Jitsi Developer Folks :slight_smile:

I'm having a live event in San Francisco for the Third Annual Aaron Swartz
Day and International Hackathon, at the Internet Archive, on November 7,
2015.

On of my remote guests, Jacob Applebaum, has requested that we use Jitsi
over Tor for his appearance.

I have Jitsi running but am unsure about what the server configuration
settings should be to successfully run over Tor. This would be preferable
as a proof of concept, during the event. (Much of the event will be
featuring Tor.)

Any assistance would be very much appreciated.

Thanks!

lisa

Lisa Rein

http://www.aaronswartzday.org

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev