[jitsi-dev] [jitsi] Offline text messages are not displayed (#95)


#1

ref: http://lists.jitsi.org/pipermail/dev/2013-July/017908.html

···

------------------------------------------------------------------------

server environment:

ejabberd-2.1.5

Debian Linux www 2.6.32-5-amd64 #1 SMP Fri May 10 08:43:19 UTC 2013 x86_64 GNU/Linux running on hp dl380 quad core machine

client environment:

jitsi-2.3.4759
Debian Linux debt 3.2.0-4-686-pae #1 SMP Debian 3.2.46-1 i686 GNU/Linux
Windows 7

------------------------------------------------------------------------

reproduction (copied from jitsi-dev-mailing-list-thread:

A - user jt2 did not yet start jitsi

A.1. user jt1 starts up jitsi, logs in and sends a message to user jt1
(who's jitsi is not yet running) - using ejabberd admin uif, the message is visible

A.2. user jt2 starts up jitsi, logs in
  => no message is displayed and message is removed from ejabberd's storage

B - user jt2's jisti is running but jt2 is offline/online via tools->options

B.1. user jt2 goes offline via tools->options removed the tick at his account

B.2. user jt1 sends offline message which can be viewed using ejabberd admin if

B.2. user jt2 goes online via tools->options adds the tick at his account
  => no message is displayed and message is removed from ejabberd's memory

C - user jt2's jisti is running but jt2 is offline/online via 'status-menuebox'

C.1. user jt2 goes offline by clicking on onlie and selecting offline

C.2. user jt1 sends message

C.3. user jt2 goes online by clicking offline and selecting online
  => message is displayed an removed from ejabberd's memory

in order to enable you to reproduce this issue by yourself, i could provide you with users jt1 and jt2 on our jabber server. please feel free to ask me for the passwords.

(Issue migrated from https://trac.jitsi.org/ticket/1187)

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/95


#2

The problem was fixed, try again.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/95#issuecomment-90095862


#3

Additional info:
- the behavior A and B also applies to the 'initial authorization handshake' which only seems to be possible when both users are online at the same time. (re-requesting authorization does not work as well - at least in our environment).
- neither pidgin nor psi nor gibberbot (on android) shows this behavior - offline messages are always displayed by these clients.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/95#issuecomment-90096165


#4

I have a reasonable suspicion that this issue might be originated at one of our network components (an appliance) and i'm going to verify this next week.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/95#issuecomment-90096239


#5

ew info: no, this issue seems not to be related to our appliance
testcase B:
client jitsi 2.3.4765 on linux (debian 7) - offline messages ar displayed sometimes and sometimes not
client jitsi 2.3.4764 on windows 7 - offline messages were never displayed
ejabberd.log: i cannot see any difference (except date/time and port numbers) between B and C

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/95#issuecomment-90096311


#6

I tend to state that offline messages are always displayed by jitsi runing on a linux machine (debian 7)

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/95#issuecomment-90096386