[jitsi-dev] Jitsi meet won't build any more?


#1

Hi guys,

I am the first to admit that I am an inexperienced front-end developer, so
perhaps this is my own dumb fault, but: I cannot build jitsi-meet any
longer (it used to build just fine)

I'm getting this:

vagrant@vagrant:/vagrant$ npm install
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture:
fsevents@1.1.1
npm WARN eslint-plugin-mocha@2.0.0 requires a peer of eslint@^2.0.0 but
none was installed.
vagrant@vagrant:/vagrant$ make
./node_modules/.bin/webpack -p
/vagrant/webpack.config.js:197
    let path = request.path;
    ^^^

SyntaxError: Block-scoped declarations (let, const, function, class) not
yet supported outside strict mode
    at exports.runInThisContext (vm.js:53:16)
    at Module._compile (module.js:374:25)
    at Object.Module._extensions..js (module.js:417:10)
    at Module.load (module.js:344:32)
    at Function.Module._load (module.js:301:12)
    at Module.require (module.js:354:17)
    at require (internal/module.js:12:17)
    at module.exports
(/vagrant/node_modules/webpack/bin/convert-argv.js:80:13)
    at Object.<anonymous>
(/vagrant/node_modules/webpack/bin/webpack.js:39:40)
    at Module._compile (module.js:410:26)
Makefile:16: recipe for target 'compile' failed
make: *** [compile] Error 1

I'm using a Vagrant based Ubuntu 16.04, with the dependencies installed as
suggested in the README. I just rebuild that box, but that gives me the
same result.

Help?

- Guus


#2

It's likely caused by an old node/npm version. Please update to
something newer such as the "current" version.


#3

Ah, I wondered about that. The README defines this:

sudo apt-get install npm nodejs-legacy

Which gives me a pretty old version. What do you recommend? Node 6 (the
current LTS)?

···

On 4 April 2017 at 20:28, Lyubomir Marinov <lyubomir.marinov@jitsi.org> wrote:

It's likely caused by an old node/npm version. Please update to
something newer such as the "current" version.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Yep, node 6 is ok.

···

On Tue, Apr 4, 2017 at 1:35 PM, Guus der Kinderen <guus.der.kinderen@gmail.com> wrote:

Ah, I wondered about that. The README defines this:

sudo apt-get install npm nodejs-legacy

Which gives me a pretty old version. What do you recommend? Node 6 (the
current LTS)?

On 4 April 2017 at 20:28, Lyubomir Marinov <lyubomir.marinov@jitsi.org> > wrote:

It's likely caused by an old node/npm version. Please update to
something newer such as the "current" version.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

That worked, although the first 'make' failed with an error message telling
me to do; npm rebuild node-sass

Would it be an idea to include a Vagrant file with the application, just to
make sure that all developers (can) have the exact same development
environment?

···

On 4 April 2017 at 20:40, Damian Minkov <damencho@jitsi.org> wrote:

Yep, node 6 is ok.

On Tue, Apr 4, 2017 at 1:35 PM, Guus der Kinderen > <guus.der.kinderen@gmail.com> wrote:
> Ah, I wondered about that. The README defines this:
>
> sudo apt-get install npm nodejs-legacy
>
> Which gives me a pretty old version. What do you recommend? Node 6 (the
> current LTS)?
>
> On 4 April 2017 at 20:28, Lyubomir Marinov <lyubomir.marinov@jitsi.org> > > wrote:
>>
>> It's likely caused by an old node/npm version. Please update to
>> something newer such as the "current" version.
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev