[jitsi-dev] [Jitsi Meet] No camera image in fresh install


#1

Hi all!

I made a new installation on Debian GNU/Linux Jessie using the
repository [1] referred to the stable build line (although catches my
attention that this repository says unstable/).

After doing a local test and accept access to my camera by Jitsi, the
camera comes on but nothing appears on the screen.

After doing some research, it seems that the problem is related to that
in the same host I have installed my XMPP server with ejabberd (14.07 is
the current version) which I have been using for several years.

If I stop the ejabberd server, the video on Jitsi Meet runs smoothly.
With this in mind, then I think that to solve these I have to make that
Jitsi Meet works with ejabberd.

In order that the the proxy pass configuration used on Nginx works for
BOSH, I've added the following in /etc/ejabberd/ejabberd.yml:

···

----------------------------------------------------------------------
  -
    port: 5280
    module: ejabberd_http
    ###### DGB - 20160623 - For Jitsi Meet ######
    http_bind: true
    ###### DGB - 20160623 - For Jitsi Meet ######
    http_poll: true
----------------------------------------------------------------------

Then, based on this [2] document, I added the following to set Jitsi
Videobridge:

----------------------------------------------------------------------
###### DGB - 20160623 - Para Jitsi Meet ######
    port: 5347
    module: ejabberd_service
    hosts:
      "jitsi-videobridge.hangouts.opcion-libre.com.ar":
        password: "p4ssW0rD"
###### DGB - 20160623 - Para Jitsi Meet ######
----------------------------------------------------------------------

I think this should correspond with the following lines in the
/etc/prosody/conf.d/hangouts.opcion-libre.com.ar.cfg.lua file:

Component "jitsi-videobridge.hangouts.opcion-libre.com.ar"
    component_secret = "p4ssW0rD"

The port should be 5347, I think:

# grep -R 5347 *
jicofo/config:JICOFO_PORT=5347
videobridge/config:JVB_PORT=5347

Please correct me if I'm wrong about something said so far.

----------------------------------------------------------------------
host_config:
  "hangouts.opcion-libre.com.ar":
    odbc_type: pgsql
    odbc_server: "127.0.0.1"
    odbc_database: "hangouts"
    odbc_username: "ejabberd"
    odbc_password: "O7herP4sswOrd"

(...)

hosts:
  - "hangouts.opcion-libre.com.ar"
----------------------------------------------------------------------

The bridge seems to be registered according to that I see in
/var/log/ejabberd/ejabberd.log

----------------------------------------------------------------------
2016-06-23 17:29:49.473 [info]
<0.800.0>@ejabberd_service:wait_for_handshake:195 Route registered for
service <<"jitsi-videobridge.hangouts.opcion-libre.com.ar">>
----------------------------------------------------------------------

But for some reason it seems that the "focus" user can not be registered:

----------------------------------------------------------------------
2016-06-23 17:31:05.855 [info]
<0.838.0>@ejabberd_c2s:wait_for_sasl_response:924
({socket_state,p1_tls,{tlssock,#Port<0.7192>,#Port<0.7196>},<0.837.0>})
Failed authentication for focus@hermes.freesoftware from IP 127.0.0.1
----------------------------------------------------------------------

I created the "focus" user in Ejabberd for the
hangouts.opcion-libre.com.ar domain. I'm not sure why the domain used is
hermes.freesoftware instead of hangouts.opcion-libre.com.ar. Noteworthy
that hermes.freesoftware is the name of the host on the local network.

Also I attached a screenshot of Firebug error console. The errors
mentioned there may be due to this problem of authentication?

All contributions are welcome.

Thanks in advance.

Kind regards,
Daniel

[1] https://jitsi.org/Main/DebianRepository
[2] https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd


#2

Hi,

from the screenshot I think your bosh is not working correctly. Try
going directly to the http-bind address and you should see a
successful result, here you can see the prosody reply:
https://meet.jit.si/http-bind

Regards
damencho

···

On Thu, Jun 23, 2016 at 3:49 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi all!

I made a new installation on Debian GNU/Linux Jessie using the
repository [1] referred to the stable build line (although catches my
attention that this repository says unstable/).

After doing a local test and accept access to my camera by Jitsi, the
camera comes on but nothing appears on the screen.

After doing some research, it seems that the problem is related to that
in the same host I have installed my XMPP server with ejabberd (14.07 is
the current version) which I have been using for several years.

If I stop the ejabberd server, the video on Jitsi Meet runs smoothly.
With this in mind, then I think that to solve these I have to make that
Jitsi Meet works with ejabberd.

In order that the the proxy pass configuration used on Nginx works for
BOSH, I've added the following in /etc/ejabberd/ejabberd.yml:

----------------------------------------------------------------------
  -
    port: 5280
    module: ejabberd_http
    ###### DGB - 20160623 - For Jitsi Meet ######
    http_bind: true
    ###### DGB - 20160623 - For Jitsi Meet ######
    http_poll: true
----------------------------------------------------------------------

Then, based on this [2] document, I added the following to set Jitsi
Videobridge:

----------------------------------------------------------------------
###### DGB - 20160623 - Para Jitsi Meet ######
    port: 5347
    module: ejabberd_service
    hosts:
      "jitsi-videobridge.hangouts.opcion-libre.com.ar":
        password: "p4ssW0rD"
###### DGB - 20160623 - Para Jitsi Meet ######
----------------------------------------------------------------------

I think this should correspond with the following lines in the
/etc/prosody/conf.d/hangouts.opcion-libre.com.ar.cfg.lua file:

Component "jitsi-videobridge.hangouts.opcion-libre.com.ar"
    component_secret = "p4ssW0rD"

The port should be 5347, I think:

# grep -R 5347 *
jicofo/config:JICOFO_PORT=5347
videobridge/config:JVB_PORT=5347

Please correct me if I'm wrong about something said so far.

----------------------------------------------------------------------
host_config:
  "hangouts.opcion-libre.com.ar":
    odbc_type: pgsql
    odbc_server: "127.0.0.1"
    odbc_database: "hangouts"
    odbc_username: "ejabberd"
    odbc_password: "O7herP4sswOrd"

(...)

hosts:
  - "hangouts.opcion-libre.com.ar"
----------------------------------------------------------------------

The bridge seems to be registered according to that I see in
/var/log/ejabberd/ejabberd.log

----------------------------------------------------------------------
2016-06-23 17:29:49.473 [info]
<0.800.0>@ejabberd_service:wait_for_handshake:195 Route registered for
service <<"jitsi-videobridge.hangouts.opcion-libre.com.ar">>
----------------------------------------------------------------------

But for some reason it seems that the "focus" user can not be registered:

----------------------------------------------------------------------
2016-06-23 17:31:05.855 [info]
<0.838.0>@ejabberd_c2s:wait_for_sasl_response:924
({socket_state,p1_tls,{tlssock,#Port<0.7192>,#Port<0.7196>},<0.837.0>})
Failed authentication for focus@hermes.freesoftware from IP 127.0.0.1
----------------------------------------------------------------------

I created the "focus" user in Ejabberd for the
hangouts.opcion-libre.com.ar domain. I'm not sure why the domain used is
hermes.freesoftware instead of hangouts.opcion-libre.com.ar. Noteworthy
that hermes.freesoftware is the name of the host on the local network.

Also I attached a screenshot of Firebug error console. The errors
mentioned there may be due to this problem of authentication?

All contributions are welcome.

Thanks in advance.

Kind regards,
Daniel

[1] https://jitsi.org/Main/DebianRepository
[2] https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi,

Hi, Damian.

from the screenshot I think your bosh is not working correctly. Try
going directly to the http-bind address and you should see a
successful result, here you can see the prosody reply:
https://meet.jit.si/http-bind

I think it is responding. What you mention is a test that I had done
before. Attached a screenshot.

Let me know what you think, please.

Thanks for your reply.

Kind regards,
Daniel

···

On 24/06/16 10:37, Damian Minkov wrote: