[jitsi-dev] Jitsi-meet ldap auth - black screen


#1

Hi guys,

it seems that i am missing something in the configs or so..

I try to configure my jitsi-meet installation (installed via apt-get) for ldap-auth and i made the following changes:

- Installed the mod_auth_ldap2 for prosody (and the corresponding lib_ldap...)

- Made some configuration so prosody now connects to my Microsoft AD with a special service user for this (this is working, checked it with pidgin and connected to my prosody instance with LDAP credentials)

- Added the following in /etc/jitsi/jicofo/sip-communicator.properties:

         org.jitsi.jicofo.auth.URL=XMPP:<myxmppdomain>

- the <myxmppdomain> is also the domain that is configured in prosody and worked with authentication in pidgin

After all changes and restarting all services (jicofo, prosody, jitsi-videobridge) I get now a black screen with the jitsi menus if i try to create a new conference. There is no authentication window. In the logs i could not find some errors regarding failed authentication or something.. the auth.<myxmppdomain> is not changed so it does "internal_plain" authentication.

Any suggestions?

Thanks in advance!

Best Regards

Th3R3al


#2

Hi,

Are there any error logs in the js console?

Regards
damencho

···

On Mon, Jun 5, 2017 at 9:28 AM, Th3R3al <th3r3al@cloudreboot.de> wrote:

Hi guys,

it seems that i am missing something in the configs or so..

I try to configure my jitsi-meet installation (installed via apt-get) for
ldap-auth and i made the following changes:

- Installed the mod_auth_ldap2 for prosody (and the corresponding
lib_ldap...)

- Made some configuration so prosody now connects to my Microsoft AD with a
special service user for this (this is working, checked it with pidgin and
connected to my prosody instance with LDAP credentials)

- Added the following in /etc/jitsi/jicofo/sip-communicator.properties:

        org.jitsi.jicofo.auth.URL=XMPP:<myxmppdomain>

- the <myxmppdomain> is also the domain that is configured in prosody and
worked with authentication in pidgin

After all changes and restarting all services (jicofo, prosody,
jitsi-videobridge) I get now a black screen with the jitsi menus if i try to
create a new conference. There is no authentication window. In the logs i
could not find some errors regarding failed authentication or something..
the auth.<myxmppdomain> is not changed so it does "internal_plain"
authentication.

Any suggestions?

Thanks in advance!

Best Regards

Th3R3al

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi Damencho,

yeah i found this:

lib-jitsi-meet.min.js:12 [/modules/RTC/RTCUtils.js] <>: onUserMediaSuccess
app.bundle.min.js:1 failed to create local tracks Array(2) JitsiTrackErrorgum: Objectmessage: "Generic getUserMedia error"name: "gum.general"stack: "Error↵ at new JitsiTrackError (https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:3:19089)↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:5164↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:3129↵ at maybeApply (https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26671)↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26890"proto: Errorconstructor: function JitsiTrackError(error,options,devices)arguments: nullcaller: nulllength: 3name: "JitsiTrackError"prototype: Error__proto__: function ()[[FunctionLocation]]: <unknown>[[Scopes]]: Scopes[3]__proto__: Objectconstructor: function Error()message: ""name: "Error"toString: function toString()arguments: nullcaller: nulllength: 0name: “toString”__proto__: function ()apply: function apply()arguments: (...)bind: function bind()call: function call()caller: (...)constructor: function Function()length: 0name: ""toString: function toString()Symbol(Symbol.hasInstance): function [Symbol.hasInstance]()get arguments: function ThrowTypeError()set arguments: function ThrowTypeError()get caller: function ThrowTypeError()set caller: function ThrowTypeError()__proto__: Object[[FunctionLocation]]: <unknown>__proto__: Object
(anonymous) @ app.bundle.min.js:1

I looked also in the prosody logs .. and cant find an auth request to jitsi.my.domain if i try create a new conference.

···

Am 05.06.2017 um 17:05 schrieb Damian Minkov:

Hi,

Are there any error logs in the js console?

Regards
damencho

On Mon, Jun 5, 2017 at 9:28 AM, Th3R3al <th3r3al@cloudreboot.de> wrote:

Hi guys,

it seems that i am missing something in the configs or so..

I try to configure my jitsi-meet installation (installed via apt-get) for
ldap-auth and i made the following changes:

- Installed the mod_auth_ldap2 for prosody (and the corresponding
lib_ldap...)

- Made some configuration so prosody now connects to my Microsoft AD with a
special service user for this (this is working, checked it with pidgin and
connected to my prosody instance with LDAP credentials)

- Added the following in /etc/jitsi/jicofo/sip-communicator.properties:

         org.jitsi.jicofo.auth.URL=XMPP:<myxmppdomain>

- the <myxmppdomain> is also the domain that is configured in prosody and
worked with authentication in pidgin

After all changes and restarting all services (jicofo, prosody,
jitsi-videobridge) I get now a black screen with the jitsi menus if i try to
create a new conference. There is no authentication window. In the logs i
could not find some errors regarding failed authentication or something..
the auth.<myxmppdomain> is not changed so it does "internal_plain"
authentication.

Any suggestions?

Thanks in advance!

Best Regards

Th3R3al

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Yep, this error prevents the client to continue with connecting. Not
sure what is the cause of this problem ...
Are you accessing your site with https? Do you have problems accessing
meet.jit.si from the same PC?

···

On Mon, Jun 5, 2017 at 10:13 AM, Th3R3al <th3r3al@cloudreboot.de> wrote:

Hi Damencho,

yeah i found this:

lib-jitsi-meet.min.js:12 [/modules/RTC/RTCUtils.js] <>: onUserMediaSuccess
app.bundle.min.js:1 failed to create local tracks Array(2)
JitsiTrackErrorgum: Objectmessage: "Generic getUserMedia error"name:
"gum.general"stack: "Error↵ at new JitsiTrackError
(https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:3:19089)↵ at
https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:5164↵ at
https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:3129↵ at
maybeApply
(https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26671)↵ at
https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26890"proto:
Errorconstructor: function JitsiTrackError(error,options,devices)arguments:
nullcaller: nulllength: 3name: "JitsiTrackError"prototype: Error__proto__:
function ()[[FunctionLocation]]: <unknown>[[Scopes]]: Scopes[3]__proto__:
Objectconstructor: function Error()message: ""name: "Error"toString:
function toString()arguments: nullcaller: nulllength: 0name:
“toString”__proto__: function ()apply: function apply()arguments: (...)bind:
function bind()call: function call()caller: (...)constructor: function
Function()length: 0name: ""toString: function
toString()Symbol(Symbol.hasInstance): function [Symbol.hasInstance]()get
arguments: function ThrowTypeError()set arguments: function
ThrowTypeError()get caller: function ThrowTypeError()set caller: function
ThrowTypeError()__proto__: Object[[FunctionLocation]]: <unknown>__proto__:
Object
(anonymous) @ app.bundle.min.js:1

I looked also in the prosody logs .. and cant find an auth request to
jitsi.my.domain if i try create a new conference.

Am 05.06.2017 um 17:05 schrieb Damian Minkov:

Hi,

Are there any error logs in the js console?

Regards
damencho

On Mon, Jun 5, 2017 at 9:28 AM, Th3R3al <th3r3al@cloudreboot.de> wrote:

Hi guys,

it seems that i am missing something in the configs or so..

I try to configure my jitsi-meet installation (installed via apt-get) for
ldap-auth and i made the following changes:

- Installed the mod_auth_ldap2 for prosody (and the corresponding
lib_ldap...)

- Made some configuration so prosody now connects to my Microsoft AD with
a
special service user for this (this is working, checked it with pidgin
and
connected to my prosody instance with LDAP credentials)

- Added the following in /etc/jitsi/jicofo/sip-communicator.properties:

         org.jitsi.jicofo.auth.URL=XMPP:<myxmppdomain>

- the <myxmppdomain> is also the domain that is configured in prosody and
worked with authentication in pidgin

After all changes and restarting all services (jicofo, prosody,
jitsi-videobridge) I get now a black screen with the jitsi menus if i try
to
create a new conference. There is no authentication window. In the logs i
could not find some errors regarding failed authentication or something..
the auth.<myxmppdomain> is not changed so it does "internal_plain"
authentication.

Any suggestions?

Thanks in advance!

Best Regards

Th3R3al

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Just to give additional information. If i change my authentication method on prosody again to internal_plain the authentication is working again. (without changing some on my reverse proxy or something like this). Changing it back to prosodys ldap2 authentication breaks it again. (but authentication to prosody with pidgin works with ldap credentials)

Anyone got a suggestion how to debug this? Should i open an issue on the jitsi-meet repo?

···

Am 05.06.2017 um 17:13 schrieb Th3R3al:

Hi Damencho,

yeah i found this:

lib-jitsi-meet.min.js:12 [/modules/RTC/RTCUtils.js] <>: onUserMediaSuccess
app.bundle.min.js:1 failed to create local tracks Array(2) JitsiTrackErrorgum: Objectmessage: "Generic getUserMedia error"name: "gum.general"stack: "Error↵ at new JitsiTrackError (https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:3:19089)↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:5164↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:3129↵ at maybeApply (https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26671)↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26890"proto: Errorconstructor: function JitsiTrackError(error,options,devices)arguments: nullcaller: nulllength: 3name: "JitsiTrackError"prototype: Error__proto__: function ()[[FunctionLocation]]: <unknown>[[Scopes]]: Scopes[3]__proto__: Objectconstructor: function Error()message: ""name: "Error"toString: function toString()arguments: nullcaller: nulllength: 0name: “toString”__proto__: function ()apply: function apply()arguments: (...)bind: function bind()call: function call()caller: (...)constructor: function Function()length: 0name: ""toString: function toString()Symbol(Symbol.hasInstance): function [Symbol.hasInstance]()get arguments: function ThrowTypeError()set arguments: function ThrowTypeError()get caller: function ThrowTypeError()set caller: function ThrowTypeError()__proto__: Object[[FunctionLocation]]: <unknown>__proto__: Object
(anonymous) @ app.bundle.min.js:1

I looked also in the prosody logs .. and cant find an auth request to jitsi.my.domain if i try create a new conference.

Am 05.06.2017 um 17:05 schrieb Damian Minkov:

Hi,

Are there any error logs in the js console?

Regards
damencho

On Mon, Jun 5, 2017 at 9:28 AM, Th3R3al <th3r3al@cloudreboot.de> wrote:

Hi guys,

it seems that i am missing something in the configs or so..

I try to configure my jitsi-meet installation (installed via apt-get) for
ldap-auth and i made the following changes:

- Installed the mod_auth_ldap2 for prosody (and the corresponding
lib_ldap...)

- Made some configuration so prosody now connects to my Microsoft AD with a
special service user for this (this is working, checked it with pidgin and
connected to my prosody instance with LDAP credentials)

- Added the following in /etc/jitsi/jicofo/sip-communicator.properties:

         org.jitsi.jicofo.auth.URL=XMPP:<myxmppdomain>

- the <myxmppdomain> is also the domain that is configured in prosody and
worked with authentication in pidgin

After all changes and restarting all services (jicofo, prosody,
jitsi-videobridge) I get now a black screen with the jitsi menus if i try to
create a new conference. There is no authentication window. In the logs i
could not find some errors regarding failed authentication or something..
the auth.<myxmppdomain> is not changed so it does "internal_plain"
authentication.

Any suggestions?

Thanks in advance!

Best Regards

Th3R3al

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Hey Guys,

i researched a bit and find that i was using the unstable ppa. I changed this now to jitsi stable and reinstalled the jitsi-meet package and prosody. I use now the following versions:

jitsi-meet 1.0.2098-1

jicofo 1.0.1.0-357

jvb 0.1.953

prosody 0.9.12

Also Damencho and i found that if I enable the mod_auth_ldap2 in the prosody config - the BOSH connection mystically is not working. If I change it back to "internal_plain" auth in prosody - the bosh connection is working fine.

I get this on Google Chrome:

    /[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError:
    null Script: null Line: null Column: null StackTrace: Error:
    Strophe: BOSH-Connection failed: null//
    // at Object.Strophe.log (lib-jitsi-meet.min.js:30)//
    // at Object.error (app.bundle.min.js:104)//
    // at e.Bosh._connect_cb (app.bundle.min.js:105)//
    // at u.Connection._connect_cb (app.bundle.min.js:104)//
    // at e.Bosh._onRequestStateChange (app.bundle.min.js:105)//
    //r @ lib-jitsi-meet.min.js:6//
    //getGlobalOnErrorHandler @ lib-jitsi-meet.min.js:32//
    //window.onerror @ app.bundle.min.js:87//
    //callErrorHandler @ lib-jitsi-meet.min.js:1//
    //Strophe.log @ lib-jitsi-meet.min.js:30//
    //error @ app.bundle.min.js:104//
    //_connect_cb @ app.bundle.min.js:105//
    //_connect_cb @ app.bundle.min.js:104//
    //_onRequestStateChange @ app.bundle.min.js:105//
    //lib-jitsi-meet.min.js:6 [modules/xmpp/strophe.util.js]
    <Object.Strophe.log>: Strophe: BOSH-Connection failed: null/

Any idea what could cause this behavior?

Thanks all!

Greetings

Th3R3al

···

Am 05.06.2017 um 21:40 schrieb Th3R3al:

Just to give additional information. If i change my authentication method on prosody again to internal_plain the authentication is working again. (without changing some on my reverse proxy or something like this). Changing it back to prosodys ldap2 authentication breaks it again. (but authentication to prosody with pidgin works with ldap credentials)

Anyone got a suggestion how to debug this? Should i open an issue on the jitsi-meet repo?

Am 05.06.2017 um 17:13 schrieb Th3R3al:

Hi Damencho,

yeah i found this:

lib-jitsi-meet.min.js:12 [/modules/RTC/RTCUtils.js] <>: onUserMediaSuccess
app.bundle.min.js:1 failed to create local tracks Array(2) JitsiTrackErrorgum: Objectmessage: "Generic getUserMedia error"name: "gum.general"stack: "Error↵ at new JitsiTrackError (https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:3:19089)↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:5164↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:3129↵ at maybeApply (https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26671)↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26890"proto: Errorconstructor: function JitsiTrackError(error,options,devices)arguments: nullcaller: nulllength: 3name: "JitsiTrackError"prototype: Error__proto__: function ()[[FunctionLocation]]: <unknown>[[Scopes]]: Scopes[3]__proto__: Objectconstructor: function Error()message: ""name: "Error"toString: function toString()arguments: nullcaller: nulllength: 0name: “toString”__proto__: function ()apply: function apply()arguments: (...)bind: function bind()call: function call()caller: (...)constructor: function Function()length: 0name: ""toString: function toString()Symbol(Symbol.hasInstance): function [Symbol.hasInstance]()get arguments: function ThrowTypeError()set arguments: function ThrowTypeError()get caller: function ThrowTypeError()set caller: function ThrowTypeError()__proto__: Object[[FunctionLocation]]: <unknown>__proto__: Object
(anonymous) @ app.bundle.min.js:1

I looked also in the prosody logs .. and cant find an auth request to jitsi.my.domain if i try create a new conference.

Am 05.06.2017 um 17:05 schrieb Damian Minkov:

Hi,

Are there any error logs in the js console?

Regards
damencho

On Mon, Jun 5, 2017 at 9:28 AM, Th3R3al <th3r3al@cloudreboot.de> wrote:

Hi guys,

it seems that i am missing something in the configs or so..

I try to configure my jitsi-meet installation (installed via apt-get) for
ldap-auth and i made the following changes:

- Installed the mod_auth_ldap2 for prosody (and the corresponding
lib_ldap...)

- Made some configuration so prosody now connects to my Microsoft AD with a
special service user for this (this is working, checked it with pidgin and
connected to my prosody instance with LDAP credentials)

- Added the following in /etc/jitsi/jicofo/sip-communicator.properties:

         org.jitsi.jicofo.auth.URL=XMPP:<myxmppdomain>

- the <myxmppdomain> is also the domain that is configured in prosody and
worked with authentication in pidgin

After all changes and restarting all services (jicofo, prosody,
jitsi-videobridge) I get now a black screen with the jitsi menus if i try to
create a new conference. There is no authentication window. In the logs i
could not find some errors regarding failed authentication or something..
the auth.<myxmppdomain> is not changed so it does "internal_plain"
authentication.

Any suggestions?

Thanks in advance!

Best Regards

Th3R3al

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Hi,

We recently made a custom authentication for a JItsi-meet installation using prosody external authentication instead of internal_plain and we should set consider_bosh_secure = true in prosody.cfg.lua to make it work.

As Bosh XMPP connection is made through the Nginx proxy with JItsi-meet (HTTPS bosh to HTTP bosh) prosody should consider it secure to enable authentication method different to internal_plain that's why you should set consider_bosh_secure to true (http://prosody.im/doc/modules/mod_bosh).

Regards,
Damien Fétis.

···

De: "Th3R3al" <th3r3al@cloudreboot.de>
À: "dev" <dev@jitsi.org>
Envoyé: Mercredi 7 Juin 2017 20:47:21
Objet: Re: [jitsi-dev] Jitsi-meet ldap auth - black screen

Hey Guys,

i researched a bit and find that i was using the unstable ppa. I changed this now to jitsi stable and reinstalled the jitsi-meet package and prosody. I use now the following versions:

jitsi-meet 1.0.2098-1

jicofo 1.0.1.0-357

jvb 0.1.953

prosody 0.9.12

Also Damencho and i found that if I enable the mod_auth_ldap2 in the prosody config - the BOSH connection mystically is not working. If I change it back to "internal_plain" auth in prosody - the bosh connection is working fine.

I get this on Google Chrome:

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: BOSH-Connection failed: null
at Object.Strophe.log (lib-jitsi-meet.min.js:30)
at Object.error (app.bundle.min.js:104)
at e.Bosh._connect_cb (app.bundle.min.js:105)
at u.Connection._connect_cb (app.bundle.min.js:104)
at e.Bosh._onRequestStateChange (app.bundle.min.js:105)
r @ lib-jitsi-meet.min.js:6
getGlobalOnErrorHandler @ lib-jitsi-meet.min.js:32
window.onerror @ app.bundle.min.js:87
callErrorHandler @ lib-jitsi-meet.min.js:1
Strophe.log @ lib-jitsi-meet.min.js:30
error @ app.bundle.min.js:104
_connect_cb @ app.bundle.min.js:105
_connect_cb @ app.bundle.min.js:104
_onRequestStateChange @ app.bundle.min.js:105
lib-jitsi-meet.min.js:6 [modules/xmpp/strophe.util.js] <Object.Strophe.log>: Strophe: BOSH-Connection failed: null

Any idea what could cause this behavior?

Thanks all!

Greetings

Th3R3al

Am 05.06.2017 um 21:40 schrieb Th3R3al:

BQ_BEGIN
Just to give additional information. If i change my authentication method on prosody again to internal_plain the authentication is working again. (without changing some on my reverse proxy or something like this). Changing it back to prosodys ldap2 authentication breaks it again. (but authentication to prosody with pidgin works with ldap credentials)

Anyone got a suggestion how to debug this? Should i open an issue on the jitsi-meet repo?

Am 05.06.2017 um 17:13 schrieb Th3R3al:

BQ_BEGIN
Hi Damencho,

yeah i found this:

lib-jitsi-meet.min.js:12 [/modules/RTC/RTCUtils.js] <>: onUserMediaSuccess
app.bundle.min.js:1 failed to create local tracks Array(2) JitsiTrackErrorgum: Objectmessage: "Generic getUserMedia error"name: "gum.general"stack: "Error↵ at new JitsiTrackError ( https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:3:19089 )↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:5164↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:3129↵ at maybeApply ( https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26671 )↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26890 "__proto__: Errorconstructor: function JitsiTrackError(error,options,devices)arguments: nullcaller: nulllength: 3name: "JitsiTrackError"prototype: Error__proto__: function ()[[FunctionLocation]]: <unknown>[[Scopes]]: Scopes[3]__proto__: Objectconstructor: function Error()message: ""name: "Error"toString: function toString()arguments: nullcaller: nulllength: 0name: "toString"__proto__: function ()apply: function apply()arguments: (...)bind: function bind()call: function call()caller: (...)constructor: function Function()length: 0name: ""toString: function toString()Symbol(Symbol.hasInstance): function [Symbol.hasInstance]()get arguments: function ThrowTypeError()set arguments: function ThrowTypeError()get caller: function ThrowTypeError()set caller: function ThrowTypeError()__proto__: Object[[FunctionLocation]]: <unknown>__proto__: Object
(anonymous) @ app.bundle.min.js:1

I looked also in the prosody logs .. and cant find an auth request to jitsi.my.domain if i try create a new conference.

Am 05.06.2017 um 17:05 schrieb Damian Minkov:

BQ_BEGIN
Hi,

Are there any error logs in the js console?

Regards
damencho

On Mon, Jun 5, 2017 at 9:28 AM, Th3R3al <th3r3al@cloudreboot.de> wrote:

BQ_BEGIN
Hi guys,

it seems that i am missing something in the configs or so..

I try to configure my jitsi-meet installation (installed via apt-get) for
ldap-auth and i made the following changes:

- Installed the mod_auth_ldap2 for prosody (and the corresponding
lib_ldap...)

- Made some configuration so prosody now connects to my Microsoft AD with a
special service user for this (this is working, checked it with pidgin and
connected to my prosody instance with LDAP credentials)

- Added the following in /etc/jitsi/jicofo/sip-communicator.properties:

org.jitsi.jicofo.auth.URL=XMPP:<myxmppdomain>

- the <myxmppdomain> is also the domain that is configured in prosody and
worked with authentication in pidgin

After all changes and restarting all services (jicofo, prosody,
jitsi-videobridge) I get now a black screen with the jitsi menus if i try to
create a new conference. There is no authentication window. In the logs i
could not find some errors regarding failed authentication or something..
the auth.<myxmppdomain> is not changed so it does "internal_plain"
authentication.

Any suggestions?

Thanks in advance!

Best Regards

Th3R3al

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

BQ_END
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

BQ_END

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

BQ_END

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

BQ_END

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Hello,

can you please specify if the change has been included in the latest
stable/nightly quick installation method or not (and where can we download
this working custom version for external authentication)?

Regards,

Petros

···

From: dev-bounces@jitsi.org [mailto:dev-bounces@jitsi.org] On Behalf Of
Damien FETIS
Sent: Thursday, June 08, 2017 10:59 AM
To: dev
Subject: Re: [jitsi-dev] Jitsi-meet ldap auth - black screen

Hi,

We recently made a custom authentication for a JItsi-meet installation using
prosody external authentication instead of internal_plain and we should set
consider_bosh_secure = true in prosody.cfg.lua to make it work.

As Bosh XMPP connection is made through the Nginx proxy with JItsi-meet
(HTTPS bosh to HTTP bosh) prosody should consider it secure to enable
authentication method different to internal_plain that's why you should set
consider_bosh_secure to true (http://prosody.im/doc/modules/mod_bosh).

Regards,

Damien Fétis.

  _____

De: "Th3R3al" <th3r3al@cloudreboot.de>
À: "dev" <dev@jitsi.org>
Envoyé: Mercredi 7 Juin 2017 20:47:21
Objet: Re: [jitsi-dev] Jitsi-meet ldap auth - black screen

Hey Guys,

i researched a bit and find that i was using the unstable ppa. I changed
this now to jitsi stable and reinstalled the jitsi-meet package and prosody.
I use now the following versions:

jitsi-meet 1.0.2098-1

jicofo 1.0.1.0-357

jvb 0.1.953

prosody 0.9.12

Also Damencho and i found that if I enable the mod_auth_ldap2 in the prosody
config - the BOSH connection mystically is not working. If I change it back
to "internal_plain" auth in prosody - the bosh connection is working fine.

I get this on Google Chrome:

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null
Script: null Line: null Column: null StackTrace: Error: Strophe:
BOSH-Connection failed: null
    at Object.Strophe.log (lib-jitsi-meet.min.js:30)
    at Object.error (app.bundle.min.js:104)
    at e.Bosh._connect_cb (app.bundle.min.js:105)
    at u.Connection._connect_cb (app.bundle.min.js:104)
    at e.Bosh._onRequestStateChange (app.bundle.min.js:105)
r @ lib-jitsi-meet.min.js:6
getGlobalOnErrorHandler @ lib-jitsi-meet.min.js:32
window.onerror @ app.bundle.min.js:87
callErrorHandler @ lib-jitsi-meet.min.js:1
Strophe.log @ lib-jitsi-meet.min.js:30
error @ app.bundle.min.js:104
_connect_cb @ app.bundle.min.js:105
_connect_cb @ app.bundle.min.js:104
_onRequestStateChange @ app.bundle.min.js:105
lib-jitsi-meet.min.js:6 [modules/xmpp/strophe.util.js] <Object.Strophe.log>:
Strophe: BOSH-Connection failed: null

Any idea what could cause this behavior?

Thanks all!

Greetings

Th3R3al

Am 05.06.2017 um 21:40 schrieb Th3R3al:

Just to give additional information. If i change my authentication method on
prosody again to internal_plain the authentication is working again.
(without changing some on my reverse proxy or something like this). Changing
it back to prosodys ldap2 authentication breaks it again. (but
authentication to prosody with pidgin works with ldap credentials)

Anyone got a suggestion how to debug this? Should i open an issue on the
jitsi-meet repo?

Am 05.06.2017 um 17:13 schrieb Th3R3al:

Hi Damencho,

yeah i found this:

lib-jitsi-meet.min.js:12 [/modules/RTC/RTCUtils.js] <>: onUserMediaSuccess
app.bundle.min.js:1 failed to create local tracks Array(2)
JitsiTrackErrorgum: Objectmessage: "Generic getUserMedia error"name:
"gum.general"stack: "Error↵ at new JitsiTrackError
(https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:3:19089)↵ at
https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:5164
<https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:5164?> ↵ at
https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:3129
<https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:3129?> ↵ at
maybeApply
(https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26671)↵ at
https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26890"proto:
Errorconstructor: function JitsiTrackError(error,options,devices)arguments:
nullcaller: nulllength: 3name: "JitsiTrackError"prototype: Error__proto__:
function ()[[FunctionLocation]]: <unknown>[[Scopes]]: Scopes[3]__proto__:
Objectconstructor: function Error()message: ""name: "Error"toString:
function toString()arguments: nullcaller: nulllength: 0name:
“toString”__proto__: function ()apply: function apply()arguments: (...)bind:
function bind()call: function call()caller: (...)constructor: function
Function()length: 0name: ""toString: function
toString()Symbol(Symbol.hasInstance): function [Symbol.hasInstance]()get
arguments: function ThrowTypeError()set arguments: function
ThrowTypeError()get caller: function ThrowTypeError()set caller: function
ThrowTypeError()__proto__: Object[[FunctionLocation]]: <unknown>__proto__:
Object
(anonymous) @ app.bundle.min.js:1

I looked also in the prosody logs .. and cant find an auth request to
jitsi.my.domain if i try create a new conference.

Am 05.06.2017 um 17:05 schrieb Damian Minkov:

Hi,

Are there any error logs in the js console?

Regards
damencho

On Mon, Jun 5, 2017 at 9:28 AM, Th3R3al <mailto:th3r3al@cloudreboot.de> <th3r3al@cloudreboot.de> wrote:

Hi guys,

it seems that i am missing something in the configs or so..

I try to configure my jitsi-meet installation (installed via apt-get) for
ldap-auth and i made the following changes:

- Installed the mod_auth_ldap2 for prosody (and the corresponding
lib_ldap...)

- Made some configuration so prosody now connects to my Microsoft AD with a
special service user for this (this is working, checked it with pidgin and
connected to my prosody instance with LDAP credentials)

- Added the following in /etc/jitsi/jicofo/sip-communicator.properties:

         org.jitsi.jicofo.auth.URL=XMPP:<myxmppdomain>

- the <myxmppdomain> is also the domain that is configured in prosody and
worked with authentication in pidgin

After all changes and restarting all services (jicofo, prosody,
jitsi-videobridge) I get now a black screen with the jitsi menus if i try to
create a new conference. There is no authentication window. In the logs i
could not find some errors regarding failed authentication or something..
the auth.<myxmppdomain> is not changed so it does "internal_plain"
authentication.

Any suggestions?

Thanks in advance!

Best Regards

Th3R3al

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Hi Damien,

thanks for the hint.

The parameter consider_bosh_secure is set in my config already and it is not working with ldap2 auth for me.
(Tested the Parameter in prosody.cfg.lua and in the specific jitsi host configuration file..)

Greetings
Th3R3al

···

Am 08.06.2017 um 09:58 schrieb Damien FETIS <damien.fetis@renater.fr>:

Hi,

We recently made a custom authentication for a JItsi-meet installation using prosody external authentication instead of internal_plain and we should set consider_bosh_secure = true in prosody.cfg.lua to make it work.

As Bosh XMPP connection is made through the Nginx proxy with JItsi-meet (HTTPS bosh to HTTP bosh) prosody should consider it secure to enable authentication method different to internal_plain that's why you should set consider_bosh_secure to true (http://prosody.im/doc/modules/mod_bosh).

Regards,
Damien Fétis.

De: "Th3R3al" <th3r3al@cloudreboot.de>
À: "dev" <dev@jitsi.org>
Envoyé: Mercredi 7 Juin 2017 20:47:21
Objet: Re: [jitsi-dev] Jitsi-meet ldap auth - black screen

Hey Guys,

i researched a bit and find that i was using the unstable ppa. I changed this now to jitsi stable and reinstalled the jitsi-meet package and prosody. I use now the following versions:

jitsi-meet 1.0.2098-1

jicofo 1.0.1.0-357

jvb 0.1.953

prosody 0.9.12

Also Damencho and i found that if I enable the mod_auth_ldap2 in the prosody config - the BOSH connection mystically is not working. If I change it back to "internal_plain" auth in prosody - the bosh connection is working fine.

I get this on Google Chrome:

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: BOSH-Connection failed: null
    at Object.Strophe.log (lib-jitsi-meet.min.js:30)
    at Object.error (app.bundle.min.js:104)
    at e.Bosh._connect_cb (app.bundle.min.js:105)
    at u.Connection._connect_cb (app.bundle.min.js:104)
    at e.Bosh._onRequestStateChange (app.bundle.min.js:105)
r @ lib-jitsi-meet.min.js:6
getGlobalOnErrorHandler @ lib-jitsi-meet.min.js:32
window.onerror @ app.bundle.min.js:87
callErrorHandler @ lib-jitsi-meet.min.js:1
Strophe.log @ lib-jitsi-meet.min.js:30
error @ app.bundle.min.js:104
_connect_cb @ app.bundle.min.js:105
_connect_cb @ app.bundle.min.js:104
_onRequestStateChange @ app.bundle.min.js:105
lib-jitsi-meet.min.js:6 [modules/xmpp/strophe.util.js] <Object.Strophe.log>: Strophe: BOSH-Connection failed: null

Any idea what could cause this behavior?

Thanks all!

Greetings

Th3R3al

Am 05.06.2017 um 21:40 schrieb Th3R3al:
Just to give additional information. If i change my authentication method on prosody again to internal_plain the authentication is working again. (without changing some on my reverse proxy or something like this). Changing it back to prosodys ldap2 authentication breaks it again. (but authentication to prosody with pidgin works with ldap credentials)

Anyone got a suggestion how to debug this? Should i open an issue on the jitsi-meet repo?

Am 05.06.2017 um 17:13 schrieb Th3R3al:
Hi Damencho,

yeah i found this:

lib-jitsi-meet.min.js:12 [/modules/RTC/RTCUtils.js] <>: onUserMediaSuccess
app.bundle.min.js:1 failed to create local tracks Array(2) JitsiTrackErrorgum: Objectmessage: "Generic getUserMedia error"name: "gum.general"stack: "Error↵ at new JitsiTrackError (https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:3:19089)↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:5164↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:3129↵ at maybeApply (https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26671)↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26890"proto: Errorconstructor: function JitsiTrackError(error,options,devices)arguments: nullcaller: nulllength: 3name: "JitsiTrackError"prototype: Error__proto__: function ()[[FunctionLocation]]: <unknown>[[Scopes]]: Scopes[3]__proto__: Objectconstructor: function Error()message: ""name: "Error"toString: function toString()arguments: nullcaller: nulllength: 0name: “toString”__proto__: function ()apply: function apply()arguments: (...)bind: function bind()call: function call()caller: (...)constructor: function Function()length: 0name: ""toString: function toString()Symbol(Symbol.hasInstance): function [Symbol.hasInstance]()get arguments: function ThrowTypeError()set arguments: function ThrowTypeError()get caller: function ThrowTypeError()set caller: function ThrowTypeError()__proto__: Object[[FunctionLocation]]: <unknown>__proto__: Object
(anonymous) @ app.bundle.min.js:1

I looked also in the prosody logs .. and cant find an auth request to jitsi.my.domain if i try create a new conference.

Am 05.06.2017 um 17:05 schrieb Damian Minkov:
Hi,

Are there any error logs in the js console?

Regards
damencho

On Mon, Jun 5, 2017 at 9:28 AM, Th3R3al <th3r3al@cloudreboot.de> wrote:
Hi guys,

it seems that i am missing something in the configs or so..

I try to configure my jitsi-meet installation (installed via apt-get) for
ldap-auth and i made the following changes:

- Installed the mod_auth_ldap2 for prosody (and the corresponding
lib_ldap...)

- Made some configuration so prosody now connects to my Microsoft AD with a
special service user for this (this is working, checked it with pidgin and
connected to my prosody instance with LDAP credentials)

- Added the following in /etc/jitsi/jicofo/sip-communicator.properties:

         org.jitsi.jicofo.auth.URL=XMPP:<myxmppdomain>

- the <myxmppdomain> is also the domain that is configured in prosody and
worked with authentication in pidgin

After all changes and restarting all services (jicofo, prosody,
jitsi-videobridge) I get now a black screen with the jitsi menus if i try to
create a new conference. There is no authentication window. In the logs i
could not find some errors regarding failed authentication or something..
the auth.<myxmppdomain> is not changed so it does "internal_plain"
authentication.

Any suggestions?

Thanks in advance!

Best Regards

Th3R3al

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

Hi,

The parameter consider_bosh_secure is set in my config already and it is not working with ldap2 auth for me.
(Tested the Parameter in prosody.cfg.lua and in the specific jitsi host configuration file..)

Have you also added the configuration for anonymous/guest domain in prosody and meet config files as described in https://github.com/jitsi/jicofo#secure-domain ?

I use mod_auth_ldap (without the 2) and it works (with eDirectory instead of AD).

Regards,
Bernhard


#11

Hello,

sorry but this custom authentication version is currently only made for integration with our internal tools (I'm not part of JItsi Team).
You should modify prosody configuration by hand after quick installation.

Damien Fetis.
RENATER

···

De: "Petros Louca" <louca.petros@ucy.ac.cy>
À: "dev" <dev@jitsi.org>
Envoyé: Jeudi 8 Juin 2017 10:37:32
Objet: Re: [jitsi-dev] Jitsi-meet ldap auth - black screen

Hello,

can you please specify if the change has been included in the latest stable/nightly quick installation method or not (and where can we download this working custom version for external authentication)?

Regards,

Petros

From: dev-bounces@jitsi.org [mailto:dev-bounces@jitsi.org] On Behalf Of Damien FETIS
Sent: Thursday, June 08, 2017 10:59 AM
To: dev
Subject: Re: [jitsi-dev] Jitsi-meet ldap auth - black screen

Hi,

We recently made a custom authentication for a JItsi-meet installation using prosody external authentication instead of internal_plain and we should set consider_bosh_secure = true in prosody.cfg.lua to make it work.

As Bosh XMPP connection is made through the Nginx proxy with JItsi-meet (HTTPS bosh to HTTP bosh) prosody should consider it secure to enable authentication method different to internal_plain that's why you should set consider_bosh_secure to true ( http://prosody.im/doc/modules/mod_bosh ).

Regards,

Damien Fétis.

De: "Th3R3al" < th3r3al@cloudreboot.de >
À: "dev" < dev@jitsi.org >
Envoyé: Mercredi 7 Juin 2017 20:47:21
Objet: Re: [jitsi-dev] Jitsi-meet ldap auth - black screen

Hey Guys,

i researched a bit and find that i was using the unstable ppa. I changed this now to jitsi stable and reinstalled the jitsi-meet package and prosody. I use now the following versions:

jitsi-meet 1.0.2098-1

jicofo 1.0.1.0-357

jvb 0.1.953

prosody 0.9.12

Also Damencho and i found that if I enable the mod_auth_ldap2 in the prosody config - the BOSH connection mystically is not working. If I change it back to "internal_plain" auth in prosody - the bosh connection is working fine.

I get this on Google Chrome:

[JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: BOSH-Connection failed: null
at Object.Strophe.log (lib-jitsi-meet.min.js:30)
at Object.error (app.bundle.min.js:104)
at e.Bosh._connect_cb (app.bundle.min.js:105)
at u.Connection._connect_cb (app.bundle.min.js:104)
at e.Bosh._onRequestStateChange (app.bundle.min.js:105)
r @ lib-jitsi-meet.min.js:6
getGlobalOnErrorHandler @ lib-jitsi-meet.min.js:32
window.onerror @ app.bundle.min.js:87
callErrorHandler @ lib-jitsi-meet.min.js:1
Strophe.log @ lib-jitsi-meet.min.js:30
error @ app.bundle.min.js:104
_connect_cb @ app.bundle.min.js:105
_connect_cb @ app.bundle.min.js:104
_onRequestStateChange @ app.bundle.min.js:105
lib-jitsi-meet.min.js:6 [modules/xmpp/strophe.util.js] <Object.Strophe.log>: Strophe: BOSH-Connection failed: null

Any idea what could cause this behavior?

Thanks all!

Greetings

Th3R3al

Am 05.06.2017 um 21:40 schrieb Th3R3al:

BQ_BEGIN

Just to give additional information. If i change my authentication method on prosody again to internal_plain the authentication is working again. (without changing some on my reverse proxy or something like this). Changing it back to prosodys ldap2 authentication breaks it again. (but authentication to prosody with pidgin works with ldap credentials)

Anyone got a suggestion how to debug this? Should i open an issue on the jitsi-meet repo?

Am 05.06.2017 um 17:13 schrieb Th3R3al:

Hi Damencho,

yeah i found this:

lib-jitsi-meet.min.js:12 [/modules/RTC/RTCUtils.js] <>: onUserMediaSuccess
app.bundle.min.js:1 failed to create local tracks Array(2) JitsiTrackErrorgum: Objectmessage: "Generic getUserMedia error"name: "gum.general"stack: "Error ↵ at new JitsiTrackError ( https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:3:19089 ) ↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:5164 ↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:5:3129 ↵ at maybeApply ( https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26671 ) ↵ at https://jitsi.my.domain/libs/lib-jitsi-meet.min.js?v=1073:4:26890 "__proto__: Errorconstructor: function JitsiTrackError(error,options,devices)arguments: nullcaller: nulllength: 3name: "JitsiTrackError"prototype: Error__proto__: function ()[[FunctionLocation]]: <unknown>[[Scopes]]: Scopes[3]__proto__: Objectconstructor: function Error()message: ""name: "Error"toString: function toString()arguments: nullcaller: nulllength: 0name: "toString"__proto__: function ()apply: function apply()arguments: (...)bind: function bind()call: function call()caller: (...)constructor: function Function()length: 0name: ""toString: function toString()Symbol(Symbol.hasInstance): function [Symbol.hasInstance]()get arguments: function ThrowTypeError()set arguments: function ThrowTypeError()get caller: function ThrowTypeError()set caller: function ThrowTypeError()__proto__: Object[[FunctionLocation]]: <unknown>__proto__: Object
(anonymous) @ app.bundle.min.js:1

I looked also in the prosody logs .. and cant find an auth request to jitsi.my.domain if i try create a new conference.

Am 05.06.2017 um 17:05 schrieb Damian Minkov:

Hi,

Are there any error logs in the js console?

Regards
damencho

On Mon, Jun 5, 2017 at 9:28 AM, Th3R3al <th3r3al@cloudreboot.de> wrote:

Hi guys,

it seems that i am missing something in the configs or so..

I try to configure my jitsi-meet installation (installed via apt-get) for
ldap-auth and i made the following changes:

- Installed the mod_auth_ldap2 for prosody (and the corresponding
lib_ldap...)

- Made some configuration so prosody now connects to my Microsoft AD with a
special service user for this (this is working, checked it with pidgin and
connected to my prosody instance with LDAP credentials)

- Added the following in /etc/jitsi/jicofo/sip-communicator.properties:

org.jitsi.jicofo.auth.URL=XMPP:<myxmppdomain>

- the <myxmppdomain> is also the domain that is configured in prosody and
worked with authentication in pidgin

After all changes and restarting all services (jicofo, prosody,
jitsi-videobridge) I get now a black screen with the jitsi menus if i try to
create a new conference. There is no authentication window. In the logs i
could not find some errors regarding failed authentication or something..
the auth.<myxmppdomain> is not changed so it does "internal_plain"
authentication.

Any suggestions?

Thanks in advance!

Best Regards

Th3R3al

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
BQ_END

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

Hello Bernhard,

This was a good one, I now get an authentication window. But it hang on „connecting..“ (After entering credentials)

I investigate a bit more..

Regards
Th3R3al

···

Am 08.06.2017 um 12:47 schrieb Lichtinger, Bernhard <Bernhard.Lichtinger@lrz.de>:

Hi,

The parameter consider_bosh_secure is set in my config already and it is not working with ldap2 auth for me.
(Tested the Parameter in prosody.cfg.lua and in the specific jitsi host configuration file..)

Have you also added the configuration for anonymous/guest domain in prosody and meet config files as described in https://github.com/jitsi/jicofo#secure-domain ?

I use mod_auth_ldap (without the 2) and it works (with eDirectory instead of AD).

Regards,
Bernhard

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#13

Hey Bernhard,

Seems that I get the connecting.. message only if I try to connect with just my samAccountName. If I try samAccountName@domain.my <mailto:samAccountName@domain.my> with the correct password the entire web application is crashing (Something went wrong, we reconnect you..) and I am again at the login prompt.

In the console I see directly after the crash the following message:

JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: BOSH-Connection failed: host-unknown
    at Object.Strophe.log (strophe.util.js:87)
    at Object.error (strophe.js:1560)
    at e.Bosh._connect_cb (strophe.js:4462)
    at u.Connection._connect_cb (strophe.js:3177)
    at e.Bosh._onRequestStateChange (strophe.js:4729)
r @ Logger.js:125
getGlobalOnErrorHandler @ JitsiMeetJS.js:504
window.onerror @ conference.js:557
callErrorHandler @ GlobalOnErrorHandler.js:63
Strophe.log @ strophe.util.js:87
error @ strophe.js:1560
_connect_cb @ strophe.js:4462
_connect_cb @ strophe.js:3177
_onRequestStateChange @ strophe.js:4729
Logger.js:125 [modules/xmpp/strophe.util.js] <Object.Strophe.log>: Strophe: BOSH-Connection failed: host-unknown
[react/features/overlay/reducer.js] <r>: XMPP connection error: host-unknown

Should the guest domain external available? Or is this just for internal communication? Can not find documentation that covers this..

Regards
Th3R3al

···

Am 08.06.2017 um 19:11 schrieb thereal33c3 <th3r3al@cloudreboot.de>:

Hello Bernhard,

This was a good one, I now get an authentication window. But it hang on „connecting..“ (After entering credentials)

I investigate a bit more..

Regards
Th3R3al

Am 08.06.2017 um 12:47 schrieb Lichtinger, Bernhard <Bernhard.Lichtinger@lrz.de>:

Hi,

The parameter consider_bosh_secure is set in my config already and it is not working with ldap2 auth for me.
(Tested the Parameter in prosody.cfg.lua and in the specific jitsi host configuration file..)

Have you also added the configuration for anonymous/guest domain in prosody and meet config files as described in https://github.com/jitsi/jicofo#secure-domain ?

I use mod_auth_ldap (without the 2) and it works (with eDirectory instead of AD).

Regards,
Bernhard

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#14

Hi,

Seems that I get the connecting.. message only if I try to connect with just my samAccountName. If I try samAccountName@domain.my with the correct password the entire web application is crashing (Something went wrong, we reconnect you..) and I am again at the login prompt.

Do you also have

in meet config.js:
  domain: 'domain.my'
  anonymousdomain: 'guest.domain.my'

in /etc/jitsi/jicofo/sip-communicator.properties:
org.jitsi.jicofo.auth.URL=XMPP:domain.my

in prosody-config:
VirtualHost "domain.my"
    your_ldap_auth_stuff

VirtualHost "guest.domain.my"
    authentication = "anonymous"

and your webserver is serving 'domain.my'?

When you type in only an username in the login form, jitsi-meet will automatically append "@" followed by domain from meet config file.

Regards,
Bernhard


#15

Hi,

I checked the parameters and they are ok.

Then I authenticate I get this very often in the jicofo log:

org.jitsi.jicofo.xmpp.FocusComponent.handleconferenceIq().396 Focus request for room: <conferencename>@conference.domain.my

Just for your information: If i set my deployment to "internal_plain" auth all is working fine. So I guess there seems to be all ok for the setup itself. Hm. :frowning: Maybe the ldap2 is faulty, but login with pidgin on prosody is also working fine with ldap credentials.

Thanks for your help!

···

Am 09.06.2017 um 13:53 schrieb Lichtinger, Bernhard <Bernhard.Lichtinger@lrz.de>:

Hi,

Seems that I get the connecting.. message only if I try to connect with just my samAccountName. If I try samAccountName@domain.my with the correct password the entire web application is crashing (Something went wrong, we reconnect you..) and I am again at the login prompt.

Do you also have

in meet config.js:
domain: 'domain.my'
anonymousdomain: 'guest.domain.my'

in /etc/jitsi/jicofo/sip-communicator.properties:
org.jitsi.jicofo.auth.URL=XMPP:domain.my

in prosody-config:
VirtualHost "domain.my"
   your_ldap_auth_stuff

VirtualHost "guest.domain.my"
   authentication = "anonymous"

and your webserver is serving 'domain.my'?

When you type in only an username in the login form, jitsi-meet will automatically append "@" followed by domain from meet config file.

Regards,
Bernhard
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#16

Additionally I found this in my debug prosody log..

Any idea what is causing this? Normal behaviour?

···

Jun 09 16:06:27 jcp2538ba0 debug Received[component]: <iq id='c5898834-c161-45f6-b6b4-68e76866ad31:sendIQ' type='error' to='c6e04d8e-bf95-4469-afca-379e49982c34@guest.domain.my/6bcc97fd-d3e7-4f8b-8531-bb2023029cac' from='focus.domain.my'>

Am 09.06.2017 um 16:05 schrieb Th3r3al <th3r3al@cloudreboot.de>:

Hi,

I checked the parameters and they are ok.

Then I authenticate I get this very often in the jicofo log:

org.jitsi.jicofo.xmpp.FocusComponent.handleconferenceIq().396 Focus request for room: <conferencename>@conference.domain.my

Just for your information: If i set my deployment to "internal_plain" auth all is working fine. So I guess there seems to be all ok for the setup itself. Hm. :frowning: Maybe the ldap2 is faulty, but login with pidgin on prosody is also working fine with ldap credentials.

Thanks for your help!

Am 09.06.2017 um 13:53 schrieb Lichtinger, Bernhard <Bernhard.Lichtinger@lrz.de>:

Hi,

Seems that I get the connecting.. message only if I try to connect with just my samAccountName. If I try samAccountName@domain.my with the correct password the entire web application is crashing (Something went wrong, we reconnect you..) and I am again at the login prompt.

Do you also have

in meet config.js:
domain: 'domain.my'
anonymousdomain: 'guest.domain.my'

in /etc/jitsi/jicofo/sip-communicator.properties:
org.jitsi.jicofo.auth.URL=XMPP:domain.my

in prosody-config:
VirtualHost "domain.my"
  your_ldap_auth_stuff

VirtualHost "guest.domain.my"
  authentication = "anonymous"

and your webserver is serving 'domain.my'?

When you type in only an username in the login form, jitsi-meet will automatically append "@" followed by domain from meet config file.

Regards,
Bernhard
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev