[jitsi-dev] jitsi-meet/jigasi: Problem with "focusMucJid" not being set - outbound call with jigasi fails


#1

Hi,
it seems that there is a certain scenario depending on the room name where the formerly global variable „focusMucJid“ (now in the latest connection.emuc…) is not being set at all - although moderator rights had been granted.
This results in dial error in strophe.rayo as the „from“-field is set to null.

The way I can reproduce is that the chosen room name equals the main domain name. - is there a regex problem in jicofo?

JS console log:
xmpp.bundle.js:4437 Strophe status changed to CONNECTED
xmpp.bundle.js:4445 My Jabber ID: efe68bd0-c347-4175-84a8-38b90dea6bf7@meet.mydomain.net/9f61e97e-e807-4b92-a7cb-9e4d2e8ab7a3
xmpp.bundle.js:2864 Focus jid set to: undefined
xmpp.bundle.js:2864 Focus jid set to: focus@auth.meet.mydomain.net
xmpp.bundle.js:2948 External authentication enabled: false
xmpp.bundle.js:2957 Sip gateway enabled: true
xmpp.bundle.js:3249 Joined MUC as iparlo@conference.meet.mydomain.net/efe68bd0
UI.bundle.js:377 My role changed, new role: moderator
XHR finished loading: POST "https://meet.mydomain.net/http-bind".
xmpp.bundle.js?v=4:4310 Dial error <iq xmlns="jabber:client" type="error" to="efe68bd0-c347-4175-84a8-38b90dea6bf7@meet.mydomain.net/9f61e97e-e807-4b92-a7cb-9e4d2e8ab7a3" from="null" id="3:sendIQ"><error type="cancel"><not-allowed xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/><text xmlns="urn:ietf:params:xml:ns:xmpp-stanzas">Communication with remote domains is not enabled</text></error></iq>

jicofo.log:
org.jitsi.jicofo.xmpp.FocusComponent.handleIQSet().222 Focus request for room: mydomain@conference.meet.mydomain.net

Please check that immediately after joining the muc, the role changed to moderator. You would expect a line like:
   Ignore focus:xyz@conference.meet.mydomain.net/focus, real JID: focus@auth.meet.mydomain.net/focus320588857970572