[jitsi-dev] Jitsi-meet install failure, npm and webpack


#1

Yes, i have tired just running npm intsall and that is where it fails with
the webpack error

···

On Wed, Nov 9, 2016 at 11:00 AM, <dev-request@jitsi.org> wrote:

Send dev mailing list submissions to
        dev@jitsi.org

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.jitsi.org/mailman/listinfo/dev
or, via email, send a message with subject or body 'help' to
        dev-request@jitsi.org

You can reach the person managing the list at
        dev-owner@jitsi.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of dev digest..."

Today's Topics:

   1. Jitsi-meet install failure, npm and webpack (Adam Barnett)
   2. Re: Jitsi-meet install failure, npm and webpack (Damian Minkov)

----------------------------------------------------------------------

Message: 1
Date: Tue, 8 Nov 2016 16:39:07 +0000
From: Adam Barnett <adambarnett52@gmail.com>
To: dev@jitsi.org
Subject: [jitsi-dev] Jitsi-meet install failure, npm and webpack
Message-ID:
        <CAFjD+F8+cJonw_VikX98NgXnpMHFCMLwDUGkpA3A7k0+
f7ACkA@mail.gmail.com>
Content-Type: text/plain; charset="utf-8"

Hi All

When trying to install jitsui meet from the github page, i get this error

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0
(node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for
fsevents@1.0.15: wanted {"os":"darwin","arch":"any"} (current:
{"os":"linux","arch":"x64"})
npm ERR! Linux 3.13.0-100-generic
npm ERR! argv "node" "/tmp/node-v6.9.1-linux-x64/bin/npm" "install"
npm ERR! node v0.10.25
npm ERR! npm v3.10.8
npm ERR! code ELIFECYCLE

npm ERR! lib-jitsi-meet@0.0.0 install: `webpack -p`
npm ERR! Exit status 8
npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 install script 'webpack -p'.
npm ERR! Make sure you have the latest version of node.js and npm
installed.
npm ERR! If you do, this is most likely a problem with the lib-jitsi-meet
package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! webpack -p
npm ERR! You can get information on how to open an issue for this project
with:
npm ERR! npm bugs lib-jitsi-meet
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls lib-jitsi-meet
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /usr/share/jitsi-meet/npm-debug.log

I am using the lastest node.js from their site

Thanks for the help

PS sorry if i posted this early, i did not put a subject on it so decided
to do it again
--
Adam Barnett
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jitsi.org/pipermail/dev/attachments/
20161108/65ca0946/attachment-0001.html>

------------------------------

Message: 2
Date: Tue, 8 Nov 2016 10:58:29 -0600
From: Damian Minkov <damencho@jitsi.org>
To: Jitsi Developers <dev@jitsi.org>
Subject: Re: [jitsi-dev] Jitsi-meet install failure, npm and webpack
Message-ID:
        <CAE07f0LpSLBjE3aop51sGM0eUxGV+UqRKJ+=-XkdZ457Z5mrmw@mail.
gmail.com>
Content-Type: text/plain; charset=UTF-8

HI,

Did you do npm install prior make?

Regards
damencho

On Tue, Nov 8, 2016 at 10:39 AM, Adam Barnett <adambarnett52@gmail.com> > wrote:
> Hi All
>
> When trying to install jitsui meet from the github page, i get this error
>
> npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0
> (node_modules/chokidar/node_modules/fsevents):
> npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for
> fsevents@1.0.15: wanted {"os":"darwin","arch":"any"} (current:
> {"os":"linux","arch":"x64"})
> npm ERR! Linux 3.13.0-100-generic
> npm ERR! argv "node" "/tmp/node-v6.9.1-linux-x64/bin/npm" "install"
> npm ERR! node v0.10.25
> npm ERR! npm v3.10.8
> npm ERR! code ELIFECYCLE
>
> npm ERR! lib-jitsi-meet@0.0.0 install: `webpack -p`
> npm ERR! Exit status 8
> npm ERR!
> npm ERR! Failed at the lib-jitsi-meet@0.0.0 install script 'webpack -p'.
> npm ERR! Make sure you have the latest version of node.js and npm
installed.
> npm ERR! If you do, this is most likely a problem with the lib-jitsi-meet
> package,
> npm ERR! not with npm itself.
> npm ERR! Tell the author that this fails on your system:
> npm ERR! webpack -p
> npm ERR! You can get information on how to open an issue for this project
> with:
> npm ERR! npm bugs lib-jitsi-meet
> npm ERR! Or if that isn't available, you can get their info via:
> npm ERR! npm owner ls lib-jitsi-meet
> npm ERR! There is likely additional logging output above.
>
> npm ERR! Please include the following file with any support request:
> npm ERR! /usr/share/jitsi-meet/npm-debug.log
>
> I am using the lastest node.js from their site
>
> Thanks for the help
>
> PS sorry if i posted this early, i did not put a subject on it so
decided to
> do it again
> --
> Adam Barnett
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

------------------------------

Subject: Digest Footer

_______________________________________________
dev mailing list
dev@jitsi.org
http://lists.jitsi.org/mailman/listinfo/dev

------------------------------

End of dev Digest, Vol 44, Issue 29
***********************************

--
Adam Barnett