[jitsi-dev] [jitsi-meet] etherpad and desktop streaming not working on my self-hosted jitmeet (#63)


#1

* Nudge nudge *

Seriously though, I've been able to get desktop streaming working with
webRTC, but etherpad remains a problem.
I'm pretty certain that the jitmeet github is missing some key info, namely
etherpad.base in config.js (ie domain = config
.etherpad_base seems to be missing).

I presume that indeed there is an etherpad (etherpad-lite?) install in
meet.jit.si or another domain you control, which is why etherpad isn't
working for us self-hosters.
Could you please confirm this and/or share the proper etherpad setup to
have it work with jitmeet?

Thanks,

Peter

···

On Sat, May 3, 2014 at 8:10 AM, Emil Ivov <notifications@github.com> wrote:

We explicitly ask people to open issues when we think this is necessary.
Oh and you can nudge us if your mail on the list is not getting a response
for a few days :slight_smile:


Reply to this email directly or view it on GitHub<https://github.com/jitsi/jitsi-meet/issues/63#issuecomment-42098289>
.


#2

* Nudge nudge *

Thanks :slight_smile:

Seriously though, I've been able to get desktop streaming working with
webRTC, but etherpad remains a problem.

That's surprising. There is actually a missing part for desktop streaming that you need to get from the chrome store. There's no such thing for etherpard though.

I'm pretty certain that the jitmeet github is missing some key info,
namely etherpad.base in config.js (ie domain = config
.etherpad_base seems to be missing).
I presume that indeed there is an etherpad (etherpad-lite?) install in
meet.jit.si <http://meet.jit.si> or another domain you control, which is
why etherpad isn't working for us self-hosters.

I assume you have already had a look at meet.jit.si's config.js:

https://meet.jit.si/config.js

and that you have added the etherpad line, right?

Could you please confirm this and/or share the proper etherpad setup to
have it work with jitmeet?

Etherpad-lite is a separate project so we are not in the best position to advise people how to deploy it. Once you do get it installed though and you point meet.jit.si to it, there's nothing else you need.

Emil

···

On 05.05.14, 16:17, Peter Villeneuve wrote:

Thanks,

Peter

On Sat, May 3, 2014 at 8:10 AM, Emil Ivov <notifications@github.com > <mailto:notifications@github.com>> wrote:

    We explicitly ask people to open issues when we think this is
    necessary. Oh and you can nudge us if your mail on the list is not
    getting a response for a few days :slight_smile:

    �
    Reply to this email directly or view it on GitHub
    <https://github.com/jitsi/jitsi-meet/issues/63#issuecomment-42098289>.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org


#3

Dear Peter

How did you solve the desktop streaming issue? Could you please give me a
hand?

Kind regards,

···

* Nudge nudge *

Seriously though, I've been able to get desktop streaming working with
webRTC, but etherpad remains a problem.
I'm pretty certain that the jitmeet github is missing some key info,
namely
etherpad.base in config.js (ie domain = config
.etherpad_base seems to be missing).

I presume that indeed there is an etherpad (etherpad-lite?) install in
meet.jit.si or another domain you control, which is why etherpad isn't
working for us self-hosters.
Could you please confirm this and/or share the proper etherpad setup to
have it work with jitmeet?

Thanks,

Peter

On Sat, May 3, 2014 at 8:10 AM, Emil Ivov <notifications@github.com> > wrote:

We explicitly ask people to open issues when we think this is necessary.
Oh and you can nudge us if your mail on the list is not getting a
response
for a few days :slight_smile:


Reply to this email directly or view it on
GitHub<https://github.com/jitsi/jitsi-meet/issues/63#issuecomment-42098289>
.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

*That's surprising. There is actually a missing part for desktop streaming
that you need to get from the chrome store. There's no such thing for
etherpard though.*

Yes, I know that to use the ext option one needs to install the jitsi
streaming extension from Chrome. I did do that and edited the extension's
manifest to allow connections from my domains.

I also tried using webRTC option, and with that, one doesn't need the jitsi
extension at all. One just needs to enable
chrome://flags/#enable-usermedia-screen-capture.
Although that works, it is an all or nothing stream without the ability to
just share designated windows like in the jitsi extension. By the way, can
you share whatever backend code you have for that extension? I would prefer
to use that one instead of webRTC.

As for etherpad, you answered my question, thanks. I was just uncertain if
there was any special etherpad config needed server side. Apparently it
should work on a regular etherpad install.

Cheers

···

On Mon, May 5, 2014 at 3:58 PM, Emil Ivov <emcho@jitsi.org> wrote:

On 05.05.14, 16:17, Peter Villeneuve wrote:

* Nudge nudge *

Thanks :slight_smile:

Seriously though, I've been able to get desktop streaming working with

webRTC, but etherpad remains a problem.

That's surprising. There is actually a missing part for desktop streaming
that you need to get from the chrome store. There's no such thing for
etherpard though.

I'm pretty certain that the jitmeet github is missing some key info,

namely etherpad.base in config.js (ie domain = config
.etherpad_base seems to be missing).
I presume that indeed there is an etherpad (etherpad-lite?) install in
meet.jit.si <http://meet.jit.si> or another domain you control, which is

why etherpad isn't working for us self-hosters.

I assume you have already had a look at meet.jit.si's config.js:

https://meet.jit.si/config.js

and that you have added the etherpad line, right?

Could you please confirm this and/or share the proper etherpad setup to

have it work with jitmeet?

Etherpad-lite is a separate project so we are not in the best position to
advise people how to deploy it. Once you do get it installed though and you
point meet.jit.si to it, there's nothing else you need.

Emil

Thanks,

Peter

On Sat, May 3, 2014 at 8:10 AM, Emil Ivov <notifications@github.com >> <mailto:notifications@github.com>> wrote:

    We explicitly ask people to open issues when we think this is
    necessary. Oh and you can nudge us if your mail on the list is not
    getting a response for a few days :slight_smile:

    —
    Reply to this email directly or view it on GitHub
    <https://github.com/jitsi/jitsi-meet/issues/63#issuecomment-42098289
>.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org


#5

Hi Peter,

I have a self-hosted installation with Etherpad as well,
and I got it to work correctly eventually.

I first had some issues with the config.js file (missing a comma, duh).
Also, IIRC, etherpad should not be set to use https if you have a
self-signed or invalid cert.
You could also make sure it works standalone first.

Good luck,
Jean

···

On Tue, May 6, 2014 at 4:23 PM, Damian Raspachini < damian.raspachini@riseup.net> wrote:

Dear Peter

How did you solve the desktop streaming issue? Could you please give me a
hand?

Kind regards,

> * Nudge nudge *
>
> Seriously though, I've been able to get desktop streaming working with
> webRTC, but etherpad remains a problem.
> I'm pretty certain that the jitmeet github is missing some key info,
> namely
> etherpad.base in config.js (ie domain = config
> .etherpad_base seems to be missing).
>
> I presume that indeed there is an etherpad (etherpad-lite?) install in
> meet.jit.si or another domain you control, which is why etherpad isn't
> working for us self-hosters.
> Could you please confirm this and/or share the proper etherpad setup to
> have it work with jitmeet?
>
> Thanks,
>
> Peter
>
>
> On Sat, May 3, 2014 at 8:10 AM, Emil Ivov <notifications@github.com> > > wrote:
>
>> We explicitly ask people to open issues when we think this is necessary.
>> Oh and you can nudge us if your mail on the list is not getting a
>> response
>> for a few days :slight_smile:
>>
>> —
>> Reply to this email directly or view it on
>> GitHub<
https://github.com/jitsi/jitsi-meet/issues/63#issuecomment-42098289>
>> .
>>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Oh Oh, now it has sense. Thanks Jean.

···

Hi Peter,

I have a self-hosted installation with Etherpad as well,
and I got it to work correctly eventually.

I first had some issues with the config.js file (missing a comma, duh).
Also, IIRC, etherpad should not be set to use https if you have a
self-signed or invalid cert.
You could also make sure it works standalone first.

Good luck,
Jean

On Tue, May 6, 2014 at 4:23 PM, Damian Raspachini < > damian.raspachini@riseup.net> wrote:

Dear Peter

How did you solve the desktop streaming issue? Could you please give me
a
hand?

Kind regards,

> * Nudge nudge *
>
> Seriously though, I've been able to get desktop streaming working with
> webRTC, but etherpad remains a problem.
> I'm pretty certain that the jitmeet github is missing some key info,
> namely
> etherpad.base in config.js (ie domain = config
> .etherpad_base seems to be missing).
>
> I presume that indeed there is an etherpad (etherpad-lite?) install in
> meet.jit.si or another domain you control, which is why etherpad isn't
> working for us self-hosters.
> Could you please confirm this and/or share the proper etherpad setup
to
> have it work with jitmeet?
>
> Thanks,
>
> Peter
>
>
> On Sat, May 3, 2014 at 8:10 AM, Emil Ivov <notifications@github.com> >> > wrote:
>
>> We explicitly ask people to open issues when we think this is
necessary.
>> Oh and you can nudge us if your mail on the list is not getting a
>> response
>> for a few days :slight_smile:
>>
>> —
>> Reply to this email directly or view it on
>> GitHub<
https://github.com/jitsi/jitsi-meet/issues/63#issuecomment-42098289>
>> .
>>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Also, the way I got it to work for me was to make sure that webRTC is
chosen in config.js instead of ext.
Then just make sure that Chrome has
chrome://flags/#enable-usermedia-screen-capture
enabled.
That's it. You should now be able to stream the desktop window.

The jitsi extension seems a much better option since one can choose to
share only 1 window and not the whole desktop but I'm not sure the jitsi
team is sharing details on that.

Hope that helps.

Cheers,
Peter

···

On Tue, May 6, 2014 at 8:58 AM, Damian Raspachini < damian.raspachini@riseup.net> wrote:

Oh Oh, now it has sense. Thanks Jean.

> Hi Peter,
>
> I have a self-hosted installation with Etherpad as well,
> and I got it to work correctly eventually.
>
> I first had some issues with the config.js file (missing a comma, duh).
> Also, IIRC, etherpad should not be set to use https if you have a
> self-signed or invalid cert.
> You could also make sure it works standalone first.
>
> Good luck,
> Jean
>
>
> On Tue, May 6, 2014 at 4:23 PM, Damian Raspachini < > > damian.raspachini@riseup.net> wrote:
>
>> Dear Peter
>>
>> How did you solve the desktop streaming issue? Could you please give me
>> a
>> hand?
>>
>> Kind regards,
>>
>> > * Nudge nudge *
>> >
>> > Seriously though, I've been able to get desktop streaming working with
>> > webRTC, but etherpad remains a problem.
>> > I'm pretty certain that the jitmeet github is missing some key info,
>> > namely
>> > etherpad.base in config.js (ie domain = config
>> > .etherpad_base seems to be missing).
>> >
>> > I presume that indeed there is an etherpad (etherpad-lite?) install in
>> > meet.jit.si or another domain you control, which is why etherpad
isn't
>> > working for us self-hosters.
>> > Could you please confirm this and/or share the proper etherpad setup
>> to
>> > have it work with jitmeet?
>> >
>> > Thanks,
>> >
>> > Peter
>> >
>> >
>> > On Sat, May 3, 2014 at 8:10 AM, Emil Ivov <notifications@github.com> > >> > wrote:
>> >
>> >> We explicitly ask people to open issues when we think this is
>> necessary.
>> >> Oh and you can nudge us if your mail on the list is not getting a
>> >> response
>> >> for a few days :slight_smile:
>> >>
>> >> —
>> >> Reply to this email directly or view it on
>> >> GitHub<
>> https://github.com/jitsi/jitsi-meet/issues/63#issuecomment-42098289>
>> >> .
>> >>
>> > _______________________________________________
>> > dev mailing list
>> > dev@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/dev
>>
>>
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Hi Peter

I don't really know neither, because at the very begining, I tried to use
the Jitsi Extension for Chrome without success, now with your solution
works absolutely fantastic.

Thanks 4 that.

Regards,

···

Also, the way I got it to work for me was to make sure that webRTC is
chosen in config.js instead of ext.
Then just make sure that Chrome has
chrome://flags/#enable-usermedia-screen-capture
enabled.
That's it. You should now be able to stream the desktop window.

The jitsi extension seems a much better option since one can choose to
share only 1 window and not the whole desktop but I'm not sure the jitsi
team is sharing details on that.

Hope that helps.

Cheers,
Peter

On Tue, May 6, 2014 at 8:58 AM, Damian Raspachini < > damian.raspachini@riseup.net> wrote:

Oh Oh, now it has sense. Thanks Jean.

> Hi Peter,
>
> I have a self-hosted installation with Etherpad as well,
> and I got it to work correctly eventually.
>
> I first had some issues with the config.js file (missing a comma,
duh).
> Also, IIRC, etherpad should not be set to use https if you have a
> self-signed or invalid cert.
> You could also make sure it works standalone first.
>
> Good luck,
> Jean
>
>
> On Tue, May 6, 2014 at 4:23 PM, Damian Raspachini < >> > damian.raspachini@riseup.net> wrote:
>
>> Dear Peter
>>
>> How did you solve the desktop streaming issue? Could you please give
me
>> a
>> hand?
>>
>> Kind regards,
>>
>> > * Nudge nudge *
>> >
>> > Seriously though, I've been able to get desktop streaming working
with
>> > webRTC, but etherpad remains a problem.
>> > I'm pretty certain that the jitmeet github is missing some key
info,
>> > namely
>> > etherpad.base in config.js (ie domain = config
>> > .etherpad_base seems to be missing).
>> >
>> > I presume that indeed there is an etherpad (etherpad-lite?) install
in
>> > meet.jit.si or another domain you control, which is why etherpad
isn't
>> > working for us self-hosters.
>> > Could you please confirm this and/or share the proper etherpad
setup
>> to
>> > have it work with jitmeet?
>> >
>> > Thanks,
>> >
>> > Peter
>> >
>> >
>> > On Sat, May 3, 2014 at 8:10 AM, Emil Ivov >> <notifications@github.com> >> >> > wrote:
>> >
>> >> We explicitly ask people to open issues when we think this is
>> necessary.
>> >> Oh and you can nudge us if your mail on the list is not getting a
>> >> response
>> >> for a few days :slight_smile:
>> >>
>> >> —
>> >> Reply to this email directly or view it on
>> >> GitHub<
>> https://github.com/jitsi/jitsi-meet/issues/63#issuecomment-42098289>
>> >> .
>> >>
>> > _______________________________________________
>> > dev mailing list
>> > dev@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/dev
>>
>>
>>
>> _______________________________________________
>> dev mailing list
>> dev@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/dev
>>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev