[jitsi-dev] [jitsi-meet] Error when I run 'make' command


#1

Hi,

Follow the steps below. This is the exact method I make jitsi-meet webRTC.

1.1.1 Jitsi-Meet WebRTC Deployment with Source Build

Jitsi-meet uses Browserify <http://browserify.org/> . If you want to make
changes in the code, you need to install Browserify
<http://browserify.org/#install> . Browserify requires nodejs
<https://nodejs.org/en/> . The official jitsi nodejs-legacy installation has
some compatibility issues. Follow steps below to update both the tools to
nodejs v0.10.41 and npm v3.6.0

On Debian/Ubuntu systems, the required packages can be installed with:

¨ $ sudo apt-get install nodejs-legacy npm

¨ To update nodejs to version 0.10.41

§ echo 'deb <https://deb.nodesource.com/node_0.10>
https://deb.nodesource.com/node_0.10 trusty main' >
/etc/apt/sources.list.d/nodesource.list

§ echo 'deb-src https://deb.nodesource.com/node_0.10 trusty main' >>
/etc/apt/sources.list.d/nodesource.list

§ sudo apt-get update

§ sudo apt-get install nodejs

¨ $ sudo npm -g install npm@latest

Note: If your jisti-meet directory is accessible without root, then issue
all below commands without the $ sudo

¨ $ cd jitsi-meet

¨ $ npm install

To build the Jitsi-Meet application, just type

¨ $ make

During make process, you may experience some missing commands in
./node_modules/.bin. Create the missing command links in .bin directory as
below in particular e.g.

¨ $ ln –s ../browerfly/bin/cmd.js browerify

¨ $ ln –s ../clean-css/bin/cleancss cleancss

1.1.2 Working with the library sources (lib-jitsi-meet)

By default the lib-jitsi-meet library is built from its git repository
sources. The default dependency path in package.json is: "lib-jitsi-meet":
"jitsi/lib-jitsi-meet".

To work with local copy you must download the source to e.g.
“/usr/share/jitsi-meet/lib-jitsi-meet” and change the path to:
"lib-jitsi-meet": "./lib-jitsi-meet".

Before “make” the project, you must force it to take the local
“./lib-jitsi-meet” sources; as 'npm update' will not do it automatically.

¨ $ npm install lib-jitsi-meet –force

To build the jitsi-meet application using local “./lib-jitsi-meet”, just
type

¨ $ npm install

¨ $ make

···

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus


#2

Hi!

The 'make' is completed, thank you very much!!!

I followed the steps 1.1.1 Jitsi-Meet WebRTC Deployment with Source Build

Anyway, it shows:

...

bufferutil@1.1.0 install /var/www/myapp/node_modules/bufferutil
node-gyp rebuild

gyp ERR! configure error
gyp ERR! stack Error: "pre" versions of node cannot be installed, use the
--nodedir flag instead
gyp ERR! stack at install
(/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/install.js:64:16)
gyp ERR! stack at Object.self.commands.(anonymous function) [as
install]
(/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/node-gyp.js:66:37)
gyp ERR! stack at getNodeDir
(/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:74:20)
gyp ERR! stack at
/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:41:7
gyp ERR! stack at
/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:393:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:719:7)
gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:107:17)
gyp ERR! stack at maybeClose (child_process.js:991:16)
gyp ERR! stack at Process.ChildProcess._handle.onexit
(child_process.js:1058:5)
gyp ERR! System Linux 3.5.0-54-generic
gyp ERR! command "node"
"/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js"
"rebuild"
gyp ERR! cwd /var/www/myapp/node_modules/bufferutil
gyp ERR! node -v v0.11.13-pre
gyp ERR! node-gyp -v v3.2.1
gyp ERR! not ok
npm WARN install:bufferutil@1.1.0 bufferutil@1.1.0 install: `node-gyp
rebuild`
npm WARN install:bufferutil@1.1.0 Exit status 1

utf-8-validate@1.1.0 install /var/www/myapp/node_modules/utf-8-validate
node-gyp rebuild

gyp ERR! configure error
gyp ERR! stack Error: "pre" versions of node cannot be installed, use the
--nodedir flag instead
gyp ERR! stack at install
(/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/install.js:64:16)
gyp ERR! stack at Object.self.commands.(anonymous function) [as
install]
(/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/node-gyp.js:66:37)
gyp ERR! stack at getNodeDir
(/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:74:20)
gyp ERR! stack at
/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:41:7
gyp ERR! stack at
/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:393:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:719:7)
gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:107:17)
gyp ERR! stack at maybeClose (child_process.js:991:16)
gyp ERR! stack at Process.ChildProcess._handle.onexit
(child_process.js:1058:5)
gyp ERR! System Linux 3.5.0-54-generic
gyp ERR! command "node"
"/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js"
"rebuild"
gyp ERR! cwd /var/www/myapp/node_modules/utf-8-validate
gyp ERR! node -v v0.11.13-pre
gyp ERR! node-gyp -v v3.2.1
gyp ERR! not ok
npm WARN install:utf-8-validate@1.1.0 utf-8-validate@1.1.0 install:
`node-gyp rebuild`
npm WARN install:utf-8-validate@1.1.0 Exit status 1

...
npm WARN You are using a pre-release version of node and things may not
work as expected
./node_modules/.bin/browserify -d -e app.js -s APP |
./node_modules/.bin/exorcist ./app.bundle.js.map > ./app.bundle.js
./node_modules/.bin/uglifyjs -p relative ./app.bundle.js -o
./app.bundle.min.js --source-map ./app.bundle.min.map --in-source-map
./app.bundle.js.map
mkdir -p libs
cp ./app.bundle.min.js ./app.bundle.min.map \
libs
cp node_modules/lib-jitsi-meet//lib-jitsi-meet.min.js \
node_modules/lib-jitsi-meet//lib-jitsi-meet.min.map libs
(cd css; cat font.css toastr.css main.css videolayout_default.css
font-awesome.css jquery-impromptu.css modaldialog.css notice.css
popup_menu.css login_menu.css popover.css jitsi_popover.css
contact_list.css chat.css welcome_page.css settingsmenu.css feedback.css) |
./node_modules/.bin/cleancss > css/all.css
([ ! -x deploy-local.sh ] || ./deploy-local.sh)
rm -f ./app.bundle.*

I hope everything is ok.

Thanks again!

Sadiel.

···

2016-02-09 0:47 GMT-05:00 cmeng.gm <cmeng.gm@gmail.com>:

Hi,

Follow the steps below. This is the exact method I make jitsi-meet webRTC.
1.1.1 Jitsi-Meet WebRTC Deployment with Source Build

Jitsi-meet uses Browserify <http://browserify.org/>. If you want to make
changes in the code, you need to install Browserify
<http://browserify.org/#install>. Browserify requires nodejs
<https://nodejs.org/en/>. The official jitsi nodejs-legacy installation
has some compatibility issues. Follow steps below to update both the tools
to nodejs v0.10.41 and npm v3.6.0

On Debian/Ubuntu systems, the required packages can be installed with:

¨ $ sudo apt-get install nodejs-legacy npm

¨ To update nodejs to version 0.10.41

§ echo 'deb https://deb.nodesource.com/node_0.10 trusty main' >
/etc/apt/sources.list.d/nodesource.list

§ echo 'deb-src https://deb.nodesource.com/node_0.10 trusty main' >>
/etc/apt/sources.list.d/nodesource.list

§ sudo apt-get update

§ sudo apt-get install nodejs

¨ $ sudo npm -g install npm@latest

Note: If your jisti-meet directory is accessible without root, then issue
all below commands without the $ sudo

¨ $ cd jitsi-meet

¨ $ npm install

To build the Jitsi-Meet application, just type

¨ $ make

During make process, you may experience some missing commands in
./node_modules/.bin. Create the missing command links in .bin directory as
below in particular e.g.

¨ $ ln –s ../browerfly/bin/cmd.js browerify

¨ $ ln –s ../clean-css/bin/cleancss cleancss
1.1.2 Working with the library sources (lib-jitsi-meet)

By default the lib-jitsi-meet library is built from its git repository
sources. The default dependency path in package.json is: "lib-jitsi-meet":
"jitsi/lib-jitsi-meet".

To work with local copy you must download the source to e.g.
“/usr/share/jitsi-meet/lib-jitsi-meet” and change the path to:
"lib-jitsi-meet": "./lib-jitsi-meet".

Before “make” the project, you must force it to take the local
“./lib-jitsi-meet” sources; as 'npm update' will not do it automatically.

¨ $ npm install lib-jitsi-meet –force

To build the jitsi-meet application using local “./lib-jitsi-meet”, just
type

¨ $ npm install

¨ $ make

<https://www.avast.com/sig-email> This email has been sent from a
virus-free computer protected by Avast.
www.avast.com <https://www.avast.com/sig-email>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev