[jitsi-dev] Jitsi Meet .deb pkgs now available (amd64). Please help test!


#1

Hi,

We have beta versions of the deb packages needed to get Jitsi Meet
running and we'll be happy if you could give us a hand testing them
and telling us if something goes wrong.

The packages are in the Jitsi nightly repository
https://jitsi.org/Main/DebianNightlyRepository

You can get Jitsi Meet by marking for install the package "jitsi-meet".

For now these are just amd64 packages, we'll be adding i386 shortly.

The install should work on Trusty, Jessie and Sid -- that means
anything above Debian Stable (Wheezy).

Please report anything wrong you find with these packages.
We're open for ideas and suggestions.
Thanks!

···

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#2

is there a step-by-step "how to" available? (especially for not advanced
commandline people like me) ?

which *.deb files to install in which order etc
(I am running Debian testing 64bit )

sorry for the inconvenience..
MS

···

On 7/9/14 11:48 AM, Yasen Pramatarov wrote:

Hi,

We have beta versions of the deb packages needed to get Jitsi Meet
running and we'll be happy if you could give us a hand testing them
and telling us if something goes wrong.

The packages are in the Jitsi nightly repository
https://jitsi.org/Main/DebianNightlyRepository

You can get Jitsi Meet by marking for install the package "jitsi-meet".

For now these are just amd64 packages, we'll be adding i386 shortly.

The install should work on Trusty, Jessie and Sid -- that means
anything above Debian Stable (Wheezy).

Please report anything wrong you find with these packages.
We're open for ideas and suggestions.
Thanks!


#3

We have newer versions, you can test the packages by updating your
sources and installing the 'jitsi-meet' package.

as root:

apt-get update
apt-get install jitsi-meet

- it asks for hostname for the Jitsi Meet instance
- browse http://the-domainname-you-entered
- enjoy!

remove the packages with

apt-get remove jitsi-meet
or
apt-get purge jitsi-meet

- there is a bug in the removal script, it raises an error on first
   run, but you just run it twice and it should remove (or purge)
   everything (I'll fix that error later, sorry for the trouble).

Thanks for helping!
Happy testing!

···

On Wed, 9 Jul 2014 11:48:26 +0300 Yasen Pramatarov wrote:

We have beta versions of the deb packages needed to get Jitsi Meet
running and we'll be happy if you could give us a hand testing them
and telling us if something goes wrong.

The packages are in the Jitsi nightly repository
https://jitsi.org/Main/DebianNightlyRepository

You can get Jitsi Meet by marking for install the package
"jitsi-meet".

For now these are just amd64 packages, we'll be adding i386 shortly.

The install should work on Trusty, Jessie and Sid -- that means
anything above Debian Stable (Wheezy).

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#4

There is no step-by-step howto, but here is a short example of how to
do it.

You need to mark for installation the package "jitsi-meet". The latest
version of that package that is in the repo. It will install as
dependencies all the other needed stuff.

You can do this on commandline, with aptitude's ncurses interface or
a graphical installer of your choice. The steps are:

1) add the jitsi nightly repo to your apt sources

  open the file /etc/apt/sources.list as root (run
  `sudo mcedit /etc/apt/sources.list` or sth like that) and add the
  following line at the end of the file:

  deb http://download.jitsi.org/nightly/deb unstable/

  save the file and close it

2) update the package lists

  on command line:

   run `apt-get update` or `aptitude update`
   or start aptitude and from inside it press "u"

  or the corresponding button or menu item in your GUI package
  management program for updating.

3) install jitsi-meet

  on command line run `apt-get install jitsi-meet` or `aptitude install
  jitsi-meet` or in aptitude find (with "/") jitsi-meet and press "+"
  on it, after that press two times "g"

  (or use the button for installing on the GUI apt manager)

  The package should ask you for the domain name of the server -- it is
  the one that you'll be using as URL when accessing your Jitsi Meet
  with the web browser. Enter the domain name, press enter.

  That should be it -- now when you point a web browser to
  http://yourdomain.name you should be redirected to https and you
  should see your Jitsi Meet instance loaded.

For package removal remove (or purge) the package "jitsi-meet", it
should uninstall all the other ones.

If there are any errors, especially if you are sure they are a result
of the jitsi-meet installation, please write back to the list to
report them.

Any help in debugging and enhancing the packages with code snippets is
welcome too.

···

On Wed, 09 Jul 2014 14:57:03 +0300 Mr.Smith wrote:

is there a step-by-step "how to" available? (especially for not
advanced commandline people like me) ?

which *.deb files to install in which order etc
(I am running Debian testing 64bit )

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#5

Installation worked (!) however I am not able to open the entered domain
- chromium gives following error (on computer where installation
occurred and also on other computer):
The server at *jitmeet.xxxxxx.org* can't be found, because the DNS
lookup failed. DNS is the network service that translates a website's
name to its Internet address. This error is most often caused by having
no connection to the Internet or a misconfigured network. It can also be
caused by an unresponsive DNS server or a firewall
preventing Chromium from accessing the network.
Error code: DNS_PROBE_FINISHED_NXDOMAIN

are there any restrictions for the domain name etc?

MS

···

On 07/11/2014 03:02 PM, Yasen Pramatarov wrote:

On Wed, 9 Jul 2014 11:48:26 +0300 Yasen Pramatarov wrote:

We have beta versions of the deb packages needed to get Jitsi Meet
running and we'll be happy if you could give us a hand testing them
and telling us if something goes wrong.

The packages are in the Jitsi nightly repository
https://jitsi.org/Main/DebianNightlyRepository

You can get Jitsi Meet by marking for install the package
"jitsi-meet".

For now these are just amd64 packages, we'll be adding i386 shortly.

The install should work on Trusty, Jessie and Sid -- that means
anything above Debian Stable (Wheezy).

We have newer versions, you can test the packages by updating your
sources and installing the 'jitsi-meet' package.

as root:

apt-get update
apt-get install jitsi-meet

- it asks for hostname for the Jitsi Meet instance
- browse http://the-domainname-you-entered
- enjoy!

remove the packages with

apt-get remove jitsi-meet
or
apt-get purge jitsi-meet

- there is a bug in the removal script, it raises an error on first
   run, but you just run it twice and it should remove (or purge)
   everything (I'll fix that error later, sorry for the trouble).

Thanks for helping!
Happy testing!


#6

Here the output during synaptic installation (I have masked my domain):

(synaptic:19380): GLib-CRITICAL **: g_child_watch_add_full: assertion
'pid > 0' failed

Preconfiguring packages ...

Selecting previously unselected package jitsi-videobridge.

(Reading database ... 149756 files and directories currently installed.)

Preparing to unpack .../jitsi-videobridge_139-2_amd64.deb ...

Unpacking jitsi-videobridge (139-2) ...

Setting up jitsi-videobridge (139-2) ...

Warning: The home dir /usr/share/jitsi-videobridge you specified already
exists.

Adding system user `jvb' (UID 117) ...

Adding new group `jvb' (GID 127) ...

Adding new user `jvb' (UID 117) with group `jvb' ...

The home directory `/usr/share/jitsi-videobridge' already exists. Not
copying from `/etc/skel'.

Skipping adding existing rule

Skipping adding existing rule (v6)

Skipping adding existing rule

Skipping adding existing rule (v6)

Generating a 4096 bit RSA private key

......................................++

...................................................................................................++

writing new private key to '/var/lib/prosody/jitmeet.xxxxxx.org.key'

···

-----

[ ok ] Restarting Prosody XMPP Server: prosody.

Starting restund: restund.

[ ok ] Restarting Prosody XMPP Server: prosody.

insserv: warning: script 'K01restund' missing LSB tags and overrides

insserv: warning: script 'restund' missing LSB tags and overrides

insserv: warning: script 'K01restund' missing LSB tags and overrides

insserv: warning: script 'restund' missing LSB tags and overrides

Starting jitsi-videobridge: jvb.

Processing triggers for libc-bin (2.19-4) ...

Selecting previously unselected package jitsi-meet.

(Reading database ... 149814 files and directories currently installed.)

Preparing to unpack .../jitsi-meet_1.0.1-13_all.deb ...

Unpacking jitsi-meet (1.0.1-13) ...

Setting up jitsi-meet (1.0.1-13) ...

Skipping adding existing rule

Skipping adding existing rule (v6)

[ ok ] Restarting nginx: nginx.

On 07/11/2014 03:02 PM, Yasen Pramatarov wrote:

On Wed, 9 Jul 2014 11:48:26 +0300 Yasen Pramatarov wrote:

We have beta versions of the deb packages needed to get Jitsi Meet
running and we'll be happy if you could give us a hand testing them
and telling us if something goes wrong.

The packages are in the Jitsi nightly repository
https://jitsi.org/Main/DebianNightlyRepository

You can get Jitsi Meet by marking for install the package
"jitsi-meet".

For now these are just amd64 packages, we'll be adding i386 shortly.

The install should work on Trusty, Jessie and Sid -- that means
anything above Debian Stable (Wheezy).

We have newer versions, you can test the packages by updating your
sources and installing the 'jitsi-meet' package.

as root:

apt-get update
apt-get install jitsi-meet

- it asks for hostname for the Jitsi Meet instance
- browse http://the-domainname-you-entered
- enjoy!

remove the packages with

apt-get remove jitsi-meet
or
apt-get purge jitsi-meet

- there is a bug in the removal script, it raises an error on first
   run, but you just run it twice and it should remove (or purge)
   everything (I'll fix that error later, sorry for the trouble).

Thanks for helping!
Happy testing!


#7

So I followed these and received the following issues.
When doing apt-get update it says:
"GPG error: http://download.jitsi.org unstable/ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C697D823EB0AB654"

When doing the apt-get install jitsi-meet:
Err http://download.jitsi.org/nightly/deb/ unstable/ lua-socket-prosody 2.1.0-5~sid
  404 Not Found [IP: 130.79.200.22 80]
Err http://download.jitsi.org/nightly/deb/ unstable/ lua-sec-prosody 0.5.1-2~sid
  404 Not Found [IP: 130.79.200.22 80]
E: Failed to fetch http://download.jitsi.org/nightly/deb/unstable/lua-socket-prosody_2.1.0-5~sid_amd64.deb 404 Not Found [IP: 130.79.200.22 80]

E: Failed to fetch http://download.jitsi.org/nightly/deb/unstable/lua-sec-prosody_0.5.1-2~sid_amd64.deb 404 Not Found [IP: 130.79.200.22 80]

···

----------
Phillip Kenney

is there a step-by-step "how to" available? (especially for not
advanced commandline people like me) ?

which *.deb files to install in which order etc (I am running Debian
testing 64bit )

There is no step-by-step howto, but here is a short example of how to do it.

You need to mark for installation the package "jitsi-meet". The latest version of that package that is in the repo. It will install as dependencies all the other needed stuff.

You can do this on commandline, with aptitude's ncurses interface or a graphical installer of your choice. The steps are:

1) add the jitsi nightly repo to your apt sources

  open the file /etc/apt/sources.list as root (run
  `sudo mcedit /etc/apt/sources.list` or sth like that) and add the
  following line at the end of the file:

  deb http://download.jitsi.org/nightly/deb unstable/

  save the file and close it

2) update the package lists

  on command line:

   run `apt-get update` or `aptitude update`
   or start aptitude and from inside it press "u"

  or the corresponding button or menu item in your GUI package
  management program for updating.

3) install jitsi-meet

  on command line run `apt-get install jitsi-meet` or `aptitude install
  jitsi-meet` or in aptitude find (with "/") jitsi-meet and press "+"
  on it, after that press two times "g"

  (or use the button for installing on the GUI apt manager)

  The package should ask you for the domain name of the server -- it is
  the one that you'll be using as URL when accessing your Jitsi Meet
  with the web browser. Enter the domain name, press enter.

  That should be it -- now when you point a web browser to
  http://yourdomain.name you should be redirected to https and you
  should see your Jitsi Meet instance loaded.

For package removal remove (or purge) the package "jitsi-meet", it should uninstall all the other ones.

If there are any errors, especially if you are sure they are a result of the jitsi-meet installation, please write back to the list to report them.

Any help in debugging and enhancing the packages with code snippets is welcome too.

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#8

So I followed these and received the following issues.
When doing apt-get update it says:
"GPG error: http://download.jitsi.org unstable/ Release: The following
signatures couldn't be verified because the public key is not
available: NO_PUBKEY C697D823EB0AB654"

You can download the public key here:
https://download.jitsi.org/jitsi/nightly/debian/archive.key

Compare it with this
http://pgp.mit.edu/pks/lookup?op=get&search=0xC697D823EB0AB654

And import it after that with `apt-key add archive.key`

E: Failed to fetch
http://download.jitsi.org/nightly/deb/unstable/lua-socket-prosody_2.1.0-5~sid_amd64.deb
404 Not Found [IP: 130.79.200.22 80]

Sorry that was some sysadmin error, the files got deleted -- I
re-uploaded them and this should be ok now. I'll keep an eye on this.

Thanks for testing!

···

On Wed, 9 Jul 2014 14:22:36 +0000 Phillip Kenney wrote:

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#9

Hi Yasen,
installed as you indicated (THANKS a LOT) and it almost went through,
following error:

/var/lib: Is a directory
140362108319376:error:02001015:system library:fopen:Is a
directory:bss_file.c:398:fopen('/var/lib','w')
140362108319376:error:20074002:BIO routines:FILE_CTRL:system
lib:bss_file.c:400:
dpkg: error processing package jitsi-videobridge (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
jitsi-videobridge
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up jitsi-videobridge (137-1) ...
Skipping adding existing rule
Skipping adding existing rule (v6)
Skipping adding existing rule
Skipping adding existing rule (v6)
Generating a 4096 bit RSA private key
...............................................................................................................................................................................++
................................................................++
writing new private key to '/var/lib/prosody/sunflower.key'

···

-----
/var/lib: Is a directory
140387199194768:error:02001015:system library:fopen:Is a
directory:bss_file.c:398:fopen('/var/lib','w')
140387199194768:error:20074002:BIO routines:FILE_CTRL:system
lib:bss_file.c:400:
dpkg: error processing package jitsi-videobridge (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
jitsi-videobridge

---------------------------

I am running everything via Synaptic as root, using Debian testing 64bit
with LMDE repositories:
uname -a:
Linux linux 3.14-1-amd64 #1 SMP Debian 3.14.9-1 (2014-06-30) x86_64
GNU/Linux

MS

On 07/09/2014 03:22 PM, Yasen Pramatarov wrote:

On Wed, 09 Jul 2014 14:57:03 +0300 Mr.Smith wrote:

is there a step-by-step "how to" available? (especially for not
advanced commandline people like me) ?

which *.deb files to install in which order etc
(I am running Debian testing 64bit )

There is no step-by-step howto, but here is a short example of how to
do it.

You need to mark for installation the package "jitsi-meet". The latest
version of that package that is in the repo. It will install as
dependencies all the other needed stuff.

You can do this on commandline, with aptitude's ncurses interface or
a graphical installer of your choice. The steps are:

1) add the jitsi nightly repo to your apt sources

  open the file /etc/apt/sources.list as root (run
  `sudo mcedit /etc/apt/sources.list` or sth like that) and add the
  following line at the end of the file:

  deb http://download.jitsi.org/nightly/deb unstable/

  save the file and close it

2) update the package lists

  on command line:

   run `apt-get update` or `aptitude update`
   or start aptitude and from inside it press "u"

  or the corresponding button or menu item in your GUI package
  management program for updating.

3) install jitsi-meet

  on command line run `apt-get install jitsi-meet` or `aptitude install
  jitsi-meet` or in aptitude find (with "/") jitsi-meet and press "+"
  on it, after that press two times "g"

  (or use the button for installing on the GUI apt manager)

  The package should ask you for the domain name of the server -- it is
  the one that you'll be using as URL when accessing your Jitsi Meet
  with the web browser. Enter the domain name, press enter.

  That should be it -- now when you point a web browser to
  http://yourdomain.name you should be redirected to https and you
  should see your Jitsi Meet instance loaded.

For package removal remove (or purge) the package "jitsi-meet", it
should uninstall all the other ones.

If there are any errors, especially if you are sure they are a result
of the jitsi-meet installation, please write back to the list to
report them.

Any help in debugging and enhancing the packages with code snippets is
welcome too.


#10

No, no restrictions -- it just has to be resolvable. Maybe it was some
network error at your browser's end. If the DNS record is a new one,
the DNS zone maybe still hasn't been refreshed.

We don't pose any restrictions, it is just a name, but it has to be
reachable in order to work in the browser.

···

On Fri, 11 Jul 2014 16:32:04 +0300 Mr.Smith wrote:

Installation worked (!) however I am not able to open the entered
domain
- chromium gives following error (on computer where installation
occurred and also on other computer):
The server at *jitmeet.xxxxxx.org* can't be found, because the DNS
lookup failed. DNS is the network service that translates a website's
name to its Internet address. This error is most often caused by having
no connection to the Internet or a misconfigured network. It can also
be caused by an unresponsive DNS server or a firewall
preventing Chromium from accessing the network.
Error code: DNS_PROBE_FINISHED_NXDOMAIN

are there any restrictions for the domain name etc?

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#11

[...]

Great! Thanks!

It went smooth and now you can enjoy your Jitsi Meet (once you have
the dns issue in the other mail resolved).

BTW, once set up, you can install your own SSL certificate, if you
wish -- just have to edit the nginx conf in
/etc/nginx/sites-available/your-domain.conf and then reload your nginx
server with `/etc/init.d/nginx reload` as root.

This option to add custom SSL will be included in the config step of
the next version of the packages.

···

On Fri, 11 Jul 2014 16:35:46 +0300 Mr.Smith wrote:

Here the output during synaptic installation

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#12

So I followed these and received the following issues.
When doing apt-get update it says:
"GPG error: http://download.jitsi.org unstable/ Release: The following
signatures couldn't be verified because the public key is not
available: NO_PUBKEY C697D823EB0AB654"

You can download the public key here:
https://download.jitsi.org/jitsi/nightly/debian/archive.key

Compare it with this
http://pgp.mit.edu/pks/lookup?op=get&search=0xC697D823EB0AB654

Sorry, now I see they are different -- please ignore that part, you can
trust our https server that the archive.key file is authentic.

I know that is not very secure. We'll be working on fixing this.

···

On Wed, 9 Jul 2014 18:04:52 +0300 Yasen Pramatarov wrote:

On Wed, 9 Jul 2014 14:22:36 +0000 Phillip Kenney wrote:

And import it after that with `apt-key add archive.key`

E: Failed to fetch
http://download.jitsi.org/nightly/deb/unstable/lua-socket-prosody_2.1.0-5~sid_amd64.deb
404 Not Found [IP: 130.79.200.22 80]

Sorry that was some sysadmin error, the files got deleted -- I
re-uploaded them and this should be ok now. I'll keep an eye on this.

Thanks for testing!

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#13

Ok, got further.

Now it failed with:

/var/lib: Is a directory
140432731162272:error:02001015:system library:fopen:Is a directory:bss_file.c:398:fopen('/var/lib','w')
140432731162272:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:400:
dpkg: error processing package jitsi-videobridge (--configure):
subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.19-0ubuntu6) ...
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
jitsi-videobridge
E: Sub-process /usr/bin/dpkg returned an error code (1)

···

---------------
Phillip Kenney

-----Original Message-----
From: Yasen Pramatarov [mailto:yasen@bluejimp.com]
Sent: Wednesday, July 09, 2014 11:08 AM
To: Jitsi Developers
Cc: Phillip Kenney
Subject: Re: [jitsi-dev] Jitsi Meet .deb pkgs now available (amd64). Please help test!

On Wed, 9 Jul 2014 18:04:52 +0300 Yasen Pramatarov wrote:

On Wed, 9 Jul 2014 14:22:36 +0000 Phillip Kenney wrote:

So I followed these and received the following issues.
When doing apt-get update it says:
"GPG error: http://download.jitsi.org unstable/ Release: The following
signatures couldn't be verified because the public key is not
available: NO_PUBKEY C697D823EB0AB654"

You can download the public key here:
https://download.jitsi.org/jitsi/nightly/debian/archive.key

Compare it with this
http://pgp.mit.edu/pks/lookup?op=get&search=0xC697D823EB0AB654

Sorry, now I see they are different -- please ignore that part, you can trust our https server that the archive.key file is authentic.

I know that is not very secure. We'll be working on fixing this.

And import it after that with `apt-key add archive.key`

E: Failed to fetch
http://download.jitsi.org/nightly/deb/unstable/lua-socket-prosody_2.1.
0-5~sid_amd64.deb
404 Not Found [IP: 130.79.200.22 80]

Sorry that was some sysadmin error, the files got deleted -- I
re-uploaded them and this should be ok now. I'll keep an eye on this.

Thanks for testing!

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#14

That's strange. You are ruining this as root aren't you? You should run it as root.
If you are root and this persists, pls paste the whole output. Also what version of Debian or Ubuntu are you installing on?

···

On 09 юли 2014 18:21:30 Гриинуич+0300, Phillip Kenney <pkenney@KBHMAINE.ORG> wrote:

Ok, got further.

Now it failed with:

/var/lib: Is a directory
140432731162272:error:02001015:system library:fopen:Is a
directory:bss_file.c:398:fopen('/var/lib','w')
140432731162272:error:20074002:BIO routines:FILE_CTRL:system
lib:bss_file.c:400:
dpkg: error processing package jitsi-videobridge (--configure):
subprocess installed post-installation script returned error exit
status 1
Processing triggers for libc-bin (2.19-0ubuntu6) ...
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
jitsi-videobridge
E: Sub-process /usr/bin/dpkg returned an error code (1)

---------------
Phillip Kenney

-----Original Message-----
From: Yasen Pramatarov [mailto:yasen@bluejimp.com]
Sent: Wednesday, July 09, 2014 11:08 AM
To: Jitsi Developers
Cc: Phillip Kenney
Subject: Re: [jitsi-dev] Jitsi Meet .deb pkgs now available (amd64).
Please help test!

On Wed, 9 Jul 2014 18:04:52 +0300 Yasen Pramatarov wrote:

On Wed, 9 Jul 2014 14:22:36 +0000 Phillip Kenney wrote:

So I followed these and received the following issues.
When doing apt-get update it says:
"GPG error: http://download.jitsi.org unstable/ Release: The

following

signatures couldn't be verified because the public key is not
available: NO_PUBKEY C697D823EB0AB654"

You can download the public key here:
https://download.jitsi.org/jitsi/nightly/debian/archive.key

Compare it with this
http://pgp.mit.edu/pks/lookup?op=get&search=0xC697D823EB0AB654

Sorry, now I see they are different -- please ignore that part, you can
trust our https server that the archive.key file is authentic.

I know that is not very secure. We'll be working on fixing this.

And import it after that with `apt-key add archive.key`

E: Failed to fetch
http://download.jitsi.org/nightly/deb/unstable/lua-socket-prosody_2.1.
0-5~sid_amd64.deb
404 Not Found [IP: 130.79.200.22 80]

Sorry that was some sysadmin error, the files got deleted -- I
re-uploaded them and this should be ok now. I'll keep an eye on this.

Thanks for testing!

--
Yasen Pramatarov
sysadmin, https://jitsi.org

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#15

I got the problem -- the postinst file got a line truncated. I guess
it was while copying it between dev and build machines -- a totally
human error that I'm responsible for... Sorry!

I'll fix that and prepare next version for real tests this time, later
today. Thanks everyone for taking part :slight_smile:

···

On Wed, 9 Jul 2014 15:21:30 +0000 Phillip Kenney wrote:

/var/lib: Is a directory
140432731162272:error:02001015:system library:fopen:Is a
directory:bss_file.c:398:fopen('/var/lib','w')
140432731162272:error:20074002:BIO routines:FILE_CTRL:system
lib:bss_file.c:400: dpkg: error processing package jitsi-videobridge
(--configure):
subprocess installed post-installation script returned error exit
status 1

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#16

removal of videobridge failed:

(synaptic:17444): GLib-CRITICAL **: g_child_watch_add_full: assertion
'pid > 0' failed
(Reading database ... 149288 files and directories currently installed.)
Removing jitsi-videobridge (137-1) ...

Usage:
kill [options] <pid> [...]

Options:
<pid> [...] send signal to every <pid> listed
-<signal>, -s, --signal <signal>
                        specify the <signal> to be sent
-l, --list=[<signal>] list all signal names, or convert one to a name
-L, --table list all signal names in a nice table

-h, --help display this help and exit
-V, --version output version information and exit

For more details see kill(1).
dpkg: error processing package jitsi-videobridge (--remove):
subprocess installed post-removal script returned error exit status 123
Errors were encountered while processing:
jitsi-videobridge
E: Sub-process /usr/bin/dpkg returned an error c

···

On 07/09/2014 07:52 PM, Yasen Pramatarov wrote:

Yasen Pramatarov


#17

Thanks for testing!

It's strange that the install didn't work -- I tested all of it before
writing here, I guess maybe something changed while generating the
latest version of package "jitsi-videobridge"...

I'll investigate and will write again for tests.

Until then, you can deinstall this broken package and restore your
system by going to /var/lib/dpkg/info/jitsi-videobridge.postrm and
commenting out the line

`ps -u jvb -o pid h | xargs kill`

(it should be around line 23)

And after that trying again the package removal.

···

On Thu, 10 Jul 2014 07:47:45 +0300 Mr.Smith wrote:

removal of videobridge failed:

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#18

here the output of jitsi-videobridge.postrm:
(I will try to deinstall videobridge meanwhile)

#!/bin/sh
# postrm script for jitsi-videobridge
set -e
# Load debconf
. /usr/share/debconf/confmodule
case "$1" in
purge>remove)
# Clear the debconf variable
db_purge
# stop the jitsi-videobridge
if [ -x /etc/init.d/jitsi-videobridge ]; then
invoke-rc.d jitsi-videobridge stop
fi
# clear user and group
if getent passwd jvb > /dev/null ; then
`ps -u jvb -o pid h | xargs kill`
deluser jvb
fi
# clear logs
if [ -d "/var/log/jitsi" ]; then
rm -rf "/var/log/jitsi"
fi
;;
upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
;;
*)
echo "postrm called with unknown argument \`$1'" >&2
exit 1
;;
esac
# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.
# Automatically added by dh_makeshlibs
if [ "$1" = "remove" ]; then
ldconfig
fi
# End automatically added section
# Automatically added by dh_installinit
if [ "$1" = "purge" ] ; then
update-rc.d jitsi-videobridge remove >/dev/null
fi
# End automatically added section# Automatically added by dh_installdebconf
if [ "$1" = purge ] && [ -e /usr/share/debconf/confmodule ]; then
. /usr/share/debconf/confmodule
db_purge
fi
# End automatically added section
db_stop
exit 0

···

On 07/10/2014 11:23 AM, Yasen Pramatarov wrote:

On Thu, 10 Jul 2014 07:47:45 +0300 Mr.Smith wrote:

removal of videobridge failed:

Thanks for testing!

It's strange that the install didn't work -- I tested all of it before
writing here, I guess maybe something changed while generating the
latest version of package "jitsi-videobridge"...

I'll investigate and will write again for tests.

Until then, you can deinstall this broken package and restore your
system by going to /var/lib/dpkg/info/jitsi-videobridge.postrm and
commenting out the line

`ps -u jvb -o pid h | xargs kill`

(it should be around line 23)

And after that trying again the package removal.


#19

sorry for confusion!!

I opted out the described line and removed now videobridge successfully

pls let us know when we can repeat testing!

MS

···

On 07/10/2014 11:23 AM, Yasen Pramatarov wrote:

On Thu, 10 Jul 2014 07:47:45 +0300 Mr.Smith wrote:

removal of videobridge failed:

Thanks for testing!

It's strange that the install didn't work -- I tested all of it before
writing here, I guess maybe something changed while generating the
latest version of package "jitsi-videobridge"...

I'll investigate and will write again for tests.

Until then, you can deinstall this broken package and restore your
system by going to /var/lib/dpkg/info/jitsi-videobridge.postrm and
commenting out the line

`ps -u jvb -o pid h | xargs kill`

(it should be around line 23)

And after that trying again the package removal.


#20

here the output of jitsi-videobridge.postrm:
(I will try to deinstall videobridge meanwhile)

#!/bin/sh
# postrm script for jitsi-videobridge

[...]

># clear user and group
if getent passwd jvb > /dev/null ; then
`ps -u jvb -o pid h | xargs kill`

^^ this line should go away (comment it out or delete it) and you'll
remove the package

deluser jvb
fi
># clear logs
if [ -d "/var/log/jitsi" ]; then

[...]

BTW, no need to CC me, I'm on the list :slight_smile:

···

On Thu, 10 Jul 2014 12:12:18 +0300 Mr.Smith wrote:

--
Yasen Pramatarov
sysadmin, https://jitsi.org