[jitsi-dev] Jitsi meet ansible/docker install: non functional, blue screen?


#1

Hello,

I'm doing an install of jitsi meet with ansible
https://github.com/freedomofpress/ansible-role-jitsi-meet
(stable repo)
install and welcome page are OK but when connecting, I got black/blue
screen, I can't enable tchat (nickname field empty itself when validating)
I have the same result with following docker (unstable repo)
https://hub.docker.com/r/robertoandrade/jitsi-meet/

I tried to look for errors in /var/log but didn't find anything significant?
how can I debug this?

test instance at
https://138.197.131.32.nip.io

$ grep SEVERE /var/log/jitsi/jicofo.log
Jicofo 2016-11-19 04:46:29.518 SEVERE: [17]
org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
connection temporary
Jicofo 2016-11-19 04:46:29.693 SEVERE: [30]
org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException:
Connection refused (Connection refused), host:localhost, port:5347
Jicofo 2016-11-19 04:51:09.441 SEVERE: [17]
org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
connection temporary
Jicofo 2016-11-19 04:51:09.462 SEVERE: [17]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() XMPP connection
closed on error: stream:error (text)
Jicofo 2016-11-19 12:28:23.118 SEVERE: [36]
org.jitsi.jicofo.JitsiMeetConference.onMemberLeft().747 Member not found
for cooltreesburnexpectantly@conference.138.197.131.32.xip.io/558ddce2

$ grep SEVERE /var/log/jitsi/jvb.log |tail -3
JVB 2016-11-20 14:31:31.544 SEVERE: [27]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347
JVB 2016-11-20 14:31:36.547 SEVERE: [27]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347
JVB 2016-11-20 14:31:41.550 SEVERE: [27]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347

binding seems correct

$ netstat -anp |grep 5347
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN
     9438/lua5.1
tcp 0 0 127.0.0.1:5347 127.0.0.1:42384
ESTABLISHED 9438/lua5.1
tcp6 0 0 ::1:5347 :::* LISTEN
     9438/lua5.1
tcp6 0 0 127.0.0.1:42384 127.0.0.1:5347
ESTABLISHED 9464/java
$ getent hosts localhost
::1 localhost

A note, Chrome or Firefox return javascript errors in console like:

- (TIME) index.html loaded: 1649.1100000000001
- 159.203.39.62.xip.io/:70 Uncaught ReferenceError: True is not defined(…)
do_external_connect.js:23 Uncaught TypeError: Cannot read property
'externalConnectUrl' of undefined(…)
- Logger.js:89[modules/RTC/RTCBrowserType.js] <Array.r>: This appears to
be Chrome, ver: 54
- aui.min.js:1DEPRECATED JS - Cookie has been deprecated since 5.8.0 and
will be removed in a future release. Use cookie instead.
     at assign (<anonymous>)n @ aui.min.js:1
- VideoLayout.js:16Uncaught TypeError: Cannot read property 'channelLastN'
of undefined(…)

Thanks

Ju


#2

Hi,

It seems nginx is not correctly configured for the bosh urls:

Request URL: https://138.197.131.32.nip.io/http-bind?room=memorablepenguinsblossomvanishingly
Request Method: POST
Status Code: 404 Not Found

Checkout your nginx config for:
https://github.com/jitsi/jitsi-meet/blob/master/doc/debian/jitsi-meet/jitsi-meet.example#L42

What I see from the docker file it is using the old debian repo "deb
http://download.jitsi.org/nightly/deb unstable/", the new one is "deb
http://download.jitsi.org unstable/".

Regards
damencho

···

On Sun, Nov 20, 2016 at 8:43 AM, Julien T <julien.t43@gmail.com> wrote:

Hello,

I'm doing an install of jitsi meet with ansible
https://github.com/freedomofpress/ansible-role-jitsi-meet
(stable repo)
install and welcome page are OK but when connecting, I got black/blue
screen, I can't enable tchat (nickname field empty itself when validating)
I have the same result with following docker (unstable repo)
https://hub.docker.com/r/robertoandrade/jitsi-meet/

I tried to look for errors in /var/log but didn't find anything significant?
how can I debug this?

test instance at
https://138.197.131.32.nip.io

$ grep SEVERE /var/log/jitsi/jicofo.log
Jicofo 2016-11-19 04:46:29.518 SEVERE: [17]
org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
connection temporary
Jicofo 2016-11-19 04:46:29.693 SEVERE: [30]
org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException:
Connection refused (Connection refused), host:localhost, port:5347
Jicofo 2016-11-19 04:51:09.441 SEVERE: [17]
org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
connection temporary
Jicofo 2016-11-19 04:51:09.462 SEVERE: [17]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() XMPP connection
closed on error: stream:error (text)
Jicofo 2016-11-19 12:28:23.118 SEVERE: [36]
org.jitsi.jicofo.JitsiMeetConference.onMemberLeft().747 Member not found for
cooltreesburnexpectantly@conference.138.197.131.32.xip.io/558ddce2

$ grep SEVERE /var/log/jitsi/jvb.log |tail -3
JVB 2016-11-20 14:31:31.544 SEVERE: [27]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347
JVB 2016-11-20 14:31:36.547 SEVERE: [27]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347
JVB 2016-11-20 14:31:41.550 SEVERE: [27]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347

binding seems correct

$ netstat -anp |grep 5347
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN
9438/lua5.1
tcp 0 0 127.0.0.1:5347 127.0.0.1:42384
ESTABLISHED 9438/lua5.1
tcp6 0 0 ::1:5347 :::* LISTEN
9438/lua5.1
tcp6 0 0 127.0.0.1:42384 127.0.0.1:5347
ESTABLISHED 9464/java
$ getent hosts localhost
::1 localhost

A note, Chrome or Firefox return javascript errors in console like:

- (TIME) index.html loaded: 1649.1100000000001
- 159.203.39.62.xip.io/:70 Uncaught ReferenceError: True is not defined(…)
do_external_connect.js:23 Uncaught TypeError: Cannot read property
'externalConnectUrl' of undefined(…)
- Logger.js:89[modules/RTC/RTCBrowserType.js] <Array.r>: This appears to be
Chrome, ver: 54
- aui.min.js:1DEPRECATED JS - Cookie has been deprecated since 5.8.0 and
will be removed in a future release. Use cookie instead.
     at assign (<anonymous>)n @ aui.min.js:1
- VideoLayout.js:16Uncaught TypeError: Cannot read property 'channelLastN'
of undefined(…)

Thanks

Ju

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

​Hello Damian,

Thanks for the pointer!
In the end, it was not nginx but prosody which was strangely not configured
for the right virtualhost.
there was also an optional task messing up with interface_config.js

I put an issue on the Dockerfile repository not up to date.

Thanks