[jitsi-dev] jitsi meet android app menu buttons very buggy


#1

Hi all,

I just compiled from today's git and I've noticed that the android app
seems to be rather buggy.
I'm testing on a Galaxy Tab A (2016) SM-T580 running stock 6.0.1 and the
menu buttons don't show up, or only show up randomly. Pressing around the
screen they tend to show up and disappear rather quickly.

The same happens on an S6 edge (SM-G925F) running 7.0 and on another friend
that's running older version of Android (not sure whiich one).

Has anyone else experienced this? The contrast with the iOS app couldn't be
greater. The iOS app runs flawlessly and the menu buttons show up as
expected when you touch the screen.
It would be great to get the same smooth experience on Android.

Is this a known issue or should I open a ticket on github?

Cheers,
Peter


#2

Thank you for the feedback!

As the app is written in React Native, both Android and iOS are
executing the (pretty much) same JavaScript source code. Especially in
the department of toolbox, that's even more true.

We've observed a redrawing issue on Android though which we presume is
related to the interaction of react-native-webrtc's EGL video renderer
and react-native's widgets on top of it. Basically, the toolbox
redraws partially, if at all.

Anyway, you may be observing something else.

···

On Thu, May 4, 2017 at 3:22 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

I just compiled from today's git and I've noticed that the android app seems
to be rather buggy.
I'm testing on a Galaxy Tab A (2016) SM-T580 running stock 6.0.1 and the
menu buttons don't show up, or only show up randomly. Pressing around the
screen they tend to show up and disappear rather quickly.

The same happens on an S6 edge (SM-G925F) running 7.0 and on another friend
that's running older version of Android (not sure whiich one).

Has anyone else experienced this? The contrast with the iOS app couldn't be
greater. The iOS app runs flawlessly and the menu buttons show up as
expected when you touch the screen.
It would be great to get the same smooth experience on Android.

Is this a known issue or should I open a ticket on github?


#3

No worries. It seems there aren't many testers yet. Glad to be able to give
back to a great community.

Anyway, my S6 is rooted, so tomorrow, if I find some time, I'll turn on
logcat and see if I can get some backtraces for you.

Cheers

···

On Thu, May 4, 2017 at 9:34 PM, Lyubomir Marinov <lyubomir.marinov@jitsi.org > wrote:

On Thu, May 4, 2017 at 3:22 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
> I just compiled from today's git and I've noticed that the android app
seems
> to be rather buggy.
> I'm testing on a Galaxy Tab A (2016) SM-T580 running stock 6.0.1 and the
> menu buttons don't show up, or only show up randomly. Pressing around the
> screen they tend to show up and disappear rather quickly.
>
> The same happens on an S6 edge (SM-G925F) running 7.0 and on another
friend
> that's running older version of Android (not sure whiich one).
>
> Has anyone else experienced this? The contrast with the iOS app couldn't
be
> greater. The iOS app runs flawlessly and the menu buttons show up as
> expected when you touch the screen.
> It would be great to get the same smooth experience on Android.
>
> Is this a known issue or should I open a ticket on github?

Thank you for the feedback!

As the app is written in React Native, both Android and iOS are
executing the (pretty much) same JavaScript source code. Especially in
the department of toolbox, that's even more true.

We've observed a redrawing issue on Android though which we presume is
related to the interaction of react-native-webrtc's EGL video renderer
and react-native's widgets on top of it. Basically, the toolbox
redraws partially, if at all.

Anyway, you may be observing something else.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Just opened issue #1557 regarding this

···

On Thu, May 4, 2017 at 9:57 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

No worries. It seems there aren't many testers yet. Glad to be able to
give back to a great community.

Anyway, my S6 is rooted, so tomorrow, if I find some time, I'll turn on
logcat and see if I can get some backtraces for you.

Cheers

On Thu, May 4, 2017 at 9:34 PM, Lyubomir Marinov < > lyubomir.marinov@jitsi.org> wrote:

On Thu, May 4, 2017 at 3:22 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:
> I just compiled from today's git and I've noticed that the android app
seems
> to be rather buggy.
> I'm testing on a Galaxy Tab A (2016) SM-T580 running stock 6.0.1 and the
> menu buttons don't show up, or only show up randomly. Pressing around
the
> screen they tend to show up and disappear rather quickly.
>
> The same happens on an S6 edge (SM-G925F) running 7.0 and on another
friend
> that's running older version of Android (not sure whiich one).
>
> Has anyone else experienced this? The contrast with the iOS app
couldn't be
> greater. The iOS app runs flawlessly and the menu buttons show up as
> expected when you touch the screen.
> It would be great to get the same smooth experience on Android.
>
> Is this a known issue or should I open a ticket on github?

Thank you for the feedback!

As the app is written in React Native, both Android and iOS are
executing the (pretty much) same JavaScript source code. Especially in
the department of toolbox, that's even more true.

We've observed a redrawing issue on Android though which we presume is
related to the interaction of react-native-webrtc's EGL video renderer
and react-native's widgets on top of it. Basically, the toolbox
redraws partially, if at all.

Anyway, you may be observing something else.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev