[jitsi-dev] jitsi-meet and strophe


#1

Hi Fippo,

I'm making the latest changes to submit Debian packages for jitsi-meet
and jitsi-videobridge to their repository. One last thing left to be
fixed and its about an error caused by the fact that strophe lib is
compressed, which is considered as binary file in the sources.
I downloaded the archive for the tag version v1.1.3 and compress it
using yui compressor and then the resulted file strophe.min.js is
different from the one that is currently in the repo
strophe.jingle.bundle.js, is this ok?

I tested using strophe.min.js and it seems to work just fine. Will make the
debuild always compress the file before including it in the result deb
package.

Thanks
damencho


#2

hey Damian,

> I'm making the latest changes to submit Debian packages for jitsi-meet

and jitsi-videobridge to their repository. One last thing left to be
fixed and its about an error caused by the fact that strophe lib is
compressed, which is considered as binary file in the sources.
I downloaded the archive for the tag version v1.1.3 and compress it
using yui compressor and then the resulted file strophe.min.js is
different from the one that is currently in the repo
strophe.jingle.bundle.js, is this ok?

I tested using strophe.min.js and it seems to work just fine. Will make
the debuild always compress the file before including it in the result
deb package.

sounds good. I think the version currently shipped is based on a very old strophe version so +1 for upgrading that. This might even give us websocket-support

I'd recommend renaming it to strophe.min.js -- strophe.jingle.bundle.js is somewhat misleading since the jingle plugin is not included there.

cheers

philipp