[jitsi-dev] Jitsi linux installer error on install


#1

Hi All,

I got error on installing jitsi on linux, as some instruction on Internet I followed the instruction how to create linux installer.
I was using windows to create installer with cygwin.

I success on creating installer Jitsi-1.1.0-0.build.by.SVN-linux.bin, but on installing from terminal I got error.

This is how I ran the installer:
dedy@dedy-laptop:~/Documents$ chmod +x Jitsi-1.1.0-0.build.by.SVN-linux.bin
dedy@dedy-laptop:~/Documents$ ./Jitsi-1.1.0-0.build.by.SVN-linux.bin

SIP Communicator 1.0.draft - starting installation... please wait

Then this dialog box dispalyed:

After select OK, then this error appear:
java.lang.ClassNotFoundException: com.izforge.izpack.panels.HelloPanel2
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at com.izforge.izpack.installer.InstallerFrame.loadPanels(Unknown Source)
at com.izforge.izpack.installer.InstallerFrame.<init>(Unknown Source)
at com.izforge.izpack.installer.GUIInstaller.loadGUI(Unknown Source)
at com.izforge.izpack.installer.GUIInstaller.access$100(Unknown Source)
at com.izforge.izpack.installer.GUIInstaller$2.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

I was thinking that this Jitsi depend on izpack package, was that true?
Please help.

Thanks/Rgds


#2

Just FYI,

We are no longer supporting the bin installers. You are of course still
welcome to post questions here in case others have also seen similar
problems and can help with a fix but I thought I'd mention this so that
you won't be surprised in case no one answers.

Cheers,
Emil

···

On 06.09.12, 09:28, Dedy Julius wrote:

Hi All,

I got error on installing jitsi on linux, as some instruction on
Internet I followed the instruction how to create linux installer.
I was using windows to create installer with cygwin.
I success on creating installer Jitsi-1.1.0-0.build.by.SVN-linux.bin,
but on installing from terminal I got error.

This is how I ran the installer:
dedy@dedy-laptop:~/Documents$ chmod +x Jitsi-1.1.0-0.build.by.SVN-linux.bin
dedy@dedy-laptop:~/Documents$ ./Jitsi-1.1.0-0.build.by.SVN-linux.bin
SIP Communicator 1.0.draft - starting installation... please wait

Then this dialog box dispalyed:

After select OK, then this error appear:
java.lang.ClassNotFoundException: com.izforge.izpack.panels.HelloPanel2
    at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:169)
    at com.izforge.izpack.installer.InstallerFrame.loadPanels(Unknown
Source)
    at com.izforge.izpack.installer.InstallerFrame.<init>(Unknown Source)
    at com.izforge.izpack.installer.GUIInstaller.loadGUI(Unknown Source)
    at com.izforge.izpack.installer.GUIInstaller.access$100(Unknown Source)
    at com.izforge.izpack.installer.GUIInstaller$2.run(Unknown Source)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
    at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
    at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
    at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

I was thinking that this Jitsi depend on izpack package, was that true?
Please help.

Thanks/Rgds

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#3

Hi Emil,

Tx for answered my question.
But, jitsi still support for linux(ubuntu/debian), doesnt it?
If it does, can you gimme a clue? I dont know maybe its a .deb installer or else..

Thanks/Rgds

···

________________________________
From: Emil Ivov <emcho@jitsi.org>
To: Dedy Julius <dedy_jlsn@yahoo.com>
Cc: "dev@jitsi.java.net" <dev@jitsi.java.net>
Sent: Saturday, September 8, 2012 10:58 PM
Subject: Re: [jitsi-dev] Jitsi linux installer error on install

Just FYI,

We are no longer supporting the bin installers. You are of course still
welcome to post questions here in case others have also seen similar
problems and can help with a fix but I thought I'd mention this so that
you won't be surprised in case no one answers.

Cheers,
Emil

On 06.09.12, 09:28, Dedy Julius wrote:

Hi All,

I got error on installing jitsi on linux, as some instruction on
Internet I followed the instruction how to create linux installer.
I was using windows to create installer with cygwin.
I success on creating installer Jitsi-1.1.0-0.build.by.SVN-linux.bin,
but on installing from terminal I got error.

This is how I ran the installer:
dedy@dedy-laptop:~/Documents$ chmod +x Jitsi-1.1.0-0.build.by.SVN-linux.bin
dedy@dedy-laptop:~/Documents$ ./Jitsi-1.1.0-0.build.by.SVN-linux.bin
SIP Communicator 1.0.draft - starting installation... please wait

Then this dialog box dispalyed:

After select OK, then this error appear:
java.lang.ClassNotFoundException: com.izforge.izpack.panels.HelloPanel2
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at com.izforge.izpack.installer.InstallerFrame.loadPanels(Unknown
Source)
at com.izforge.izpack.installer.InstallerFrame.<init>(Unknown Source)
at com.izforge.izpack.installer.GUIInstaller.loadGUI(Unknown Source)
at com.izforge.izpack.installer.GUIInstaller.access$100(Unknown Source)
at com.izforge.izpack.installer.GUIInstaller$2.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

I was thinking that this Jitsi depend on izpack package, was that true?
Please help.

Thanks/Rgds

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#4

Hi,

If you go to https://jitsi.org/index.php/Main/Download

you can see the downloads available for Ubuntu.

There is also a hint how to install jitsi into your repository sources
so updates will be done automatically, either from stable or
nightly branch.

Regards, Earl

···

On 2012_09_10 05:01, Dedy Julius wrote:

Hi Emil,

Tx for answered my question.
But, jitsi still support for linux(ubuntu/debian), doesnt it?
If it does, can you gimme a clue? I dont know maybe its a .deb installer or else..

Thanks/Rgds

------------------------------------------------------------------------
*From:* Emil Ivov <emcho@jitsi.org>
*To:* Dedy Julius <dedy_jlsn@yahoo.com>
*Cc:* "dev@jitsi.java.net" <dev@jitsi.java.net>
*Sent:* Saturday, September 8, 2012 10:58 PM
*Subject:* Re: [jitsi-dev] Jitsi linux installer error on install

Just FYI,

We are no longer supporting the bin installers. You are of course still
welcome to post questions here in case others have also seen similar
problems and can help with a fix but I thought I'd mention this so that
you won't be surprised in case no one answers.

Cheers,
Emil

On 06.09.12, 09:28, Dedy Julius wrote:
> Hi All,
>
> I got error on installing jitsi on linux, as some instruction on
> Internet I followed the instruction how to create linux installer.
> I was using windows to create installer with cygwin.
> I success on creating installer Jitsi-1.1.0-0.build.by.SVN-linux.bin,
> but on installing from terminal I got error.
>
> This is how I ran the installer:
> dedy@dedy-laptop:~/Documents$ chmod +x Jitsi-1.1.0-0.build.by.SVN-linux.bin
> dedy@dedy-laptop:~/Documents$ ./Jitsi-1.1.0-0.build.by.SVN-linux.bin
> SIP Communicator 1.0.draft - starting installation... please wait
>
> Then this dialog box dispalyed:
>
> After select OK, then this error appear:
> java.lang.ClassNotFoundException: com.izforge.izpack.panels.HelloPanel2
> at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
> at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
> at java.lang.Class.forName0(Native Method)
> at java.lang.Class.forName(Class.java:169)
> at com.izforge.izpack.installer.InstallerFrame.loadPanels(Unknown
> Source)
> at com.izforge.izpack.installer.InstallerFrame.<init>(Unknown Source)
> at com.izforge.izpack.installer.GUIInstaller.loadGUI(Unknown Source)
> at com.izforge.izpack.installer.GUIInstaller.access$100(Unknown Source)
> at com.izforge.izpack.installer.GUIInstaller$2.run(Unknown Source)
> at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
> at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
> at
> java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
> at
> java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
> at
> java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
> at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
> at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
> at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
>
> I was thinking that this Jitsi depend on izpack package, was that true?
> Please help.
>
> Thanks/Rgds

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org <mailto:emcho@jitsi.org> PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#5

Adding to what Earl said,

Installing the first deb would also automatically add Jitsi's stable
build line to your sources so you don't need to do anything to stay up
to date.

You'd only need to manually update your source list if you'd like to
keep up with the nightly builds.

Cheers,
Emil

···

On 10.09.12, 19:54, Earl wrote:

Hi,

If you go to https://jitsi.org/index.php/Main/Download

you can see the downloads available for Ubuntu.

There is also a hint how to install jitsi into your repository sources
so updates will be done automatically, either from stable or
nightly branch.

Regards, Earl

On 2012_09_10 05:01, Dedy Julius wrote:

Hi Emil,

Tx for answered my question.
But, jitsi still support for linux(ubuntu/debian), doesnt it?
If it does, can you gimme a clue? I dont know maybe its a .deb
installer or else..

Thanks/Rgds

------------------------------------------------------------------------
*From:* Emil Ivov <emcho@jitsi.org>
*To:* Dedy Julius <dedy_jlsn@yahoo.com>
*Cc:* "dev@jitsi.java.net" <dev@jitsi.java.net>
*Sent:* Saturday, September 8, 2012 10:58 PM
*Subject:* Re: [jitsi-dev] Jitsi linux installer error on install

Just FYI,

We are no longer supporting the bin installers. You are of course still
welcome to post questions here in case others have also seen similar
problems and can help with a fix but I thought I'd mention this so that
you won't be surprised in case no one answers.

Cheers,
Emil

On 06.09.12, 09:28, Dedy Julius wrote:

Hi All,

I got error on installing jitsi on linux, as some instruction on
Internet I followed the instruction how to create linux installer.
I was using windows to create installer with cygwin.
I success on creating installer Jitsi-1.1.0-0.build.by.SVN-linux.bin,
but on installing from terminal I got error.

This is how I ran the installer:
dedy@dedy-laptop:~/Documents$ chmod +x

Jitsi-1.1.0-0.build.by.SVN-linux.bin

dedy@dedy-laptop:~/Documents$ ./Jitsi-1.1.0-0.build.by.SVN-linux.bin
SIP Communicator 1.0.draft - starting installation... please wait

Then this dialog box dispalyed:

After select OK, then this error appear:
java.lang.ClassNotFoundException: com.izforge.izpack.panels.HelloPanel2
   at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
   at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
   at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
   at java.lang.Class.forName0(Native Method)
   at java.lang.Class.forName(Class.java:169)
   at com.izforge.izpack.installer.InstallerFrame.loadPanels(Unknown
Source)
   at com.izforge.izpack.installer.InstallerFrame.<init>(Unknown Source)
   at com.izforge.izpack.installer.GUIInstaller.loadGUI(Unknown Source)
   at com.izforge.izpack.installer.GUIInstaller.access$100(Unknown

Source)

   at com.izforge.izpack.installer.GUIInstaller$2.run(Unknown Source)
   at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
   at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
   at

java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)

   at

java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)

   at

java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)

   at

java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)

   at

java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)

   at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

I was thinking that this Jitsi depend on izpack package, was that true?
Please help.

Thanks/Rgds

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org <mailto:emcho@jitsi.org> PHONE:
+33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31