[jitsi-dev] [jitsi/jitsi-videobridge] Set up the pinned endpoints in a conference if a new peer enters (#215)


#1

Selected endpoints are set correctly if a peer uses the receive-simulcast-layer attribute in the channel IQ
You can view, comment on, or merge this pull request online at:

  https://github.com/jitsi/jitsi-videobridge/pull/215

-- Commit Summary --

  * Set up the pinned endpoints in a conference if a new peer enters

-- File Changes --

    M src/main/java/org/jitsi/videobridge/Endpoint.java (10)
    M src/main/java/org/jitsi/videobridge/Videobridge.java (61)
    M src/main/java/org/jitsi/videobridge/simulcast/SimulcastReceiver.java (23)

-- Patch Links --

https://github.com/jitsi/jitsi-videobridge/pull/215.patch
https://github.com/jitsi/jitsi-videobridge/pull/215.diff

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/215


#2

Can someone help me with this?
I can't find out what is the problem with this. The build work for me and I can't find the output of jenkins.

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/215#issuecomment-211913276


#3

Jenkins, test this please

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/215#issuecomment-211930906


#4

Hi @varrocs, I'm thinking that maybe this is fixed by https://github.com/jitsi/jitsi-videobridge/commit/5f47f13c03a2af7e98fa310a93bbc6d1e5f4d31e. Could you please try with a recent bridge >= 725 and check if this is still valid?

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/215#issuecomment-215115572


#5

I'm sorry, I meant this https://github.com/jitsi/jitsi-videobridge/commit/f941a25f460aed074da74fbdd484fab7fa982670

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/215#issuecomment-215115888


#6

I've just tried it with the latest version and it is working.
We'll run some test for that later.

Thanks

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/215#issuecomment-215120670


#7

Closed #215.

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/215#event-643061978