[jitsi-dev] [jitsi/jitsi] OPUS "Use inband FEC" setting is ignored by jitsi (#272)


#1

Despite having the "Use inband FEC" setting set, the following SDP is generated on INVITEs originated from jitsi:

v=0
o=3162030020-jitsi.org 0 0 IN IP4 XXX.XXX.XXX.XXX
s=-
c=IN IP4 XXX.XXX.XXX.XXX
t=0 0
m=audio 5024 RTP/AVP 0
a=rtpmap:0 PCMU/8000
a=extmap:1 urn:ietf:params:rtp-hdrext:csrc-audio-level
a=extmap:2 urn:ietf:params:rtp-hdrext:ssrc-audio-level
a=rtcp-xr:voip-metrics

There is no `useinbandfec=1` header as is expected for notifying the use of inband FEC. This was seen when using nightly build 2.9.5519

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/272


#2

If I remember correctly, we don't implement the full negotiation logic. The "Use inband FEC" setting enables FEC for our encoder (and forces it, by lying to the encoder that there is constant 1% packet loss, unless you override net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.MIN_EXPECTED_PACKET_LOSS).

The useinbandfec parameter is [used to signal support (or lack thereof) on the decoder side](https://tools.ietf.org/html/rfc7587#section-6). We do support it, so we should include the parameter regardless of the settings.

···

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/272#issuecomment-225905077