[jitsi-dev] [jitsi] Jitsi doesn't easily conects to ostel.co (#99)


#1

I discussed this on the Jitsi mailing lists and the link to that discussion is: http://lists.jitsi.org/pipermail/users/2013-July/004770.html
I was instructed to report this bug in the users e-mail list. Several
people agreed that it is indeed a bug, including user BitMessage
(message in Wed, 31 Jul 2013 10:32:15 +0930) and Boris Grozev (message
sent in Wed, 31 Jul 2013 09:35:57 +0300)
Jitsi has been working just fine with jabber servers. But when it
comes to using ostel.co as SIP server, I've been experiencing the
exact same issue described here:
https://guardianproject.info/2013/07/22/jitsi-ostel-co-and-isp-censorship/
I can sucessfully use ostel.co in my phone, using CSIPSimple as
client, in the same home/work/3G networks I use in my windows PC.
According to Boris, the workaround mentioned in the link above
shouldn't be necessary, and, actually, in a clean fresh install it
isn't. As he says:
"The problem seems to be that just going to Options->Advanced->SIP and
changing the focus between the two text fields makes jitsi change it's
configuration to always use 5060/5061 as the source ports for SIP. And
there is no way to go back to the default, which is to not use a
specific port at all."
The workaround works to me, but people seems to agree that something
could be changed in order to make it possible not to need the
workaround, making it easier for users with no technical expertise,
and also making Jitsi work like CSIPSimple (which doesn't need
workarounds).
By the way, the interface could be more intuitive. I took some days to
find Options->Advanced->SIP, since Options->Account settings->Edit
Account->Conection tab->Registrar Port seemed to be the right place to
make the workaround, but it wasn't. I still don't know what the last
one is for.

(Issue migrated from https://trac.jitsi.org/ticket/1193)

ยทยทยท

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/99