[jitsi-dev] [jitsi] Jitsi crashing in windows traced back to run.c (#229)


#1

I have narrowed it down to run.c when it tries to do the JNI call.

The following commit seems to be partially responsible. I can fiddle with the sofware in /jre and get it to work by trying things like copying files to other directories or using 64bit Java. It all seems to be related to JNI. Also when I remove this commit I can get a more graceful crash as opposed to a hard crash when the splash screen comes up.

I have tried many different version of everything in my development environment. I have also verfied all my paths and dependencies are ok. It all comes back to run.c

http://code.metager.de/source/diff/jitsi/src/native/windows/run/run.c?r1=/jitsi/src/native/windows/run/run.c@f7361e133800b3b3c0de5c22e9d2e494194e84c3&r2=/jitsi/src/native/windows/run/run.c@dc1c301d2d23a469da8f0cde5bcdf5183232b3a9&format=s&full=0

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229


#2

There's nothing special in there. Have you verified that the `runtimeLib` and `javaHome` arguments in `Run_runJavaFromRuntimeLib` are what they should be? I'm suspecting that these point to a 64bit JRE.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#issuecomment-190071056


#3

Thank you for the response. Based on your advice I tried creating a 64bit installer which worked perfectly. Using the same setup I tried creating a 32bit installer making sure to change my paths to all 32 development software including JDK and embedded JRE. It still won't work and I cannot find any 64bit paths or software anywhere other than my OS.

I went so far as to uninstall all 64bit development software including JDK ,JRE and Eclipse and TDM64 GCC. Even with all 32bit develpment sofware I cannot get it to work. My next step would be to try set this all up on a 32bit Windows OS which I don't have. I guess I will have to keep looking for the root cause on 64bit OS.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#issuecomment-190332215


#4

I removed the -O2 compiler flag and now I see it is getting as far as loading Java bundles. The splash screen freezes on "NimbuzzAvatars". So it is running SIPCommunicator.java and getting as far as org.apache.felix.main.Java.

The only thing I find related to that error is this. I confirmed my load order is 13 as per that fix.
https://github.com/jitsi/jitsi/commit/f5dc6edede237288d6b09dddcabd1ed47f55c8c2

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#issuecomment-190537435


#5

I had looked for that but there is no folder or file with that name or any similar name. I also did a drive and registry search.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#issuecomment-190768774


#6

You'll need to get access to what Java is printing to STDOUT. You can e.g. change SIPCommunicator.java (near the end of the main(...) method) to print this into a file.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#issuecomment-190770324


#7

If I run jitsi.exe that was compiled without the -O2 flag it installs and runs on Windows 7 32bit. If I compile with the -O2 flag it crashes the same as it does on Windows 10 64bit.

I found this line in SIPCommunicator.java
    System.setOut(new ScStdOut(System.out));
and had a look at ScStdOut.java and read all the comments in the file but it's not clear to me what I should do here to print out STDOUT.

This still looks like it could be a JNI issue to me because if I remove that code as explained in my first post it will work.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#issuecomment-191959890


#8

I managed to get my 32bit compiled version running on Win10 64bit. It requires a combination of using a slightly older embedded JRE (JRE8u40) in combination with removing the -O2 CPPFLAG from ./src/native/windows/run/Makefile.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#issuecomment-192048839


#9

I thought I had everything working. I have 32bit app working on windows 7 32bit and Windows 10 32bit. I have 64bit app working on Windows 10 64bit.

However, I cannot get the exact same 32 or 64bit apps working on Windows 7 64bit. Freezes at splash screen.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#issuecomment-192995894


#10

I have it working on Win 7 64 now. When my development environment is Win 7 64bit it works. When my development environment is Win 10 it doesn't seem to be portable to Win 7 64bit.

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#issuecomment-193025743


#11

The Jitsi releases are built on Windows 7 64bit, using cygwin.
32bit compiler: gcc version 4.5.2 (tdm-1)
64bit compiler: gcc version 4.5.2 (tdm64-1)
Embedded JRE: 8.0.40.25

I don't know what else could be the problem, so I'm closing this issue.

···

---
You are receiving this because you commented.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#issuecomment-219230796


#12

Closed #229.

···

---
You are receiving this because you commented.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/229#event-660763334


#13

Try removing your sip-communicator.bin folder that is in your home folder
and try starting again.

···

On Mon, Feb 29, 2016 at 10:32 PM, powerpbx <notifications@github.com> wrote:

I removed the -O2 compiler flag and now I see it is getting as far as
loading Java bundles. The splash screen freezes on "NimbuzzAvatars". So it
is running SIPCommunicator.java and getting as far as
org.apache.felix.main.Java.

The only thing I find related to that error is this. I confirmed my load
order is 13 as per that fix.
f5dc6ed
<https://github.com/jitsi/jitsi/commit/f5dc6edede237288d6b09dddcabd1ed47f55c8c2>


Reply to this email directly or view it on GitHub
<https://github.com/jitsi/jitsi/issues/229#issuecomment-190537435>.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev