[jitsi-dev] [jitsi] IPv6 SDP problems (#170)


#1

I have two machines both running dual-stack IPv4 and IPv6

I make a SIP call from the softphone on one machine to Jitsi on the other machine

In the SDP offer from the caller, the "c=" line contains "IP6" and an IPv6 address

In the SDP answer from Jitsi, the "c=" line contains "IP4" and an IPv4 address.

Jitsi then starts sending media to the caller using an IPv4-Mapped IPv6 source address [::ffff:192.168.1.128]

The caller could potentially send to Jitsi using one of its IPv4 addresses, but if the caller was a pure-IPv6 host then it wouldn't work. Why doesn't Jitsi just use IPv6 in the SDP answer?

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170


#2

discussed on users list http://lists.jitsi.org/pipermail/users/2015-October/010290.html

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-148188816


#3

I no expert in ICE, NAT, STUN and so forth. But maybe this is related https://github.com/jitsi/jitsi-android/issues/36

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-148372372


#4

It is not related to ICE, NAT or STUN, both machines are on the same LAN

Jitsi doesn't even support ICE or STUN on SIP, they are only supported with XMPP

···

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-148380127


#5

@dpocock What was your test setup for this? Was a SIP proxy/registrar involved? Any DNS resolution?

I tried a call which had IP6 in both the invite and the answer. - two registrarless Jitsi instances on the same network
- both PCs had a DHCP assigned IPv4 address
- both PCs had a statically configured IPv6 address (from a unique local range)
- call to the IPv6-address of the other machine (no DNS involved)

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-270495313


#6

I think I was testing through a repro SIP proxy

When you made the call, was there IPv6 in the offer SDP? If not, try initiating the call from a host without any IPv4 enabled.

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-270571662


#7

Hm, a proxy makes this more difficult to test.

Yes, offer and answer both contained `c= ... IP6 ...`. Not much of a surprise given that it was a call to an IPv6 address and not some DNS name.

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-270586630


#8

Could you test it through the proxy used for the GSoC projects? test.sip5060.net

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-270587826


#9

No, as I still don't have IPv6 on my internet connection :frowning:

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-270591198


#10

Can you try an IPv6 tunnel service?

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-270642256


#11

My router seems to block protocol 41 (6to4). Do you have a config for whatever you run on sip5060 that you could share so I can easily setup a local server?

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-270770173


#12

pfSense to the rescue and fiddling with the crappy Cablecom router. Will continue investigating...

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-270797760


#13

@dpocock Thanks for the config. I had managed to get a tunnel up and used your ws5060 for a while. The c= has always been constructed with what Jitsi used to connect to the proxy. I understand this is problematic (i.e. a (dual-stack )host connecting to the proxy over IPv6 and an IPv4 host cannot 'talk' to each other), but I don't see a real possibility to solve this without ICE.
If the proxy would relay media (and change the sdp for that) it should work. And this is the only supported scenario in Jitsi.

While investigating the issue I fixed several other (IPv6) bugs.

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-271221723


#14

Closed #170.

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#event-947128861


#15

Closing this as a duplicate of #233.

···

--
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi/issues/170#issuecomment-277081426