[jitsi-dev] jitsi-hammer problem


#1

Hi,

I am trying to make jitsi-hammer work and have the same problem as reported here https://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword --> which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

···

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si<mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------


#2

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

···

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi, <>

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword à which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si <mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

···

De: "George Politis" <gp@jitsi.org>
À: "dev" <dev@jitsi.org>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej < Jernej.Trnkoczy@fgg.uni-lj.si > wrote:

Hi,
I am trying to make jitsi-hammer work and have the same problem as reported here https://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword à which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?
Best regards,
Jernej
------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si
------------------------------------------------
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Dear Damien, George

The proposed hack of running “mvn compile exec:java” actually works. The java code of hammer starts running now, hammer joins the room – however no video/audio is sent.
I get the following:
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
And then later on:
WARNING: Codec org.jitsi.impl.neomedia.codec.audio.amrwb.JNIDecoder is NOT successfully registered
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg

The same error is described here http://lists.jitsi.org/pipermail/dev/2016-May/028492.html - however no working solution was proposed.
It seems that the pom.xml files of some dependencies are broken, and maven cannot get all the dependencies that are needed.
I am not familiar with maven - so can anybody help me to resolve this?

Best regards,
Jernej

···

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damien FETIS
Sent: 1. marec 2017 23:08
To: dev
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

________________________________
De: "George Politis" <gp@jitsi.org<mailto:gp@jitsi.org>>
À: "dev" <dev@jitsi.org<mailto:dev@jitsi.org>>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword --> which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si<mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi Jernej, how do you launch the hammer? Which video resource are you using? Have you installed git-lfs? We’re using git-lfs because the a/v resources are large, so you must have that installed to properly checkout the resource files.

···

On Mar 2, 2017, at 8:46 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Dear Damien, George

The proposed hack of running “mvn compile exec:java” actually works. The java code of hammer starts running now, hammer joins the room – however no video/audio is sent.
I get the following:
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
And then later on:
WARNING: Codec org.jitsi.impl.neomedia.codec.audio.amrwb.JNIDecoder is NOT successfully registered
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg

The same error is described here http://lists.jitsi.org/pipermail/dev/2016-May/028492.html - however no working solution was proposed.
It seems that the pom.xml files of some dependencies are broken, and maven cannot get all the dependencies that are needed.
I am not familiar with maven - so can anybody help me to resolve this?

Best regards,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damien FETIS
Sent: 1. marec 2017 23:08
To: dev
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

De: "George Politis" <gp@jitsi.org <mailto:gp@jitsi.org>>
À: "dev" <dev@jitsi.org <mailto:dev@jitsi.org>>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si <mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

<>Hi,

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword à which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si <mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Hi George,

I am starting hammer like this: ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/ -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats

I checked the .rtpdump files in the /resources folder – they were there however they were extremely small (e.g. 132 bytes)- probably corrupted (I did not install git-lfs). So I downloaded the files manually.
The only difference that this makes is that now after the warnings reported in the previous e-mail, I also get a huge number of following warnings like this:
WARNING: Packets dropped (hashCode=925361542): 11120

And that is it, after that the hammer hungs….

Cheers,
Jernej

···

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 2. marec 2017 15:56
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej, how do you launch the hammer? Which video resource are you using? Have you installed git-lfs? We’re using git-lfs because the a/v resources are large, so you must have that installed to properly checkout the resource files.

On Mar 2, 2017, at 8:46 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Dear Damien, George

The proposed hack of running “mvn compile exec:java” actually works. The java code of hammer starts running now, hammer joins the room – however no video/audio is sent.
I get the following:
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
And then later on:
WARNING: Codec org.jitsi.impl.neomedia.codec.audio.amrwb.JNIDecoder is NOT successfully registered
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg

The same error is described here http://lists.jitsi.org/pipermail/dev/2016-May/028492.html - however no working solution was proposed.
It seems that the pom.xml files of some dependencies are broken, and maven cannot get all the dependencies that are needed.
I am not familiar with maven - so can anybody help me to resolve this?

Best regards,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damien FETIS
Sent: 1. marec 2017 23:08
To: dev
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

________________________________
De: "George Politis" <gp@jitsi.org<mailto:gp@jitsi.org>>
À: "dev" <dev@jitsi.org<mailto:dev@jitsi.org>>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword --> which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si<mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Hi,

Using git-lfs it seems that hammer started to work. I would just like to share this – in case anybody else has the same problems that I had. So the process of running jitsi-hammer should be something like:

1) Install git-lfs (copying the test audio/video files provided here https://github.com/jitsi/jitsi-hammer/tree/master/resources with git or manually will result in corrupted input files that cannot be used with hammer). Git-lfs will take care of getting the right input files.

2) Before running the ./jitsi-hammer.sh script run mvn compile exec:java once. This will of course fail, but the effect will be that maven will be able to download the needed plugins/dependencies before the ./jitsi-hammer.sh script modifies the keyStore and trustStore (which will break maven)

3) Setup a working jitsi server-side

4) Connect with browser to jitsi server, open a “room” with some name

5) Run ./jitsi-hammer.sh script with a command similar to : ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/ -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats

6) ignore various warnings about corrupted .pom files, registered java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg, and so on… It seems like these are not relevant (or maybe I am wrong?).

7) Wait a little bit

8) The hammer participant should show-up in a room and the sample sound file should begin playing in the browser (however the video – at least in my case - appears only in the participant icon – not full screen)

9) After specified amount of time (-length 120 above) the hammer will try to stop (Stopping Jitsi-Hammer... in terminal). However in my case it never actually stops – and I need to forcefully kill the process with kill -9 processID

Cheers,
Jernej

···

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Trnkoczy, Jernej
Sent: 2. marec 2017 17:31
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George,

I am starting hammer like this: ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/ -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats

I checked the .rtpdump files in the /resources folder – they were there however they were extremely small (e.g. 132 bytes)- probably corrupted (I did not install git-lfs). So I downloaded the files manually.
The only difference that this makes is that now after the warnings reported in the previous e-mail, I also get a huge number of following warnings like this:
WARNING: Packets dropped (hashCode=925361542): 11120

And that is it, after that the hammer hungs….

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 2. marec 2017 15:56
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej, how do you launch the hammer? Which video resource are you using? Have you installed git-lfs? We’re using git-lfs because the a/v resources are large, so you must have that installed to properly checkout the resource files.

On Mar 2, 2017, at 8:46 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Dear Damien, George

The proposed hack of running “mvn compile exec:java” actually works. The java code of hammer starts running now, hammer joins the room – however no video/audio is sent.
I get the following:
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
And then later on:
WARNING: Codec org.jitsi.impl.neomedia.codec.audio.amrwb.JNIDecoder is NOT successfully registered
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg

The same error is described here http://lists.jitsi.org/pipermail/dev/2016-May/028492.html - however no working solution was proposed.
It seems that the pom.xml files of some dependencies are broken, and maven cannot get all the dependencies that are needed.
I am not familiar with maven - so can anybody help me to resolve this?

Best regards,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damien FETIS
Sent: 1. marec 2017 23:08
To: dev
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

________________________________
De: "George Politis" <gp@jitsi.org<mailto:gp@jitsi.org>>
À: "dev" <dev@jitsi.org<mailto:dev@jitsi.org>>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword --> which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si<mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Hi Jernej,

I’m glad that it finally worked for you! I think your guide would make a nice and very much appreciated addition to the hammer README file, so please feel free to open a PR for that, if you feel like it.

Best,
George

···

On Mar 3, 2017, at 4:32 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi,

Using git-lfs it seems that hammer started to work. I would just like to share this – in case anybody else has the same problems that I had. So the process of running jitsi-hammer should be something like:
1) Install git-lfs (copying the test audio/video files provided here https://github.com/jitsi/jitsi-hammer/tree/master/resources with git or manually will result in corrupted input files that cannot be used with hammer). Git-lfs will take care of getting the right input files.
2) Before running the ./jitsi-hammer.sh script run mvn compile exec:java once. This will of course fail, but the effect will be that maven will be able to download the needed plugins/dependencies before the ./jitsi-hammer.sh script modifies the keyStore and trustStore (which will break maven)
3) Setup a working jitsi server-side
4) Connect with browser to jitsi server, open a “room” with some name
5) Run ./jitsi-hammer.sh script with a command similar to : ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/ <https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats
6) ignore various warnings about corrupted .pom files, registered java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg, and so on… It seems like these are not relevant (or maybe I am wrong?).
7) Wait a little bit
8) The hammer participant should show-up in a room and the sample sound file should begin playing in the browser (however the video – at least in my case - appears only in the participant icon – not full screen)
9) After specified amount of time (-length 120 above) the hammer will try to stop (Stopping Jitsi-Hammer... in terminal). However in my case it never actually stops – and I need to forcefully kill the process with kill -9 processID

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Trnkoczy, Jernej
Sent: 2. marec 2017 17:31
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George,

I am starting hammer like this: ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/ <https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats

I checked the .rtpdump files in the /resources folder – they were there however they were extremely small (e.g. 132 bytes)- probably corrupted (I did not install git-lfs). So I downloaded the files manually.
The only difference that this makes is that now after the warnings reported in the previous e-mail, I also get a huge number of following warnings like this:
WARNING: Packets dropped (hashCode=925361542): 11120

And that is it, after that the hammer hungs….

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org <mailto:dev-bounces@jitsi.org>] On Behalf Of George Politis
Sent: 2. marec 2017 15:56
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej, how do you launch the hammer? Which video resource are you using? Have you installed git-lfs? We’re using git-lfs because the a/v resources are large, so you must have that installed to properly checkout the resource files.

On Mar 2, 2017, at 8:46 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si <mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Dear Damien, George

The proposed hack of running “mvn compile exec:java” actually works. The java code of hammer starts running now, hammer joins the room – however no video/audio is sent.
I get the following:
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
And then later on:
WARNING: Codec org.jitsi.impl.neomedia.codec.audio.amrwb.JNIDecoder is NOT successfully registered
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg

The same error is described here http://lists.jitsi.org/pipermail/dev/2016-May/028492.html - however no working solution was proposed.
It seems that the pom.xml files of some dependencies are broken, and maven cannot get all the dependencies that are needed.
I am not familiar with maven - so can anybody help me to resolve this?

Best regards,
Jernej

From: dev [mailto:dev-bounces@jitsi.org <mailto:dev-bounces@jitsi.org>] On Behalf Of Damien FETIS
Sent: 1. marec 2017 23:08
To: dev
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

De: "George Politis" <gp@jitsi.org <mailto:gp@jitsi.org>>
À: "dev" <dev@jitsi.org <mailto:dev@jitsi.org>>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si <mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

<>Hi,

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword à which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si <mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Hi George,
Indeed I think it would be a good idea to add this information to the documentation. I am ready to do it – however I would need some guidance. What do you mean “open a PR for that”? Sorry I am not aware of the process…
Cheers,
Jernej

···

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 3. marec 2017 17:01
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

I’m glad that it finally worked for you! I think your guide would make a nice and very much appreciated addition to the hammer README file, so please feel free to open a PR for that, if you feel like it.

Best,
George

On Mar 3, 2017, at 4:32 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

Using git-lfs it seems that hammer started to work. I would just like to share this – in case anybody else has the same problems that I had. So the process of running jitsi-hammer should be something like:
1) Install git-lfs (copying the test audio/video files provided here https://github.com/jitsi/jitsi-hammer/tree/master/resources with git or manually will result in corrupted input files that cannot be used with hammer). Git-lfs will take care of getting the right input files.
2) Before running the ./jitsi-hammer.sh script run mvn compile exec:java once. This will of course fail, but the effect will be that maven will be able to download the needed plugins/dependencies before the ./jitsi-hammer.sh script modifies the keyStore and trustStore (which will break maven)
3) Setup a working jitsi server-side
4) Connect with browser to jitsi server, open a “room” with some name
5) Run ./jitsi-hammer.sh script with a command similar to : ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/<https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats
6) ignore various warnings about corrupted .pom files, registered java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg, and so on… It seems like these are not relevant (or maybe I am wrong?).
7) Wait a little bit
8) The hammer participant should show-up in a room and the sample sound file should begin playing in the browser (however the video – at least in my case - appears only in the participant icon – not full screen)
9) After specified amount of time (-length 120 above) the hammer will try to stop (Stopping Jitsi-Hammer... in terminal). However in my case it never actually stops – and I need to forcefully kill the process with kill -9 processID

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Trnkoczy, Jernej
Sent: 2. marec 2017 17:31
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George,

I am starting hammer like this: ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/<https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats

I checked the .rtpdump files in the /resources folder – they were there however they were extremely small (e.g. 132 bytes)- probably corrupted (I did not install git-lfs). So I downloaded the files manually.
The only difference that this makes is that now after the warnings reported in the previous e-mail, I also get a huge number of following warnings like this:
WARNING: Packets dropped (hashCode=925361542): 11120

And that is it, after that the hammer hungs….

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 2. marec 2017 15:56
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej, how do you launch the hammer? Which video resource are you using? Have you installed git-lfs? We’re using git-lfs because the a/v resources are large, so you must have that installed to properly checkout the resource files.

On Mar 2, 2017, at 8:46 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Dear Damien, George

The proposed hack of running “mvn compile exec:java” actually works. The java code of hammer starts running now, hammer joins the room – however no video/audio is sent.
I get the following:
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
And then later on:
WARNING: Codec org.jitsi.impl.neomedia.codec.audio.amrwb.JNIDecoder is NOT successfully registered
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg

The same error is described here http://lists.jitsi.org/pipermail/dev/2016-May/028492.html - however no working solution was proposed.
It seems that the pom.xml files of some dependencies are broken, and maven cannot get all the dependencies that are needed.
I am not familiar with maven - so can anybody help me to resolve this?

Best regards,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damien FETIS
Sent: 1. marec 2017 23:08
To: dev
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

________________________________
De: "George Politis" <gp@jitsi.org<mailto:gp@jitsi.org>>
À: "dev" <dev@jitsi.org<mailto:dev@jitsi.org>>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword --> which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si<mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

Hi Jernej,

It’s really great to hear that you’re willing to contribute! If you decide to proceed with your contribution and if you haven't already done so, please make sure you sign our CLA (https://jitsi.org/icla for individuals and https://jitsi.org/ccla for corporations). We would unfortunately be unable to merge your patch unless we have that piece.

After that part is done, the technical workflow goes like this:

1. You clone the github project.
2. You add, commit and push your changes to your clone.
3. You open a Pull Request (https://help.github.com/articles/creating-a-pull-request/)
4. I can merge your pull request into the mainline.

I hope this helps!

Best,
George

···

On Mar 6, 2017, at 3:03 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi George,
Indeed I think it would be a good idea to add this information to the documentation. I am ready to do it – however I would need some guidance. What do you mean “open a PR for that”? Sorry I am not aware of the process…
Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 3. marec 2017 17:01
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

I’m glad that it finally worked for you! I think your guide would make a nice and very much appreciated addition to the hammer README file, so please feel free to open a PR for that, if you feel like it.

Best,
George
  
On Mar 3, 2017, at 4:32 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si <mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

Using git-lfs it seems that hammer started to work. I would just like to share this – in case anybody else has the same problems that I had. So the process of running jitsi-hammer should be something like:
1) Install git-lfs (copying the test audio/video files provided here https://github.com/jitsi/jitsi-hammer/tree/master/resources with git or manually will result in corrupted input files that cannot be used with hammer). Git-lfs will take care of getting the right input files.
2) Before running the ./jitsi-hammer.sh script run mvn compile exec:java once. This will of course fail, but the effect will be that maven will be able to download the needed plugins/dependencies before the ./jitsi-hammer.sh script modifies the keyStore and trustStore (which will break maven)
3) Setup a working jitsi server-side
4) Connect with browser to jitsi server, open a “room” with some name
5) Run ./jitsi-hammer.sh script with a command similar to : ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/ <https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats
6) ignore various warnings about corrupted .pom files, registered java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg, and so on… It seems like these are not relevant (or maybe I am wrong?).
7) Wait a little bit
8) The hammer participant should show-up in a room and the sample sound file should begin playing in the browser (however the video – at least in my case - appears only in the participant icon – not full screen)
9) After specified amount of time (-length 120 above) the hammer will try to stop (Stopping Jitsi-Hammer... in terminal). However in my case it never actually stops – and I need to forcefully kill the process with kill -9 processID

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org <mailto:dev-bounces@jitsi.org>] On Behalf Of Trnkoczy, Jernej
Sent: 2. marec 2017 17:31
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George,

I am starting hammer like this: ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/ <https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats

I checked the .rtpdump files in the /resources folder – they were there however they were extremely small (e.g. 132 bytes)- probably corrupted (I did not install git-lfs). So I downloaded the files manually.
The only difference that this makes is that now after the warnings reported in the previous e-mail, I also get a huge number of following warnings like this:
WARNING: Packets dropped (hashCode=925361542): 11120

And that is it, after that the hammer hungs….

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org <mailto:dev-bounces@jitsi.org>] On Behalf Of George Politis
Sent: 2. marec 2017 15:56
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej, how do you launch the hammer? Which video resource are you using? Have you installed git-lfs? We’re using git-lfs because the a/v resources are large, so you must have that installed to properly checkout the resource files.

On Mar 2, 2017, at 8:46 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si <mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Dear Damien, George

The proposed hack of running “mvn compile exec:java” actually works. The java code of hammer starts running now, hammer joins the room – however no video/audio is sent.
I get the following:
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
And then later on:
WARNING: Codec org.jitsi.impl.neomedia.codec.audio.amrwb.JNIDecoder is NOT successfully registered
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg

The same error is described here http://lists.jitsi.org/pipermail/dev/2016-May/028492.html - however no working solution was proposed.
It seems that the pom.xml files of some dependencies are broken, and maven cannot get all the dependencies that are needed.
I am not familiar with maven - so can anybody help me to resolve this?

Best regards,
Jernej

From: dev [mailto:dev-bounces@jitsi.org <mailto:dev-bounces@jitsi.org>] On Behalf Of Damien FETIS
Sent: 1. marec 2017 23:08
To: dev
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

De: "George Politis" <gp@jitsi.org <mailto:gp@jitsi.org>>
À: "dev" <dev@jitsi.org <mailto:dev@jitsi.org>>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si <mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

<>Hi,

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword à which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si <mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#11

Hi George,

I’ve signed the CLA, however currently I am stuck with the Pull Request process (I am not experienced with GitHub - sorry). So I made the local repository, cloned the project, committed the changes to my local repo. I am not allowed to push this to the https://github.com/jitsi/jitsi-hammer.git .
So what am I supposed to do? Create my own remote repository and open a pull request on this one? Or create a branch in https://github.com/jitsi/jitsi-hammer.git (am I even allowed to do that?) and open a pull request?
Anyway the modified README.md file for jitsi-hammer is attached.
Cheers,
Jernej

README.md (8.87 KB)

···

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 6. marec 2017 15:55
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

It’s really great to hear that you’re willing to contribute! If you decide to proceed with your contribution and if you haven't already done so, please make sure you sign our CLA (https://jitsi.org/icla for individuals and https://jitsi.org/ccla for corporations). We would unfortunately be unable to merge your patch unless we have that piece.

After that part is done, the technical workflow goes like this:

1. You clone the github project.
2. You add, commit and push your changes to your clone.
3. You open a Pull Request (https://help.github.com/articles/creating-a-pull-request/)
4. I can merge your pull request into the mainline.

I hope this helps!

Best,
George

On Mar 6, 2017, at 3:03 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi George,
Indeed I think it would be a good idea to add this information to the documentation. I am ready to do it – however I would need some guidance. What do you mean “open a PR for that”? Sorry I am not aware of the process…
Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 3. marec 2017 17:01
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

I’m glad that it finally worked for you! I think your guide would make a nice and very much appreciated addition to the hammer README file, so please feel free to open a PR for that, if you feel like it.

Best,
George

On Mar 3, 2017, at 4:32 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

Using git-lfs it seems that hammer started to work. I would just like to share this – in case anybody else has the same problems that I had. So the process of running jitsi-hammer should be something like:
1) Install git-lfs (copying the test audio/video files provided here https://github.com/jitsi/jitsi-hammer/tree/master/resources with git or manually will result in corrupted input files that cannot be used with hammer). Git-lfs will take care of getting the right input files.
2) Before running the ./jitsi-hammer.sh script run mvn compile exec:java once. This will of course fail, but the effect will be that maven will be able to download the needed plugins/dependencies before the ./jitsi-hammer.sh script modifies the keyStore and trustStore (which will break maven)
3) Setup a working jitsi server-side
4) Connect with browser to jitsi server, open a “room” with some name
5) Run ./jitsi-hammer.sh script with a command similar to : ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/<https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats
6) ignore various warnings about corrupted .pom files, registered java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg, and so on… It seems like these are not relevant (or maybe I am wrong?).
7) Wait a little bit
8) The hammer participant should show-up in a room and the sample sound file should begin playing in the browser (however the video – at least in my case - appears only in the participant icon – not full screen)
9) After specified amount of time (-length 120 above) the hammer will try to stop (Stopping Jitsi-Hammer... in terminal). However in my case it never actually stops – and I need to forcefully kill the process with kill -9 processID

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Trnkoczy, Jernej
Sent: 2. marec 2017 17:31
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George,

I am starting hammer like this: ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/<https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats

I checked the .rtpdump files in the /resources folder – they were there however they were extremely small (e.g. 132 bytes)- probably corrupted (I did not install git-lfs). So I downloaded the files manually.
The only difference that this makes is that now after the warnings reported in the previous e-mail, I also get a huge number of following warnings like this:
WARNING: Packets dropped (hashCode=925361542): 11120

And that is it, after that the hammer hungs….

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 2. marec 2017 15:56
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej, how do you launch the hammer? Which video resource are you using? Have you installed git-lfs? We’re using git-lfs because the a/v resources are large, so you must have that installed to properly checkout the resource files.

On Mar 2, 2017, at 8:46 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Dear Damien, George

The proposed hack of running “mvn compile exec:java” actually works. The java code of hammer starts running now, hammer joins the room – however no video/audio is sent.
I get the following:
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
And then later on:
WARNING: Codec org.jitsi.impl.neomedia.codec.audio.amrwb.JNIDecoder is NOT successfully registered
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg

The same error is described here http://lists.jitsi.org/pipermail/dev/2016-May/028492.html - however no working solution was proposed.
It seems that the pom.xml files of some dependencies are broken, and maven cannot get all the dependencies that are needed.
I am not familiar with maven - so can anybody help me to resolve this?

Best regards,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damien FETIS
Sent: 1. marec 2017 23:08
To: dev
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

________________________________
De: "George Politis" <gp@jitsi.org<mailto:gp@jitsi.org>>
À: "dev" <dev@jitsi.org<mailto:dev@jitsi.org>>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword --> which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si<mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

Hi Jernej, apologies for the late reply and thank you for your patience and your efforts. In order to create a PR you must first fork the jitsi-hammer project from the github interface, commit and push your changes to your fork and then create a Pull Request (again from the github interface).

I hope this helps.

Cheer,
George

···

On Mar 13, 2017, at 7:03 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si> wrote:

Hi George,

I’ve signed the CLA, however currently I am stuck with the Pull Request process (I am not experienced with GitHub - sorry). So I made the local repository, cloned the project, committed the changes to my local repo. I am not allowed to push this to the https://github.com/jitsi/jitsi-hammer.git .
So what am I supposed to do? Create my own remote repository and open a pull request on this one? Or create a branch in https://github.com/jitsi/jitsi-hammer.git (am I even allowed to do that?) and open a pull request?
Anyway the modified README.md file for jitsi-hammer is attached.
Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 6. marec 2017 15:55
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

It’s really great to hear that you’re willing to contribute! If you decide to proceed with your contribution and if you haven't already done so, please make sure you sign our CLA (https://jitsi.org/icla for individuals and https://jitsi.org/ccla for corporations). We would unfortunately be unable to merge your patch unless we have that piece.

After that part is done, the technical workflow goes like this:

1. You clone the github project.
2. You add, commit and push your changes to your clone.
3. You open a Pull Request (https://help.github.com/articles/creating-a-pull-request/)
4. I can merge your pull request into the mainline.

I hope this helps!

Best,
George

On Mar 6, 2017, at 3:03 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si <mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi George,
Indeed I think it would be a good idea to add this information to the documentation. I am ready to do it – however I would need some guidance. What do you mean “open a PR for that”? Sorry I am not aware of the process…
Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org <mailto:dev-bounces@jitsi.org>] On Behalf Of George Politis
Sent: 3. marec 2017 17:01
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

I’m glad that it finally worked for you! I think your guide would make a nice and very much appreciated addition to the hammer README file, so please feel free to open a PR for that, if you feel like it.

Best,
George
  
On Mar 3, 2017, at 4:32 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si <mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

Using git-lfs it seems that hammer started to work. I would just like to share this – in case anybody else has the same problems that I had. So the process of running jitsi-hammer should be something like:
1) Install git-lfs (copying the test audio/video files provided here https://github.com/jitsi/jitsi-hammer/tree/master/resources with git or manually will result in corrupted input files that cannot be used with hammer). Git-lfs will take care of getting the right input files.
2) Before running the ./jitsi-hammer.sh script run mvn compile exec:java once. This will of course fail, but the effect will be that maven will be able to download the needed plugins/dependencies before the ./jitsi-hammer.sh script modifies the keyStore and trustStore (which will break maven)
3) Setup a working jitsi server-side
4) Connect with browser to jitsi server, open a “room” with some name
5) Run ./jitsi-hammer.sh script with a command similar to : ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/ <https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats
6) ignore various warnings about corrupted .pom files, registered java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg, and so on… It seems like these are not relevant (or maybe I am wrong?).
7) Wait a little bit
8) The hammer participant should show-up in a room and the sample sound file should begin playing in the browser (however the video – at least in my case - appears only in the participant icon – not full screen)
9) After specified amount of time (-length 120 above) the hammer will try to stop (Stopping Jitsi-Hammer... in terminal). However in my case it never actually stops – and I need to forcefully kill the process with kill -9 processID

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org <mailto:dev-bounces@jitsi.org>] On Behalf Of Trnkoczy, Jernej
Sent: 2. marec 2017 17:31
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George,

I am starting hammer like this: ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/ <https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats

I checked the .rtpdump files in the /resources folder – they were there however they were extremely small (e.g. 132 bytes)- probably corrupted (I did not install git-lfs). So I downloaded the files manually.
The only difference that this makes is that now after the warnings reported in the previous e-mail, I also get a huge number of following warnings like this:
WARNING: Packets dropped (hashCode=925361542): 11120

And that is it, after that the hammer hungs….

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org <mailto:dev-bounces@jitsi.org>] On Behalf Of George Politis
Sent: 2. marec 2017 15:56
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej, how do you launch the hammer? Which video resource are you using? Have you installed git-lfs? We’re using git-lfs because the a/v resources are large, so you must have that installed to properly checkout the resource files.

On Mar 2, 2017, at 8:46 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si <mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Dear Damien, George

The proposed hack of running “mvn compile exec:java” actually works. The java code of hammer starts running now, hammer joins the room – however no video/audio is sent.
I get the following:
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
And then later on:
WARNING: Codec org.jitsi.impl.neomedia.codec.audio.amrwb.JNIDecoder is NOT successfully registered
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg

The same error is described here http://lists.jitsi.org/pipermail/dev/2016-May/028492.html - however no working solution was proposed.
It seems that the pom.xml files of some dependencies are broken, and maven cannot get all the dependencies that are needed.
I am not familiar with maven - so can anybody help me to resolve this?

Best regards,
Jernej

From: dev [mailto:dev-bounces@jitsi.org <mailto:dev-bounces@jitsi.org>] On Behalf Of Damien FETIS
Sent: 1. marec 2017 23:08
To: dev
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

De: "George Politis" <gp@jitsi.org <mailto:gp@jitsi.org>>
À: "dev" <dev@jitsi.org <mailto:dev@jitsi.org>>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si <mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

<>Hi,

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword à which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si <mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

<README.md>_______________________________________________
dev mailing list
dev@jitsi.org <mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#13

Hi George,
Thanks for the support, I’ve created the pull request now…
Cheers,
Jernej

···

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 18. marec 2017 17:56
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej, apologies for the late reply and thank you for your patience and your efforts. In order to create a PR you must first fork the jitsi-hammer project from the github interface, commit and push your changes to your fork and then create a Pull Request (again from the github interface).

I hope this helps.

Cheer,
George

On Mar 13, 2017, at 7:03 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi George,

I’ve signed the CLA, however currently I am stuck with the Pull Request process (I am not experienced with GitHub - sorry). So I made the local repository, cloned the project, committed the changes to my local repo. I am not allowed to push this to the https://github.com/jitsi/jitsi-hammer.git .
So what am I supposed to do? Create my own remote repository and open a pull request on this one? Or create a branch in https://github.com/jitsi/jitsi-hammer.git (am I even allowed to do that?) and open a pull request?
Anyway the modified README.md file for jitsi-hammer is attached.
Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 6. marec 2017 15:55
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

It’s really great to hear that you’re willing to contribute! If you decide to proceed with your contribution and if you haven't already done so, please make sure you sign our CLA (https://jitsi.org/icla for individuals and https://jitsi.org/ccla for corporations). We would unfortunately be unable to merge your patch unless we have that piece.

After that part is done, the technical workflow goes like this:

1. You clone the github project.
2. You add, commit and push your changes to your clone.
3. You open a Pull Request (https://help.github.com/articles/creating-a-pull-request/)
4. I can merge your pull request into the mainline.

I hope this helps!

Best,
George

On Mar 6, 2017, at 3:03 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi George,
Indeed I think it would be a good idea to add this information to the documentation. I am ready to do it – however I would need some guidance. What do you mean “open a PR for that”? Sorry I am not aware of the process…
Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 3. marec 2017 17:01
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

I’m glad that it finally worked for you! I think your guide would make a nice and very much appreciated addition to the hammer README file, so please feel free to open a PR for that, if you feel like it.

Best,
George

On Mar 3, 2017, at 4:32 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

Using git-lfs it seems that hammer started to work. I would just like to share this – in case anybody else has the same problems that I had. So the process of running jitsi-hammer should be something like:
1) Install git-lfs (copying the test audio/video files provided here https://github.com/jitsi/jitsi-hammer/tree/master/resources with git or manually will result in corrupted input files that cannot be used with hammer). Git-lfs will take care of getting the right input files.
2) Before running the ./jitsi-hammer.sh script run mvn compile exec:java once. This will of course fail, but the effect will be that maven will be able to download the needed plugins/dependencies before the ./jitsi-hammer.sh script modifies the keyStore and trustStore (which will break maven)
3) Setup a working jitsi server-side
4) Connect with browser to jitsi server, open a “room” with some name
5) Run ./jitsi-hammer.sh script with a command similar to : ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/<https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats
6) ignore various warnings about corrupted .pom files, registered java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg, and so on… It seems like these are not relevant (or maybe I am wrong?).
7) Wait a little bit
8) The hammer participant should show-up in a room and the sample sound file should begin playing in the browser (however the video – at least in my case - appears only in the participant icon – not full screen)
9) After specified amount of time (-length 120 above) the hammer will try to stop (Stopping Jitsi-Hammer... in terminal). However in my case it never actually stops – and I need to forcefully kill the process with kill -9 processID

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Trnkoczy, Jernej
Sent: 2. marec 2017 17:31
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George,

I am starting hammer like this: ./jitsi-hammer.sh -u https://MY_SERVER_IP/http-bind/<https://my_server_ip/http-bind/> -room MY_ROOM_NAME -length 120 -audiortpdump ./resources/badger-audio.rtpdump -videortpdump ./resources/badger-video.rtpdump –summarystats

I checked the .rtpdump files in the /resources folder – they were there however they were extremely small (e.g. 132 bytes)- probably corrupted (I did not install git-lfs). So I downloaded the files manually.
The only difference that this makes is that now after the warnings reported in the previous e-mail, I also get a huge number of following warnings like this:
WARNING: Packets dropped (hashCode=925361542): 11120

And that is it, after that the hammer hungs….

Cheers,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of George Politis
Sent: 2. marec 2017 15:56
To: Jitsi Developers
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej, how do you launch the hammer? Which video resource are you using? Have you installed git-lfs? We’re using git-lfs because the a/v resources are large, so you must have that installed to properly checkout the resource files.

On Mar 2, 2017, at 8:46 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Dear Damien, George

The proposed hack of running “mvn compile exec:java” actually works. The java code of hammer starts running now, hammer joins the room – however no video/audio is sent.
I get the following:
[WARNING] The POM for org.jitsi:ice4j:jar:1.0-20151202.233708-16 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
[WARNING] The POM for org.jitsi:libjitsi:jar:1.0-20160202.152655-85 is invalid, transitive dependencies (if any) will not be available, enable debug logging for more details
And then later on:
WARNING: Codec org.jitsi.impl.neomedia.codec.audio.amrwb.JNIDecoder is NOT successfully registered
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.impl.neomedia.codec.FFmpeg

The same error is described here http://lists.jitsi.org/pipermail/dev/2016-May/028492.html - however no working solution was proposed.
It seems that the pom.xml files of some dependencies are broken, and maven cannot get all the dependencies that are needed.
I am not familiar with maven - so can anybody help me to resolve this?

Best regards,
Jernej

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Damien FETIS
Sent: 1. marec 2017 23:08
To: dev
Subject: Re: [jitsi-dev] jitsi-hammer problem

Hi George and Jernej,
A simple solution to enable Maven plugin importing for jitsi-hammer is to run once "mvn compile exec:java" without other arguments.
This maven execution will import all necessary plugin and after you can use jitsi-hamer.sh script.

Best regards,
Damien.

________________________________
De: "George Politis" <gp@jitsi.org<mailto:gp@jitsi.org>>
À: "dev" <dev@jitsi.org<mailto:dev@jitsi.org>>
Envoyé: Mercredi 1 Mars 2017 18:29:47
Objet: Re: [jitsi-dev] jitsi-hammer problem

Hi Jernej,

Thanks for bringing this up on the mailing list. I have replied in the Github issue, since there’s a discussion already. Please let us know if this helps.

Best,
George

On Mar 1, 2017, at 11:19 AM, Trnkoczy, Jernej <Jernej.Trnkoczy@fgg.uni-lj.si<mailto:Jernej.Trnkoczy@fgg.uni-lj.si>> wrote:

Hi,

I am trying to make jitsi-hammer work and have the same problem as reported herehttps://github.com/jitsi/jitsi-hammer/issues/17 .
It seems like the jitsi-hammer.sh script modifies the Java system properties javax.net.ssl.keyStore, javax.net.ssl.keyStorePassword, javax.net.ssl.trustStore and javax.net.ssl.trustStorePassword --> which obviously breaks downloading the maven exec plugin (from some https-enabled repository).
Does anybody know how to resolve this?

Best regards,
Jernej

------------------------------------------------
Jernej Trnkoczy
Researcher
Faculty of Civil and Geodetic Engineering
University of Ljubljana
Phone: +386 1 4768 588
e-mail: jernej.trnkoczy@fgg.uni-lj.si<mailto:jernej.trnkoczy@fgg.uni-lj.si>
------------------------------------------------

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

<README.md>_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev