[jitsi-dev] jitsi.exe (run.c) APPCRASH


#1

Was there ever a solution found for this? I have exactly the same problem


#2

Here is cut/paste from previous thread.

*Vieri*rentorbuy at yahoo.com<mailto:dev%40jitsi.org?Subject=Re%3A%20[jitsi-dev]%20jitsi.exe%20(run.c)%20APPCRASH&In-Reply-To=<116696613.3761683.1421750264062.JavaMail.yahoo%40jws10647.mail.bf1.yahoo.com>>
/Tue Jan 20 11:37:44 CET 2015/

  * Previous message:[jitsi-dev] jitsi.exe (run.c) APPCRASH
    <http://lists.jitsi.org/pipermail/dev/2015-January/023208.html>
  * Next message:[jitsi-dev] How can I play WAV sound file during call?
    <http://lists.jitsi.org/pipermail/dev/2015-January/023174.html>
  * *Messages sorted by:*[ date ]
    <http://lists.jitsi.org/pipermail/dev/2015-January/date.html#23224>[
    thread ]
    <http://lists.jitsi.org/pipermail/dev/2015-January/thread.html#23224>[
    subject ]
    <http://lists.jitsi.org/pipermail/dev/2015-January/subject.html#23224>[
    author ]
    <http://lists.jitsi.org/pipermail/dev/2015-January/author.html#23224>

···

------------------------------------------------------------------------

Hi again,

I've been struggling with this for the past few days and I'd really appreciate it if someone could lend a hand. Surely someone must be compiling from source on Windows and I'm afraid that the instructions here aren't quite complete:

https://jitsi.org/Documentation/RetrievingAndBuildingTheSources

If you can or can't reproduce the problem by following my steps below then please let me know in both cases. I'd really like to know what I'm doing wrong.

With earlier source code snapshots I was having jvm.dll errors at startup.
Now I'm experiencing an APPCRASH when compiling and running jitsi from source snapshot v. 2.5.5383 on Win 7 32bits:

Faulting Application Name: Jitsi.exe
Faulting Module Name: ntdll.dll, version: 6.1.7601.18205

Steps I performed on original source:

1- customized jitsi-src-2.5.5371\jitsi\src\net\java\sip\communicator\impl\version\NightlyBuildID.java:

public static final String BUILD_ID="3.4";

2- added in jitsi-src-2.5.5371\jitsi\resources\install\ant-build-config.properties:
splashscreen.enable=true

3- customized jitsi-src-2.5.5371\jitsi\resources\install\installers.properties:
windows.jre.zip=C:\\jre-32bits.zip

4- created jre-32bits.zip by taking the jre dir from an official Jitsi Windows installer.

5- in jitsi-src-2.5.5371\jitsi;
ant rebuild

6- in jitsi-src-2.5.5371\jitsi\resources\install:

mkdir classes
ant build-installation-wix

7- ran jitsi-src-2.5.5371\jitsi\release\windows\jitsi-2.5.3.4-x86.exe

8- ran %PROGRAMFILES%\Jitsi\Jitsi.exe.
ntdll.dll error reported above.
A debug trace shows:
EXCEPTION_RECORD: ffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 00000000
ExceptionCode: 80000003 (Break instruction exception)
ExceptionFlags: 00000000
NumberParameters: 0

PROCESS_NAME: Jitsi.exe

MODULE_NAME: Jitsi

FAULTING_MODULE: 779b0000 ntdll

STACK_TEXT:
WARNING: Stack unwind information not available. Following frames may be wrong.
0022fd60 76ff9cca 0000006c 0022fe18 00000008 ntdll!KiFastSystemCallRet
0022fda8 004031d9 0000006c 0022fe18 00000008 kernel32!ReadFile+0x54
0022fe98 0040422b 00400000 00000000 00662c44 Jitsi+0x31d9
0022feb0 7709a442 771302a8 00000044 0067d210 Jitsi+0x422b
0022fefc 770f5bc4 00403c40 0022ff94 0022ff30 msvcrt!unlock+0x15
0022ff18 004010fd 0022ff28 770a9e34 7ffdd000 msvcrt!atexit+0xd
0022ff94 77a137eb 7ffdd000 774351da 00000000 Jitsi+0x10fd
0022ffd4 77a137be 004012a0 7ffdd000 00000000 ntdll!RtlInitializeExceptionChain+0xef
0022ffec 00000000 004012a0 7ffdd000 00000000 ntdll!RtlInitializeExceptionChain+0xc2

STACK_COMMAND: ~0s; .ecxr ; kb

FOLLOWUP_IP:
Jitsi+31d9
004031d9 31c9 xor ecx,ecx

------------

Note: no other customization was performed. JRE is as follows:
"C:\Program Files\Jitsi\jre\bin\java.exe" -version
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot(TM) Client VM (build 25.25-b02, mixed mode)

The JDK on my build system is jdk1.8.0_25:
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot(TM) Client VM (build 25.25-b02, mixed mode, sharing)

apache-ant-1.9.4

cygwin bash

tdm-gcc-4.9.2

*Any* help at all is greatly appreciated.

Thanks,

Vieri

On 25/02/16 11:22 AM, canuck15 wrote:

Was there ever a solution found for this? I have exactly the same problem

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev