[jitsi-dev] Jitsi double icons - let installer clear cache by default?


#1

Hi all,

Given that there are quite a number of users that either:
1. accidentally load the old MSN jars, and/or
2. get all preferences icons in duplicate (and maybe more, idk)

Should we update the installer to automatically clear the
sip-communicator.bin cache directory?
That should be possible right? Or would that have other issues?

Regards,
Danny


#2

Hi,

Ingo yesterday added deleting the cache folder on major version
change. So this should work.

Regards
damencho

···

On Wed, Feb 4, 2015 at 12:41 AM, Danny van Heumen <danny@dannyvanheumen.nl> wrote:

Hi all,

Given that there are quite a number of users that either:
1. accidentally load the old MSN jars, and/or
2. get all preferences icons in duplicate (and maybe more, idk)

Should we update the installer to automatically clear the
sip-communicator.bin cache directory?
That should be possible right? Or would that have other issues?

Regards,
Danny

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hey Ingo and devs,

I got an error this morning, not really sure how the build made it and
I got a compilation error.

....jitsi.git/src/net/java/sip/communicator/launcher/SIPCommunicator.java:220:
error: enhanced for loops are not supported in -source 1.4
    [javac] for (File c : f.listFiles())
    [javac] ^
    [javac] (use -source 5 or higher to enable for-each loops)
    [javac] 1 error
    [javac] 4 warnings

But as soon as we are targeting 1.6 we can move this from 1.4 to 1.5
(in build.xml and there is one more check in SIPCommunicator class).
WDYT? Does anybody see a problem with this?

Regards
damencho

···

On Wed, Feb 4, 2015 at 8:26 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Ingo yesterday added deleting the cache folder on major version
change. So this should work.

Regards
damencho

On Wed, Feb 4, 2015 at 12:41 AM, Danny van Heumen > <danny@dannyvanheumen.nl> wrote:

Hi all,

Given that there are quite a number of users that either:
1. accidentally load the old MSN jars, and/or
2. get all preferences icons in duplicate (and maybe more, idk)

Should we update the installer to automatically clear the
sip-communicator.bin cache directory?
That should be possible right? Or would that have other issues?

Regards,
Danny

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

I got an error this morning, not really sure how the build made it and
I got a compilation error.

....jitsi.git/src/net/java/sip/communicator/launcher/SIPCommunicator.java
:220 : error: enhanced for loops are not supported in -source 1.4
    [javac] for (File c : f.listFiles())
    [javac] ^
    [javac] (use -source 5 or higher to enable for-each loops)
    [javac] 1 error
    [javac] 4 warnings
But as soon as we are targeting 1.6 we can move this from 1.4 to 1.5
(in build.xml and there is one more check in SIPCommunicator class).
WDYT? Does anybody see a problem with this?

Argh, I forgot about the 1.4 stuff in the launcher package again. Anyway, on the way back to Strasbourg Emil agreed to lift the whole project to 1.8 (Desktop client only though). I'd double check with the Debian guys if this is okay, otherwise me might need to stay on 1.7 for a while. In any case, 1.4 is definitely not required anymore.

Then I'm also not sure if the build.xml needs to be modified to include the VersionImpl class files or if javac inlines constancts...

Regards
damencho

Ingo