[jitsi-dev] Jitsi doesn't ring


#1

Hi,

yesterday I tried Jitsi because I was unhappy with other sip
softphones I tried so far. Jitsi convinced me and so I configured the
two sip accounts I have access to.

All went very well until I noticed that none of the calls I received via
pbxes.org were signaled to jitsi - jitsi simply doesn't ring. I made
some tests by calling the extension jitsi is connected to but without
success.

The symptoms are always the same: the call is canceled immediately and
the pbxes.org call monitor reports "Congestion".

I also tried a couple of other softphones (sflphone, twinkle, linphone
and blink) and had no problem with incoming calls and pbxes.org, all
these softphones rang on incoming calls - unfortunately only jitsi seem
to have problems with incoming calls and pbxes.org -- interestingly the
second sip account I tried jitsi with works flawlessly with incomming calls.

So my question is: what can I do to fix this problem?

Any help is very appreciated because I would like to use jitsi in future
in conjunction with the pbxes.org service.

Attached are the logs from a call to Jitsi (no ring) and a call from
Jitsi (ring).

jimy

jitsi0.pcap (23.7 KB)

jitsi0.log.0 (31.6 KB)


#2

Hey jimy,

Damencho and I just had a few tests with pbxes.org and they seem to be
sending invalid SIP messages. We noticed the following problems:

* Their request URI contains a display name.
* Their "To" header contains an extra "<" (less than) in the beginning.

There might be others that we have missed.

You might want to get in touch with the service maintainers and ask them
to check this out.

Hope this helps,
Emil

···

On 27.06.12 20:53, jimy wrote:

Hi,

yesterday I tried Jitsi because I was unhappy with other sip
softphones I tried so far. Jitsi convinced me and so I configured the
two sip accounts I have access to.

All went very well until I noticed that none of the calls I received via
pbxes.org were signaled to jitsi - jitsi simply doesn't ring. I made
some tests by calling the extension jitsi is connected to but without
success.

The symptoms are always the same: the call is canceled immediately and
the pbxes.org call monitor reports "Congestion".

I also tried a couple of other softphones (sflphone, twinkle, linphone
and blink) and had no problem with incoming calls and pbxes.org, all
these softphones rang on incoming calls - unfortunately only jitsi seem
to have problems with incoming calls and pbxes.org -- interestingly the
second sip account I tried jitsi with works flawlessly with incomming calls.

So my question is: what can I do to fix this problem?

Any help is very appreciated because I would like to use jitsi in future
in conjunction with the pbxes.org service.

Attached are the logs from a call to Jitsi (no ring) and a call from
Jitsi (ring).

jimy

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#3

Hi Emil,

thank you very much for your investigation. I posted a message in the
pbxes.org bugs forum (http://53u.z2.sl.pt).

···

Am 28/06/12 10:48, schrieb Emil Ivov:

pbxes.org and they seem to be
sending invalid SIP messages. We noticed the following problems:

* Their request URI contains a display name.
* Their "To" header contains an extra "<" (less than) in the beginning.

jimy