[jitsi-dev] Jitsi doesn't catch web cameras on OpenSuSE Linux


#1

For many jitsi releases on Open SuSE 11.4 x 64 and 12.1 x 64 jitsi doesn't catch all the video sources. With one comp there are two video sources /dev/video0 for web camera and /dev/video1 for tv card, jitsi catch only /dev/video1. On other comp there is only web camera for /dev/video0 , jitsi report there is no video source. The last one I have tried is jitsi-1.0-beta1.nightly.build.3820.x86_64.rpm. Thank for fixing the problem in advance.


#2

had the same problem on my older Lenovo Thinkpad Z61m with Ubuntu 12.04,
which I installed very recently (I am new to Linux, maybe OpenSuse
deals here different than Ubuntu)

However in my case it appeared to be a webcam driver problem, I found
help on the web to install new gspca_sn9c20x drivers (for my webcam
0c45:627b Microdia PC Camera (SN9C201 + OV7660)

after installing the (newer) gspca_sn9c20x drivers I got it working with
this command in Jitsi (also the latest nightly builds now):

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so jitsi

Maybe I am wrong but I am also not able to provide more expertise in
this case

Hope this helps
MS

ยทยทยท

On 5/30/12 3:27 PM, Oleg Miloshev wrote:

For many jitsi releases on Open SuSE 11.4 x 64 and 12.1 x 64 jitsi doesn't catch all the video sources. With one comp there are two video sources /dev/video0 for web camera and /dev/video1 for tv card, jitsi catch only /dev/video1. On other comp there is only web camera for /dev/video0 , jitsi report there is no video source. The last one I have tried is jitsi-1.0-beta1.nightly.build.3820.x86_64.rpm. Thank for fixing the problem in advance.