[jitsi-dev] jitsi debian packages


#1

Hi,

We've updated jitsi packages and uploaded them to mentors.debian.net.
We have extracted the libjitsi library in a separate package and added
jitsi-common which holds the common bundles that are shared between
packages.
We have added jitsi-videobridge which uses libjitsi and jitsi-common
to add WebRTC compatible Selective Forwarding Unit to debian
repository.

We have also added jitsi-meet, a WebRTC JavaScript application that
provides high quality, scalable video conferences. Adding this package
required us to update the package libjs-strophe to latest version.

http://mentors.debian.net/debian/pool/main/libj/libjitsi/libjitsi_513-1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi/jitsi_2.5.5299-1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi-videobridge/jitsi-videobridge_256-1.dsc
http://mentors.debian.net/debian/pool/main/s/strophejs/strophejs_1.1.3-0.1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi-meet/jitsi-meet_1.0.1-1.dsc

Regards
damencho


#2

I'm looking at them.

strophejs is maintained by someone else. Could you please start
by filing a wishlist bug for this new upstream version against the
package so that the maintainer can update it?

Kurt

···

On Tue, Sep 16, 2014 at 03:08:48PM +0300, Damian Minkov wrote:

Hi,

We've updated jitsi packages and uploaded them to mentors.debian.net.
We have extracted the libjitsi library in a separate package and added
jitsi-common which holds the common bundles that are shared between
packages.
We have added jitsi-videobridge which uses libjitsi and jitsi-common
to add WebRTC compatible Selective Forwarding Unit to debian
repository.

We have also added jitsi-meet, a WebRTC JavaScript application that
provides high quality, scalable video conferences. Adding this package
required us to update the package libjs-strophe to latest version.

http://mentors.debian.net/debian/pool/main/libj/libjitsi/libjitsi_513-1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi/jitsi_2.5.5299-1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi-videobridge/jitsi-videobridge_256-1.dsc
http://mentors.debian.net/debian/pool/main/s/strophejs/strophejs_1.1.3-0.1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi-meet/jitsi-meet_1.0.1-1.dsc


#3

Hi,

We've updated jitsi packages and uploaded them to mentors.debian.net.
We have extracted the libjitsi library in a separate package and added
jitsi-common which holds the common bundles that are shared between
packages.
We have added jitsi-videobridge which uses libjitsi and jitsi-common
to add WebRTC compatible Selective Forwarding Unit to debian
repository.

We have also added jitsi-meet, a WebRTC JavaScript application that
provides high quality, scalable video conferences. Adding this package
required us to update the package libjs-strophe to latest version.

Thanks for doing.

http://mentors.debian.net/debian/pool/main/libj/libjitsi/libjitsi_513-1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi/jitsi_2.5.5299-1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi-videobridge/jitsi-videobridge_256-1.dsc
http://mentors.debian.net/debian/pool/main/s/strophejs/strophejs_1.1.3-0.1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi-meet/jitsi-meet_1.0.1-1.dsc

How to turn that information in something that makes

   apt-get install jitsi

installing the lateste jitsi possible?

Groeten
Geert Stappers

···

--
Leven en laten leven


#4

Hi Marcelo,

The Jitsi team are using the strophejs package you uploaded in 2010:
   https://packages.qa.debian.org/s/strophejs.html

Are you happy for other members of pkg-xmpp including myself to upload?

Let me know and I can add a README.source too with guidelines for NMU
and other team members.

Regards,

Daniel

···

On 16/09/14 19:54, Kurt Roeckx wrote:

On Tue, Sep 16, 2014 at 03:08:48PM +0300, Damian Minkov wrote:

Hi,

We've updated jitsi packages and uploaded them to mentors.debian.net.
We have extracted the libjitsi library in a separate package and added
jitsi-common which holds the common bundles that are shared between
packages.
We have added jitsi-videobridge which uses libjitsi and jitsi-common
to add WebRTC compatible Selective Forwarding Unit to debian
repository.

We have also added jitsi-meet, a WebRTC JavaScript application that
provides high quality, scalable video conferences. Adding this package
required us to update the package libjs-strophe to latest version.

http://mentors.debian.net/debian/pool/main/libj/libjitsi/libjitsi_513-1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi/jitsi_2.5.5299-1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi-videobridge/jitsi-videobridge_256-1.dsc
http://mentors.debian.net/debian/pool/main/s/strophejs/strophejs_1.1.3-0.1.dsc
http://mentors.debian.net/debian/pool/main/j/jitsi-meet/jitsi-meet_1.0.1-1.dsc

I'm looking at them.

strophejs is maintained by someone else. Could you please start
by filing a wishlist bug for this new upstream version against the
package so that the maintainer can update it?

Kurt


#5

Meanwhile I found https://jitsi.org/Main/DebianRepository

That page is IMNSHO wrong, at least out-dated.

The
  deb http://download.jitsi.org/deb unstable/
should be
  deb http://download.jitsi.org/deb sid main

That will work for people with architecture i386.
Other architectures will get error messages like

  W: Failed to fetch http://download.jitsi.org/deb/dists/sid/main/binary-amd64/Packages: 404 Not Found

Groeten
Geert Stappers

···

On Wed, Sep 17, 2014 at 02:38:54PM +0200, Geert Stappers wrote:

damencho:

> http://mentors.debian.net/debian/pool/main/libj/libjitsi/libjitsi_513-1.dsc
> http://mentors.debian.net/debian/pool/main/j/jitsi/jitsi_2.5.5299-1.dsc
> http://mentors.debian.net/debian/pool/main/j/jitsi-videobridge/jitsi-videobridge_256-1.dsc
> http://mentors.debian.net/debian/pool/main/s/strophejs/strophejs_1.1.3-0.1.dsc
> http://mentors.debian.net/debian/pool/main/j/jitsi-meet/jitsi-meet_1.0.1-1.dsc

How to turn that information in something that makes

   apt-get install jitsi

installing the lateste jitsi possible?

--
Leven en laten leven


#6

Hi,

the link "deb http://download.jitsi.org/deb unstable/" is ok. You can
try again cause there was a server downtime, which was fixed a few
hours ago.

Regards
damencho

···

On Wed, Sep 17, 2014 at 4:50 PM, Geert Stappers <stappers@stappers.nl> wrote:

On Wed, Sep 17, 2014 at 02:38:54PM +0200, Geert Stappers wrote:

damencho:

> http://mentors.debian.net/debian/pool/main/libj/libjitsi/libjitsi_513-1.dsc
> http://mentors.debian.net/debian/pool/main/j/jitsi/jitsi_2.5.5299-1.dsc
> http://mentors.debian.net/debian/pool/main/j/jitsi-videobridge/jitsi-videobridge_256-1.dsc
> http://mentors.debian.net/debian/pool/main/s/strophejs/strophejs_1.1.3-0.1.dsc
> http://mentors.debian.net/debian/pool/main/j/jitsi-meet/jitsi-meet_1.0.1-1.dsc

How to turn that information in something that makes

   apt-get install jitsi

installing the lateste jitsi possible?

Meanwhile I found https://jitsi.org/Main/DebianRepository

That page is IMNSHO wrong, at least out-dated.

The
  deb http://download.jitsi.org/deb unstable/
should be
  deb http://download.jitsi.org/deb sid main

That will work for people with architecture i386.
Other architectures will get error messages like

  W: Failed to fetch http://download.jitsi.org/deb/dists/sid/main/binary-amd64/Packages: 404 Not Found

Groeten
Geert Stappers
--
Leven en laten leven

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Hi,

···

On Tue, 2014-09-16 at 21:41 +0200, Daniel Pocock wrote:

Hi Marcelo,

The Jitsi team are using the strophejs package you uploaded in 2010:
   https://packages.qa.debian.org/s/strophejs.html

Are you happy for other members of pkg-xmpp including myself to upload?

No problem, go ahead!

Cheers,

--
Marcelo Jorge Vieira
xmpp:metal@jabber-br.org
http://metaldot.alucinados.com


#8

>
> Meanwhile I found https://jitsi.org/Main/DebianRepository
>
> That page is IMNSHO wrong, at least out-dated.
>
> The
> deb http://download.jitsi.org/deb unstable/
> should be
> deb http://download.jitsi.org/deb sid main
>
> That will work for people with architecture i386.
> Other architectures will get error messages like
>
> W: Failed to fetch http://download.jitsi.org/deb/dists/sid/main/binary-amd64/Packages: 404 Not Found
>

the link "deb http://download.jitsi.org/deb unstable/" is ok. You can
try again cause there was a server downtime, which was fixed a few
hours ago.

Yes, it works with that "deb line".

Thanks (and thanks for telling a server that was down)

Regards
damencho

Groeten
Geert Stappers

···

On Wed, Sep 17, 2014 at 05:01:02PM +0300, Damian Minkov wrote:

On Wed, Sep 17, 2014 at 4:50 PM, Geert Stappers wrote:

--
Leven en laten leven