[jitsi-dev] jitsi debian packages error


#1

Hi,

not sure what are you mean, but what we do we just build the package
using the following command: dpkg-buildpackage -tc -us -uc -b -d
-a${deb-arch}
And we haven't change that for more than five years.

Regards
damencho

···

On Mon, Feb 10, 2014 at 11:31 PM, Philippe Bourdin <Kontakt@angiebecker.ch> wrote:

        Hello,

just want to report that both new jitsi packages
"jitsi_2.4.4997-1_amd64.deb" and "jitsi_2.5.5065-1_i386.deb" do contain
a ".xz" compressed file. This is unreadable to older versions of the
gdebi package manager, deployed e.g. on ubuntu LTS versions like 10.04.

If you have the choice, could you maybe use the older ".tgz" package
format to construct the .deb files so that older systems still in use
have a chance to upgrade to newest jitsi versions?

I have the solution to unpack the .deb file and reconstruct it with an
older version of dpkg, so that I can use these packages - others might
get into larger trouble (read: frustration).

Thanks and best regards,

        Philippe Bourdin.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#2

Hello,

···

On 11/02/14 08:19, Damian Minkov wrote:

Hi,

not sure what are you mean, but what we do we just build the package
using the following command: dpkg-buildpackage -tc -us -uc -b -d
-a${deb-arch}
And we haven't change that for more than five years.

I don't know where it comes from, but indeed using 'ar x' on the deb
package makes a .xz file.

We could add -Zgzip to the arguments, although the dpkg-source(1) claims
that gzip is the default.

Regards,
Boris


#3

Yes,
from dpkg-source manual:
'gzip is the default. xz is only supported since dpkg 1.15.5.'
And the dpkg version installed on build machine is 1.17.1.
I will try adding the option, but this will affect nightlies and next
stable build.

Thanks
damencho


#4

Hey Bobi,

passing -Zgzip doesn't work, maybe cause for our deb packages we build
binary only packages. Will search later what is happening.

Regards
damencho

···

On Tue, Feb 11, 2014 at 11:17 AM, Damian Minkov <damencho@jitsi.org> wrote:

Yes,
from dpkg-source manual:
'gzip is the default. xz is only supported since dpkg 1.15.5.'
And the dpkg version installed on build machine is 1.17.1.
I will try adding the option, but this will affect nightlies and next
stable build.

Thanks
damencho


#5

Also checked that the official debian package is packaged the same way.

···

On Tue, Feb 11, 2014 at 12:07 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hey Bobi,

passing -Zgzip doesn't work, maybe cause for our deb packages we build
binary only packages. Will search later what is happening.

Regards
damencho

On Tue, Feb 11, 2014 at 11:17 AM, Damian Minkov <damencho@jitsi.org> wrote:

Yes,
from dpkg-source manual:
'gzip is the default. xz is only supported since dpkg 1.15.5.'
And the dpkg version installed on build machine is 1.17.1.
I will try adding the option, but this will affect nightlies and next
stable build.

Thanks
damencho