[jitsi-dev] Jitsi (Debian 32-bit) crashes at startup


#1

Version 4093 crashes at startup. Previous ones work.

$ jitsi
Exception in thread "main" java.lang.NoClassDefFoundError:
org/jitsi/util/OSUtils
  at
net.java.sip.communicator.util.launchutils.LaunchArgHandler.<init>(LaunchArgHandler.java:172)
  at
net.java.sip.communicator.util.launchutils.LaunchArgHandler.getInstance(LaunchArgHandler.java:186)
  at
net.java.sip.communicator.launcher.SIPCommunicator.main(SIPCommunicator.java:106)
Caused by: java.lang.ClassNotFoundException: org.jitsi.util.OSUtils
  at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
  at java.security.AccessController.doPrivileged(Native Method)
  at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
  at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
  ... 3 more

···

--
O zi buna,
Kertesz Laszlo


#2

Kertesz Laszlo wrote:

Version 4093 crashes at startup. Previous ones work.

$ jitsi
Exception in thread "main" java.lang.NoClassDefFoundError:
org/jitsi/util/OSUtils
  at
net.java.sip.communicator.util.launchutils.LaunchArgHandler.<init>(LaunchArgHandler.java:172)
  at
net.java.sip.communicator.util.launchutils.LaunchArgHandler.getInstance(LaunchArgHandler.java:186)
  at
net.java.sip.communicator.launcher.SIPCommunicator.main(SIPCommunicator.java:106)
Caused by: java.lang.ClassNotFoundException: org.jitsi.util.OSUtils
  at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
  at java.security.AccessController.doPrivileged(Native Method)
  at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
  at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
  ... 3 more

Correction: version 4092 too crashes. 4091 works. Probably this is
related to the libjitsi changes?

···

--
O zi buna,
Kertesz Laszlo


#3

Seeing same behaviour after switching to nightly builds on a XUbuntu
12.4 32-bit system. Steps I took:

1. Was running stable branch
2. Added the following to my apt.sources file:
deb http://download.jitsi.org/nightly/deb unstable/
3. Executed sudo apt-get update && sudo apt-get upgrade
4. Launched jitsi

Appears CLASSPATH is not set correctly, but this wasn't a problem before.

Something gone funny in .deb's install scripts perhaps?

Cheers

Alex

···

On 29 June 2012 23:31, Kertesz Laszlo <laszlo.kertesz@gmail.com> wrote:

Kertesz Laszlo wrote:

Version 4093 crashes at startup. Previous ones work.

$ jitsi
Exception in thread "main" java.lang.NoClassDefFoundError:
org/jitsi/util/OSUtils
at
net.java.sip.communicator.util.launchutils.LaunchArgHandler.<init>(LaunchArgHandler.java:172)
at
net.java.sip.communicator.util.launchutils.LaunchArgHandler.getInstance(LaunchArgHandler.java:186)
at
net.java.sip.communicator.launcher.SIPCommunicator.main(SIPCommunicator.java:106)
Caused by: java.lang.ClassNotFoundException: org.jitsi.util.OSUtils
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
... 3 more

Correction: version 4092 too crashes. 4091 works. Probably this is
related to the libjitsi changes?


#4

Alexandros Papadopoulos wrote:

Kertesz Laszlo wrote:

Version 4093 crashes at startup. Previous ones work.

$ jitsi
Exception in thread "main" java.lang.NoClassDefFoundError:
org/jitsi/util/OSUtils
      at
net.java.sip.communicator.util.launchutils.LaunchArgHandler.<init>(LaunchArgHandler.java:172)
      at
net.java.sip.communicator.util.launchutils.LaunchArgHandler.getInstance(LaunchArgHandler.java:186)
      at
net.java.sip.communicator.launcher.SIPCommunicator.main(SIPCommunicator.java:106)
Caused by: java.lang.ClassNotFoundException: org.jitsi.util.OSUtils
      at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      ... 3 more

Correction: version 4092 too crashes. 4091 works. Probably this is
related to the libjitsi changes?

Seeing same behaviour after switching to nightly builds on a XUbuntu
12.4 32-bit system. Steps I took:

1. Was running stable branch
2. Added the following to my apt.sources file:
deb http://download.jitsi.org/nightly/deb unstable/
3. Executed sudo apt-get update && sudo apt-get upgrade
4. Launched jitsi

Appears CLASSPATH is not set correctly, but this wasn't a problem before.

Something gone funny in .deb's install scripts perhaps?

I'd rather say the builds are messed up because thy changed stuff around
in the sources.
Here:
http://download.jitsi.org/jitsi/nightly/windows/updates/

4092 is the version where they switched to the libjitsi trunk and that
is the first non working version.

···

On 29 June 2012 23:31, Kertesz Laszlo <laszlo.kertesz@gmail.com> wrote:

Cheers

Alex

--
O zi buna,
Kertesz Laszlo