[jitsi-dev] [jitsi-commits] master: Updated IRC client library irc-api to custom version to test bug fix. (c0cebfe)


#1

Repository : ssh://lists.jitsi.org/jitsi

On branch : master Link :
https://github.com/jitsi/jitsi/compare/cc4b3ee0a052f9963cf1432d78ccee4f63
2aec ca...c0cebfe7c11ba5de1c9c4dbd873f79826a51ee98

exclude/irc-api-1.0.jar
index 732781d..8bc4944 100644
Binary files a/lib/installer-exclude/irc-api-1.0.jar and b/lib/installer-
exclude/irc-api-1.0.jar differ

Please don't forget to update libsrc.

Ingo

···

wrote on uthor: Danny van Heumen <danny@dannyvanheumen.nl>: > [...] > > wrote on ib/installer-exclude/irc-api-1.0.jar | Bin 186418 -> 186675 bytes:


#2

Hi Ingo,

I won't. Just wanted to give it a day so George could try it out. I also
wanted to see if I could get confirmation from upstream. (I had already
pushed to change to my 'irc-api' repo on github. So no risk there :slight_smile: )

Now committed and pushed to libsrc.

Danny

···

On 27-11-14 00:22, Ingo Bauersachs wrote:

Repository : ssh://lists.jitsi.org/jitsi

On branch : master Link :
https://github.com/jitsi/jitsi/compare/cc4b3ee0a052f9963cf1432d78ccee4f63
2aec ca...c0cebfe7c11ba5de1c9c4dbd873f79826a51ee98

wrote on uthor: Danny van Heumen <danny@dannyvanheumen.nl>: >> [...] >> >> wrote on ib/installer-exclude/irc-api-1.0.jar | Bin 186418 -> 186675 > bytes:
exclude/irc-api-1.0.jar
index 732781d..8bc4944 100644
Binary files a/lib/installer-exclude/irc-api-1.0.jar and b/lib/installer-
exclude/irc-api-1.0.jar differ

Please don't forget to update libsrc.

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hey Ingo,

···

On Thu, Nov 27, 2014 at 1:22 AM, Ingo Bauersachs <ingo@jitsi.org> wrote:

Please don't forget to update libsrc.

no need to update the libsrc.
I've updated the debian-src procedure to use repos:
https://github.com/jitsi/jitsi/blob/master/resources/install/README.Debian

Regards
damencho


#4

irc-api to custom version to test bug fix. (c0cebfe)
Hey Ingo,

Please don't forget to update libsrc.

no need to update the libsrc. I've updated the debian-src procedure to
use repos:
https://github.com/jitsi/jitsi/blob/master/resources/install/README.Debia
n

Uhm... okay. This would be possible for almost all the libraries in libsrc.
AFAIK our initial intention behind that was to
1) keep a copy in case the original source goes down/somewhere else
2) have the exact version as the binary in lib

Now that Danny committed a patched version, 2 is already no longer the case
for irc. And for projects hosted by ourselves, we could use git externals
instead of just linking to an arbitrary version of otr4j.

I might give some lib management with Maven another ago these days. There's
a couple of our own projects already using it and I just saw that George has
already set up a repo at http://jitsi.github.io/otr4j/repository.

And apropos libraries: IMO we need to start versioning libjitsi properly.
Consider Debian where the videobridge is more likely to go into stable than
Jitsi itself. It'll be great fun to have different versions of libjitsi as a
dependency...

Regards
damencho

Ingo

···

On Thu, Nov 27, 2014 at 1:22 AM, Ingo Bauersachs <ingo@jitsi.org> wrote: