[jitsi-dev] [jitsi-commits] master: Fix line endings (8a8aba3)


#1

Hey Ingo,

was there a problem with line endings? Seems this one breaks the build.

18:21:37 [mkdir] Created dir: C:\jitsi\jitsi\release\windows\tmp\light
18:21:38 [exec] rm.exe -f ../../../../resources/install/windows/config.h
18:21:38 [exec] cygwin warning:
18:21:38 [exec] MS-DOS style path detected: C:/mingw/x64/bin
18:21:38 [exec] Preferred POSIX equivalent is: /cygdrive/c/mingw/x64/bin
18:21:38 [exec] CYGWIN environment variable option
"nodosfilewarning" turns off this warning.
18:21:38 [exec] Consult the user's guide for more details about
POSIX paths:
18:21:38 [exec]
http://cygwin.com/cygwin-ug-net/using.html#using-pathnames
18:21:38 [exec] echo.exe -e '#define PRODUCTNAME "Jitsi"\n#define
COMPANYNAME "jitsi.org"\n#define PRODUCTBUILDVERSION
"2.7.5395"\n#define PRODUCTBUILDVERSION_COMMA 2,7,5395\n#define
TARGET_BASENAME "Jitsi"\n#define TARGET_BASENAME_EXE "Jitsi.exe"' >
/cygdrive/c/jitsi/jitsi/release/windows/tmp/light/config.h
18:21:38 [exec] C:/mingw/x64/bin/windres.exe
-I../../../../resources/install/windows
-IC:/jitsi/jitsi/release/windows/tmp/light run.rc -O coff -o
C:/jitsi/jitsi/release/windows/tmp/light/run.res
18:21:43 [exec] C:\mingw\x64\bin\windres.exe: run.rc:25: syntax error
18:21:43 [exec] make: ***
[/cygdrive/c/jitsi/jitsi/release/windows/tmp/light/run.res] Error 1
18:21:43 [exec] Makefile:54: recipe for target
`/cygdrive/c/jitsi/jitsi/release/windows/tmp/light/run.res' failed
18:21:43
18:21:43 BUILD FAILED
18:21:43 C:\jitsi\jitsi\resources\install\build.xml:304: The following
error occurred while executing this line:
18:21:43 C:\jitsi\jitsi\resources\install\build.xml:457: exec returned: 2
18:21:43

Regards
damencho

···

On Wed, Feb 4, 2015 at 11:56 PM, <ingo@jitsi.org> wrote:

Repository : ssh://lists.jitsi.org/jitsi

On branch : master
Link : https://github.com/jitsi/jitsi/compare/c02180a47e1b8e06b3cc585af0faada98ff48cf4...ac28b5888a8d59794569be8c8cb7db2e929cab7c

---------------------------------------------------------------

commit 8a8aba36888027ea454a10dfe00b660eaf5f65bf
Author: Ingo Bauersachs <ingo@jitsi.org>
Date: Wed Feb 4 22:40:59 2015 +0100

    Fix line endings

---------------------------------------------------------------

8a8aba36888027ea454a10dfe00b660eaf5f65bf
src/native/windows/run/Makefile | 0
src/native/windows/run/run.rc | 0
2 files changed, 0 insertions(+), 0 deletions(-)

_______________________________________________
commits mailing list
commits@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/commits


#2

Hey

was there a problem with line endings? Seems this one breaks the build.

Ahm, kind of. The two Makefiles had DOS line endings (CRLF) and as my git config of "core.autocrlf" is "input", git converts all line endings to Unix (LF), as is the standard for git and our repository. So 8a8aba36888027ea454a10dfe00b660eaf5f65bf is simply converting the line endings, while ac28b5888a8d59794569be8c8cb7db2e929cab7c tries to correctly set the file version property to Jitsi.exe's resource manifest.

I assume this is failing now because PRODUCTBUILDVERSION_COMMA lacks a trailing ",0". The file version attribute must probably always be in a 4-part format. Simple fix would be to stuff in a ",0" in line 464 of resources/install/build.xml, but that would break builds that actually have a 4-part version number.

[make output]

Regards
damencho

Ingo