[jitsi-dev] [jitsi-commits] master: Adds Jitsi to the list of IM Providers in windows registry.


#1

+ <RegistryKey
+ Key="Software\IM Providers"
+ Root="HKCU">
+ <RegistryValue
+ KeyPath="yes"
+ Name="DefaultIMApp"
+ Type="string"
+ Value="@APP_NAME@" />
+ </RegistryKey>
+ </Component>

That should IMO be HKLM, not HKCU. Otherwise it's going to be set for the NT-Authority\SYSTEM (well, at least in an unattended installation). A second user logging in would also be completely unaffected.

(Btw. the same goes for the autostart option)

Ingo


#2

Hi Ingo,

Thank you for the notice. I used a guide where the registry key was in HKCU. I’ll test your solution.

Regards,
Hristo.

···

On Mar 5, 2014, at 1:25 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

+ <RegistryKey
+ Key="Software\IM Providers"
+ Root="HKCU">
+ <RegistryValue
+ KeyPath="yes"
+ Name="DefaultIMApp"
+ Type="string"
+ Value="@APP_NAME@" />
+ </RegistryKey>
+ </Component>

That should IMO be HKLM, not HKCU. Otherwise it's going to be set for the NT-Authority\SYSTEM (well, at least in an unattended installation). A second user logging in would also be completely unaffected.

(Btw. the same goes for the autostart option)

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Just throwing in some related info...

I use Group Policy to push out this registry key to our users:

Change HKEY_CURRENT_USER\SOFTWARE\IM Providers from Lync to Communicator

Otherwise Outlook/Sharepoint integration does not work.

Aaron Dixon | IT Specialist | SSDC Services
Office: 248-277-9304 | Cell: 248-935-7353 | aaron.dixon@ssdcservices.com

···

-----Original Message-----
From: dev-bounces@jitsi.org [mailto:dev-bounces@jitsi.org] On Behalf Of Hristo Terezov
Sent: Wednesday, March 5, 2014 7:57 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] [jitsi-commits] master: Adds Jitsi to the list of IM Providers in windows registry.

Hi Ingo,

Thank you for the notice. I used a guide where the registry key was in HKCU. I'll test your solution.

Regards,
Hristo.

On Mar 5, 2014, at 1:25 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

+ <RegistryKey
+ Key="Software\IM Providers"
+ Root="HKCU">
+ <RegistryValue
+ KeyPath="yes"
+ Name="DefaultIMApp"
+ Type="string"
+ Value="@APP_NAME@" />
+ </RegistryKey>
+ </Component>

That should IMO be HKLM, not HKCU. Otherwise it's going to be set for the NT-Authority\SYSTEM (well, at least in an unattended installation). A second user logging in would also be completely unaffected.

(Btw. the same goes for the autostart option)

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev