[jitsi-dev] Jitsi build 3846 adds one more set of input devices to the audio options on each start (Linux 32-bit)


#1

Hello,

I observed that every time i restart Jitsi, in the Audio menu the "Audio in" dropdown list has one more set of devices. I use Debian Wheezy, 32-bit, openjdk 6b24~pre1-1 (debians versioning).

For example i have the following 4 items in the drop down menu (i have pulseaudio installed):

HDA Nvidia: VT-1708B 8Ch Analog (hw 0:0)
pulse
default
/dev/dsp

Now, if i shut down and restart Jitsi i will have the following:

HDA Nvidia: VT-1708B 8Ch Analog (hw 0:0)
pulse
default
/dev/dsp
HDA Nvidia: VT-1708B 8Ch Analog (hw 0:0)
pulse
default
/dev/dsp

And so on, every restart one more set.
Removing the ~/.jitsi/.fmj.registry file solves the issue (only one set of devices on startup) until i restart Jitsi. Then i will have one more etc.
I assume that file contains the data discovered from various media sources like input/output devices sound cards and video input + it has some audio/video formats in it and it is created/updated at each start.
Now this seems a cosmetic issue, but if you select another device from the wrong "set" (i had a 10 set long list and i failed to make it work) the voice input/output sound stops working (notifications play). Probably the bottom device set is the active one i assume, but the list gets a bit long after a while...

Somebody should take a look into this.

···

--
O zi buna,

Kertesz Laszlo

Using Opera's revolutionary email client: http://www.opera.com/mail/


#2

Kertesz, thank you very much for the detailed report! I'll try to look
into it and fix it tonight.

···

2011/12/23 Kertesz Laszlo <laszlo.kertesz@gmail.com>:

I observed that every time i restart Jitsi, in the Audio menu the "Audio in"
dropdown list has one more set of devices.

Removing the ~/.jitsi/.fmj.registry file solves the issue (only one set of
devices on startup) until i restart Jitsi.

Somebody should take a look into this.


#3

Kertesz, a fix has been committed into revision 9271 which is expected
to be integrated in nightly build 3847.

···

2011/12/23 Kertesz Laszlo <laszlo.kertesz@gmail.com>:

I observed that every time i restart Jitsi, in the Audio menu the "Audio in"
dropdown list has one more set of devices.

Removing the ~/.jitsi/.fmj.registry file solves the issue (only one set of
devices on startup) until i restart Jitsi.