[jitsi-dev] Jitsi as IM Provider


#1

Hey

There's a mismatch of the configured registry for Jitsi as the default IM
provider:
- Jitsi (java part) set HKCU\Software\IM Providers\DefaultIMApp:=Jitsi (or
whatever is configured in server.gui.APPLICATION_NAME)
- The COM Server however sets HKCU\Software\IM
Providers\Communicator\UpAndRunning:=2

The second part is wrong. It has to be the subkey that is configured in the
first part (i.e. Jitsi, not Communicator). So unless one manually creates
HKCU\Software\IM Providers\Jitsi\UpAndRunning:=2, IM integration doesn't
work.

Ingo


#2

Hello Ingo,

Hey

There's a mismatch of the configured registry for Jitsi as the default IM
provider:
- Jitsi (java part) set HKCU\Software\IM Providers\DefaultIMApp:=Jitsi (or
whatever is configured in server.gui.APPLICATION_NAME)
- The COM Server however sets HKCU\Software\IM
Providers\Communicator\UpAndRunning:=2

The second part is wrong. It has to be the subkey that is configured in the
first part (i.e. Jitsi, not Communicator). So unless one manually creates
HKCU\Software\IM Providers\Jitsi\UpAndRunning:=2, IM integration doesn't
work.

With the latest build of Jitsi it is working for me without any manual registry changes. I have the IM status in Outlook and I have options to send messages and to call the contacts.

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

Regards,
Hristo.

···

On Feb 26, 2015, at 10:41 AM, Ingo Bauersachs <ingo@jitsi.org> wrote:


#3

There's a mismatch of the configured registry for Jitsi as the default IM
provider:
- Jitsi (java part) set HKCU\Software\IM Providers\DefaultIMApp:=Jitsi (or
whatever is configured in server.gui.APPLICATION_NAME)
- The COM Server however sets HKCU\Software\IM
Providers\Communicator\UpAndRunning:=2

The second part is wrong. It has to be the subkey that is configured in the
first part (i.e. Jitsi, not Communicator). So unless one manually creates
HKCU\Software\IM Providers\Jitsi\UpAndRunning:=2, IM integration doesn't
work.

With the latest build of Jitsi it is working for me without any manual
registry changes. I have the IM status in Outlook and I have options to send
messages and to call the contacts.

Well, this is nice for you, but it doesn't help. I lost said functionality and had to manually create Jitsi\UpAndRunning:=2. Do you have "Set Jitsi as default IM app" disabled? Setting this option to false restores "Communicator" as DefaultIMApp and therefore it might work because UpAndRunning is set and Outlook will start using it.

Writing to the Communicator key is just plain wrong on Office 2010 or newer. We're not Office Communicator 2007.

Ingo

Regards,
Hristo.

Ingo


#4

There's a mismatch of the configured registry for Jitsi as the default IM
provider:
- Jitsi (java part) set HKCU\Software\IM Providers\DefaultIMApp:=Jitsi (or
whatever is configured in server.gui.APPLICATION_NAME)
- The COM Server however sets HKCU\Software\IM
Providers\Communicator\UpAndRunning:=2

The second part is wrong. It has to be the subkey that is configured in the
first part (i.e. Jitsi, not Communicator). So unless one manually creates
HKCU\Software\IM Providers\Jitsi\UpAndRunning:=2, IM integration doesn't
work.

With the latest build of Jitsi it is working for me without any manual
registry changes. I have the IM status in Outlook and I have options to send
messages and to call the contacts.

Well, this is nice for you, but it doesn't help. I lost said functionality and had to manually create Jitsi\UpAndRunning:=2. Do you have "Set Jitsi as default IM app" disabled? Setting this option to false restores "Communicator" as DefaultIMApp and therefore it might work because UpAndRunning is set and Outlook will start using it.

Yes it is my default IM app and I have tested this with Outlook 2010.

Writing to the Communicator key is just plain wrong on Office 2010 or newer. We're not Office Communicator 2007.

Are you reproducing the issue all the time? Do you have any ideas how to reproduce it?

I tested to manually change the key from Communicator to Jitsi. Then I restarted Outlook and the presence status was working for me but I wasn’t able to call or send message to the contact.

···

On Feb 26, 2015, at 1:06 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

Ingo

Regards,
Hristo.

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Writing to the Communicator key is just plain wrong on Office 2010 or
newer. We're not Office Communicator 2007.

Are you reproducing the issue all the time? Do you have any ideas how to
reproduce it?

No I can't reproduce it anymore. Probably because the Communicator key is used as a fallback from Office 2007 behavior when the Jitsi subkey is not present. But this fallback apparently doesn't work reliably all the time.

I tested to manually change the key from Communicator to Jitsi. Then I
restarted Outlook and the presence status was working for me but I wasn’t
able to call or send message to the contact.

I can confirm the problem with not being able start calls/chats. But even if the value is set to Communicator, starting a chat doesn't work: the account to send from is always set to Facebook, and it is the only account in the dropdown box (for contacts that I don't even have as Facebook friends and I obviously do have other accounts online)

What's more: the HKLM\Software\[Wow6432Node\]IM Providers\Jitsi\ProcessName and GUID are only read when the HKCU is correctly set. If the values in HKLM are not correct, then this likely causes the problem with not being able to start a call or chat. If I remove the HKLM\...\Jitsi key, Outlook performs the fallback to Communicator again. The GUID {8885370D-B33E-44B7-875D-28E403CF9270} set there is the one from Office Communicator.

I don't understand why there's such an insist on wrong behavior.
Office 2007: Always use Communicator. Implement the TreatAs.
Office 2010 and up: Always use Jitsi, correctly register the GUID.

Ingo

Hristo.

Ingo

Office2007_IM_Integration.doc (43 KB)

Office2010_IM_Integration.doc (48.5 KB)