[jitsi-dev] [Jitsi] Anyone having any luck compiling and running current master branch?


#1

Hopefully the following steps can help someone trying to perform source
build jitsi on windows 7 for debug. I am still having problem to do
“build-installation-wix-64”. Any advice is appreciated.

1. Jitsi-Windows Setup

Jitsi clients support running on multiple OS platforms including Windows 7.
This section provides the desired steps on how to compile and debug
jitsi-windows from source. The required steps are equally applicable for
jisti under ubuntu, probably simpler as most the IDE & tools setup may not
be required.

Please refer to the following sites for more information:

¨ https://github.com/jitsi/jitsi

¨ http://mingw-w64.org/doku.php

¨
https://www.igniterealtime.org/builds/smack/docs/latest/documentation/debugg
ing.html

To allow jitsi compilation from source using eclipse IDE on windows 7,
followings tools are required.

¨ Mingw-w64: an advancement of the original mingw.org project, created
to support the GCC compiler on Windows systems. It has forked it in 2007 in
order to provide support for 64 bits and new APIs.

§ mingw-w64-install.exe from

§ <https://sourceforge.net/projects/mingw-w64/>
https://sourceforge.net/projects/mingw-w64/

¨ WiX: a set of tools that allows you to create Windows Installer-based
deployment packages for your application. The WiX toolset is based on a
declarative XML authoring model. You can use WiX on the command line by
using the WiX tools or MSBuild.

§ WiX Toolset (WiX v3.10.2 - Stable) from

§ <http://wixtoolset.org/releases/> http://wixtoolset.org/releases/

1.1 Jitsi Project Installation & Setup

¨ Use SVN to checkout or clone source from the Github repo:

§ git clone https://github.com/jitsi/jitsi.git

¨ Import the jitsi project into eclipse as “Existing Projects into
Workspace” as “jitsi” project

You need to update the following source or script files for compilation and
debugging. It is assumed that mingw-w64 is installed in the following home
directory: C:\mingw\mingw64; and WiX tool in “C:\Program Files (x86)\WiX
Toolset v3.10”

¨ Update \jitsi\build.xml.

§

§ <property name='maxwarns' value='10000' />

§ <property name='label' value='5497' />

§ <property name='smack.debugEnabled' value='true' />

§ <property name="smack.debuggerClass"
value="org.jivesoftware.smack.debugger.ConsoleDebugger" />

§ <!-- property name="smack.debuggerClass"
value="org.jivesoftware.smack.debugger.LiteDebugger" / -->

§ <!-- property name="smack.debuggerClass"
value="org.jivesoftware.smack.debugger.SmackDebugger" / -->

§ <property name='java.net.preferIPv6Addresses' value='true'
/>

§
.

§ <!--DEBUG-JITSI -->

§ <target name="debug" depends="deploy-os-specific-bundles"

§
.

§ <sysproperty key="smack.debugEnabled"

§ value="${smack.debugEnabled}"/>

§ <sysproperty key="smack.debuggerClass"

§ value="${smack.debuggerClass}"/>

§
.

§ </target>

§ <!--RUN-JITSI -->

§ <target name="run"
depends="deploy-os-specific-bundles,load-properties"

§
.

§ <sysproperty key="smack.debugEnabled"

§ value="${smack.debugEnabled}"/>

§ <sysproperty key="smack.debuggerClass"

§ value="${smack.debuggerClass}"/>

§
.

§ </target>

¨ Note:

§ $label: the latest nightly build version and will be shown in jitsi
About dialog e.g. Jitsi version 2.9.5497

§ $smack.debugEnabled: set to true to enable smak debugger

§ $smack.debuggerClass: the type of smack debugger interface selected.
Refer to for more detail:
https://www.igniterealtime.org/builds/smack/docs/latest/documentation/debugg
ing.html

§ ConsoleDebugger is selected to display smack Send/Receive messages on
console, so as to sync with jitsi application debug messages.

¨ Update \Jitsi\resources\install\build.xml and make the following
changes from (-) to (+) with all the occurrences in the files:

§ - <property name="mingw.home" value="C:/mingw/x86" />

§ + <property name="mingw.home"
value="C:\mingw\mingw64\x86_64-w64-mingw32" />

§

§ - <property name="mingw.home" value="C:/mingw/x64" />

§ + <property name="mingw.home" value="C:\mingw\mingw64" />

§

§ - executable="make.exe"

§ + executable="c:\mingw\mingw64\bin/mingw32-make.exe"

§

§ - <property name="wix.home" value="C:\Program Files\WiX" />

§ + <property name="wix.home" value="C:\Program Files (x86)\WiX Toolset
v3.10\bin" />

¨ Update \Jitsi\resources\install\installers.properties to reflect the
java run time library location e.g.

§ - windows.jre64.zip=C:\\Install\\jre-8u40-windows-x64.zip

§ +
windows.jre64.zip=C:\\Progra~1\\Java\\jre1.8.0_73\\lib\\deploy\\jre-8u73-win
dows-x64.zip

¨ Update \Jitsi\lib\logging.properties

§ - java.util.logging.ConsoleHandler.level = SEVERE

§ + java.util.logging.ConsoleHandler.level = FINEST

§

§ - net.java.sip.communicator.impl.protocol.irc.level = INFO

§ + net.java.sip.communicator.impl.protocol.irc.level = FINEST

¨ Update \Jitsi\src\native\windows\run\Makefile

§ - MINGW_HOME ?= C:/mingw

§ + MINGW_HOME ?= C:/mingw/mingw64

§

¨ Update \Jitsi\src\native\windows\setup\Makefile

§ - MINGW_HOME ?= C:/mingw

§ + MINGW_HOME ?= C:/mingw/mingw64

§

§ - ARCH = $(shell $(CC) -dumpmachine | sed.exe -e s/x86_64-.*/x64/ -e
s/i.86-.*/x86/ -e s/mingw32/x86/)

§ + ARCH = $(shell $(CC) -dumpmachine | sed.exe -e s/x86_64-.*/x64/ -e
s/i.86-.*/x86/ -e s/mingw-w64/mingw32/)

¨ Note: During the “build-installation-wix-64” creation, still
encountered problem in the following lines 54/71 in both the above two
‘Makefile’ files. Deb-64 build under Ubuntu is successful without any
problem.
Still under investigation.

§ [exec] Makefile:54: *** target pattern contains no '%'. Stop.

§ $(cygwin.target.dir)/$(TARGET_BASENAME).exe:

.

¨ Update
\Jitsi\src\net\java\sip\communicator\impl\protocol\jabber\ProtocolProviderSe
rviceJabberImpl.java
Note: below changes are not required if
/org/jivesoftware/Smack/SmackConfigure.java jave version SMACK_VERSION =
"3.2.2". Smack debug is enabled by default

§ // user have the possibility to disable TLS but in this case,
it will

§ // not be able to connect to a server which requires TLS

§ confConn.setSecurityMode(

§ tlsRequired ?
ConnectionConfiguration.SecurityMode.required :

§ ConnectionConfiguration.SecurityMode.enabled);

§

§ // cmeng - enable smack debuuger

§ SmackConfiguration.DEBUG = true;

§

§ TLSUtils.setTLSOnly(confConn);

1.2 Jitsi Client Remote Debug

Jitsi-videobrige is executed in JVM machine. Following steps outline the
method to perform remote debug.

¨ From within eclipse, select jitsi project, right click and select
“Debug As|Debug Configurations". Enter parameters as shown below i.e. with
port set to 5432:

¨ Check “Display in favorite menu|Debug” option in Common Tab. Click
“Close” to complete.

¨ Right click on \jitsi\build.xml and select Run As | 2.Ant Build
. |
make | run

¨ Right click on \jitsi\build.xml and select Run As | 2.Ant Build
. |
debug | run

¨ The eclipse console will display the following message:

§ Jitsi build.xml [Ant Build] C:\Program
Files\Java\jdk1.7.0_xx\bin\javaw.exe (Mar3, 2016, 3:06:08 PM)

§ Buildfile: D:\workspace\Jitsi\build.xml

§ deploy-os-specific-bundles:

§ debug:

§ [java] Listening for transport dt_socket at address: 5432

¨ From the top menu, right click on debug tool icon ande select
‘jitsi-windows’

···

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus


#2

I have the opposite problem. I can build wix-64 and have it run fine. However my wix (32bit) crashes when I try run it. I am compiling on Windows 10 64bit. I have tried various versions of JDK v7 and embedded JRE 32bit and various compilers. I think there is something wrong with run.c but still haven't figured it out.

For compiling 64bit check that ARCH variable in the Makefile is in fact being assigned "x64". I just set it manually. "ARCH = x64". Also, "C:\jitsi.org\jitsi\src\native\windows\setup" or whatever your workspace is needs to be part of the windows path so that it static links C:\jitsi.org\jitsi\src\native\windows\setup\lib\x64\libbz2.a and liblzma.a instead of the versions in mingw. You would have installed them there if you followed any guides found doing an internet search. They are all now wrong. All of them! You do not need them because they are included with jitsi at C:\jitsi.org\jitsi\src\native\windows\setup\lib\x64\ and x86

Also set the path in Eclipse to the windows-64 path like the guide on the jitsi site says. That way it will put the 64bit DLL's into the installer, not the 32bit ones.

I use TDM64-GCC. I have tried Mingw and Mingw64 but I prefer TDM. I am also using it to compile 32 bit. You need to add -m32 to CPPFLAGS and add "--target=pe-i386" after "coff". The Makefiles are a mess and needed multiple changes. If I ever get 32bit wix running I will make a comprehensive guide showing the current correct way to do it. All the guides out there that I have found are old and do not work.

···

On 2016-03-02 12:22 PM, cmeng.gm wrote:

Hopefully the following steps can help someone trying to perform source build jitsi on windows 7 for debug. I am still having problem to do “build-installation-wix-64”. Any advice is appreciated.

  1.Jitsi-Windows Setup

Jitsi clients support running on multiple OS platforms including Windows 7. This section provides the desired steps on how to compile and debug jitsi-windows from source. The required steps are equally applicable for jisti under ubuntu, probably simpler as most the IDE & tools setup may not be required.

Please refer to the following sites for more information:

¨https://github.com/jitsi/jitsi

¨http://mingw-w64.org/doku.php

¨https://www.igniterealtime.org/builds/smack/docs/latest/documentation/debugging.html

To allow jitsi compilation from source using eclipse IDE on windows 7, followings tools are required.

¨Mingw-w64: an advancement of the original mingw.org project, created to support the GCC compiler on Windows systems. It has forked it in 2007 in order to provide support for 64 bits and new APIs.

§mingw-w64-install.exe from

§https://sourceforge.net/projects/mingw-w64/

¨WiX: a set of tools that allows you to create Windows Installer-based deployment packages for your application. The WiX toolset is based on a declarative XML authoring model. You can use WiX on the command line by using the WiX tools or MSBuild.

§WiX Toolset (WiX v3.10.2 - Stable) from

§http://wixtoolset.org/releases/

    1.1Jitsi Project Installation & Setup

¨Use SVN to checkout or clone source from the Github repo:

§git clone https://github.com/jitsi/jitsi.git

¨Import the jitsi project into eclipse as “Existing Projects into Workspace” as “jitsi” project

You need to update the following source or script files for compilation and debugging. It is assumed that mingw-w64 is installed in the following home directory: C:\mingw\mingw64; and WiX tool in “C:\Program Files (x86)\WiX Toolset v3.10”

¨Update \jitsi\build.xml.

§ ……

§ <property name='maxwarns' value='10000' />

§ <property name='label' value='5497' />

§ <property name='smack.debugEnabled' value='true' />

§<property name="smack.debuggerClass" value="org.jivesoftware.smack.debugger.ConsoleDebugger" />

§ <!-- property name="smack.debuggerClass" value="org.jivesoftware.smack.debugger.LiteDebugger" / -->

§ <!-- property name="smack.debuggerClass" value="org.jivesoftware.smack.debugger.SmackDebugger" / -->

§<property name='java.net.preferIPv6Addresses' value='true' />

§ ….

§ <!--DEBUG-JITSI -->

§ <target name="debug" depends="deploy-os-specific-bundles"

§ ….

§ <sysproperty key="smack.debugEnabled"

§ value="${smack.debugEnabled}"/>

§ <sysproperty key="smack.debuggerClass"

§ value="${smack.debuggerClass}"/>

§ ….

§ </target>

§ <!--RUN-JITSI -->

§ <target name="run" depends="deploy-os-specific-bundles,load-properties"

§ ….

§ <sysproperty key="smack.debugEnabled"

§ value="${smack.debugEnabled}"/>

§ <sysproperty key="smack.debuggerClass"

§ value="${smack.debuggerClass}"/>

§ ….

§ </target>

¨Note:

§$label: the latest nightly build version and will be shown in jitsi About dialog e.g. Jitsi version 2.9.5497

§$smack.debugEnabled: set to true to enable smak debugger

§$smack.debuggerClass: the type of smack debugger interface selected. Refer to for more detail: https://www.igniterealtime.org/builds/smack/docs/latest/documentation/debugging.html

§ConsoleDebugger is selected to display smack Send/Receive messages on console, so as to sync with jitsi application debug messages.

¨Update \Jitsi\resources\install\build.xml and make the following changes from (-) to (+) with all the occurrences in the files:

§- <property name="mingw.home" value="C:/mingw/x86" />

§+ <property name="mingw.home" value="C:\mingw\mingw64\x86_64-w64-mingw32" />

§

§- <property name="mingw.home" value="C:/mingw/x64" />

§+ <property name="mingw.home" value="C:\mingw\mingw64" />

§

§- executable="make.exe"

§+ executable="c:\mingw\mingw64\bin/mingw32-make.exe"

§

§- <property name="wix.home" value="C:\Program Files\WiX" />

§+ <property name="wix.home" value="C:\Program Files (x86)\WiX Toolset v3.10\bin" />

¨Update \Jitsi\resources\install\installers.properties to reflect the java run time library location e.g.

§- windows.jre64.zip=C:\\Install\\jre-8u40-windows-x64.zip

§+ windows.jre64.zip=C:\\Progra~1\\Java\\jre1.8.0_73\\lib\\deploy\\jre-8u73-windows-x64.zip

¨Update \Jitsi\lib\logging.properties

§- java.util.logging.ConsoleHandler.level = SEVERE

§+ java.util.logging.ConsoleHandler.level = FINEST

§

§- net.java.sip.communicator.impl.protocol.irc.level = INFO

§+ net.java.sip.communicator.impl.protocol.irc.level = FINEST

¨Update \Jitsi\src\native\windows\run\Makefile

§- MINGW_HOME ?= C:/mingw

§+ MINGW_HOME ?= C:/mingw/mingw64

§

¨Update \Jitsi\src\native\windows\setup\Makefile

§- MINGW_HOME ?= C:/mingw

§+ MINGW_HOME ?= C:/mingw/mingw64

§

§- ARCH = $(shell $(CC) -dumpmachine | sed.exe -e s/x86_64-.*/x64/ -e s/i.86-.*/x86/ -e s/mingw32/x86/)

§+ ARCH = $(shell $(CC) -dumpmachine | sed.exe -e s/x86_64-.*/x64/ -e s/i.86-.*/x86/ -e s/mingw-w64/mingw32/)

¨Note: During the “build-installation-wix-64” creation, still encountered problem in the following lines 54/71 in both the above two ‘Makefile’ files. Deb-64 build under Ubuntu is successful without any problem.
Still under investigation.

§[_exec_] Makefile:54: *** target pattern contains no '%'. Stop.

§$(cygwin.target.dir)/$(TARGET_BASENAME).exe: ……….

¨Update \Jitsi\src\net\java\sip\communicator\impl\protocol\jabber\ProtocolProviderServiceJabberImpl.java
Note: below changes are not required if /org/jivesoftware/Smack/SmackConfigure.java jave version SMACK_VERSION = "3.2.2". Smack debug is enabled by default

§ // user have the possibility to disable TLS but in this case, it will

§ // not be able to connect to a server which requires TLS

§ confConn.setSecurityMode(

§ tlsRequired ? ConnectionConfiguration.SecurityMode.required :

§ ConnectionConfiguration.SecurityMode.enabled);

§

§// cmeng - enable smack debuuger

§SmackConfiguration.DEBUG = true;

§

§ TLSUtils.setTLSOnly(confConn);

    1.2Jitsi Client Remote Debug

Jitsi-videobrige is executed in JVM machine. Following steps outline the method to perform remote debug.

¨From within eclipse, select jitsi project, right click and select “Debug As|Debug Configurations". Enter parameters as shown below i.e. with port set to 5432:

¨Check “Display in favorite menu|Debug” option in Common Tab. Click “Close” to complete.

¨Right click on \jitsi\build.xml and select Run As | 2.Ant Build …. | make | run

¨Right click on \jitsi\build.xml and select Run As | 2.Ant Build …. | debug | run

¨The eclipse console will display the following message:

§Jitsi build.xml [Ant Build] C:\Program Files\Java\jdk1.7.0_xx\bin\javaw.exe (Mar3, 2016, 3:06:08 PM)

§Buildfile: D:\workspace\Jitsi\build.xml

§deploy-os-specific-bundles:

§debug:

§ [java] Listening for transport dt_socket at address: 5432

¨From the top menu, right click on debug tool icon ande select ‘jitsi-windows’

This email has been sent from a virus-free computer protected by Avast.
www.avast.com <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>


#3

I believe that error is because you did not remove the "".

Go through the 3 makefiles and change

target.dir := "$(TARGET_DIR)"
cygwin.target.dir := "$(TARGET_DIR)"

to

target.dir := $(TARGET_DIR)
cygwin.target.dir := $(TARGET_DIR)

···

On 03/03/16 3:02 AM, cmeng.gm wrote:

Hi,

My present problem encountered is much earlier in the build process. It happens while execute the following statement in jitsi/native/windows/run/Makefile (line 54)

$(cygwin.target.dir)/$(TARGET_BASENAME).exe: $(cygwin.target.dir)/config.h registry.c run.c $(cygwin.target.dir)/run.res ../setup/nls.c

$(CC)$(CPPFLAGS)registry.c run.c $(target.dir)/run.res ../setup/nls.c $(LDFLAGS)-o $(target.dir)/$(TARGET_BASENAME).exe $(LIBS)

       -$(MINGW_HOME)/$(MACHINE)/bin/strip.exe $(target.dir)/$(TARGET_BASENAME).exe

Giving the With the following output error message:

….

_build-installation-wix-base_:

[_propertyfile_] Creating new property file: D:\workspace\Jitsi\release\windows\versionupdate.properties

[_mkdir_] Created dir: D:\workspace\Jitsi\release\windows\tmp\light

[_exec_] Makefile:54: *** target pattern contains no '%'. Stop.

[_exec_] Result: 2

….

From my understanding $(cygwin.target.dir) & $(target.dir) are actually referring to jitsi/release/windows/tmp. But I cannot find any of files that are specified in the line 54 run.exe statement. Not sure if there is a pre-process I need to perform before running wix-64 build.

Regards,

CM Eng

*From:*canuck15 [mailto:canuck15@hotmail.com]
*Sent:* Thursday, March 03, 2016 11:48 AM
*To:* cmeng.gm
*Subject:* Re: [jitsi-dev] [Jitsi] Anyone having any luck compiling and running current master branch?

I have the opposite problem. I can build wix-64 and have it run fine. However my wix (32bit) crashes when I try run it. I am compiling on Windows 10 64bit. I have tried various versions of JDK v7 and embedded JRE 32bit and various compilers. I think there is something wrong with run.c but still haven't figured it out.

For compiling 64bit check that ARCH variable in the Makefile is in fact being assigned "x64". I just set it manually. "ARCH = x64". Also, "C:\jitsi.org\jitsi\src\native\windows\setup" or whatever your workspace is needs to be part of the windows path so that it static links C:\jitsi.org\jitsi\src\native\windows\setup\lib\x64\libbz2.a and liblzma.a instead of the versions in mingw. You would have installed them there if you followed any guides found doing an internet search. They are all now wrong. All of them! You do not need them because they are included with jitsi at C:\jitsi.org\jitsi\src\native\windows\setup\lib\x64\ and x86

Also set the path in Eclipse to the windows-64 path like the guide on the jitsi site says. That way it will put the 64bit DLL's into the installer, not the 32bit ones.

I use TDM64-GCC. I have tried Mingw and Mingw64 but I prefer TDM. I am also using it to compile 32 bit. You need to add -m32 to CPPFLAGS and add "--target=pe-i386" after "coff". The Makefiles are a mess and needed multiple changes. If I ever get 32bit wix running I will make a comprehensive guide showing the current correct way to do it. All the guides out there that I have found are old and do not work.

On 02/03/16 12:22 PM, cmeng.gm wrote:

    Hopefully the following steps can help someone trying to perform
    source build jitsi on windows 7 for debug. I am still having
    problem to do “build-installation-wix-64”. Any advice is appreciated.

      1.Jitsi-Windows Setup

    Jitsi clients support running on multiple OS platforms including
    Windows 7. This section provides the desired steps on how to
    compile and debug jitsi-windows from source. The required steps
    are equally applicable for jisti under ubuntu, probably simpler as
    most the IDE & tools setup may not be required.

    Please refer to the following sites for more information:

    ¨https://github.com/jitsi/jitsi

    ¨http://mingw-w64.org/doku.php

    ¨https://www.igniterealtime.org/builds/smack/docs/latest/documentation/debugging.html

    To allow jitsi compilation from source using eclipse IDE on
    windows 7, followings tools are required.

    ¨Mingw-w64: an advancement of the original mingw.org project,
    created to support the GCC compiler on Windows systems. It has
    forked it in 2007 in order to provide support for 64 bits and new
    APIs.

    §mingw-w64-install.exe from

    §https://sourceforge.net/projects/mingw-w64/

    ¨WiX: a set of tools that allows you to create Windows
    Installer-based deployment packages for your application. The WiX
    toolset is based on a declarative XML authoring model. You can use
    WiX on the command line by using the WiX tools or MSBuild.

    §WiX Toolset (WiX v3.10.2 - Stable) from

    §http://wixtoolset.org/releases/

        1.1Jitsi Project Installation & Setup

    ¨Use SVN to checkout or clone source from the Github repo:

    §git clone https://github.com/jitsi/jitsi.git

    ¨Import the jitsi project into eclipse as “Existing Projects into
    Workspace” as “jitsi” project

    You need to update the following source or script files for
    compilation and debugging. It is assumed that mingw-w64 is
    installed in the following home directory: C:\mingw\mingw64; and
    WiX tool in “C:\Program Files (x86)\WiX Toolset v3.10”

    ¨Update \jitsi\build.xml.

    § ……

    § <property name='maxwarns' value='10000' />

    § <property name='label' value='5497' />

    § <property name='smack.debugEnabled' value='true' />

    §<property name="smack.debuggerClass"
    value="org.jivesoftware.smack.debugger.ConsoleDebugger" />

    § <!-- property name="smack.debuggerClass"
    value="org.jivesoftware.smack.debugger.LiteDebugger" / -->

    § <!-- property name="smack.debuggerClass"
    value="org.jivesoftware.smack.debugger.SmackDebugger" / -->

    §<property name='java.net.preferIPv6Addresses' value='true' />

    § ….

    § <!--DEBUG-JITSI -->

    § <target name="debug" depends="deploy-os-specific-bundles"

    § ….

    § <sysproperty key="smack.debugEnabled"

    § value="${smack.debugEnabled}"/>

    § <sysproperty key="smack.debuggerClass"

    § value="${smack.debuggerClass}"/>

    § ….

    § </target>

    § <!--RUN-JITSI -->

    § <target name="run"
    depends="deploy-os-specific-bundles,load-properties"

    § ….

    § <sysproperty key="smack.debugEnabled"

    § value="${smack.debugEnabled}"/>

    § <sysproperty key="smack.debuggerClass"

    § value="${smack.debuggerClass}"/>

    § ….

    § </target>

    ¨Note:

    §$label: the latest nightly build version and will be shown in
    jitsi About dialog e.g. Jitsi version 2.9.5497

    §$smack.debugEnabled: set to true to enable smak debugger

    §$smack.debuggerClass: the type of smack debugger interface
    selected. Refer to for more detail:
    https://www.igniterealtime.org/builds/smack/docs/latest/documentation/debugging.html

    §ConsoleDebugger is selected to display smack Send/Receive
    messages on console, so as to sync with jitsi application debug
    messages.

    ¨Update \Jitsi\resources\install\build.xml and make the following
    changes from (-) to (+) with all the occurrences in the files:

    §- <property name="mingw.home" value="C:/mingw/x86" />

    §+ <property name="mingw.home"
    value="C:\mingw\mingw64\x86_64-w64-mingw32" />

    §

    §- <property name="mingw.home" value="C:/mingw/x64" />

    §+ <property name="mingw.home" value="C:\mingw\mingw64" />

    §

    §- executable="make.exe"

    §+ executable="c:\mingw\mingw64\bin/mingw32-make.exe"

    §

    §- <property name="wix.home" value="C:\Program Files\WiX" />

    §+ <property name="wix.home" value="C:\Program Files (x86)\WiX
    Toolset v3.10\bin" />

    ¨Update \Jitsi\resources\install\installers.properties to reflect
    the java run time library location e.g.

    §- windows.jre64.zip=C:\\Install\\jre-8u40-windows-x64.zip

    §+
    windows.jre64.zip=C:\\Progra~1\\Java\\jre1.8.0_73\\lib\\deploy\\jre-8u73-windows-x64.zip

    ¨Update \Jitsi\lib\logging.properties

    §- java.util.logging.ConsoleHandler.level = SEVERE

    §+ java.util.logging.ConsoleHandler.level = FINEST

    §

    §- net.java.sip.communicator.impl.protocol.irc.level = INFO

    §+ net.java.sip.communicator.impl.protocol.irc.level = FINEST

    ¨Update \Jitsi\src\native\windows\run\Makefile

    §- MINGW_HOME ?= C:/mingw

    §+ MINGW_HOME ?= C:/mingw/mingw64

    §

    ¨Update \Jitsi\src\native\windows\setup\Makefile

    §- MINGW_HOME ?= C:/mingw

    §+ MINGW_HOME ?= C:/mingw/mingw64

    §

    §- ARCH = $(shell $(CC) -dumpmachine | sed.exe -e s/x86_64-.*/x64/
    -e s/i.86-.*/x86/ -e s/mingw32/x86/)

    §+ ARCH = $(shell $(CC) -dumpmachine | sed.exe -e s/x86_64-.*/x64/
    -e s/i.86-.*/x86/ -e s/mingw-w64/mingw32/)

    ¨Note: During the “build-installation-wix-64” creation, still
    encountered problem in the following lines 54/71 in both the above
    two ‘Makefile’ files. Deb-64 build under Ubuntu is successful
    without any problem.
    Still under investigation.

    §[_exec_] Makefile:54: *** target pattern contains no '%'. Stop.

    §$(cygwin.target.dir)/$(TARGET_BASENAME).exe: ……….

    ¨Update
    \Jitsi\src\net\java\sip\communicator\impl\protocol\jabber\ProtocolProviderServiceJabberImpl.java
    Note: below changes are not required if
    /org/jivesoftware/Smack/SmackConfigure.java jave version
    SMACK_VERSION = "3.2.2". Smack debug is enabled by default

    § // user have the possibility to disable TLS but in this
    case, it will

    § // not be able to connect to a server which requires TLS

    § confConn.setSecurityMode(

    § tlsRequired ?
    ConnectionConfiguration.SecurityMode.required :

    § ConnectionConfiguration.SecurityMode.enabled);

    §

    §// cmeng - enable smack debuuger

    §SmackConfiguration.DEBUG = true;

    §

    § TLSUtils.setTLSOnly(confConn);

        1.2Jitsi Client Remote Debug

    Jitsi-videobrige is executed in JVM machine. Following steps
    outline the method to perform remote debug.

    ¨From within eclipse, select jitsi project, right click and select
    “Debug As|Debug Configurations". Enter parameters as shown below
    i.e. with port set to 5432:

    ¨Check “Display in favorite menu|Debug” option in Common Tab.
    Click “Close” to complete.

    ¨Right click on \jitsi\build.xml and select Run As | 2.Ant Build
    …. | make | run

    ¨Right click on \jitsi\build.xml and select Run As | 2.Ant Build
    …. | debug | run

    ¨The eclipse console will display the following message:

    §Jitsi build.xml [Ant Build] C:\Program
    Files\Java\jdk1.7.0_xx\bin\javaw.exe (Mar3, 2016, 3:06:08 PM)

    §Buildfile: D:\workspace\Jitsi\build.xml

    §deploy-os-specific-bundles:

    §debug:

    § [java] Listening for transport dt_socket at address: 5432

    ¨From the top menu, right click on debug tool icon ande select
    ‘jitsi-windows’

    This email has been sent from a virus-free computer protected by
    Avast.
    www.avast.com
    <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>

This email has been sent from a virus-free computer protected by Avast.
www.avast.com <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>


#4

Hi,

Many thanks, fixing that syntax error has allowed me procced the whole build
process to the end. But I am still facing some problems along the way.

Note: There are other changes required to Makefile as shown in the above
attached file.

1a. There are duplicated command i.e. echo on both windows and Cygwin. Just
execute echo in Makefile have problem.

I need to force it to use C:/cygwin64/bin/echo to generate a correct
config.h

1b. Even after installed the Cygwin on windows, there are script that cannot
be executed on windows e.g. shell.

Replacing shell with “C:\cygwin64\bin\mintty.exe” is also not perfect and
may not work in all cases.

So I removed all shell commands in all windows 7 scripts.

2. The variable definition for TARGET_DIR ?= ../../../../release/windows/tmp

But in the build console output, I found that the >
$(cygwin.target.dir)/config.h has become

D:\workspace\Jitsi/release/windows/tmp/light/config.h

i.e.
tmp/light. Is this correct?

3. Error message found in build console:

build-installation-wix-msi:

     [move] Warning: Could not find file
D:\workspace\Jitsi\release\windows\tmp\setup.msi to copy.

I can see that setup.msi does exist, but only further down the build process
and after the above error message. Any idea?

4. There are other warnings e.g. warning CNDL1138, warning LGHT1076 but I
just ignore right now.

5. Also found the following syntax error at the end of the build

wix-sign-file:

     [exec] setup.msi: 78.5 MiB / 236.3 MiB = 0.332, 1.4 MiB/s, 2:53

     [exec] echo.exe -e '#define PRODUCTNAME "Jitsi"\n#undef
PACKAGECODE\n#undef PACKAGESIZE\n#define PRODUCTBUILDVERSION "2.9.5497"' >
D:\workspace\Jitsi/release/windows/tmp/config.h

     [exec] C:/mingw/mingw64/bin/windres.exe
-I../../../../resources/install/windows
-ID:\workspace\Jitsi/release/windows/tmp setup.rc -O coff -o
D:\workspace\Jitsi/release/windows/tmp/setup.res

     [exec] Makefile:82: recipe for target
'D:\workspace\Jitsi/release/windows/tmp/setup.res' failed

     [exec] C:/mingw/mingw64/bin/windres.exe: setup.rc:59: syntax error

     [exec] mingw32-make: ***
[D:\workspace\Jitsi/release/windows/tmp/setup.res] Error 1

It appears to be an string concatenation error not supported by rc compiler.
How do you fix it?

6. There is a zip file defined in the
D:\workspace\Jitsi\resources\install\installers.properties:

windows.jre64.zip=C:\\Install\\jre-8u40-windows-x64.zip

I cannot find this file online. Currently I just download
jre-8u73-windows-x64.gz and convert it to a zip file. No sure if this the
correct way?

Regards,

CM Eng

Makefile (2.64 KB)

···

From: canuck15 [mailto:canuck15@hotmail.com]
Sent: Friday, March 04, 2016 1:59 AM
To: cmeng.gm; dev@jitsi.org
Subject: Re: [jitsi-dev] [Jitsi] Anyone having any luck compiling and
running current master branch?

I believe that error is because you did not remove the "".

Go through the 3 makefiles and change

target.dir := "$(TARGET_DIR)"
cygwin.target.dir := "$(TARGET_DIR)"

to

target.dir := $(TARGET_DIR)
cygwin.target.dir := $(TARGET_DIR)

On 03/03/16 3:02 AM, cmeng.gm wrote:

Hi,

My present problem encountered is much earlier in the build process. It
happens while execute the following statement in
jitsi/native/windows/run/Makefile (line 54)

$(cygwin.target.dir)/$(TARGET_BASENAME).exe: $(cygwin.target.dir)/config.h
registry.c run.c $(cygwin.target.dir)/run.res ../setup/nls.c

       $(CC) $(CPPFLAGS) registry.c run.c $(target.dir)/run.res
../setup/nls.c $(LDFLAGS) -o $(target.dir)/$(TARGET_BASENAME).exe $(LIBS)

       -$(MINGW_HOME)/$(MACHINE)/bin/strip.exe
$(target.dir)/$(TARGET_BASENAME).exe

Giving the With the following output error message:

.

build-installation-wix-base:

[propertyfile] Creating new property file:
D:\workspace\Jitsi\release\windows\versionupdate.properties

    [mkdir] Created dir: D:\workspace\Jitsi\release\windows\tmp\light

     [exec] Makefile:54: *** target pattern contains no '%'. Stop.

     [exec] Result: 2

.

From my understanding $(cygwin.target.dir) & $(target.dir) are actually

referring to jitsi/release/windows/tmp. But I cannot find any of files that
are specified in the line 54 run.exe statement. Not sure if there is a
pre-process I need to perform before running wix-64 build.

Regards,

CM Eng

From: canuck15 [mailto:canuck15@hotmail.com]
Sent: Thursday, March 03, 2016 11:48 AM
To: cmeng.gm
Subject: Re: [jitsi-dev] [Jitsi] Anyone having any luck compiling and
running current master branch?

I have the opposite problem. I can build wix-64 and have it run fine.
However my wix (32bit) crashes when I try run it. I am compiling on Windows
10 64bit. I have tried various versions of JDK v7 and embedded JRE 32bit
and various compilers. I think there is something wrong with run.c but
still haven't figured it out.

For compiling 64bit check that ARCH variable in the Makefile is in fact
being assigned "x64". I just set it manually. "ARCH = x64". Also,
"C:\jitsi.org\jitsi\src\native\windows\setup" or whatever your workspace is
needs to be part of the windows path so that it static links
C:\jitsi.org\jitsi\src\native\windows\setup\lib\x64\libbz2.a and liblzma.a
instead of the versions in mingw. You would have installed them there if
you followed any guides found doing an internet search. They are all now
wrong. All of them! You do not need them because they are included with
jitsi at C:\jitsi.org\jitsi\src\native\windows\setup\lib\x64\ and x86

Also set the path in Eclipse to the windows-64 path like the guide on the
jitsi site says. That way it will put the 64bit DLL's into the installer,
not the 32bit ones.

I use TDM64-GCC. I have tried Mingw and Mingw64 but I prefer TDM. I am
also using it to compile 32 bit. You need to add -m32 to CPPFLAGS and add
"--target=pe-i386" after "coff". The Makefiles are a mess and needed
multiple changes. If I ever get 32bit wix running I will make a
comprehensive guide showing the current correct way to do it. All the
guides out there that I have found are old and do not work.

On 02/03/16 12:22 PM, cmeng.gm wrote:

Hopefully the following steps can help someone trying to perform source
build jitsi on windows 7 for debug. I am still having problem to do
“build-installation-wix-64”. Any advice is appreciated.

1. Jitsi-Windows Setup

Jitsi clients support running on multiple OS platforms including Windows 7.
This section provides the desired steps on how to compile and debug
jitsi-windows from source. The required steps are equally applicable for
jisti under ubuntu, probably simpler as most the IDE & tools setup may not
be required.

Please refer to the following sites for more information:

¨ https://github.com/jitsi/jitsi

¨ http://mingw-w64.org/doku.php

¨
https://www.igniterealtime.org/builds/smack/docs/latest/documentation/debugg
ing.html

To allow jitsi compilation from source using eclipse IDE on windows 7,
followings tools are required.

¨ Mingw-w64: an advancement of the original mingw.org project, created
to support the GCC compiler on Windows systems. It has forked it in 2007 in
order to provide support for 64 bits and new APIs.

§ mingw-w64-install.exe from

§ https://sourceforge.net/projects/mingw-w64/

¨ WiX: a set of tools that allows you to create Windows Installer-based
deployment packages for your application. The WiX toolset is based on a
declarative XML authoring model. You can use WiX on the command line by
using the WiX tools or MSBuild.

§ WiX Toolset (WiX v3.10.2 - Stable) from

§ http://wixtoolset.org/releases/

1.1 Jitsi Project Installation & Setup

¨ Use SVN to checkout or clone source from the Github repo:

§ git clone https://github.com/jitsi/jitsi.git

¨ Import the jitsi project into eclipse as “Existing Projects into
Workspace” as “jitsi” project

You need to update the following source or script files for compilation and
debugging. It is assumed that mingw-w64 is installed in the following home
directory: C:\mingw\mingw64; and WiX tool in “C:\Program Files (x86)\WiX
Toolset v3.10”

¨ Update \jitsi\build.xml.

§

§ <property name='maxwarns' value='10000' />

§ <property name='label' value='5497' />

§ <property name='smack.debugEnabled' value='true' />

§ <property name="smack.debuggerClass"
value="org.jivesoftware.smack.debugger.ConsoleDebugger" />

§ <!-- property name="smack.debuggerClass"
value="org.jivesoftware.smack.debugger.LiteDebugger" / -->

§ <!-- property name="smack.debuggerClass"
value="org.jivesoftware.smack.debugger.SmackDebugger" / -->

§ <property name='java.net.preferIPv6Addresses' value='true'
/>

§
.

§ <!--DEBUG-JITSI -->

§ <target name="debug" depends="deploy-os-specific-bundles"

§
.

§ <sysproperty key="smack.debugEnabled"

§ value="${smack.debugEnabled}"/>

§ <sysproperty key="smack.debuggerClass"

§ value="${smack.debuggerClass}"/>

§
.

§ </target>

§ <!--RUN-JITSI -->

§ <target name="run"
depends="deploy-os-specific-bundles,load-properties"

§
.

§ <sysproperty key="smack.debugEnabled"

§ value="${smack.debugEnabled}"/>

§ <sysproperty key="smack.debuggerClass"

§ value="${smack.debuggerClass}"/>

§
.

§ </target>

¨ Note:

§ $label: the latest nightly build version and will be shown in jitsi
About dialog e.g. Jitsi version 2.9.5497

§ $smack.debugEnabled: set to true to enable smak debugger

§ $smack.debuggerClass: the type of smack debugger interface selected.
Refer to for more detail:
https://www.igniterealtime.org/builds/smack/docs/latest/documentation/debugg
ing.html

§ ConsoleDebugger is selected to display smack Send/Receive messages on
console, so as to sync with jitsi application debug messages.

¨ Update \Jitsi\resources\install\build.xml and make the following
changes from (-) to (+) with all the occurrences in the files:

§ - <property name="mingw.home" value="C:/mingw/x86" />

§ + <property name="mingw.home"
value="C:\mingw\mingw64\x86_64-w64-mingw32" />

§

§ - <property name="mingw.home" value="C:/mingw/x64" />

§ + <property name="mingw.home" value="C:\mingw\mingw64" />

§

§ - executable="make.exe"

§ + executable="c:\mingw\mingw64\bin/mingw32-make.exe"

§

§ - <property name="wix.home" value="C:\Program Files\WiX" />

§ + <property name="wix.home" value="C:\Program Files (x86)\WiX Toolset
v3.10\bin" />

¨ Update \Jitsi\resources\install\installers.properties to reflect the
java run time library location e.g.

§ - windows.jre64.zip=C:\\Install\\jre-8u40-windows-x64.zip

§ +
windows.jre64.zip=C:\\Progra~1\\Java\\jre1.8.0_73\\lib\\deploy\\jre-8u73-win
dows-x64.zip

¨ Update \Jitsi\lib\logging.properties

§ - java.util.logging.ConsoleHandler.level = SEVERE

§ + java.util.logging.ConsoleHandler.level = FINEST

§

§ - net.java.sip.communicator.impl.protocol.irc.level = INFO

§ + net.java.sip.communicator.impl.protocol.irc.level = FINEST

¨ Update \Jitsi\src\native\windows\run\Makefile

§ - MINGW_HOME ?= C:/mingw

§ + MINGW_HOME ?= C:/mingw/mingw64

§

¨ Update \Jitsi\src\native\windows\setup\Makefile

§ - MINGW_HOME ?= C:/mingw

§ + MINGW_HOME ?= C:/mingw/mingw64

§

§ - ARCH = $(shell $(CC) -dumpmachine | sed.exe -e s/x86_64-.*/x64/ -e
s/i.86-.*/x86/ -e s/mingw32/x86/)

§ + ARCH = $(shell $(CC) -dumpmachine | sed.exe -e s/x86_64-.*/x64/ -e
s/i.86-.*/x86/ -e s/mingw-w64/mingw32/)

¨ Note: During the “build-installation-wix-64” creation, still
encountered problem in the following lines 54/71 in both the above two
‘Makefile’ files. Deb-64 build under Ubuntu is successful without any
problem.
Still under investigation.

§ [exec] Makefile:54: *** target pattern contains no '%'. Stop.

§ $(cygwin.target.dir)/$(TARGET_BASENAME).exe:

.

¨ Update
\Jitsi\src\net\java\sip\communicator\impl\protocol\jabber\ProtocolProviderSe
rviceJabberImpl.java
Note: below changes are not required if
/org/jivesoftware/Smack/SmackConfigure.java jave version SMACK_VERSION =
"3.2.2". Smack debug is enabled by default

§ // user have the possibility to disable TLS but in this case,
it will

§ // not be able to connect to a server which requires TLS

§ confConn.setSecurityMode(

§ tlsRequired ?
ConnectionConfiguration.SecurityMode.required :

§ ConnectionConfiguration.SecurityMode.enabled);

§

§ // cmeng - enable smack debuuger

§ SmackConfiguration.DEBUG = true;

§

§ TLSUtils.setTLSOnly(confConn);

1.2 Jitsi Client Remote Debug

Jitsi-videobrige is executed in JVM machine. Following steps outline the
method to perform remote debug.

¨ From within eclipse, select jitsi project, right click and select
“Debug As|Debug Configurations". Enter parameters as shown below i.e. with
port set to 5432:

¨ Check “Display in favorite menu|Debug” option in Common Tab. Click
“Close” to complete.

¨ Right click on \jitsi\build.xml and select Run As | 2.Ant Build
. |
make | run

¨ Right click on \jitsi\build.xml and select Run As | 2.Ant Build
. |
debug | run

¨ The eclipse console will display the following message:

§ Jitsi build.xml [Ant Build] C:\Program
Files\Java\jdk1.7.0_xx\bin\javaw.exe (Mar3, 2016, 3:06:08 PM)

§ Buildfile: D:\workspace\Jitsi\build.xml

§ deploy-os-specific-bundles:

§ debug:

§ [java] Listening for transport dt_socket at address: 5432

¨ From the top menu, right click on debug tool icon ande select
‘jitsi-windows’

This email has been sent from a virus-free computer protected by Avast.

<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campai
gn=sig-email&utm_content=emailclient> www.avast.com

This email has been sent from a virus-free computer protected by Avast.

<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campai
gn=sig-email&utm_content=emailclient> www.avast.com

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus


#5

I am not using cygwin for anything. Do not have it installed. Not needed.

The echo commands will not work in the makefiles as is. You have to redo them all as follows:

$(cygwin.target.dir)/config.h:
     -rm.exe -f ../../../../resources/install/windows/config.h
     echo #define PRODUCTNAME "$(PRODUCTNAME)" > $(cygwin.target.dir)/config.h
     echo #define COMPANYNAME "$(COMPANYNAME)" >> $(cygwin.target.dir)/config.h
     echo #define PRODUCTBUILDVERSION "$(PRODUCTBUILDVERSION)" >> $(cygwin.target.dir)/config.h
     echo #define PRODUCTBUILDVERSION_COMMA $(PRODUCTBUILDVERSION_COMMA) >> $(cygwin.target.dir)/config.h
     echo #define TARGET_BASENAME "$(TARGET_BASENAME)" >> $(cygwin.target.dir)/config.h
     echo #define TARGET_BASENAME_EXE "$(TARGET_BASENAME).exe" >> $(cygwin.target.dir)/config.h

That is the exact working sytax. Directly from my build environment. 100% working now on 64 and 32bit. Will be making an install guide soon.

···

On 2016-03-03 6:43 PM, cmeng.gm wrote:

Hi,

Many thanks, fixing that syntax error has allowed me procced the whole build process to the end. But I am still facing some problems along the way.

Note: There are other changes required to Makefile as shown in the above attached file.

1a. There are duplicated command i.e. echo on both windows and Cygwin. Just execute echo in Makefile have problem.

I need to force it to use C:/cygwin64/bin/echo to generate a correct config.h

1b. Even after installed the Cygwin on windows, there are script that cannot be executed on windows e.g. shell.

Replacing shell with “C:\cygwin64\bin\mintty.exe” is also not perfect and may not work in all cases.

So I removed all shell commands in all windows 7 scripts.

2. The variable definition for TARGET_DIR ?= ../../../../release/windows/tmp

But in the build console output, I found that the > $(cygwin.target.dir)/config.h has become

> D:\workspace\Jitsi/release/windows/tmp/light/config.h

i.e. …tmp/light. Is this correct?

3. Error message found in build console:

_build-installation-wix-msi_:

[_move_] Warning: Could not find file D:\workspace\Jitsi\release\windows\tmp\setup.msi to copy.

I can see that setup.msi does exist, but only further down the build process and after the above error message. Any idea?

4. There are other warnings e.g. warning CNDL1138, warning LGHT1076 but I just ignore right now.

5. Also found the following syntax error at the end of the build

_wix-sign-file_:

[_exec_] setup.msi: 78.5 MiB / 236.3 MiB = 0.332, 1.4 MiB/s, 2:53

[_exec_] echo.exe -e '#define PRODUCTNAME "Jitsi"\n#undef PACKAGECODE\n#undef PACKAGESIZE\n#define PRODUCTBUILDVERSION "2.9.5497"' > D:\workspace\Jitsi/release/windows/tmp/config.h

[_exec_] C:/mingw/mingw64/bin/windres.exe -I../../../../resources/install/windows -ID:\workspace\Jitsi/release/windows/tmp setup.rc -O coff -o D:\workspace\Jitsi/release/windows/tmp/setup.res

[_exec_] Makefile:82: recipe for target 'D:\workspace\Jitsi/release/windows/tmp/setup.res' failed

[_exec_] C:/mingw/mingw64/bin/windres.exe: setup.rc:59: syntax error

[_exec_] mingw32-make: *** [D:\workspace\Jitsi/release/windows/tmp/setup.res] Error 1

It appears to be an string concatenation error not supported by rc compiler. How do you fix it?

6. There is a zip file defined in the D:\workspace\Jitsi\resources\install\installers.properties:

windows.jre64.zip=C:\\Install\\jre-8u40-windows-x64.zip

I cannot find this file online. Currently I just download jre-8u73-windows-x64.gz and convert it to a zip file. No sure if this the correct way?

Regards,

CM Eng

*From:*canuck15 [mailto:canuck15@hotmail.com]
*Sent:* Friday, March 04, 2016 1:59 AM
*To:* cmeng.gm; dev@jitsi.org
*Subject:* Re: [jitsi-dev] [Jitsi] Anyone having any luck compiling and running current master branch?

I believe that error is because you did not remove the "".

Go through the 3 makefiles and change

target.dir := "$(TARGET_DIR)"
cygwin.target.dir := "$(TARGET_DIR)"

to

target.dir := $(TARGET_DIR)
cygwin.target.dir := $(TARGET_DIR)

On 03/03/16 3:02 AM, cmeng.gm wrote:

    Hi,

    My present problem encountered is much earlier in the build
    process. It happens while execute the following statement in
    jitsi/native/windows/run/Makefile (line 54)

    $(cygwin.target.dir)/$(TARGET_BASENAME).exe:
    $(cygwin.target.dir)/config.h registry.c run.c
    $(cygwin.target.dir)/run.res ../setup/nls.c

    $(CC)$(CPPFLAGS)registry.c run.c $(target.dir)/run.res
    ../setup/nls.c $(LDFLAGS)-o $(target.dir)/$(TARGET_BASENAME).exe
    $(LIBS)

           -$(MINGW_HOME)/$(MACHINE)/bin/strip.exe
    $(target.dir)/$(TARGET_BASENAME).exe

    Giving the With the following output error message:

    ….

    _build-installation-wix-base_:

    [_propertyfile_] Creating new property file:
    D:\workspace\Jitsi\release\windows\versionupdate.properties

    [_mkdir_] Created dir: D:\workspace\Jitsi\release\windows\tmp\light

    [_exec_] Makefile:54: *** target pattern contains no '%'. Stop.

    [_exec_] Result: 2

    ….

    From my understanding $(cygwin.target.dir) & $(target.dir) are
    actually referring to jitsi/release/windows/tmp. But I cannot find
    any of files that are specified in the line 54 run.exe statement.
    Not sure if there is a pre-process I need to perform before
    running wix-64 build.

    Regards,

    CM Eng

    *From:*canuck15 [mailto:canuck15@hotmail.com]
    *Sent:* Thursday, March 03, 2016 11:48 AM
    *To:* cmeng.gm
    *Subject:* Re: [jitsi-dev] [Jitsi] Anyone having any luck
    compiling and running current master branch?

    I have the opposite problem. I can build wix-64 and have it run
    fine. However my wix (32bit) crashes when I try run it. I am
    compiling on Windows 10 64bit. I have tried various versions of
    JDK v7 and embedded JRE 32bit and various compilers. I think
    there is something wrong with run.c but still haven't figured it out.

    For compiling 64bit check that ARCH variable in the Makefile is in
    fact being assigned "x64". I just set it manually. "ARCH = x64". Also, "C:\jitsi.org\jitsi\src\native\windows\setup" or whatever
    your workspace is needs to be part of the windows path so that it
    static links
    C:\jitsi.org\jitsi\src\native\windows\setup\lib\x64\libbz2.a and
    liblzma.a instead of the versions in mingw. You would have
    installed them there if you followed any guides found doing an
    internet search. They are all now wrong. All of them! You do
    not need them because they are included with jitsi at
    C:\jitsi.org\jitsi\src\native\windows\setup\lib\x64\ and x86

    Also set the path in Eclipse to the windows-64 path like the guide
    on the jitsi site says. That way it will put the 64bit DLL's into
    the installer, not the 32bit ones.

    I use TDM64-GCC. I have tried Mingw and Mingw64 but I prefer
    TDM. I am also using it to compile 32 bit. You need to add -m32
    to CPPFLAGS and add "--target=pe-i386" after "coff". The
    Makefiles are a mess and needed multiple changes. If I ever get
    32bit wix running I will make a comprehensive guide showing the
    current correct way to do it. All the guides out there that I
    have found are old and do not work.

    On 02/03/16 12:22 PM, cmeng.gm wrote:

        Hopefully the following steps can help someone trying to
        perform source build jitsi on windows 7 for debug. I am still
        having problem to do “build-installation-wix-64”. Any advice
        is appreciated.

          1.Jitsi-Windows Setup

        Jitsi clients support running on multiple OS platforms
        including Windows 7. This section provides the desired steps
        on how to compile and debug jitsi-windows from source. The
        required steps are equally applicable for jisti under ubuntu,
        probably simpler as most the IDE & tools setup may not be
        required.

        Please refer to the following sites for more information:

        ¨https://github.com/jitsi/jitsi

        ¨http://mingw-w64.org/doku.php

        ¨https://www.igniterealtime.org/builds/smack/docs/latest/documentation/debugging.html

        To allow jitsi compilation from source using eclipse IDE on
        windows 7, followings tools are required.

        ¨Mingw-w64: an advancement of the original mingw.org project,
        created to support the GCC compiler on Windows systems. It has
        forked it in 2007 in order to provide support for 64 bits and
        new APIs.

        §mingw-w64-install.exe from

        §https://sourceforge.net/projects/mingw-w64/

        ¨WiX: a set of tools that allows you to create Windows
        Installer-based deployment packages for your application. The
        WiX toolset is based on a declarative XML authoring model. You
        can use WiX on the command line by using the WiX tools or MSBuild.

        §WiX Toolset (WiX v3.10.2 - Stable) from

        §http://wixtoolset.org/releases/

            1.1Jitsi Project Installation & Setup

        ¨Use SVN to checkout or clone source from the Github repo:

        §git clone https://github.com/jitsi/jitsi.git

        ¨Import the jitsi project into eclipse as “Existing Projects
        into Workspace” as “jitsi” project

        You need to update the following source or script files for
        compilation and debugging. It is assumed that mingw-w64 is
        installed in the following home directory: C:\mingw\mingw64;
        and WiX tool in “C:\Program Files (x86)\WiX Toolset v3.10”

        ¨Update \jitsi\build.xml.

        § ……

        § <property name='maxwarns' value='10000' />

        § <property name='label' value='5497' />

        § <property name='smack.debugEnabled' value='true' />

        §<property name="smack.debuggerClass"
        value="org.jivesoftware.smack.debugger.ConsoleDebugger" />

        § <!-- property name="smack.debuggerClass"
        value="org.jivesoftware.smack.debugger.LiteDebugger" / -->

        § <!-- property name="smack.debuggerClass"
        value="org.jivesoftware.smack.debugger.SmackDebugger" / -->

        §<property name='java.net.preferIPv6Addresses' value='true' />

        § ….

        § <!--DEBUG-JITSI -->

        § <target name="debug" depends="deploy-os-specific-bundles"

        § ….

        § <sysproperty key="smack.debugEnabled"

        § value="${smack.debugEnabled}"/>

        § <sysproperty key="smack.debuggerClass"

        § value="${smack.debuggerClass}"/>

        § ….

        § </target>

        § <!--RUN-JITSI -->

        § <target name="run"
        depends="deploy-os-specific-bundles,load-properties"

        § ….

        § <sysproperty key="smack.debugEnabled"

        § value="${smack.debugEnabled}"/>

        § <sysproperty key="smack.debuggerClass"

        § value="${smack.debuggerClass}"/>

        § ….

        § </target>

        ¨Note:

        §$label: the latest nightly build version and will be shown in
        jitsi About dialog e.g. Jitsi version 2.9.5497

        §$smack.debugEnabled: set to true to enable smak debugger

        §$smack.debuggerClass: the type of smack debugger interface
        selected. Refer to for more detail:
        https://www.igniterealtime.org/builds/smack/docs/latest/documentation/debugging.html

        §ConsoleDebugger is selected to display smack Send/Receive
        messages on console, so as to sync with jitsi application
        debug messages.

        ¨Update \Jitsi\resources\install\build.xml and make the
        following changes from (-) to (+) with all the occurrences in
        the files:

        §- <property name="mingw.home" value="C:/mingw/x86" />

        §+ <property name="mingw.home"
        value="C:\mingw\mingw64\x86_64-w64-mingw32" />

        §

        §- <property name="mingw.home" value="C:/mingw/x64" />

        §+ <property name="mingw.home" value="C:\mingw\mingw64" />

        §

        §- executable="make.exe"

        §+ executable="c:\mingw\mingw64\bin/mingw32-make.exe"

        §

        §- <property name="wix.home" value="C:\Program Files\WiX" />

        §+ <property name="wix.home" value="C:\Program Files (x86)\WiX
        Toolset v3.10\bin" />

        ¨Update \Jitsi\resources\install\installers.properties to
        reflect the java run time library location e.g.

        §- windows.jre64.zip=C:\\Install\\jre-8u40-windows-x64.zip

        §+
        windows.jre64.zip=C:\\Progra~1\\Java\\jre1.8.0_73\\lib\\deploy\\jre-8u73-windows-x64.zip

        ¨Update \Jitsi\lib\logging.properties

        §- java.util.logging.ConsoleHandler.level = SEVERE

        §+ java.util.logging.ConsoleHandler.level = FINEST

        §

        §- net.java.sip.communicator.impl.protocol.irc.level = INFO

        §+ net.java.sip.communicator.impl.protocol.irc.level = FINEST

        ¨Update \Jitsi\src\native\windows\run\Makefile

        §- MINGW_HOME ?= C:/mingw

        §+ MINGW_HOME ?= C:/mingw/mingw64

        §

        ¨Update \Jitsi\src\native\windows\setup\Makefile

        §- MINGW_HOME ?= C:/mingw

        §+ MINGW_HOME ?= C:/mingw/mingw64

        §

        §- ARCH = $(shell $(CC) -dumpmachine | sed.exe -e
        s/x86_64-.*/x64/ -e s/i.86-.*/x86/ -e s/mingw32/x86/)

        §+ ARCH = $(shell $(CC) -dumpmachine | sed.exe -e
        s/x86_64-.*/x64/ -e s/i.86-.*/x86/ -e s/mingw-w64/mingw32/)

        ¨Note: During the “build-installation-wix-64” creation, still
        encountered problem in the following lines 54/71 in both the
        above two ‘Makefile’ files. Deb-64 build under Ubuntu is
        successful without any problem.
        Still under investigation.

        §[_exec_] Makefile:54: *** target pattern contains no '%'. Stop.

        §$(cygwin.target.dir)/$(TARGET_BASENAME).exe: ……….

        ¨Update
        \Jitsi\src\net\java\sip\communicator\impl\protocol\jabber\ProtocolProviderServiceJabberImpl.java
        Note: below changes are not required if
        /org/jivesoftware/Smack/SmackConfigure.java jave version
        SMACK_VERSION = "3.2.2". Smack debug is enabled by default

        § // user have the possibility to disable TLS but in
        this case, it will

        § // not be able to connect to a server which requires TLS

        § confConn.setSecurityMode(

        § tlsRequired ?
        ConnectionConfiguration.SecurityMode.required :

        § ConnectionConfiguration.SecurityMode.enabled);

        §

        §// cmeng - enable smack debuuger

        §SmackConfiguration.DEBUG = true;

        §

        § TLSUtils.setTLSOnly(confConn);

            1.2Jitsi Client Remote Debug

        Jitsi-videobrige is executed in JVM machine. Following steps
        outline the method to perform remote debug.

        ¨From within eclipse, select jitsi project, right click and
        select “Debug As|Debug Configurations". Enter parameters as
        shown below i.e. with port set to 5432:

        ¨Check “Display in favorite menu|Debug” option in Common Tab.
        Click “Close” to complete.

        ¨Right click on \jitsi\build.xml and select Run As | 2.Ant
        Build …. | make | run

        ¨Right click on \jitsi\build.xml and select Run As | 2.Ant
        Build …. | debug | run

        ¨The eclipse console will display the following message:

        §Jitsi build.xml [Ant Build] C:\Program
        Files\Java\jdk1.7.0_xx\bin\javaw.exe (Mar3, 2016, 3:06:08 PM)

        §Buildfile: D:\workspace\Jitsi\build.xml

        §deploy-os-specific-bundles:

        §debug:

        § [java] Listening for transport dt_socket at address: 5432

        ¨From the top menu, right click on debug tool icon ande select
        ‘jitsi-windows’

        This email has been sent from a virus-free computer protected
        by Avast.
        www.avast.com
        <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>

    This email has been sent from a virus-free computer protected by
    Avast.
    www.avast.com
    <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>

This email has been sent from a virus-free computer protected by Avast.
www.avast.com <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient>