[jitsi-dev] Jitsi 2.2 and sipXecs 4.6: What is configuration to avoid "Authentication failed for... (Jabber). The password you entered is not valid."?


#1

Hi!

I would like to get sipXecs and Jitsi working both on XMPP and SIP as
part of the Tiki Suite project (http://suite.tiki.org/Tiki+Suite)

Not configured SIP yet, but on XMPP, I get "Authentication failed for
... (Jabber). The password you entered is not valid." But the same
setup on Pidgin works.

Can anyone with sipXecs 4.6 and Jitsi help me make this work? I can
provide test accounts if this helps.

A little squirrel told me it could be related to an "exotic form of
authentication for XMPP" and that Jitsi has a "property to fix this".
With this info, I will update the documentation:
http://wiki.sipfoundry.org/display/sipXecs/Jitsi (And if it doesn't,
I'll file a proper bug report)

Thanks!

···

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net


#2

Hi,

try adding this property
net.java.sip.communicator.impl.protocol.jabber.DISABLE_CUSTOM_DIGEST_MD5=true
Hope it helps.

Regards
damencho

···

On Mon, Nov 11, 2013 at 6:06 PM, Marc Laporte <marc@marclaporte.com> wrote:

Hi!

I would like to get sipXecs and Jitsi working both on XMPP and SIP as
part of the Tiki Suite project (http://suite.tiki.org/Tiki+Suite)

Not configured SIP yet, but on XMPP, I get "Authentication failed for
... (Jabber). The password you entered is not valid." But the same
setup on Pidgin works.

Can anyone with sipXecs 4.6 and Jitsi help me make this work? I can
provide test accounts if this helps.

A little squirrel told me it could be related to an "exotic form of
authentication for XMPP" and that Jitsi has a "property to fix this".
With this info, I will update the documentation:
http://wiki.sipfoundry.org/display/sipXecs/Jitsi (And if it doesn't,
I'll file a proper bug report)

Thanks!

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Thanks Damencho

I tried that (putting that line at as per
https://jitsi.org/Documentation/FAQ#conf )

But I still have the same error.

Thanks!

···

On Mon, Nov 11, 2013 at 11:10 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

try adding this property
net.java.sip.communicator.impl.protocol.jabber.DISABLE_CUSTOM_DIGEST_MD5=true
Hope it helps.

Regards
damencho

On Mon, Nov 11, 2013 at 6:06 PM, Marc Laporte <marc@marclaporte.com> wrote:

Hi!

I would like to get sipXecs and Jitsi working both on XMPP and SIP as
part of the Tiki Suite project (http://suite.tiki.org/Tiki+Suite)

Not configured SIP yet, but on XMPP, I get "Authentication failed for
... (Jabber). The password you entered is not valid." But the same
setup on Pidgin works.

Can anyone with sipXecs 4.6 and Jitsi help me make this work? I can
provide test accounts if this helps.

A little squirrel told me it could be related to an "exotic form of
authentication for XMPP" and that Jitsi has a "property to fix this".
With this info, I will update the documentation:
http://wiki.sipfoundry.org/display/sipXecs/Jitsi (And if it doesn't,
I'll file a proper bug report)

Thanks!

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net


#4

Hey Marc,

You either need to do this through the configuration editor, or you need to:

1) stop jitsi (make sure the process is no longer there)
2) edit and save the file
3) start jitsi

You can also do this for one specific account:

net.java.sip.communicator.impl.protocol.jabber.acc1384444444213.DISABLE_CUSTOM_DIGEST_MD5=true

where acc1384444444213 should be replaced by the ID for your sipx account.

I just tried this on your server and managed to log in successfully.

Emil

···

On Mon, Nov 11, 2013 at 7:10 PM, Marc Laporte <marc@marclaporte.com> wrote:

Thanks Damencho

I tried that (putting that line at as per
https://jitsi.org/Documentation/FAQ#conf )

But I still have the same error.

Thanks!

On Mon, Nov 11, 2013 at 11:10 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

try adding this property
net.java.sip.communicator.impl.protocol.jabber.DISABLE_CUSTOM_DIGEST_MD5=true
Hope it helps.

Regards
damencho

On Mon, Nov 11, 2013 at 6:06 PM, Marc Laporte <marc@marclaporte.com> wrote:

Hi!

I would like to get sipXecs and Jitsi working both on XMPP and SIP as
part of the Tiki Suite project (http://suite.tiki.org/Tiki+Suite)

Not configured SIP yet, but on XMPP, I get "Authentication failed for
... (Jabber). The password you entered is not valid." But the same
setup on Pidgin works.

Can anyone with sipXecs 4.6 and Jitsi help me make this work? I can
provide test accounts if this helps.

A little squirrel told me it could be related to an "exotic form of
authentication for XMPP" and that Jitsi has a "property to fix this".
With this info, I will update the documentation:
http://wiki.sipfoundry.org/display/sipXecs/Jitsi (And if it doesn't,
I'll file a proper bug report)

Thanks!

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#5

Hi Emil!

I confirm this works!

Thanks!

···

On Mon, Nov 11, 2013 at 1:28 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Marc,

You either need to do this through the configuration editor, or you need to:

1) stop jitsi (make sure the process is no longer there)
2) edit and save the file
3) start jitsi

You can also do this for one specific account:

net.java.sip.communicator.impl.protocol.jabber.acc1384444444213.DISABLE_CUSTOM_DIGEST_MD5=true

where acc1384444444213 should be replaced by the ID for your sipx account.

I just tried this on your server and managed to log in successfully.

Emil

On Mon, Nov 11, 2013 at 7:10 PM, Marc Laporte <marc@marclaporte.com> wrote:

Thanks Damencho

I tried that (putting that line at as per
https://jitsi.org/Documentation/FAQ#conf )

But I still have the same error.

Thanks!

On Mon, Nov 11, 2013 at 11:10 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

try adding this property
net.java.sip.communicator.impl.protocol.jabber.DISABLE_CUSTOM_DIGEST_MD5=true
Hope it helps.

Regards
damencho

On Mon, Nov 11, 2013 at 6:06 PM, Marc Laporte <marc@marclaporte.com> wrote:

Hi!

I would like to get sipXecs and Jitsi working both on XMPP and SIP as
part of the Tiki Suite project (http://suite.tiki.org/Tiki+Suite)

Not configured SIP yet, but on XMPP, I get "Authentication failed for
... (Jabber). The password you entered is not valid." But the same
setup on Pidgin works.

Can anyone with sipXecs 4.6 and Jitsi help me make this work? I can
provide test accounts if this helps.

A little squirrel told me it could be related to an "exotic form of
authentication for XMPP" and that Jitsi has a "property to fix this".
With this info, I will update the documentation:
http://wiki.sipfoundry.org/display/sipXecs/Jitsi (And if it doesn't,
I'll file a proper bug report)

Thanks!

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net


#6

Hi!

So, ideally, this extra step would not be necessary, but it's fine for
this phase.

Should I consider this as a limitation in Jitsi, in sipXecs or in both?

Thanks!

···

On Mon, Nov 11, 2013 at 2:04 PM, Marc Laporte <marc@marclaporte.com> wrote:

Hi Emil!

I confirm this works!

Thanks!

On Mon, Nov 11, 2013 at 1:28 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Marc,

You either need to do this through the configuration editor, or you need to:

1) stop jitsi (make sure the process is no longer there)
2) edit and save the file
3) start jitsi

You can also do this for one specific account:

net.java.sip.communicator.impl.protocol.jabber.acc1384444444213.DISABLE_CUSTOM_DIGEST_MD5=true

where acc1384444444213 should be replaced by the ID for your sipx account.

I just tried this on your server and managed to log in successfully.

Emil

On Mon, Nov 11, 2013 at 7:10 PM, Marc Laporte <marc@marclaporte.com> wrote:

Thanks Damencho

I tried that (putting that line at as per
https://jitsi.org/Documentation/FAQ#conf )

But I still have the same error.

Thanks!

On Mon, Nov 11, 2013 at 11:10 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

try adding this property
net.java.sip.communicator.impl.protocol.jabber.DISABLE_CUSTOM_DIGEST_MD5=true
Hope it helps.

Regards
damencho

On Mon, Nov 11, 2013 at 6:06 PM, Marc Laporte <marc@marclaporte.com> wrote:

Hi!

I would like to get sipXecs and Jitsi working both on XMPP and SIP as
part of the Tiki Suite project (http://suite.tiki.org/Tiki+Suite)

Not configured SIP yet, but on XMPP, I get "Authentication failed for
... (Jabber). The password you entered is not valid." But the same
setup on Pidgin works.

Can anyone with sipXecs 4.6 and Jitsi help me make this work? I can
provide test accounts if this helps.

A little squirrel told me it could be related to an "exotic form of
authentication for XMPP" and that Jitsi has a "property to fix this".
With this info, I will update the documentation:
http://wiki.sipfoundry.org/display/sipXecs/Jitsi (And if it doesn't,
I'll file a proper bug report)

Thanks!

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net


#7

Hi!

So, ideally, this extra step would not be necessary, but it's fine for
this phase.

If you are planning on using SIP and XMPP together you'd probably need
to consider use of provisioning anyway. If so this step becomes
entirely transparent to the user.

Should I consider this as a limitation in Jitsi, in sipXecs or in both?

We don't have the issue with other servers and you don't seem to have
it with other clients so I'd say it's an issue of the combination :slight_smile:

Emil

···

On Wed, Nov 13, 2013 at 12:18 AM, Marc Laporte <marc@marclaporte.com> wrote:

Thanks!

On Mon, Nov 11, 2013 at 2:04 PM, Marc Laporte <marc@marclaporte.com> wrote:

Hi Emil!

I confirm this works!

Thanks!

On Mon, Nov 11, 2013 at 1:28 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Marc,

You either need to do this through the configuration editor, or you need to:

1) stop jitsi (make sure the process is no longer there)
2) edit and save the file
3) start jitsi

You can also do this for one specific account:

net.java.sip.communicator.impl.protocol.jabber.acc1384444444213.DISABLE_CUSTOM_DIGEST_MD5=true

where acc1384444444213 should be replaced by the ID for your sipx account.

I just tried this on your server and managed to log in successfully.

Emil

On Mon, Nov 11, 2013 at 7:10 PM, Marc Laporte <marc@marclaporte.com> wrote:

Thanks Damencho

I tried that (putting that line at as per
https://jitsi.org/Documentation/FAQ#conf )

But I still have the same error.

Thanks!

On Mon, Nov 11, 2013 at 11:10 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

try adding this property
net.java.sip.communicator.impl.protocol.jabber.DISABLE_CUSTOM_DIGEST_MD5=true
Hope it helps.

Regards
damencho

On Mon, Nov 11, 2013 at 6:06 PM, Marc Laporte <marc@marclaporte.com> wrote:

Hi!

I would like to get sipXecs and Jitsi working both on XMPP and SIP as
part of the Tiki Suite project (http://suite.tiki.org/Tiki+Suite)

Not configured SIP yet, but on XMPP, I get "Authentication failed for
... (Jabber). The password you entered is not valid." But the same
setup on Pidgin works.

Can anyone with sipXecs 4.6 and Jitsi help me make this work? I can
provide test accounts if this helps.

A little squirrel told me it could be related to an "exotic form of
authentication for XMPP" and that Jitsi has a "property to fix this".
With this info, I will update the documentation:
http://wiki.sipfoundry.org/display/sipXecs/Jitsi (And if it doesn't,
I'll file a proper bug report)

Thanks!

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

--
Marc Laporte

http://MarcLaporte.com
http://Tiki.org/MarcLaporte
http://AvanTech.net

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31