[jitsi-dev] JitMeet installation with Openfire


#1

Hi,

When I tried to install JitMeet, I tried to use it with Openfire and not
prosody (because Openfire was already installed for the jitsi-videobridge
install tutorial).

I discover that with the config files you recommend to use, only prosody
work, but with Openfire, it doesn't : Jitmeet try at one moment (and I
don't know why) to send an HTTP request to the bosh URL that is in
config.js, ans send a GET request, not a POST one. Openfire responds with a
HTTP Error 400 Bad Request.
I honestly don't know why JitMeet send a GET request, and not a POST,
because when all is working, JitMeet only send POST request.

What I do know is how you can fix this issue, you can choose between (or do
both, it will also work) :
-in the nginx config file for jitmeet virtualhost, when you set the proxy
for BOSH, in the line starting with proxy_pass, you need to put a slash "/"
at the end of the URL : "proxy_pass http://localhost:5280/http-bind/;"
-in config.js, in the jitmeet root directory, you put a slash at the end of
the URL for the BOSH line : " bosh: '//jitmeet.example.com/http-bind/' ".

Like I said, you can do both, or just one, but in any case, after that,
JitMeet will work on you computer.
This configuration also work for Openfire AND prosody, so I would recommend
to put the '/' in config.js and/or in nginx vhost config file, just to be
sure.

NB : you can also put a slash '/' in the line "location /http-bind" in the
nginx vhost config file, but if you do and if you use Openfire, you MUST
put a slash in the "proxy_pass" line.

Maybe you didn't have theses problems, and maybe it's just me and my
computer, but I thought I should still share it.

Sorry for the wall of text.

Thomas Kuntz.