[jitsi-dev] jitmeet etherpad menu button not clickable?


#1

Hi,

I'm not sure what changed from yesterday to today, but now when using
jitmeet's etherpad it seems that the dropdown toolbar is always in the
foreground which prevents me from clicking on any of the ertherpad menus
(settings, username, etc).

I'm pretty certain this was working fine yesterday (a few days ago?), so
I'm not sure what changed suddenly and why the dropdown toolbar doesn't
autohide like it does in the main window.

Can someone please confirm that this is also happening to them? I would
imagine this maybe due to z-index in css, but not really sure which one to
tinker with.

Thanks,

Peter


#2

I cannot click the etherpad buttons, but I think it has been like this
for some time.

This might help, but I haven't tried:
https://github.com/peili/jitsi-meet/commit/1367248633d868f5da8637ec1ff5556945382b79

Regards,
Boris

···

On 07/05/14 17:06, Peter Villeneuve wrote:

Hi,

I'm not sure what changed from yesterday to today, but now when using
jitmeet's etherpad it seems that the dropdown toolbar is always in the
foreground which prevents me from clicking on any of the ertherpad menus
(settings, username, etc).

I'm pretty certain this was working fine yesterday (a few days ago?), so
I'm not sure what changed suddenly and why the dropdown toolbar doesn't
autohide like it does in the main window.

Can someone please confirm that this is also happening to them? I would
imagine this maybe due to z-index in css, but not really sure which one
to tinker with.


#3

Thanks Boris,

That indeed does make most of the etherpad buttons clickable, except the
ones that are behind the dropdown toolbar.
I'm 100% certain that it was working for me a few days ago (ie. the
dropdown toolbar would autohide), but now the toolbar always stays in the
foreground when etherpad is engaged.
I've been messing a lot with the css, so apparently I did find a solution
at some point but now I forgot what I did ):

Cheers,

Peter

···

On Wed, May 7, 2014 at 4:18 PM, Boris Grozev <boris@jitsi.org> wrote:

On 07/05/14 17:06, Peter Villeneuve wrote:
> Hi,
>
> I'm not sure what changed from yesterday to today, but now when using
> jitmeet's etherpad it seems that the dropdown toolbar is always in the
> foreground which prevents me from clicking on any of the ertherpad menus
> (settings, username, etc).
>
> I'm pretty certain this was working fine yesterday (a few days ago?), so
> I'm not sure what changed suddenly and why the dropdown toolbar doesn't
> autohide like it does in the main window.
>
> Can someone please confirm that this is also happening to them? I would
> imagine this maybe due to z-index in css, but not really sure which one
> to tinker with.
>

I cannot click the etherpad buttons, but I think it has been like this
for some time.

This might help, but I haven't tried:

https://github.com/peili/jitsi-meet/commit/1367248633d868f5da8637ec1ff5556945382b79

Regards,
Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Can someone else confirm that the menu button doesn't autohide in etherpad?
Trying to figure out if it's something I've done or a bug in jitmeet.

Thanks

···

On Wed, May 7, 2014 at 4:30 PM, Peter Villeneuve <petervnv1@gmail.com>wrote:

Thanks Boris,

That indeed does make most of the etherpad buttons clickable, except the
ones that are behind the dropdown toolbar.
I'm 100% certain that it was working for me a few days ago (ie. the
dropdown toolbar would autohide), but now the toolbar always stays in the
foreground when etherpad is engaged.
I've been messing a lot with the css, so apparently I did find a solution
at some point but now I forgot what I did ):

Cheers,

Peter

On Wed, May 7, 2014 at 4:18 PM, Boris Grozev <boris@jitsi.org> wrote:

On 07/05/14 17:06, Peter Villeneuve wrote:
> Hi,
>
> I'm not sure what changed from yesterday to today, but now when using
> jitmeet's etherpad it seems that the dropdown toolbar is always in the
> foreground which prevents me from clicking on any of the ertherpad menus
> (settings, username, etc).
>
> I'm pretty certain this was working fine yesterday (a few days ago?), so
> I'm not sure what changed suddenly and why the dropdown toolbar doesn't
> autohide like it does in the main window.
>
> Can someone please confirm that this is also happening to them? I would
> imagine this maybe due to z-index in css, but not really sure which one
> to tinker with.
>

I cannot click the etherpad buttons, but I think it has been like this
for some time.

This might help, but I haven't tried:

https://github.com/peili/jitsi-meet/commit/1367248633d868f5da8637ec1ff5556945382b79

Regards,
Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

It does not auto-hide for me.

Boris

···

On 16/05/14 19:50, Peter Villeneuve wrote:

Can someone else confirm that the menu button doesn't autohide in etherpad?
Trying to figure out if it's something I've done or a bug in jitmeet.


#6

Thanks for the quick reply.
Glad this time it's not something I did :wink:

···

On Fri, May 16, 2014 at 6:54 PM, Boris Grozev <boris@jitsi.org> wrote:

On 16/05/14 19:50, Peter Villeneuve wrote:
> Can someone else confirm that the menu button doesn't autohide in
etherpad?
> Trying to figure out if it's something I've done or a bug in jitmeet.

It does not auto-hide for me.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Thanks for the quick reply.
Glad this time it's not something I did :wink:

Not only that but it's also intentional. Mouse events are consumed by etherpad so we keep the menu open because we can't pop it on mouse move as with video.

Emil

···

On 16.05.14, 19:59, Peter Villeneuve wrote:

On Fri, May 16, 2014 at 6:54 PM, Boris Grozev <boris@jitsi.org > <mailto:boris@jitsi.org>> wrote:

    On 16/05/14 19:50, Peter Villeneuve wrote:
     > Can someone else confirm that the menu button doesn't autohide in
    etherpad?
     > Trying to figure out if it's something I've done or a bug in jitmeet.

    It does not auto-hide for me.

    Boris

    _______________________________________________
    dev mailing list
    dev@jitsi.org <mailto:dev@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
https://jitsi.org