[jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.


#1

Using the prosody lockdown config, a conference room must be created by an authenticated user. After that, anonymous users are allowed to connect. That seems to work fine but when the authenticated moderator leaves the room, the first connected anonymous user is promoted to moderator. Is it possible to dump the room (or automatically kick all anonymous participants) when the moderator leaves?

Also, there’s some logic in the app.bundle library that would appear to want to “park" those anonymous users until an authenticated user creates the room. This isn’t what happens. The anonymous user is just blocked with a server error. Is there some configuration required to unlock that parking behavior?
Thanks,
John


#2

Hi,

···

On Wed, Mar 4, 2015 at 5:20 AM, John Lightfoot <john@vizhn.com> wrote:

Using the prosody lockdown config, a conference room must be created by an
authenticated user. After that, anonymous users are allowed to connect.
That seems to work fine but when the authenticated moderator leaves the
room, the first connected anonymous user is promoted to moderator. Is it
possible to dump the room (or automatically kick all anonymous participants)
when the moderator leaves?

Also, there’s some logic in the app.bundle library that would appear to want
to “park" those anonymous users until an authenticated user creates the
room. This isn’t what happens. The anonymous user is just blocked with a
server error. Is there some configuration required to unlock that parking
behavior?

What Prosody config do you use exactly ? This[1] one can be used to
enable "parking".

[1]: https://github.com/jitsi/jicofo#secure-domain

Regards,
Pawel


#3

That’s the config I was referring to. In addition, I had to enable
cross_domain_bosh and set restrict_room_creation = “local” on the muc
component. After that, when I append ?login=true to the full room URL, I
can logon and create a room. I can connect to that same room anonymously.
That’s all good. If I try to connect to the room anonymously before it’s
created, I get an “oops … please contact your service admin” error. I
don’t get put into a 5 second wait loop.

···

On 3/3/15, 11:35 PM, "Paweł Domas" <pawel.domas@jitsi.org> wrote:

Hi,

On Wed, Mar 4, 2015 at 5:20 AM, John Lightfoot <john@vizhn.com> wrote:

Using the prosody lockdown config, a conference room must be created by
an
authenticated user. After that, anonymous users are allowed to connect.
That seems to work fine but when the authenticated moderator leaves the
room, the first connected anonymous user is promoted to moderator. Is it
possible to dump the room (or automatically kick all anonymous
participants)
when the moderator leaves?

Also, there’s some logic in the app.bundle library that would appear to
want
to “park" those anonymous users until an authenticated user creates the
room. This isn’t what happens. The anonymous user is just blocked
with a
server error. Is there some configuration required to unlock that
parking
behavior?

What Prosody config do you use exactly ? This[1] one can be used to
enable "parking".

[1]: https://github.com/jitsi/jicofo#secure-domain

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#4

Hi,

That’s the config I was referring to. In addition, I had to enable
cross_domain_bosh and set restrict_room_creation = “local” on the muc
component. After that, when I append ?login=true to the full room URL, I
can logon and create a room. I can connect to that same room anonymously.
That’s all good. If I try to connect to the room anonymously before it’s
created, I get an “oops … please contact your service admin” error. I
don’t get put into a 5 second wait loop.

Oh sorry, I forgot about bug in Prosody. Which version do you use ?
There is problem with "restrict_room_creation" setting handling
reported here[1]. You can try to apply my patch in order to have it
working until it is fixed in the trunk.

[1]: https://code.google.com/p/lxmppd/issues/detail?id=458

Regards,
Pawel

···

On Wed, Mar 4, 2015 at 3:14 PM, John Lightfoot <john@vizhn.com> wrote:


#5

I’m using the 0.9.1 version bundled in the quick install. That bug is
related to admin users and my authenticating user is not an admin. Is
this because the focus user is an admin?

···

On 3/4/15, 6:25 AM, "Paweł Domas" <pawel.domas@jitsi.org> wrote:

Hi,

On Wed, Mar 4, 2015 at 3:14 PM, John Lightfoot <john@vizhn.com> wrote:

That’s the config I was referring to. In addition, I had to enable
cross_domain_bosh and set restrict_room_creation = “local” on the muc
component. After that, when I append ?login=true to the full room URL, I
can logon and create a room. I can connect to that same room
anonymously.
That’s all good. If I try to connect to the room anonymously before
it’s
created, I get an “oops … please contact your service admin” error. I
don’t get put into a 5 second wait loop.

Oh sorry, I forgot about bug in Prosody. Which version do you use ?
There is problem with "restrict_room_creation" setting handling
reported here[1]. You can try to apply my patch in order to have it
working until it is fixed in the trunk.

[1]: https://code.google.com/p/lxmppd/issues/detail?id=458

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Yes, but I'm not sure if the bug is valid for 0.9.1. It might be
something else too.

···

On Wed, Mar 4, 2015 at 3:59 PM, John Lightfoot <john@vizhn.com> wrote:

I’m using the 0.9.1 version bundled in the quick install. That bug is
related to admin users and my authenticating user is not an admin. Is
this because the focus user is an admin?


#7

Ok. It looks like the room is being created ok so I won’t apply your
patch. Any ideas what else to try?

···

On 3/4/15, 7:07 AM, "Paweł Domas" <pawel.domas@jitsi.org> wrote:

On Wed, Mar 4, 2015 at 3:59 PM, John Lightfoot <john@vizhn.com> wrote:

I’m using the 0.9.1 version bundled in the quick install. That bug is
related to admin users and my authenticating user is not an admin. Is
this because the focus user is an admin?

Yes, but I'm not sure if the bug is valid for 0.9.1. It might be
something else too.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Are you sure that you have this[1] configured correctly ? Jicofo
should reject user request and park the user. If this option is not
configured correctly user will try to enter the room, but it is not
allowed and this error pops up.

[1]: -Dorg.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com

···

On Wed, Mar 4, 2015 at 4:42 PM, John Lightfoot <john@vizhn.com> wrote:

Ok. It looks like the room is being created ok so I won’t apply your
patch. Any ideas what else to try?


#9

I confirmed jicofo is running with that parameter. This is what I'm seeing in the jocofo log (conf 123123 and domain jitsi.domain.com) ...

07:59:53.279 INFO: [273] org.jitsi.jicofo.xmpp.FocusComponent.handleConferenceIq().369 Focus request for room: 123123@conference.jitsi.domain.com
07:59:53.280 INFO: [273] org.jitsi.jicofo.FocusManager.createConference().231 Created new focus for 123123@conference.jitsi.domain.com@auth.jitsi.domain.com conferences count: 1 options:
    channelLastN: 1
    adaptiveLastN: false
    adaptiveSimulcast: false
    bridge: jitsi-videobridge.jitsi.domain.com
    enableFirefoxHacks: false
    openSctp: true
07:59:53.422 INFO: [274] org.jitsi.jicofo.JitsiMeetConference.registrationStateChanged().1072 Reg state changed: RegistrationStateChangeEvent[ oldState=Unregistered; newState=RegistrationState=Registered; reasonCode=-1; reason=null]
07:59:53.423 INFO: [274] org.jitsi.jicofo.JitsiMeetConference.maybeJoinTheRoom().279 Registered: XmppProtocolProvider(focus)
07:59:53.424 INFO: [274] org.jitsi.jicofo.JitsiMeetConference.joinTheRoom().290 Joining the room: 123123@conference.jitsi.domain.com
07:59:53.426 SEVERE: [274] org.jitsi.jicofo.JitsiMeetConference.joinTheRoom().305 net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join the room
net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join the room
        at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:212)
        at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.join(ChatRoomImpl.java:135)
        at org.jitsi.jicofo.JitsiMeetConference.joinTheRoom(JitsiMeetConference.java:299)
        at org.jitsi.jicofo.JitsiMeetConference.maybeJoinTheRoom(JitsiMeetConference.java:281)
        at org.jitsi.jicofo.JitsiMeetConference.registrationStateChanged(JitsiMeetConference.java:1074)
        at org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged(ProtocolProviderHandler.java:123)
        at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:176)
        at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:130)
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:176)
        at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
Caused by: not-allowed(-1)
        at org.jivesoftware.smackx.muc.MultiUserChat.create(MultiUserChat.java:360)
        at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:163)
        ... 9 more
07:59:53.427 INFO: [274] org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireConference().334 Nothing to expire - no conference allocated yet
07:59:53.428 SEVERE: [279] org.jitsi.impl.protocol.xmpp.OperationSetJingleImpl.accept().95 Received an error: code=-1 message=null, <presence id="4g03l-627" to="focus@auth.jitsi.domain.com/focus245189475451806" from="123123@conference.jitsi.domain.com/focus" type="error"><error code="-1" type="CANCEL"><not-allowed xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></presence>
07:59:53.428 WARNING: [279] org.jitsi.impl.protocol.xmpp.ChatRoomImpl.processPacket().1059 Unable to handle packet: <presence id="4g03l-627" to="focus@auth.jitsi.domain.com/focus245189475451806" from="123123@conference.jitsi.domain.com/focus" type="error"><error code="-1" type="CANCEL"><not-allowed xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></presence>
07:59:53.578 INFO: [274] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP provider Jabber:focus@auth.jitsi.domain.com/focus245189475451806@localhost disconnected
07:59:53.580 INFO: [274] org.jitsi.jicofo.FocusManager.conferenceEnded().272 Disposed conference for room: 123123@conference.jitsi.domain.com conference count: 0
07:59:53.580 SEVERE: [274] util.UtilActivator.uncaughtException().108 An uncaught exception occurred in thread=Thread[Thread-155,5,main] and message was: null
java.lang.NullPointerException
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:182)
        at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 7:49 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

On Wed, Mar 4, 2015 at 4:42 PM, John Lightfoot <john@vizhn.com> wrote:

Ok. It looks like the room is being created ok so I won’t apply your
patch. Any ideas what else to try?

Are you sure that you have this[1] configured correctly ? Jicofo should reject user request and park the user. If this option is not configured correctly user will try to enter the room, but it is not allowed and this error pops up.

[1]: -Dorg.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

There is some problem with Jicofo user. It should be an admin and be
allowed to create the room, but it is not like you can see in the
logs.

···

On Wed, Mar 4, 2015 at 5:08 PM, John Lightfoot <john@vizhn.com> wrote:

I confirmed jicofo is running with that parameter. This is what I'm seeing in the jocofo log (conf 123123 and domain jitsi.domain.com) ...

07:59:53.279 INFO: [273] org.jitsi.jicofo.xmpp.FocusComponent.handleConferenceIq().369 Focus request for room: 123123@conference.jitsi.domain.com
07:59:53.280 INFO: [273] org.jitsi.jicofo.FocusManager.createConference().231 Created new focus for 123123@conference.jitsi.domain.com@auth.jitsi.domain.com conferences count: 1 options:
    channelLastN: 1
    adaptiveLastN: false
    adaptiveSimulcast: false
    bridge: jitsi-videobridge.jitsi.domain.com
    enableFirefoxHacks: false
    openSctp: true
07:59:53.422 INFO: [274] org.jitsi.jicofo.JitsiMeetConference.registrationStateChanged().1072 Reg state changed: RegistrationStateChangeEvent[ oldState=Unregistered; newState=RegistrationState=Registered; reasonCode=-1; reason=null]
07:59:53.423 INFO: [274] org.jitsi.jicofo.JitsiMeetConference.maybeJoinTheRoom().279 Registered: XmppProtocolProvider(focus)
07:59:53.424 INFO: [274] org.jitsi.jicofo.JitsiMeetConference.joinTheRoom().290 Joining the room: 123123@conference.jitsi.domain.com
07:59:53.426 SEVERE: [274] org.jitsi.jicofo.JitsiMeetConference.joinTheRoom().305 net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join the room
net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join the room
        at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:212)
        at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.join(ChatRoomImpl.java:135)
        at org.jitsi.jicofo.JitsiMeetConference.joinTheRoom(JitsiMeetConference.java:299)
        at org.jitsi.jicofo.JitsiMeetConference.maybeJoinTheRoom(JitsiMeetConference.java:281)
        at org.jitsi.jicofo.JitsiMeetConference.registrationStateChanged(JitsiMeetConference.java:1074)
        at org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged(ProtocolProviderHandler.java:123)
        at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:176)
        at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:130)
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:176)
        at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
Caused by: not-allowed(-1)
        at org.jivesoftware.smackx.muc.MultiUserChat.create(MultiUserChat.java:360)
        at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:163)
        ... 9 more
07:59:53.427 INFO: [274] org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireConference().334 Nothing to expire - no conference allocated yet
07:59:53.428 SEVERE: [279] org.jitsi.impl.protocol.xmpp.OperationSetJingleImpl.accept().95 Received an error: code=-1 message=null, <presence id="4g03l-627" to="focus@auth.jitsi.domain.com/focus245189475451806" from="123123@conference.jitsi.domain.com/focus" type="error"><error code="-1" type="CANCEL"><not-allowed xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></presence>
07:59:53.428 WARNING: [279] org.jitsi.impl.protocol.xmpp.ChatRoomImpl.processPacket().1059 Unable to handle packet: <presence id="4g03l-627" to="focus@auth.jitsi.domain.com/focus245189475451806" from="123123@conference.jitsi.domain.com/focus" type="error"><error code="-1" type="CANCEL"><not-allowed xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></presence>
07:59:53.578 INFO: [274] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP provider Jabber:focus@auth.jitsi.domain.com/focus245189475451806@localhost disconnected
07:59:53.580 INFO: [274] org.jitsi.jicofo.FocusManager.conferenceEnded().272 Disposed conference for room: 123123@conference.jitsi.domain.com conference count: 0
07:59:53.580 SEVERE: [274] util.UtilActivator.uncaughtException().108 An uncaught exception occurred in thread=Thread[Thread-155,5,main] and message was: null
java.lang.NullPointerException
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:182)
        at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 7:49 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

On Wed, Mar 4, 2015 at 4:42 PM, John Lightfoot <john@vizhn.com> wrote:

Ok. It looks like the room is being created ok so I won’t apply your
patch. Any ideas what else to try?

Are you sure that you have this[1] configured correctly ? Jicofo should reject user request and park the user. If this option is not configured correctly user will try to enter the room, but it is not allowed and this error pops up.

[1]: -Dorg.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#11

I've been focusing on the prosody logs so hadn't seen that jicofo not allowed error. I think I'm setup correctly but just to confirm, in my prosody config I have

1. CORS config
cross_domain_bosh = true
consider_bosh_secure = true

2. main domain w/ authentication = internal_plain and 2nd domain with authentication = anonymous (enabled that 2nd domain as anonymousdomain in config.js)

3. set restrict_room_creation = "local" on the muc component

4. made focus@auth.jitsi.domain.com member of admins

I'm starting jicofo with that command line parameter you referred to earlier (output from ps -aux jicofo 12513 0.0 0.1 12420 1448 ? S 08:41 0:00 /bin/bash /usr/share/jicofo/jicofo.sh --host=localhost --domain=jitsi.domain.com --port=5347 --secret=secret --user_domain=auth.jitsi.domain.com --user_password=userpw -Dorg.jitsi.jicofo.auth.URL=XMPP:jitsi.domain.com).

This is a clean install from a few days ago so everything is pretty much default. Any ideas?

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 8:12 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

There is some problem with Jicofo user. It should be an admin and be allowed to create the room, but it is not like you can see in the logs.

On Wed, Mar 4, 2015 at 5:08 PM, John Lightfoot <john@vizhn.com> wrote:

I confirmed jicofo is running with that parameter. This is what I'm seeing in the jocofo log (conf 123123 and domain jitsi.domain.com) ...

07:59:53.279 INFO: [273]
org.jitsi.jicofo.xmpp.FocusComponent.handleConferenceIq().369 Focus
request for room: 123123@conference.jitsi.domain.com
07:59:53.280 INFO: [273] org.jitsi.jicofo.FocusManager.createConference().231 Created new focus for 123123@conference.jitsi.domain.com@auth.jitsi.domain.com conferences count: 1 options:
    channelLastN: 1
    adaptiveLastN: false
    adaptiveSimulcast: false
    bridge: jitsi-videobridge.jitsi.domain.com
    enableFirefoxHacks: false
    openSctp: true
07:59:53.422 INFO: [274]
org.jitsi.jicofo.JitsiMeetConference.registrationStateChanged().1072
Reg state changed: RegistrationStateChangeEvent[
oldState=Unregistered; newState=RegistrationState=Registered;
reasonCode=-1; reason=null]
07:59:53.423 INFO: [274]
org.jitsi.jicofo.JitsiMeetConference.maybeJoinTheRoom().279
Registered: XmppProtocolProvider(focus)
07:59:53.424 INFO: [274]
org.jitsi.jicofo.JitsiMeetConference.joinTheRoom().290 Joining the
room: 123123@conference.jitsi.domain.com
07:59:53.426 SEVERE: [274]
org.jitsi.jicofo.JitsiMeetConference.joinTheRoom().305
net.java.sip.communicator.service.protocol.OperationFailedException:
Failed to join the room
net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join the room
        at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:212)
        at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.join(ChatRoomImpl.java:135)
        at org.jitsi.jicofo.JitsiMeetConference.joinTheRoom(JitsiMeetConference.java:299)
        at org.jitsi.jicofo.JitsiMeetConference.maybeJoinTheRoom(JitsiMeetConference.java:281)
        at org.jitsi.jicofo.JitsiMeetConference.registrationStateChanged(JitsiMeetConference.java:1074)
        at org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged(ProtocolProviderHandler.java:123)
        at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:176)
        at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:130)
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:176)
        at
org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
Caused by: not-allowed(-1)
        at org.jivesoftware.smackx.muc.MultiUserChat.create(MultiUserChat.java:360)
        at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:163)
        ... 9 more
07:59:53.427 INFO: [274]
org.jitsi.impl.protocol.xmpp.OperationSetColibriConferenceImpl.expireC
onference().334 Nothing to expire - no conference allocated yet
07:59:53.428 SEVERE: [279]
org.jitsi.impl.protocol.xmpp.OperationSetJingleImpl.accept().95
Received an error: code=-1 message=null, <presence id="4g03l-627"
to="focus@auth.jitsi.domain.com/focus245189475451806"
from="123123@conference.jitsi.domain.com/focus" type="error"><error
code="-1" type="CANCEL"><not-allowed
xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></presence>
07:59:53.428 WARNING: [279]
org.jitsi.impl.protocol.xmpp.ChatRoomImpl.processPacket().1059 Unable
to handle packet: <presence id="4g03l-627"
to="focus@auth.jitsi.domain.com/focus245189475451806"
from="123123@conference.jitsi.domain.com/focus" type="error"><error
code="-1" type="CANCEL"><not-allowed
xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></presence>
07:59:53.578 INFO: [274]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP provider
Jabber:focus@auth.jitsi.domain.com/focus245189475451806@localhost
disconnected
07:59:53.580 INFO: [274]
org.jitsi.jicofo.FocusManager.conferenceEnded().272 Disposed
conference for room: 123123@conference.jitsi.domain.com conference
count: 0
07:59:53.580 SEVERE: [274] util.UtilActivator.uncaughtException().108
An uncaught exception occurred in thread=Thread[Thread-155,5,main] and message was: null java.lang.NullPointerException
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:182)
        at
org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 7:49 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

On Wed, Mar 4, 2015 at 4:42 PM, John Lightfoot <john@vizhn.com> wrote:

Ok. It looks like the room is being created ok so I won’t apply your
patch. Any ideas what else to try?

Are you sure that you have this[1] configured correctly ? Jicofo should reject user request and park the user. If this option is not configured correctly user will try to enter the room, but it is not allowed and this error pops up.

[1]: -Dorg.jitsi.jicofo.auth.URL=XMPP:jitsi-meet.example.com

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

Make sure this is included either in the global admins, or in the correct VirtualHost. I've seen it go under the wrong VH with exactle these results.

Boris

···

On 04/03/15 17:52, John Lightfoot wrote:

I've been focusing on the prosody logs so hadn't seen that jicofo not allowed error. I think I'm setup correctly but just to confirm, in my prosody config I have

1. CORS config
cross_domain_bosh = true
consider_bosh_secure = true

2. main domain w/ authentication = internal_plain and 2nd domain with authentication = anonymous (enabled that 2nd domain as anonymousdomain in config.js)

3. set restrict_room_creation = "local" on the muc component

4. made focus@auth.jitsi.domain.com member of admins


#13

I made that focus user a global admin but same results.

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Boris Grozev
Sent: Wednesday, March 4, 2015 8:59 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

On 04/03/15 17:52, John Lightfoot wrote:

I've been focusing on the prosody logs so hadn't seen that jicofo not
allowed error. I think I'm setup correctly but just to confirm, in my
prosody config I have

1. CORS config
cross_domain_bosh = true
consider_bosh_secure = true

2. main domain w/ authentication = internal_plain and 2nd domain with
authentication = anonymous (enabled that 2nd domain as anonymousdomain
in config.js)

3. set restrict_room_creation = "local" on the muc component

4. made focus@auth.jitsi.domain.com member of admins

Make sure this is included either in the global admins, or in the correct VirtualHost. I've seen it go under the wrong VH with exactle these results.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#14

Also you can try moving it to admins of MUC component.

···

On Wed, Mar 4, 2015 at 6:11 PM, John Lightfoot <john@vizhn.com> wrote:

I made that focus user a global admin but same results.

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Boris Grozev
Sent: Wednesday, March 4, 2015 8:59 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

On 04/03/15 17:52, John Lightfoot wrote:

I've been focusing on the prosody logs so hadn't seen that jicofo not
allowed error. I think I'm setup correctly but just to confirm, in my
prosody config I have

1. CORS config
cross_domain_bosh = true
consider_bosh_secure = true

2. main domain w/ authentication = internal_plain and 2nd domain with
authentication = anonymous (enabled that 2nd domain as anonymousdomain
in config.js)

3. set restrict_room_creation = "local" on the muc component

4. made focus@auth.jitsi.domain.com member of admins

Make sure this is included either in the global admins, or in the correct VirtualHost. I've seen it go under the wrong VH with exactle these results.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#15

No luck.

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 12:20 PM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

Also you can try moving it to admins of MUC component.

On Wed, Mar 4, 2015 at 6:11 PM, John Lightfoot <john@vizhn.com> wrote:

I made that focus user a global admin but same results.

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Boris Grozev
Sent: Wednesday, March 4, 2015 8:59 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

On 04/03/15 17:52, John Lightfoot wrote:

I've been focusing on the prosody logs so hadn't seen that jicofo not
allowed error. I think I'm setup correctly but just to confirm, in
my prosody config I have

1. CORS config
cross_domain_bosh = true
consider_bosh_secure = true

2. main domain w/ authentication = internal_plain and 2nd domain
with authentication = anonymous (enabled that 2nd domain as
anonymousdomain in config.js)

3. set restrict_room_creation = "local" on the muc component

4. made focus@auth.jitsi.domain.com member of admins

Make sure this is included either in the global admins, or in the correct VirtualHost. I've seen it go under the wrong VH with exactle these results.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#16

Can you try with different Prosody version ?

···

On Wed, Mar 4, 2015 at 10:07 PM, John Lightfoot <john@vizhn.com> wrote:

No luck.

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 12:20 PM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

Also you can try moving it to admins of MUC component.

On Wed, Mar 4, 2015 at 6:11 PM, John Lightfoot <john@vizhn.com> wrote:

I made that focus user a global admin but same results.

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Boris Grozev
Sent: Wednesday, March 4, 2015 8:59 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

On 04/03/15 17:52, John Lightfoot wrote:

I've been focusing on the prosody logs so hadn't seen that jicofo not
allowed error. I think I'm setup correctly but just to confirm, in
my prosody config I have

1. CORS config
cross_domain_bosh = true
consider_bosh_secure = true

2. main domain w/ authentication = internal_plain and 2nd domain
with authentication = anonymous (enabled that 2nd domain as
anonymousdomain in config.js)

3. set restrict_room_creation = "local" on the muc component

4. made focus@auth.jitsi.domain.com member of admins

Make sure this is included either in the global admins, or in the correct VirtualHost. I've seen it go under the wrong VH with exactle these results.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#17

Hello,
not sure whether it fits to this problem.
After a fresh install of the latest jitsi-meet I made a strange observation when I tried to adapt the setup to interwork with jitsi-meet client app run on a local dev machine - enabling CORS:
- header access-control-allow-origin is not set when access to http-bind via https (http only works) (although parameters in nginx and prosody for cross-domain had been set)
- prosodyctl does not offer „about“-option

So after enabling prosody telnet access, the server:version shows version 0.8.2
This means the latest debian package of jitsi-meet contains a prosody server version 0.8.2?
I had another test installation of last year which showed 0.9.7

BR
Thomas

No luck.

···

Am 04.03.2015 um 22:07 schrieb John Lightfoot <john@vizhn.com>:

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 12:20 PM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

Also you can try moving it to admins of MUC component.

On Wed, Mar 4, 2015 at 6:11 PM, John Lightfoot <john@vizhn.com> wrote:

I made that focus user a global admin but same results.

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Boris Grozev
Sent: Wednesday, March 4, 2015 8:59 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

On 04/03/15 17:52, John Lightfoot wrote:

I've been focusing on the prosody logs so hadn't seen that jicofo not
allowed error. I think I'm setup correctly but just to confirm, in
my prosody config I have

1. CORS config
cross_domain_bosh = true
consider_bosh_secure = true

2. main domain w/ authentication = internal_plain and 2nd domain
with authentication = anonymous (enabled that 2nd domain as
anonymousdomain in config.js)

3. set restrict_room_creation = "local" on the muc component

4. made focus@auth.jitsi.domain.com member of admins

Make sure this is included either in the global admins, or in the correct VirtualHost. I've seen it go under the wrong VH with exactle these results.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#18

I was looking into that now. That version 0.9.1 is installed with the
jitsi-meet package and apt indicates it’s the latest version anyway. How
do I upgrade?

···

On 3/4/15, 1:32 PM, "Paweł Domas" <pawel.domas@jitsi.org> wrote:

Can you try with different Prosody version ?

On Wed, Mar 4, 2015 at 10:07 PM, John Lightfoot <john@vizhn.com> wrote:

No luck.

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 12:20 PM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after
moderator leaves.

Also you can try moving it to admins of MUC component.

On Wed, Mar 4, 2015 at 6:11 PM, John Lightfoot <john@vizhn.com> wrote:

I made that focus user a global admin but same results.

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Boris Grozev
Sent: Wednesday, March 4, 2015 8:59 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after
moderator leaves.

On 04/03/15 17:52, John Lightfoot wrote:

I've been focusing on the prosody logs so hadn't seen that jicofo not
allowed error. I think I'm setup correctly but just to confirm, in
my prosody config I have

1. CORS config
cross_domain_bosh = true
consider_bosh_secure = true

2. main domain w/ authentication = internal_plain and 2nd domain
with authentication = anonymous (enabled that 2nd domain as
anonymousdomain in config.js)

3. set restrict_room_creation = "local" on the muc component

4. made focus@auth.jitsi.domain.com member of admins

Make sure this is included either in the global admins, or in the
correct VirtualHost. I've seen it go under the wrong VH with exactle
these results.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#19

Sorry, I figured to add the prosody repo and am now upgraded to 0.9.7. The errors in the jicofo.log went away but now my anonymous user is able to create a conference. Let me comb my configs and make sure I didn't overlook something as I was troubleshooting.

···

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 1:33 PM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

Can you try with different Prosody version ?

On Wed, Mar 4, 2015 at 10:07 PM, John Lightfoot <john@vizhn.com> wrote:

No luck.

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 12:20 PM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

Also you can try moving it to admins of MUC component.

On Wed, Mar 4, 2015 at 6:11 PM, John Lightfoot <john@vizhn.com> wrote:

I made that focus user a global admin but same results.

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Boris Grozev
Sent: Wednesday, March 4, 2015 8:59 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

On 04/03/15 17:52, John Lightfoot wrote:

I've been focusing on the prosody logs so hadn't seen that jicofo
not allowed error. I think I'm setup correctly but just to confirm,
in my prosody config I have

1. CORS config
cross_domain_bosh = true
consider_bosh_secure = true

2. main domain w/ authentication = internal_plain and 2nd domain
with authentication = anonymous (enabled that 2nd domain as
anonymousdomain in config.js)

3. set restrict_room_creation = "local" on the muc component

4. made focus@auth.jitsi.domain.com member of admins

Make sure this is included either in the global admins, or in the correct VirtualHost. I've seen it go under the wrong VH with exactle these results.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#20

Just performed apt-get update/upgrade with jitsi-meet-prosody-1.0.406-1.all.deb from today 9:39pm

a snippet from prosody.log:
Mar 04 22:41:30 general info Hello and welcome to Prosody version 0.8.2
Mar 04 22:41:30 general info Prosody is using the select backend for connection handling
Mar 04 22:41:30 modulemanager error Unable to load module 'pubsub': /usr/lib/prosody/modules/mod_pubsub.lua: No such file or directory

Could somebody check the debian package for prosody?

Hello,
not sure whether it fits to this problem.
After a fresh install of the latest jitsi-meet I made a strange observation when I tried to adapt the setup to interwork with jitsi-meet client app run on a local dev machine - enabling CORS:
- header access-control-allow-origin is not set when access to http-bind via https (http only works) (although parameters in nginx and prosody for cross-domain had been set)
- prosodyctl does not offer „about“-option

So after enabling prosody telnet access, the server:version shows version 0.8.2
This means the latest debian package of jitsi-meet contains a prosody server version 0.8.2?
I had another test installation of last year which showed 0.9.7

BR
Thomas

No luck.

···

Am 04.03.2015 um 22:38 schrieb Thomas Odorfer <odotom@gmail.com>:
Am 04.03.2015 um 22:07 schrieb John Lightfoot <john@vizhn.com>:

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Pawel Domas
Sent: Wednesday, March 4, 2015 12:20 PM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

Also you can try moving it to admins of MUC component.

On Wed, Mar 4, 2015 at 6:11 PM, John Lightfoot <john@vizhn.com> wrote:

I made that focus user a global admin but same results.

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Boris Grozev
Sent: Wednesday, March 4, 2015 8:59 AM
To: Jitsi Developers
Subject: Re: [jitsi-dev] Jitmeet: authenticated room persists after moderator leaves.

On 04/03/15 17:52, John Lightfoot wrote:

I've been focusing on the prosody logs so hadn't seen that jicofo not
allowed error. I think I'm setup correctly but just to confirm, in
my prosody config I have

1. CORS config
cross_domain_bosh = true
consider_bosh_secure = true

2. main domain w/ authentication = internal_plain and 2nd domain
with authentication = anonymous (enabled that 2nd domain as
anonymousdomain in config.js)

3. set restrict_room_creation = "local" on the muc component

4. made focus@auth.jitsi.domain.com member of admins

Make sure this is included either in the global admins, or in the correct VirtualHost. I've seen it go under the wrong VH with exactle these results.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev