[jitsi-dev] [JIGASI] Missing/broken outgoing audio


#1

Hi,

I'm happy with getting jigasi work with my jitsi installation. However i am facing a strange issue with some operators and with incoming calls. The caller successfully joins the conference and i can hear him. But he does not hear the conference audio. And this happens only with one mobile operator (at least among tested ones) : so i cant blame any firewall (or nat). With other it works perfectly.

To simplify my problem i configured jigasi to register directly to my SIP provider.
I have double checked the used codec to be the PCMA (or PCMU). No problem with SDP negotiations.

I've done some TCP dump and it seems that i send audio packets to SIP provider.

I suspect this to be an encryption issue.

BTW: jitsi windows client works perfectly with this SIP provider and with any mobile operator. And when i put a freeswitch before jigasi, i can hear Freeswitch sounds and scripts.

I join jvb and jigasi log.

Any help would be appreciated.

log_jigasi.txt (27.1 KB)

log_jvb.txt (39.3 KB)


#2

Hi,

If you are seeing audio packets going to the sip provider, this is
strange. Are you using encryption setting for the sip part when
connecting to the provider? If you are not and using pcmu or pcma you
can easily check with wireshark the audio content going to the
provider, there is an option to play the rtp streams.
And the strange is that it is working on windows with jitsi client as
jigasi is using the same stack. It can be that the provider do not
like the packet size or something, but I do not see how it will work
from windows but not from linux, strange.

Regards
damencho

···

On Wed, Dec 21, 2016 at 10:54 AM, Arthur TOUMASSIAN <artogu@live.fr> wrote:

Hi,

I'm happy with getting jigasi work with my jitsi installation. However i am
facing a strange issue with some operators and with incoming calls. The
caller successfully joins the conference and i can hear him. But he does not
hear the conference audio. And this happens only with one mobile operator
(at least among tested ones) : so i cant blame any firewall (or nat). With
other it works perfectly.

To simplify my problem i configured jigasi to register directly to my SIP
provider.
I have double checked the used codec to be the PCMA (or PCMU). No problem
with SDP negotiations.

I've done some TCP dump and it seems that i send audio packets to SIP
provider.

I suspect this to be an encryption issue.

BTW: jitsi windows client works perfectly with this SIP provider and with
any mobile operator. And when i put a freeswitch before jigasi, i can hear
Freeswitch sounds and scripts.

I join jvb and jigasi log.

Any help would be appreciated.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi Damencho,

Today i've done some tests :

i fetched all masters : jvb, jicofo, jvb this time for windows 64.

I had the same exact behavior. After capturing with Wireshark as you suggested i've managed to play outgoing stream which was correct.

Is there way test different packet sizes?

When does the crypto negotiation happen? It is possible that at this stade the provider reject non encrypted packets?

Thanks for your help

···

________________________________
De : dev <dev-bounces@jitsi.org> de la part de Damian Minkov <damencho@jitsi.org>
Envoyé : mercredi 21 décembre 2016 18:53
À : Jitsi Developers
Objet : Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

Hi,

If you are seeing audio packets going to the sip provider, this is
strange. Are you using encryption setting for the sip part when
connecting to the provider? If you are not and using pcmu or pcma you
can easily check with wireshark the audio content going to the
provider, there is an option to play the rtp streams.
And the strange is that it is working on windows with jitsi client as
jigasi is using the same stack. It can be that the provider do not
like the packet size or something, but I do not see how it will work
from windows but not from linux, strange.

Regards
damencho

On Wed, Dec 21, 2016 at 10:54 AM, Arthur TOUMASSIAN <artogu@live.fr> wrote:

Hi,

I'm happy with getting jigasi work with my jitsi installation. However i am
facing a strange issue with some operators and with incoming calls. The
caller successfully joins the conference and i can hear him. But he does not
hear the conference audio. And this happens only with one mobile operator
(at least among tested ones) : so i cant blame any firewall (or nat). With
other it works perfectly.

To simplify my problem i configured jigasi to register directly to my SIP
provider.
I have double checked the used codec to be the PCMA (or PCMU). No problem
with SDP negotiations.

I've done some TCP dump and it seems that i send audio packets to SIP
provider.

I suspect this to be an encryption issue.

BTW: jitsi windows client works perfectly with this SIP provider and with
any mobile operator. And when i put a freeswitch before jigasi, i can hear
Freeswitch sounds and scripts.

I join jvb and jigasi log.

Any help would be appreciated.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

dev -- Jitsi Developers - Mailing Lists<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where developers meet and discuss issues, code changes, etc. To see the collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where developers meet and discuss issues, code changes, etc. To see the collection of prior postings to the ...


#4

You mentioned it is working when using the desktop client when configured
to call directly the sip provider, do you configure there srtp? Did you
check jitsi desktop client account properties config and jigasi one, do you
have the same settings?

···

On Thu, Dec 22, 2016 at 9:27 AM, Arthur TOUMASSIAN <artogu@live.fr> wrote:

Hi Damencho,

Today i've done some tests :

i fetched all masters : jvb, jicofo, jvb this time for windows 64.

I had the same exact behavior. After capturing with Wireshark as you
suggested i've managed to play outgoing stream which was correct.

Is there way test different packet sizes?
When does the crypto negotiation happen? It is possible that at this stade
the provider reject non encrypted packets?

Thanks for your help

------------------------------
*De :* dev <dev-bounces@jitsi.org> de la part de Damian Minkov <
damencho@jitsi.org>
*Envoyé :* mercredi 21 décembre 2016 18:53
*À :* Jitsi Developers
*Objet :* Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

Hi,

If you are seeing audio packets going to the sip provider, this is
strange. Are you using encryption setting for the sip part when
connecting to the provider? If you are not and using pcmu or pcma you
can easily check with wireshark the audio content going to the
provider, there is an option to play the rtp streams.
And the strange is that it is working on windows with jitsi client as
jigasi is using the same stack. It can be that the provider do not
like the packet size or something, but I do not see how it will work
from windows but not from linux, strange.

Regards
damencho

On Wed, Dec 21, 2016 at 10:54 AM, Arthur TOUMASSIAN <artogu@live.fr> > wrote:
> Hi,
>
> I'm happy with getting jigasi work with my jitsi installation. However i
am
> facing a strange issue with some operators and with incoming calls. The
> caller successfully joins the conference and i can hear him. But he does
not
> hear the conference audio. And this happens only with one mobile operator
> (at least among tested ones) : so i cant blame any firewall (or nat).
With
> other it works perfectly.
>
> To simplify my problem i configured jigasi to register directly to my SIP
> provider.
> I have double checked the used codec to be the PCMA (or PCMU). No problem
> with SDP negotiations.
>
> I've done some TCP dump and it seems that i send audio packets to SIP
> provider.
>
>
> I suspect this to be an encryption issue.
>
> BTW: jitsi windows client works perfectly with this SIP provider and with
> any mobile operator. And when i put a freeswitch before jigasi, i can
hear
> Freeswitch sounds and scripts.
>
> I join jvb and jigasi log.
>
>
> Any help would be appreciated.
>
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists
<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where
developers meet and discuss issues, code changes, etc. To see the
collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists
<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where
developers meet and discuss issues, code changes, etc. To see the
collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

I played with these parameters :

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_PROTOCOL.DTLS-SRTP=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_PROTOCOL.SDES=1
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_PROTOCOL.ZRTP=2
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_PROTOCOL_STATUS.DTLS-SRTP=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_PROTOCOL_STATUS.SDES=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_PROTOCOL_STATUS.ZRTP=true

Sometimes it fails on SDP negotiations like this :

2016-12-22 17:55:07.496 GRAVE: [114] impl.protocol.sip.CallPeerSipImpl.answer().1334 Failed to create an SDP description for an OK response to an INVITE request!
java.lang.NullPointerException
        at net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.updateMediaDescriptionForSDes(CallPeerMediaHandlerSipImpl.java:1148)
        at net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.setAndAddPreferredEncryptionProtocol(CallPeerMediaHandlerSipImpl.java:1880)
        at net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.createMediaDescriptionsForAnswer(CallPeerMediaHandlerSipImpl.java:762)
        at net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.processFirstOffer(CallPeerMediaHandlerSipImpl.java:482)
        at net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.processOffer(CallPeerMediaHandlerSipImpl.java:445)
        at net.java.sip.communicator.impl.protocol.sip.CallPeerSipImpl.answer(CallPeerSipImpl.java:1320)
        at net.java.sip.communicator.impl.protocol.sip.OperationSetBasicTelephonySipImpl.answerCallPeer(OperationSetBasicTelephonySipImpl.java:1955)
        at org.jitsi.jigasi.CallManager$AnswerCallThread.run(CallManager.java:309)
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)

, sometimes it just does change nothing.

···

________________________________
De : dev <dev-bounces@jitsi.org> de la part de Damian Minkov <damencho@jitsi.org>
Envoyé : jeudi 22 décembre 2016 16:35
À : Jitsi Developers
Objet : Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

You mentioned it is working when using the desktop client when configured to call directly the sip provider, do you configure there srtp? Did you check jitsi desktop client account properties config and jigasi one, do you have the same settings?

On Thu, Dec 22, 2016 at 9:27 AM, Arthur TOUMASSIAN <artogu@live.fr<mailto:artogu@live.fr>> wrote:

Hi Damencho,

Today i've done some tests :

i fetched all masters : jvb, jicofo, jvb this time for windows 64.

I had the same exact behavior. After capturing with Wireshark as you suggested i've managed to play outgoing stream which was correct.

Is there way test different packet sizes?

When does the crypto negotiation happen? It is possible that at this stade the provider reject non encrypted packets?

Thanks for your help

________________________________
De : dev <dev-bounces@jitsi.org<mailto:dev-bounces@jitsi.org>> de la part de Damian Minkov <damencho@jitsi.org<mailto:damencho@jitsi.org>>
Envoyé : mercredi 21 décembre 2016 18:53
À : Jitsi Developers
Objet : Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

Hi,

If you are seeing audio packets going to the sip provider, this is
strange. Are you using encryption setting for the sip part when
connecting to the provider? If you are not and using pcmu or pcma you
can easily check with wireshark the audio content going to the
provider, there is an option to play the rtp streams.
And the strange is that it is working on windows with jitsi client as
jigasi is using the same stack. It can be that the provider do not
like the packet size or something, but I do not see how it will work
from windows but not from linux, strange.

Regards
damencho

On Wed, Dec 21, 2016 at 10:54 AM, Arthur TOUMASSIAN <artogu@live.fr<mailto:artogu@live.fr>> wrote:

Hi,

I'm happy with getting jigasi work with my jitsi installation. However i am
facing a strange issue with some operators and with incoming calls. The
caller successfully joins the conference and i can hear him. But he does not
hear the conference audio. And this happens only with one mobile operator
(at least among tested ones) : so i cant blame any firewall (or nat). With
other it works perfectly.

To simplify my problem i configured jigasi to register directly to my SIP
provider.
I have double checked the used codec to be the PCMA (or PCMU). No problem
with SDP negotiations.

I've done some TCP dump and it seems that i send audio packets to SIP
provider.

I suspect this to be an encryption issue.

BTW: jitsi windows client works perfectly with this SIP provider and with
any mobile operator. And when i put a freeswitch before jigasi, i can hear
Freeswitch sounds and scripts.

I join jvb and jigasi log.

Any help would be appreciated.

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

dev -- Jitsi Developers - Mailing Lists<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org<http://lists.jitsi.org>
For discussion of technical implementation details, and is where developers meet and discuss issues, code changes, etc. To see the collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org<http://lists.jitsi.org>
For discussion of technical implementation details, and is where developers meet and discuss issues, code changes, etc. To see the collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Normally if you take the working properties from jitsi home folder and
convert them to jigasi and use them there it should work. NPE is strange
and definitely is a problem.

···

On Thu, Dec 22, 2016 at 10:59 AM, Arthur TOUMASSIAN <artogu@live.fr> wrote:

I played with these parameters :

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_
PROTOCOL.DTLS-SRTP=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_
PROTOCOL.SDES=1
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_
PROTOCOL.ZRTP=2
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_
PROTOCOL_STATUS.DTLS-SRTP=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_
PROTOCOL_STATUS.SDES=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ENCRYPTION_
PROTOCOL_STATUS.ZRTP=true

Sometimes it fails on SDP negotiations like this :

2016-12-22 17:55:07.496 GRAVE: [114] impl.protocol.sip.CallPeerSipImpl.answer().1334
Failed to create an SDP description for an OK response to an INVITE request!
*java.lang.NullPointerException*
* at
net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.updateMediaDescriptionForSDes(CallPeerMediaHandlerSipImpl.java:1148)*
* at
net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.setAndAddPreferredEncryptionProtocol(CallPeerMediaHandlerSipImpl.java:1880)*
* at
net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.createMediaDescriptionsForAnswer(CallPeerMediaHandlerSipImpl.java:762)*
* at
net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.processFirstOffer(CallPeerMediaHandlerSipImpl.java:482)*
* at
net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.processOffer(CallPeerMediaHandlerSipImpl.java:445)*
* at
net.java.sip.communicator.impl.protocol.sip.CallPeerSipImpl.answer(CallPeerSipImpl.java:1320)*
* at
net.java.sip.communicator.impl.protocol.sip.OperationSetBasicTelephonySipImpl.answerCallPeer(OperationSetBasicTelephonySipImpl.java:1955)*
* at
org.jitsi.jigasi.CallManager$AnswerCallThread.run(CallManager.java:309)*
* at java.util.concurrent.Executors$RunnableAdapter.call(Unknown
Source)*
* at java.util.concurrent.FutureTask.run(Unknown Source)*
* at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown
Source)*
* at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown
Source)*
* at java.lang.Thread.run(Unknown Source)*

, sometimes it just does change nothing.

------------------------------
*De :* dev <dev-bounces@jitsi.org> de la part de Damian Minkov <
damencho@jitsi.org>
*Envoyé :* jeudi 22 décembre 2016 16:35

*À :* Jitsi Developers
*Objet :* Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

You mentioned it is working when using the desktop client when configured
to call directly the sip provider, do you configure there srtp? Did you
check jitsi desktop client account properties config and jigasi one, do you
have the same settings?

On Thu, Dec 22, 2016 at 9:27 AM, Arthur TOUMASSIAN <artogu@live.fr> wrote:

Hi Damencho,

Today i've done some tests :

i fetched all masters : jvb, jicofo, jvb this time for windows 64.

I had the same exact behavior. After capturing with Wireshark as you
suggested i've managed to play outgoing stream which was correct.

Is there way test different packet sizes?
When does the crypto negotiation happen? It is possible that at this
stade the provider reject non encrypted packets?

Thanks for your help

------------------------------
*De :* dev <dev-bounces@jitsi.org> de la part de Damian Minkov <
damencho@jitsi.org>
*Envoyé :* mercredi 21 décembre 2016 18:53
*À :* Jitsi Developers
*Objet :* Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

Hi,

If you are seeing audio packets going to the sip provider, this is
strange. Are you using encryption setting for the sip part when
connecting to the provider? If you are not and using pcmu or pcma you
can easily check with wireshark the audio content going to the
provider, there is an option to play the rtp streams.
And the strange is that it is working on windows with jitsi client as
jigasi is using the same stack. It can be that the provider do not
like the packet size or something, but I do not see how it will work
from windows but not from linux, strange.

Regards
damencho

On Wed, Dec 21, 2016 at 10:54 AM, Arthur TOUMASSIAN <artogu@live.fr> >> wrote:
> Hi,
>
> I'm happy with getting jigasi work with my jitsi installation. However
i am
> facing a strange issue with some operators and with incoming calls. The
> caller successfully joins the conference and i can hear him. But he
does not
> hear the conference audio. And this happens only with one mobile
operator
> (at least among tested ones) : so i cant blame any firewall (or nat).
With
> other it works perfectly.
>
> To simplify my problem i configured jigasi to register directly to my
SIP
> provider.
> I have double checked the used codec to be the PCMA (or PCMU). No
problem
> with SDP negotiations.
>
> I've done some TCP dump and it seems that i send audio packets to SIP
> provider.
>
>
> I suspect this to be an encryption issue.
>
> BTW: jitsi windows client works perfectly with this SIP provider and
with
> any mobile operator. And when i put a freeswitch before jigasi, i can
hear
> Freeswitch sounds and scripts.
>
> I join jvb and jigasi log.
>
>
> Any help would be appreciated.
>
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists
<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where
developers meet and discuss issues, code changes, etc. To see the
collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists
<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where
developers meet and discuss issues, code changes, etc. To see the
collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Normally if you take the working properties from jitsi home folder and
convert them to jigasi and use them there it should work. NPE is strange and
definitely is a problem.

Damencho, is it possible that Jigasi doesn't have the resources service and/or the property net.java.sip.communicator.service.neomedia.SDES_CIPHER_SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32 set? This is required - or the NPE on line 1148 when splitting the ciphers string, which is null.

Ingo


#8

Thanks Ingo for checking this,

Well the property is definitely not there by default:
https://github.com/jitsi/jigasi/blob/master/jigasi-home/sip-communicator.properties
And ResourceManagementActivator is there so it should be
misconfiguration, I think.

···

On Thu, Dec 22, 2016 at 12:37 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

Normally if you take the working properties from jitsi home folder and
convert them to jigasi and use them there it should work. NPE is strange and
definitely is a problem.

Damencho, is it possible that Jigasi doesn't have the resources service and/or the property net.java.sip.communicator.service.neomedia.SDES_CIPHER_SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32 set? This is required - or the NPE on line 1148 when splitting the ciphers string, which is null.

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#9

Thanks Ingo for checking this,

Well the property is definitely not there by default:
https://github.com/jitsi/jigasi/blob/master/jigasi-home/sip-
communicator.properties And ResourceManagementActivator is there so it
should be misconfiguration, I think.

Ahm, attention: sip-communicator.properties != ResourceManagementService :frowning:

The RMS is the old crappy thing that reads the static stuff that is bundled into a .jar. In Jitsi, it's in resources/config/defaults.properties.

Ingo


#10

Hi guys,

Thanks for your help. Today put all config of jitsi windows client to jigasi-home/sip-communicator.properties (shriked gui properties).
Always the same problem.

I share the file, may be the "magic" will operate...

Any ideas about what request i can make to my provider?

Best Regards

sip-communicator.properties (9.38 KB)

···

________________________________
De : dev <dev-bounces@jitsi.org> de la part de Damian Minkov <damencho@jitsi.org>
Envoyé : jeudi 22 décembre 2016 19:57
À : Jitsi Developers
Objet : Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

Thanks Ingo for checking this,

Well the property is definitely not there by default:
https://github.com/jitsi/jigasi/blob/master/jigasi-home/sip-communicator.properties

And ResourceManagementActivator is there so it should be
misconfiguration, I think.

On Thu, Dec 22, 2016 at 12:37 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

Normally if you take the working properties from jitsi home folder and
convert them to jigasi and use them there it should work. NPE is strange and
definitely is a problem.

Damencho, is it possible that Jigasi doesn't have the resources service and/or the property net.java.sip.communicator.service.neomedia.SDES_CIPHER_SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32 set? This is required - or the NPE on line 1148 when splitting the ciphers string, which is null.

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

dev -- Jitsi Developers - Mailing Lists<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where developers meet and discuss issues, code changes, etc. To see the collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where developers meet and discuss issues, code changes, etc. To see the collection of prior postings to the ...


#11

I do not see anything suspicious. Can you try and shrink the codecs to only
those that will be used, disable and the video codecs, I suspect it is just
the sip message becoming too big which can lead to a problem.

Ingo, in the file sent I see the account property SDES_CIPHER_SUITES so it
will not check the resource service for defaults. The exception maybe was
from a run missing that property, just a guess. Thanks

···

On Fri, Dec 23, 2016 at 3:52 AM, Arthur TOUMASSIAN <artogu@live.fr> wrote:

Hi guys,

Thanks for your help. Today put all config of jitsi windows client to
jigasi-home/sip-communicator.properties (shriked gui properties).
Always the same problem.

I share the file, may be the "magic" will operate...

Any ideas about what request i can make to my provider?

Best Regards
------------------------------
*De :* dev <dev-bounces@jitsi.org> de la part de Damian Minkov <
damencho@jitsi.org>
*Envoyé :* jeudi 22 décembre 2016 19:57
*À :* Jitsi Developers
*Objet :* Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

Thanks Ingo for checking this,

Well the property is definitely not there by default:
https://github.com/jitsi/jigasi/blob/master/jigasi-home/sip-communicator.
properties

And ResourceManagementActivator is there so it should be
misconfiguration, I think.

On Thu, Dec 22, 2016 at 12:37 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:
>> Normally if you take the working properties from jitsi home folder and
>> convert them to jigasi and use them there it should work. NPE is
strange and
>> definitely is a problem.
>
> Damencho, is it possible that Jigasi doesn't have the resources service
and/or the property net.java.sip.communicator.
service.neomedia.SDES_CIPHER_SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32
set? This is required - or the NPE on line 1148 when splitting the ciphers
string, which is null.
>
> Ingo
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists
<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where
developers meet and discuss issues, code changes, etc. To see the
collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists
<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where
developers meet and discuss issues, code changes, etc. To see the
collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

I've tried what you suggested.

The problem is not really with SIP packets, as the negotiation ends as expected.

I saw that there is 3 type of connexion for conference with 1 user + 1 telephony user :

1) JVB <-- rtp/udp ---> JIGASI

2) JVB <-- rtcp/udp ---> JIGASI

3) JIGASI <-- rtp --> SIP PROVIDER

How jigasi copies 2 <--> 3 to have outgoing sound? is it possible that we loose informations there?

···

________________________________
De : dev <dev-bounces@jitsi.org> de la part de Damian Minkov <damencho@jitsi.org>
Envoyé : vendredi 23 décembre 2016 16:25
À : Jitsi Developers
Objet : Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

I do not see anything suspicious. Can you try and shrink the codecs to only those that will be used, disable and the video codecs, I suspect it is just the sip message becoming too big which can lead to a problem.

Ingo, in the file sent I see the account property SDES_CIPHER_SUITES so it will not check the resource service for defaults. The exception maybe was from a run missing that property, just a guess. Thanks

On Fri, Dec 23, 2016 at 3:52 AM, Arthur TOUMASSIAN <artogu@live.fr<mailto:artogu@live.fr>> wrote:

Hi guys,

Thanks for your help. Today put all config of jitsi windows client to jigasi-home/sip-communicator.properties (shriked gui properties).
Always the same problem.

I share the file, may be the "magic" will operate...

Any ideas about what request i can make to my provider?

Best Regards
________________________________
De : dev <dev-bounces@jitsi.org<mailto:dev-bounces@jitsi.org>> de la part de Damian Minkov <damencho@jitsi.org<mailto:damencho@jitsi.org>>
Envoyé : jeudi 22 décembre 2016 19:57
À : Jitsi Developers
Objet : Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

Thanks Ingo for checking this,

Well the property is definitely not there by default:
https://github.com/jitsi/jigasi/blob/master/jigasi-home/sip-communicator.properties

And ResourceManagementActivator is there so it should be
misconfiguration, I think.

On Thu, Dec 22, 2016 at 12:37 PM, Ingo Bauersachs <ingo@jitsi.org<mailto:ingo@jitsi.org>> wrote:

Normally if you take the working properties from jitsi home folder and
convert them to jigasi and use them there it should work. NPE is strange and
definitely is a problem.

Damencho, is it possible that Jigasi doesn't have the resources service and/or the property net.java.sip.communicator.service.neomedia.SDES_CIPHER_SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32 set? This is required - or the NPE on line 1148 when splitting the ciphers string, which is null.

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

dev -- Jitsi Developers - Mailing Lists<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org<http://lists.jitsi.org>
For discussion of technical implementation details, and is where developers meet and discuss issues, code changes, etc. To see the collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org<http://lists.jitsi.org>
For discussion of technical implementation details, and is where developers meet and discuss issues, code changes, etc. To see the collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#13

I'm not sure that we send rtcp to the sip part, and for sure there is no
termination of the rtcp from jvb side and some kind of translation to the
other side.
So it is not that ... it needs more debugging, maybe you can look at the
signaling, by default jigasi is still producing pcap as jitsi desktop
client it is in /var/log/jitsi/jigasi ... you can find a pcap file which
you can open with wireshark. Can you paste the sdp exchanged by jigasi and
the sip provider? Or send me the files, personally if you do not want to
expose some sensible data as ips.

···

On Fri, Dec 23, 2016 at 10:13 AM, Arthur TOUMASSIAN <artogu@live.fr> wrote:

I've tried what you suggested.

The problem is not really with SIP packets, as the negotiation ends as
expected.

I saw that there is 3 type of connexion for conference with 1 user + 1
telephony user :

1) JVB <-- rtp/udp ---> JIGASI
2) JVB <-- rtcp/udp ---> JIGASI

3) JIGASI <-- rtp --> SIP PROVIDER

How jigasi copies 2 <--> 3 to have outgoing sound? is it possible that we
loose informations there?

------------------------------
*De :* dev <dev-bounces@jitsi.org> de la part de Damian Minkov <
damencho@jitsi.org>
*Envoyé :* vendredi 23 décembre 2016 16:25

*À :* Jitsi Developers
*Objet :* Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

I do not see anything suspicious. Can you try and shrink the codecs to
only those that will be used, disable and the video codecs, I suspect it is
just the sip message becoming too big which can lead to a problem.

Ingo, in the file sent I see the account property SDES_CIPHER_SUITES so it
will not check the resource service for defaults. The exception maybe was
from a run missing that property, just a guess. Thanks

On Fri, Dec 23, 2016 at 3:52 AM, Arthur TOUMASSIAN <artogu@live.fr> wrote:

Hi guys,

Thanks for your help. Today put all config of jitsi windows client to
jigasi-home/sip-communicator.properties (shriked gui properties).
Always the same problem.

I share the file, may be the "magic" will operate...

Any ideas about what request i can make to my provider?

Best Regards
------------------------------
*De :* dev <dev-bounces@jitsi.org> de la part de Damian Minkov <
damencho@jitsi.org>
*Envoyé :* jeudi 22 décembre 2016 19:57
*À :* Jitsi Developers
*Objet :* Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

Thanks Ingo for checking this,

Well the property is definitely not there by default:
https://github.com/jitsi/jigasi/blob/master/jigasi-home/sip-
communicator.properties

And ResourceManagementActivator is there so it should be
misconfiguration, I think.

On Thu, Dec 22, 2016 at 12:37 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:
>> Normally if you take the working properties from jitsi home folder and
>> convert them to jigasi and use them there it should work. NPE is
strange and
>> definitely is a problem.
>
> Damencho, is it possible that Jigasi doesn't have the resources service
and/or the property net.java.sip.communicator.serv
ice.neomedia.SDES_CIPHER_SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32
set? This is required - or the NPE on line 1148 when splitting the ciphers
string, which is null.
>
> Ingo
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists
<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where
developers meet and discuss issues, code changes, etc. To see the
collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists
<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org
For discussion of technical implementation details, and is where
developers meet and discuss issues, code changes, etc. To see the
collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#14

Of course i will send you these debugging infos. I will come back to you after this holiday period.

Meanwhile i wish you all an happy end of year!

Arthur

···

________________________________
De : dev <dev-bounces@jitsi.org> de la part de Damian Minkov <damencho@jitsi.org>
Envoyé : vendredi 23 décembre 2016 17:25
À : Jitsi Developers
Objet : Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

I'm not sure that we send rtcp to the sip part, and for sure there is no termination of the rtcp from jvb side and some kind of translation to the other side.
So it is not that ... it needs more debugging, maybe you can look at the signaling, by default jigasi is still producing pcap as jitsi desktop client it is in /var/log/jitsi/jigasi ... you can find a pcap file which you can open with wireshark. Can you paste the sdp exchanged by jigasi and the sip provider? Or send me the files, personally if you do not want to expose some sensible data as ips.

On Fri, Dec 23, 2016 at 10:13 AM, Arthur TOUMASSIAN <artogu@live.fr<mailto:artogu@live.fr>> wrote:

I've tried what you suggested.

The problem is not really with SIP packets, as the negotiation ends as expected.

I saw that there is 3 type of connexion for conference with 1 user + 1 telephony user :

1) JVB <-- rtp/udp ---> JIGASI

2) JVB <-- rtcp/udp ---> JIGASI

3) JIGASI <-- rtp --> SIP PROVIDER

How jigasi copies 2 <--> 3 to have outgoing sound? is it possible that we loose informations there?

________________________________
De : dev <dev-bounces@jitsi.org<mailto:dev-bounces@jitsi.org>> de la part de Damian Minkov <damencho@jitsi.org<mailto:damencho@jitsi.org>>
Envoyé : vendredi 23 décembre 2016 16:25

À : Jitsi Developers
Objet : Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

I do not see anything suspicious. Can you try and shrink the codecs to only those that will be used, disable and the video codecs, I suspect it is just the sip message becoming too big which can lead to a problem.

Ingo, in the file sent I see the account property SDES_CIPHER_SUITES so it will not check the resource service for defaults. The exception maybe was from a run missing that property, just a guess. Thanks

On Fri, Dec 23, 2016 at 3:52 AM, Arthur TOUMASSIAN <artogu@live.fr<mailto:artogu@live.fr>> wrote:

Hi guys,

Thanks for your help. Today put all config of jitsi windows client to jigasi-home/sip-communicator.properties (shriked gui properties).
Always the same problem.

I share the file, may be the "magic" will operate...

Any ideas about what request i can make to my provider?

Best Regards
________________________________
De : dev <dev-bounces@jitsi.org<mailto:dev-bounces@jitsi.org>> de la part de Damian Minkov <damencho@jitsi.org<mailto:damencho@jitsi.org>>
Envoyé : jeudi 22 décembre 2016 19:57
À : Jitsi Developers
Objet : Re: [jitsi-dev] [JIGASI] Missing/broken outgoing audio

Thanks Ingo for checking this,

Well the property is definitely not there by default:
https://github.com/jitsi/jigasi/blob/master/jigasi-home/sip-communicator.properties

And ResourceManagementActivator is there so it should be
misconfiguration, I think.

On Thu, Dec 22, 2016 at 12:37 PM, Ingo Bauersachs <ingo@jitsi.org<mailto:ingo@jitsi.org>> wrote:

Normally if you take the working properties from jitsi home folder and
convert them to jigasi and use them there it should work. NPE is strange and
definitely is a problem.

Damencho, is it possible that Jigasi doesn't have the resources service and/or the property net.java.sip.communicator.service.neomedia.SDES_CIPHER_SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32 set? This is required - or the NPE on line 1148 when splitting the ciphers string, which is null.

Ingo

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

dev -- Jitsi Developers - Mailing Lists<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org<http://lists.jitsi.org>
For discussion of technical implementation details, and is where developers meet and discuss issues, code changes, etc. To see the collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev
dev -- Jitsi Developers - Mailing Lists<http://lists.jitsi.org/mailman/listinfo/dev>
lists.jitsi.org<http://lists.jitsi.org>
For discussion of technical implementation details, and is where developers meet and discuss issues, code changes, etc. To see the collection of prior postings to the ...

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org<mailto:dev@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev