[jitsi-dev] Jigasi + Jitsi Meet


#1

Hi all!

With the intention of starting to test Jigasi, I was reading something
of the documented in the repository [1].

I tried installing it using the repository for the stable version of
Jitsi Meet, but it seems that there is no precompiled package for it, so
the only alternative is to clone the repository and manually compile the
code.

There is something that is not clear to me that maybe someone can help
me understand. The documentation says: "When Jigasi is called, it
expects to find a 'Jitsi-Conference-Room' header in the invite with the
name of the Jitsi Meet conference the call is to be patched through to".

From the practical point of view, if for example I am calling from a
softphone, how do I specify the value for that header?

Thanks in advance.

Kind regards,
Daniel

[1] https://github.com/jitsi/jigasi


#2

Hi Daniel,

You can add the unstable repo, where there are jigasi deb packages.
https://jitsi.org/Main/InstallJitsiMeetDebianNightlyRepository

Regards
damencho

···

On Tue, Apr 18, 2017 at 8:35 PM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi all!

With the intention of starting to test Jigasi, I was reading something
of the documented in the repository [1].

I tried installing it using the repository for the stable version of
Jitsi Meet, but it seems that there is no precompiled package for it, so
the only alternative is to clone the repository and manually compile the
code.

There is something that is not clear to me that maybe someone can help
me understand. The documentation says: "When Jigasi is called, it
expects to find a 'Jitsi-Conference-Room' header in the invite with the
name of the Jitsi Meet conference the call is to be patched through to".

From the practical point of view, if for example I am calling from a
softphone, how do I specify the value for that header?

Thanks in advance.

Kind regards,
Daniel

[1] https://github.com/jitsi/jigasi

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hey Daniel,

We expect that your softphone and Jigasi will both be connected to a SIP
proxy/ PBX that will be configured to add this header.

Hope this helps,
Emil

···

On Tue, 18 Apr 2017 at 20:38, Daniel Bareiro <daniel-listas@gmx.net> wrote:

Hi all!

With the intention of starting to test Jigasi, I was reading something
of the documented in the repository [1].

I tried installing it using the repository for the stable version of
Jitsi Meet, but it seems that there is no precompiled package for it, so
the only alternative is to clone the repository and manually compile the
code.

There is something that is not clear to me that maybe someone can help
me understand. The documentation says: "When Jigasi is called, it
expects to find a 'Jitsi-Conference-Room' header in the invite with the
name of the Jitsi Meet conference the call is to be patched through to".

From the practical point of view, if for example I am calling from a
softphone, how do I specify the value for that header?

Thanks in advance.

Kind regards,
Daniel

[1] https://github.com/jitsi/jigasi

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
sent from my mobile


#4

Hey Daniel,

Hi, Emil.

We expect that your softphone and Jigasi will both be connected to a SIP
proxy/ PBX that will be configured to add this header.

Hope this helps,

My idea was to test with a softphone connected to an Asterisk server. Do
you have any documentation on how to do this with Asterisk? I was
researching and found an earlier message [1] from this mailing list.

From that email I see that something like this should be used on the
dialplan:

···

On 18/04/17 23:27, Emil Ivov wrote:

-------------------------------------------------------------------------
exten => _42.,1,SIPAddHeader(Jitsi-Conference-Room: ${EXTEN:2})
exten => _42.,n,Dial(SIP/Jigasi)
exten => _42.,n,Hangup
-------------------------------------------------------------------------

If I understood correctly, in the previous example Asterisk will use the
prefix "42" to route the calls through the extension called "Jigasi"
(which I understand should be defined as any other extension), creating
a header with what follows to the 46. So if in this case I dial
46room1234, I understand that I would have to join in the room called
room1234. Is this correct?

Now, if I dial only "42", then Jigasi would have to send me to the
default room?

Thanks for your reply.

Kind regards,
Daniel

[1] http://lists.jitsi.org/pipermail/dev/2015-October/025373.html


#5

Hi Daniel,

Hi, Damian.

You can add the unstable repo, where there are jigasi deb packages.
https://jitsi.org/Main/InstallJitsiMeetDebianNightlyRepository

Thank you for your suggestion. I will keep it in mind. I am currently
using the stable repository. If I add the repository nigthly, do you
think there could be some conflict with the stable repo dependencies
installed for the Jitsi Meet, Prosody and Jitsi Videobridge packages?

Curious question: why the jigasi package is in nightly and not in
stable? It is because Jigasi is still not stable enough?

Kind regards,
Daniel

···

On 19/04/17 01:32, Damian Minkov wrote:


#6

Hi,

Hi Daniel,

Hi, Damian.

You can add the unstable repo, where there are jigasi deb packages.
https://jitsi.org/Main/InstallJitsiMeetDebianNightlyRepository

Thank you for your suggestion. I will keep it in mind. I am currently
using the stable repository. If I add the repository nigthly, do you
think there could be some conflict with the stable repo dependencies
installed for the Jitsi Meet, Prosody and Jitsi Videobridge packages?

Nope but probably it can update to latest jitsi-meet. You can always
just download jigasi deb package from the repo and install it and
stick with stable repo for other packages.

Curious question: why the jigasi package is in nightly and not in
stable? It is because Jigasi is still not stable enough?

We haven't used it in production and we haven't pushed a version in
the stable repo, but is about to change and expect soon a version
there, cannot give any ETA.

Regards
damencho

···

On Wed, Apr 19, 2017 at 7:30 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 19/04/17 01:32, Damian Minkov wrote:

Kind regards,
Daniel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Hi,

Hey Daniel,

Hi, Emil.

We expect that your softphone and Jigasi will both be connected to a SIP
proxy/ PBX that will be configured to add this header.

Hope this helps,

My idea was to test with a softphone connected to an Asterisk server. Do
you have any documentation on how to do this with Asterisk? I was
researching and found an earlier message [1] from this mailing list.

From that email I see that something like this should be used on the
dialplan:

-------------------------------------------------------------------------
exten => _42.,1,SIPAddHeader(Jitsi-Conference-Room: ${EXTEN:2})
exten => _42.,n,Dial(SIP/Jigasi)
exten => _42.,n,Hangup
-------------------------------------------------------------------------

If I understood correctly, in the previous example Asterisk will use the
prefix "42" to route the calls through the extension called "Jigasi"
(which I understand should be defined as any other extension), creating
a header with what follows to the 46. So if in this case I dial
46room1234, I understand that I would have to join in the room called
room1234. Is this correct?

Yes, that is correct, calling 42room1234, will strip the first 2
digits and the header will be room1234 which will instruct jigasi to
join in that room.

Now, if I dial only "42", then Jigasi would have to send me to the
default room?

I'm not sure what will happen if the header is empty, not sure whether
it will be sent empty. But if the header is missing, there is a
default room, which can be controlled in jigasi config by setting this
property org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME. By default it is set

Regards
damencho

···

On Wed, Apr 19, 2017 at 6:59 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote:

On 18/04/17 23:27, Emil Ivov wrote:

to: siptest.

Thanks for your reply.

Kind regards,
Daniel

[1] http://lists.jitsi.org/pipermail/dev/2015-October/025373.html

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

Hi,

Hi, Damian.

We expect that your softphone and Jigasi will both be connected to a SIP
proxy/ PBX that will be configured to add this header.

Hope this helps,

My idea was to test with a softphone connected to an Asterisk server. Do
you have any documentation on how to do this with Asterisk? I was
researching and found an earlier message [1] from this mailing list.

From that email I see that something like this should be used on the
dialplan:

-------------------------------------------------------------------------
exten => _42.,1,SIPAddHeader(Jitsi-Conference-Room: ${EXTEN:2})
exten => _42.,n,Dial(SIP/Jigasi)
exten => _42.,n,Hangup
-------------------------------------------------------------------------

If I understood correctly, in the previous example Asterisk will use the
prefix "42" to route the calls through the extension called "Jigasi"
(which I understand should be defined as any other extension), creating
a header with what follows to the 46. So if in this case I dial
46room1234, I understand that I would have to join in the room called
room1234. Is this correct?

Yes, that is correct, calling 42room1234, will strip the first 2
digits and the header will be room1234 which will instruct jigasi to
join in that room.

Thanks for confirm.

Now, if I dial only "42", then Jigasi would have to send me to the
default room?

I'm not sure what will happen if the header is empty, not sure whether
it will be sent empty.

Maybe Emil can help us clarify this :slight_smile:

But if the header is missing, there is a default room, which can be
controlled in jigasi config by setting this property
org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME. By default it is set
to: siptest.

Yes, I had read some of that here [1]. Although I did not know the
default value for the org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME property.
Thanks for that.

If the caller is redirected to a room that does not exist, then it get a
busy tone? I think of the situation where the default room might not
exist. That is, it has to be created manually, I suppose, or is there
any way to automate the creation of conference rooms to avoid a
situation like the one I mentioned?

Thanks for your reply.

Kind regards,
Daniel

[1] https://github.com/jitsi/jigasi

···

On 19/04/17 15:34, Damian Minkov wrote:


#9

Hi,

Hi, Damian.

You can add the unstable repo, where there are jigasi deb packages.
https://jitsi.org/Main/InstallJitsiMeetDebianNightlyRepository

Thank you for your suggestion. I will keep it in mind. I am currently
using the stable repository. If I add the repository nigthly, do you
think there could be some conflict with the stable repo dependencies
installed for the Jitsi Meet, Prosody and Jitsi Videobridge packages?

Nope but probably it can update to latest jitsi-meet. You can always
just download jigasi deb package from the repo and install it and
stick with stable repo for other packages.

Thanks for this suggestion. I'll keep that in mind for test it.

Curious question: why the jigasi package is in nightly and not in
stable? It is because Jigasi is still not stable enough?

We haven't used it in production and we haven't pushed a version in
the stable repo, but is about to change and expect soon a version
there, cannot give any ETA.

That would be great. Please let us know when we have jigasi in the
stable repo.

Kind regards,
Daniel

···

On Wed, Apr 19, 2017 at 7:30 AM, Daniel Bareiro <daniel-listas@gmx.net> wrote: