[jitsi-dev] jigasi errors on startup


#1

Hi,

I'm experimenting with jigasi and jitmeet.
After following the instructions, I get some errors when the component
starts up

OpenJDK 64-Bit Server VM warning: You have loaded library
/var/www/jigasi/lib/native/linux/libjnopus.so which might have disabled
stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c
<libfile>', or link it with '-z noexecstack'.
14:52:00.311 SEVERE: [9]
org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
register custom Renderer
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with
JMF.
java.lang.IllegalStateException: audioSystem

and further down:

14:52:00.405 FINE: [9]
plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0 already
installed providers.
14:52:00.407 SEVERE: [13] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[Thread-3,5,main] and message
was: null
java.lang.NullPointerException
at
org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)

and yet further down:

14:52:00.484 SEVERE: [1] org.jitsi.jigasi.Main.main()
java.net.ConnectException: Connection refused
org.xmpp.component.ComponentException: java.net.ConnectException:
Connection refused
...............
14:52:00.738 WARNING: [16] impl.protocol.sip.SipLogger.logWarning().174
Warning from the JAIN-SIP stackusing default tls security policy
14:52:00.754 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info from
the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
14:52:01.030 SEVERE: [23] impl.protocol.sip.SipLogger.logError().122 Error
from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
14:52:01.030 SEVERE: [23]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
14:52:01.030 SEVERE: [23] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack

Any clues as to what's wrong? I don't understand why we see the error
message Invalid argument address = ::0, when in my
sip-communicator.properties file I
have net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=127.0.0.1,
and my kamailio proxy is listening on TCP 127.0.0.1 on port 5060

Thanks


#2

Hi,

Hi,

I'm experimenting with jigasi and jitmeet.
After following the instructions, I get some errors when the component
starts up

OpenJDK 64-Bit Server VM warning: You have loaded library
/var/www/jigasi/lib/native/linux/libjnopus.so which might have disabled
stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c
<libfile>', or link it with '-z noexecstack'.

We have found an error today in jigasi.sh script. If you're running 64
bit java then please modify this line:

libs="$SCRIPT_DIR/lib/native/linux"

to

libs="$SCRIPT_DIR/lib/native/linux-64"

14:52:00.311 SEVERE: [9]
org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
register custom Renderer
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with
JMF.
java.lang.IllegalStateException: audioSystem

This one can be ignored.

and further down:

14:52:00.405 FINE: [9]
plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0 already
installed providers.
14:52:00.407 SEVERE: [13] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[Thread-3,5,main] and message
was: null
java.lang.NullPointerException
at
org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)

Ignore this one too.

Regards,
Pawel

···

On Tue, Sep 9, 2014 at 5:04 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:


#3

Hi,

···

On Tue, Sep 9, 2014 at 6:04 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

14:52:00.484 SEVERE: [1] org.jitsi.jigasi.Main.main()
java.net.ConnectException: Connection refused
org.xmpp.component.ComponentException: java.net.ConnectException: Connection
refused

Check the secret that is configured in prosody for callcontrol
component and the secret that is stored in /etc/default/jigasi. When
the secret doesn't match you get "Connection refused".

Regards
damencho


#4

Thanks guys. Almost there.

The component now registers as expected, although there are some errors
regarding vcard and carbon copies, but I presume that's due to my prosody
config and so those errors are to be expected but shouldn't have any impact
on the SIP call.
Instead I'm seeing a "failed to specify transport in their offer" error
message and the call thus fails.
Can I specify TLS transport and enable ZRTP for the outbound calls like in
Jitsi? I imagine I'd have to add those properties to the
sip-communicator.properties file, but not sure if that's correct and what
the proper syntax for that is.

Thanks again,

Peter

16:03:35.530 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122 Error
from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
16:03:35.530 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
16:03:35.531 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:255)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.addSipListener(SipStackSharing.java:162)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:329)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
Caused by: java.lang.NullPointerException
at
gov.nist.javax.sip.stack.UDPMessageProcessor.stop(UDPMessageProcessor.java:270)
at
gov.nist.javax.sip.stack.SIPTransactionStack.removeMessageProcessor(SIPTransactionStack.java:2284)
at
gov.nist.javax.sip.SipStackImpl.deleteListeningPoint(SipStackImpl.java:1429)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.createProvider(SipStackSharing.java:383)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:243)
... 3 more
16:04:07.702 INFO: [32]
org.jitsi.jigasi.xmpp.CallControlComponent.handleIQSet().162 Got dial
request fromnumber -> 1000@my.domain.com room:
sitchoosewait@conference.meet.domain.com
16:04:07.829 INFO: [32]
org.jitsi.jigasi.JvbConference.setXmppProvider().386
1485b286796@callcontrol.meet.domain.com will use
ProtocolProviderServiceJabberImpl(1485b286796@meet.domain.com (Jabber))
16:04:08.090 INFO: [33]
impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1288
Chosen TLS protocol and algorithm:
Protocol: TLSv1
Cipher suite: TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
16:04:08.093 INFO: [33]
impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().106
Jingle : ON
16:04:08.093 INFO: [33]
org.jitsi.jigasi.JvbConference.registrationStateChanged().425 XMPP (
1485b286796@callcontrol.meet.domain.com): RegistrationStateChangeEvent[
oldState=Unregistered; newState=RegistrationState=Registering;
reasonCode=-1; reason=null]
16:04:08.117 SEVERE: [33]
service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().165
An error occurred while executing
RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent)
of
net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@1d7535e2
java.lang.IllegalArgumentException: Connection cannot be anonymous
...............................
...............................
16:04:11.423 INFO: [43]
impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate().810 Failed
to process an incoming session initiate
java.lang.NullPointerException
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.processOffer(CallPeerMediaHandlerJabberImpl.java:1743)
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate(CallPeerJabberImpl.java:787)
at
net.java.sip.communicator.impl.protocol.jabber.CallJabberImpl.processSessionInitiate(CallJabberImpl.java:993)
at
net.java.sip.communicator.impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl$2.run(OperationSetBasicTelephonyJabberImpl.java:1052)
16:04:16.438 SEVERE: [43] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[Thread-26,5,main] and message
was: The initiator is expected to specify the transport in their offer.
java.lang.IllegalStateException: The initiator is expected to specify the
transport in their offer.

···

On Tue, Sep 9, 2014 at 4:36 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

Hi,

On Tue, Sep 9, 2014 at 5:04 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
> Hi,
>
> I'm experimenting with jigasi and jitmeet.
> After following the instructions, I get some errors when the component
> starts up
>
> OpenJDK 64-Bit Server VM warning: You have loaded library
> /var/www/jigasi/lib/native/linux/libjnopus.so which might have disabled
> stack guard. The VM will try to fix the stack guard now.
> It's highly recommended that you fix the library with 'execstack -c
> <libfile>', or link it with '-z noexecstack'.

We have found an error today in jigasi.sh script. If you're running 64
bit java then please modify this line:

libs="$SCRIPT_DIR/lib/native/linux"

to

libs="$SCRIPT_DIR/lib/native/linux-64"

> 14:52:00.311 SEVERE: [9]
> org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
> register custom Renderer
> org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer
with
> JMF.
> java.lang.IllegalStateException: audioSystem

This one can be ignored.

> and further down:
>
> 14:52:00.405 FINE: [9]
> plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0
already
> installed providers.
> 14:52:00.407 SEVERE: [13] util.UtilActivator.uncaughtException().108 An
> uncaught exception occurred in thread=Thread[Thread-3,5,main] and message
> was: null
> java.lang.NullPointerException
> at
>
org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)
>

Ignore this one too.

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#5

Hi,

the easiest is to run Jitsi, configure the account, make sure it goes
online (registers to server without a problem), then remove you current sip
settings in sip-communicator.properties for jigasi and just paste those
from Jitsi.

Regards
damencho

···

On Tue, Sep 9, 2014 at 7:14 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Thanks guys. Almost there.

The component now registers as expected, although there are some errors
regarding vcard and carbon copies, but I presume that's due to my prosody
config and so those errors are to be expected but shouldn't have any impact
on the SIP call.
Instead I'm seeing a "failed to specify transport in their offer" error
message and the call thus fails.
Can I specify TLS transport and enable ZRTP for the outbound calls like in
Jitsi? I imagine I'd have to add those properties to the
sip-communicator.properties file, but not sure if that's correct and what
the proper syntax for that is.

Thanks again,

Peter

16:03:35.530 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122 Error
from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
16:03:35.530 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
16:03:35.531 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:255)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.addSipListener(SipStackSharing.java:162)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:329)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
Caused by: java.lang.NullPointerException
at
gov.nist.javax.sip.stack.UDPMessageProcessor.stop(UDPMessageProcessor.java:270)
at
gov.nist.javax.sip.stack.SIPTransactionStack.removeMessageProcessor(SIPTransactionStack.java:2284)
at
gov.nist.javax.sip.SipStackImpl.deleteListeningPoint(SipStackImpl.java:1429)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.createProvider(SipStackSharing.java:383)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:243)
... 3 more
16:04:07.702 INFO: [32]
org.jitsi.jigasi.xmpp.CallControlComponent.handleIQSet().162 Got dial
request fromnumber -> 1000@my.domain.com room:
sitchoosewait@conference.meet.domain.com
16:04:07.829 INFO: [32]
org.jitsi.jigasi.JvbConference.setXmppProvider().386
1485b286796@callcontrol.meet.domain.com will use
ProtocolProviderServiceJabberImpl(1485b286796@meet.domain.com (Jabber))
16:04:08.090 INFO: [33]
impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1288
Chosen TLS protocol and algorithm:
Protocol: TLSv1
Cipher suite: TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
16:04:08.093 INFO: [33]
impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().106
Jingle : ON
16:04:08.093 INFO: [33]
org.jitsi.jigasi.JvbConference.registrationStateChanged().425 XMPP (
1485b286796@callcontrol.meet.domain.com): RegistrationStateChangeEvent[
oldState=Unregistered; newState=RegistrationState=Registering;
reasonCode=-1; reason=null]
16:04:08.117 SEVERE: [33]
service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().165
An error occurred while executing
RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent)
of
net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@1d7535e2
java.lang.IllegalArgumentException: Connection cannot be anonymous
...............................
...............................
16:04:11.423 INFO: [43]
impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate().810 Failed
to process an incoming session initiate
java.lang.NullPointerException
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.processOffer(CallPeerMediaHandlerJabberImpl.java:1743)
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate(CallPeerJabberImpl.java:787)
at
net.java.sip.communicator.impl.protocol.jabber.CallJabberImpl.processSessionInitiate(CallJabberImpl.java:993)
at
net.java.sip.communicator.impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl$2.run(OperationSetBasicTelephonyJabberImpl.java:1052)
16:04:16.438 SEVERE: [43] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[Thread-26,5,main] and message
was: The initiator is expected to specify the transport in their offer.
java.lang.IllegalStateException: The initiator is expected to specify the
transport in their offer.

On Tue, Sep 9, 2014 at 4:36 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

Hi,

On Tue, Sep 9, 2014 at 5:04 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:
> Hi,
>
> I'm experimenting with jigasi and jitmeet.
> After following the instructions, I get some errors when the component
> starts up
>
> OpenJDK 64-Bit Server VM warning: You have loaded library
> /var/www/jigasi/lib/native/linux/libjnopus.so which might have disabled
> stack guard. The VM will try to fix the stack guard now.
> It's highly recommended that you fix the library with 'execstack -c
> <libfile>', or link it with '-z noexecstack'.

We have found an error today in jigasi.sh script. If you're running 64
bit java then please modify this line:

libs="$SCRIPT_DIR/lib/native/linux"

to

libs="$SCRIPT_DIR/lib/native/linux-64"

> 14:52:00.311 SEVERE: [9]
> org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
> register custom Renderer
> org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer
with
> JMF.
> java.lang.IllegalStateException: audioSystem

This one can be ignored.

> and further down:
>
> 14:52:00.405 FINE: [9]
> plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0
already
> installed providers.
> 14:52:00.407 SEVERE: [13] util.UtilActivator.uncaughtException().108 An
> uncaught exception occurred in thread=Thread[Thread-3,5,main] and
message
> was: null
> java.lang.NullPointerException
> at
>
org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)
>

Ignore this one too.

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#6

Thanks Damian.

I already did that but I'm still seeing the
"java.lang.IllegalStateException: The initiator is expected to specify the
transport in their offer" error message and the invite never makes it to my
SIP proxy.

I see in the jigasi logs that the JAIN-SIP stack seems to be crashing. I
also don't understand why it's trying to use TCP transport when I specified
TLS transport like in my jitsi sip-communicator.properties file. I also
specified port 5061 but you can see jigasi trying to use TCP port 5060 and
then crashing. I can see in the jigasi logs that my tls and port
preferences are indeed recognized, but they seem to be ignored.

16:46:38.886 INFO: [9] org.jitsi.jigasi.osgi.ConfigPrintActivator.info()
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=5061
16:46:38.899 INFO: [9] org.jitsi.jigasi.osgi.ConfigPrintActivator.info()
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TLS

16:28:57.162 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info from
the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
16:28:57.443 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122 Error
from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
16:28:57.444 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
16:28:57.449 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack

···

On Tue, Sep 9, 2014 at 5:29 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

the easiest is to run Jitsi, configure the account, make sure it goes
online (registers to server without a problem), then remove you current sip
settings in sip-communicator.properties for jigasi and just paste those
from Jitsi.

Regards
damencho

On Tue, Sep 9, 2014 at 7:14 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:

Thanks guys. Almost there.

The component now registers as expected, although there are some errors
regarding vcard and carbon copies, but I presume that's due to my prosody
config and so those errors are to be expected but shouldn't have any impact
on the SIP call.
Instead I'm seeing a "failed to specify transport in their offer" error
message and the call thus fails.
Can I specify TLS transport and enable ZRTP for the outbound calls like
in Jitsi? I imagine I'd have to add those properties to the
sip-communicator.properties file, but not sure if that's correct and what
the proper syntax for that is.

Thanks again,

Peter

16:03:35.530 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122
Error from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
16:03:35.530 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
16:03:35.531 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:255)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.addSipListener(SipStackSharing.java:162)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:329)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
Caused by: java.lang.NullPointerException
at
gov.nist.javax.sip.stack.UDPMessageProcessor.stop(UDPMessageProcessor.java:270)
at
gov.nist.javax.sip.stack.SIPTransactionStack.removeMessageProcessor(SIPTransactionStack.java:2284)
at
gov.nist.javax.sip.SipStackImpl.deleteListeningPoint(SipStackImpl.java:1429)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.createProvider(SipStackSharing.java:383)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:243)
... 3 more
16:04:07.702 INFO: [32]
org.jitsi.jigasi.xmpp.CallControlComponent.handleIQSet().162 Got dial
request fromnumber -> 1000@my.domain.com room:
sitchoosewait@conference.meet.domain.com
16:04:07.829 INFO: [32]
org.jitsi.jigasi.JvbConference.setXmppProvider().386
1485b286796@callcontrol.meet.domain.com will use
ProtocolProviderServiceJabberImpl(1485b286796@meet.domain.com (Jabber))
16:04:08.090 INFO: [33]
impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1288
Chosen TLS protocol and algorithm:
Protocol: TLSv1
Cipher suite: TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
16:04:08.093 INFO: [33]
impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().106
Jingle : ON
16:04:08.093 INFO: [33]
org.jitsi.jigasi.JvbConference.registrationStateChanged().425 XMPP (
1485b286796@callcontrol.meet.domain.com): RegistrationStateChangeEvent[
oldState=Unregistered; newState=RegistrationState=Registering;
reasonCode=-1; reason=null]
16:04:08.117 SEVERE: [33]
service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().165
An error occurred while executing
RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent)
of
net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@1d7535e2
java.lang.IllegalArgumentException: Connection cannot be anonymous
...............................
...............................
16:04:11.423 INFO: [43]
impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate().810 Failed
to process an incoming session initiate
java.lang.NullPointerException
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.processOffer(CallPeerMediaHandlerJabberImpl.java:1743)
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate(CallPeerJabberImpl.java:787)
at
net.java.sip.communicator.impl.protocol.jabber.CallJabberImpl.processSessionInitiate(CallJabberImpl.java:993)
at
net.java.sip.communicator.impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl$2.run(OperationSetBasicTelephonyJabberImpl.java:1052)
16:04:16.438 SEVERE: [43] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[Thread-26,5,main] and message
was: The initiator is expected to specify the transport in their offer.
java.lang.IllegalStateException: The initiator is expected to specify the
transport in their offer.

On Tue, Sep 9, 2014 at 4:36 PM, Paweł Domas <pawel.domas@jitsi.org> >> wrote:

Hi,

On Tue, Sep 9, 2014 at 5:04 PM, Peter Villeneuve <petervnv1@gmail.com> >>> wrote:
> Hi,
>
> I'm experimenting with jigasi and jitmeet.
> After following the instructions, I get some errors when the component
> starts up
>
> OpenJDK 64-Bit Server VM warning: You have loaded library
> /var/www/jigasi/lib/native/linux/libjnopus.so which might have disabled
> stack guard. The VM will try to fix the stack guard now.
> It's highly recommended that you fix the library with 'execstack -c
> <libfile>', or link it with '-z noexecstack'.

We have found an error today in jigasi.sh script. If you're running 64
bit java then please modify this line:

libs="$SCRIPT_DIR/lib/native/linux"

to

libs="$SCRIPT_DIR/lib/native/linux-64"

> 14:52:00.311 SEVERE: [9]
> org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
> register custom Renderer
> org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer
with
> JMF.
> java.lang.IllegalStateException: audioSystem

This one can be ignored.

> and further down:
>
> 14:52:00.405 FINE: [9]
> plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0
already
> installed providers.
> 14:52:00.407 SEVERE: [13] util.UtilActivator.uncaughtException().108 An
> uncaught exception occurred in thread=Thread[Thread-3,5,main] and
message
> was: null
> java.lang.NullPointerException
> at
>
org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)
>

Ignore this one too.

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#7

Hi,

do you see the PROXY_AUTO_CONFIG=false property in the sip account
properties?

Regards
damencho

···

On Tue, Sep 9, 2014 at 7:52 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Thanks Damian.

I already did that but I'm still seeing the
"java.lang.IllegalStateException: The initiator is expected to specify the
transport in their offer" error message and the invite never makes it to my
SIP proxy.

I see in the jigasi logs that the JAIN-SIP stack seems to be crashing. I
also don't understand why it's trying to use TCP transport when I specified
TLS transport like in my jitsi sip-communicator.properties file. I also
specified port 5061 but you can see jigasi trying to use TCP port 5060 and
then crashing. I can see in the jigasi logs that my tls and port
preferences are indeed recognized, but they seem to be ignored.

16:46:38.886 INFO: [9] org.jitsi.jigasi.osgi.ConfigPrintActivator.info()
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=5061
16:46:38.899 INFO: [9] org.jitsi.jigasi.osgi.ConfigPrintActivator.info()
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TLS

16:28:57.162 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
16:28:57.443 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122 Error
from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
16:28:57.444 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
16:28:57.449 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack

On Tue, Sep 9, 2014 at 5:29 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

the easiest is to run Jitsi, configure the account, make sure it goes
online (registers to server without a problem), then remove you current sip
settings in sip-communicator.properties for jigasi and just paste those
from Jitsi.

Regards
damencho

On Tue, Sep 9, 2014 at 7:14 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:

Thanks guys. Almost there.

The component now registers as expected, although there are some errors
regarding vcard and carbon copies, but I presume that's due to my prosody
config and so those errors are to be expected but shouldn't have any impact
on the SIP call.
Instead I'm seeing a "failed to specify transport in their offer" error
message and the call thus fails.
Can I specify TLS transport and enable ZRTP for the outbound calls like
in Jitsi? I imagine I'd have to add those properties to the
sip-communicator.properties file, but not sure if that's correct and what
the proper syntax for that is.

Thanks again,

Peter

16:03:35.530 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122
Error from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
16:03:35.530 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
16:03:35.531 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:255)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.addSipListener(SipStackSharing.java:162)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:329)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
Caused by: java.lang.NullPointerException
at
gov.nist.javax.sip.stack.UDPMessageProcessor.stop(UDPMessageProcessor.java:270)
at
gov.nist.javax.sip.stack.SIPTransactionStack.removeMessageProcessor(SIPTransactionStack.java:2284)
at
gov.nist.javax.sip.SipStackImpl.deleteListeningPoint(SipStackImpl.java:1429)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.createProvider(SipStackSharing.java:383)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:243)
... 3 more
16:04:07.702 INFO: [32]
org.jitsi.jigasi.xmpp.CallControlComponent.handleIQSet().162 Got dial
request fromnumber -> 1000@my.domain.com room:
sitchoosewait@conference.meet.domain.com
16:04:07.829 INFO: [32]
org.jitsi.jigasi.JvbConference.setXmppProvider().386
1485b286796@callcontrol.meet.domain.com will use
ProtocolProviderServiceJabberImpl(1485b286796@meet.domain.com (Jabber))
16:04:08.090 INFO: [33]
impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1288
Chosen TLS protocol and algorithm:
Protocol: TLSv1
Cipher suite: TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
16:04:08.093 INFO: [33]
impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().106
Jingle : ON
16:04:08.093 INFO: [33]
org.jitsi.jigasi.JvbConference.registrationStateChanged().425 XMPP (
1485b286796@callcontrol.meet.domain.com): RegistrationStateChangeEvent[
oldState=Unregistered; newState=RegistrationState=Registering;
reasonCode=-1; reason=null]
16:04:08.117 SEVERE: [33]
service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().165
An error occurred while executing
RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent)
of
net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@1d7535e2
java.lang.IllegalArgumentException: Connection cannot be anonymous
...............................
...............................
16:04:11.423 INFO: [43]
impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate().810 Failed
to process an incoming session initiate
java.lang.NullPointerException
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.processOffer(CallPeerMediaHandlerJabberImpl.java:1743)
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate(CallPeerJabberImpl.java:787)
at
net.java.sip.communicator.impl.protocol.jabber.CallJabberImpl.processSessionInitiate(CallJabberImpl.java:993)
at
net.java.sip.communicator.impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl$2.run(OperationSetBasicTelephonyJabberImpl.java:1052)
16:04:16.438 SEVERE: [43] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[Thread-26,5,main] and message
was: The initiator is expected to specify the transport in their offer.
java.lang.IllegalStateException: The initiator is expected to specify
the transport in their offer.

On Tue, Sep 9, 2014 at 4:36 PM, Paweł Domas <pawel.domas@jitsi.org> >>> wrote:

Hi,

On Tue, Sep 9, 2014 at 5:04 PM, Peter Villeneuve <petervnv1@gmail.com> >>>> wrote:
> Hi,
>
> I'm experimenting with jigasi and jitmeet.
> After following the instructions, I get some errors when the component
> starts up
>
> OpenJDK 64-Bit Server VM warning: You have loaded library
> /var/www/jigasi/lib/native/linux/libjnopus.so which might have
disabled
> stack guard. The VM will try to fix the stack guard now.
> It's highly recommended that you fix the library with 'execstack -c
> <libfile>', or link it with '-z noexecstack'.

We have found an error today in jigasi.sh script. If you're running 64
bit java then please modify this line:

libs="$SCRIPT_DIR/lib/native/linux"

to

libs="$SCRIPT_DIR/lib/native/linux-64"

> 14:52:00.311 SEVERE: [9]
> org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
> register custom Renderer
>
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with
> JMF.
> java.lang.IllegalStateException: audioSystem

This one can be ignored.

> and further down:
>
> 14:52:00.405 FINE: [9]
> plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0
already
> installed providers.
> 14:52:00.407 SEVERE: [13] util.UtilActivator.uncaughtException().108
An
> uncaught exception occurred in thread=Thread[Thread-3,5,main] and
message
> was: null
> java.lang.NullPointerException
> at
>
org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)
>

Ignore this one too.

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#8

socket for SIP which is controller by different properties. I'll find
them tomorrow and let you know.

Regards,
Pawel

···

On Tue, Sep 9, 2014 at 6:52 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Thanks Damian.

I already did that but I'm still seeing the
"java.lang.IllegalStateException: The initiator is expected to specify the
transport in their offer" error message and the invite never makes it to my
SIP proxy.

I see in the jigasi logs that the JAIN-SIP stack seems to be crashing. I
also don't understand why it's trying to use TCP transport when I specified
TLS transport like in my jitsi sip-communicator.properties file. I also
specified port 5061 but you can see jigasi trying to use TCP port 5060 and
then crashing. I can see in the jigasi logs that my tls and port preferences
are indeed recognized, but they seem to be ignored.

From the stack trace it looks like it's the problem with binding local


#9

org.jitsi.jigasi.osgi.ConfigPrintActivator.info()
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false

I'm going to try and set the proxy values to see if that helps.

···

On Tue, Sep 9, 2014 at 6:15 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

do you see the PROXY_AUTO_CONFIG=false property in the sip account
properties?

Regards
damencho

On Tue, Sep 9, 2014 at 7:52 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:

Thanks Damian.

I already did that but I'm still seeing the
"java.lang.IllegalStateException: The initiator is expected to specify the
transport in their offer" error message and the invite never makes it to my
SIP proxy.

I see in the jigasi logs that the JAIN-SIP stack seems to be crashing. I
also don't understand why it's trying to use TCP transport when I specified
TLS transport like in my jitsi sip-communicator.properties file. I also
specified port 5061 but you can see jigasi trying to use TCP port 5060 and
then crashing. I can see in the jigasi logs that my tls and port
preferences are indeed recognized, but they seem to be ignored.

16:46:38.886 INFO: [9] org.jitsi.jigasi.osgi.ConfigPrintActivator.info()
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=5061
16:46:38.899 INFO: [9] org.jitsi.jigasi.osgi.ConfigPrintActivator.info()
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TLS

16:28:57.162 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
16:28:57.443 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122
Error from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
16:28:57.444 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
16:28:57.449 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack

On Tue, Sep 9, 2014 at 5:29 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

the easiest is to run Jitsi, configure the account, make sure it goes
online (registers to server without a problem), then remove you current sip
settings in sip-communicator.properties for jigasi and just paste those
from Jitsi.

Regards
damencho

On Tue, Sep 9, 2014 at 7:14 PM, Peter Villeneuve <petervnv1@gmail.com> >>> wrote:

Thanks guys. Almost there.

The component now registers as expected, although there are some errors
regarding vcard and carbon copies, but I presume that's due to my prosody
config and so those errors are to be expected but shouldn't have any impact
on the SIP call.
Instead I'm seeing a "failed to specify transport in their offer" error
message and the call thus fails.
Can I specify TLS transport and enable ZRTP for the outbound calls like
in Jitsi? I imagine I'd have to add those properties to the
sip-communicator.properties file, but not sure if that's correct and what
the proper syntax for that is.

Thanks again,

Peter

16:03:35.530 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122
Error from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
16:03:35.530 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
16:03:35.531 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:255)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.addSipListener(SipStackSharing.java:162)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:329)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
Caused by: java.lang.NullPointerException
at
gov.nist.javax.sip.stack.UDPMessageProcessor.stop(UDPMessageProcessor.java:270)
at
gov.nist.javax.sip.stack.SIPTransactionStack.removeMessageProcessor(SIPTransactionStack.java:2284)
at
gov.nist.javax.sip.SipStackImpl.deleteListeningPoint(SipStackImpl.java:1429)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.createProvider(SipStackSharing.java:383)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:243)
... 3 more
16:04:07.702 INFO: [32]
org.jitsi.jigasi.xmpp.CallControlComponent.handleIQSet().162 Got dial
request fromnumber -> 1000@my.domain.com room:
sitchoosewait@conference.meet.domain.com
16:04:07.829 INFO: [32]
org.jitsi.jigasi.JvbConference.setXmppProvider().386
1485b286796@callcontrol.meet.domain.com will use
ProtocolProviderServiceJabberImpl(1485b286796@meet.domain.com (Jabber))
16:04:08.090 INFO: [33]
impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1288
Chosen TLS protocol and algorithm:
Protocol: TLSv1
Cipher suite: TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
16:04:08.093 INFO: [33]
impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().106
Jingle : ON
16:04:08.093 INFO: [33]
org.jitsi.jigasi.JvbConference.registrationStateChanged().425 XMPP (
1485b286796@callcontrol.meet.domain.com):
RegistrationStateChangeEvent[ oldState=Unregistered;
newState=RegistrationState=Registering; reasonCode=-1; reason=null]
16:04:08.117 SEVERE: [33]
service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().165
An error occurred while executing
RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent)
of
net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@1d7535e2
java.lang.IllegalArgumentException: Connection cannot be anonymous
...............................
...............................
16:04:11.423 INFO: [43]
impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate().810 Failed
to process an incoming session initiate
java.lang.NullPointerException
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.processOffer(CallPeerMediaHandlerJabberImpl.java:1743)
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate(CallPeerJabberImpl.java:787)
at
net.java.sip.communicator.impl.protocol.jabber.CallJabberImpl.processSessionInitiate(CallJabberImpl.java:993)
at
net.java.sip.communicator.impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl$2.run(OperationSetBasicTelephonyJabberImpl.java:1052)
16:04:16.438 SEVERE: [43] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[Thread-26,5,main] and message
was: The initiator is expected to specify the transport in their offer.
java.lang.IllegalStateException: The initiator is expected to specify
the transport in their offer.

On Tue, Sep 9, 2014 at 4:36 PM, Paweł Domas <pawel.domas@jitsi.org> >>>> wrote:

Hi,

On Tue, Sep 9, 2014 at 5:04 PM, Peter Villeneuve <petervnv1@gmail.com> >>>>> wrote:
> Hi,
>
> I'm experimenting with jigasi and jitmeet.
> After following the instructions, I get some errors when the
component
> starts up
>
> OpenJDK 64-Bit Server VM warning: You have loaded library
> /var/www/jigasi/lib/native/linux/libjnopus.so which might have
disabled
> stack guard. The VM will try to fix the stack guard now.
> It's highly recommended that you fix the library with 'execstack -c
> <libfile>', or link it with '-z noexecstack'.

We have found an error today in jigasi.sh script. If you're running 64
bit java then please modify this line:

libs="$SCRIPT_DIR/lib/native/linux"

to

libs="$SCRIPT_DIR/lib/native/linux-64"

> 14:52:00.311 SEVERE: [9]
> org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
> register custom Renderer
>
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with
> JMF.
> java.lang.IllegalStateException: audioSystem

This one can be ignored.

> and further down:
>
> 14:52:00.405 FINE: [9]
> plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0
already
> installed providers.
> 14:52:00.407 SEVERE: [13] util.UtilActivator.uncaughtException().108
An
> uncaught exception occurred in thread=Thread[Thread-3,5,main] and
message
> was: null
> java.lang.NullPointerException
> at
>
org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)
>

Ignore this one too.

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#10

OK, I explicitly set the SIP proxy values this time and still I get the
error about the JAIN SIP stack and it reports it as trying to use TCP and
port 5060 instead of my proxy settings.
I still don't understand where it's getting those values from. Are they
hardcoded in the libraries?

Thanks

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=
proxy.domain.com
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=5061
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=127.0.0.1
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=5061
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TLS

···

On Tue, Sep 9, 2014 at 6:31 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

org.jitsi.jigasi.osgi.ConfigPrintActivator.info()
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false

I'm going to try and set the proxy values to see if that helps.

On Tue, Sep 9, 2014 at 6:15 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

do you see the PROXY_AUTO_CONFIG=false property in the sip account
properties?

Regards
damencho

On Tue, Sep 9, 2014 at 7:52 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:

Thanks Damian.

I already did that but I'm still seeing the
"java.lang.IllegalStateException: The initiator is expected to specify the
transport in their offer" error message and the invite never makes it to my
SIP proxy.

I see in the jigasi logs that the JAIN-SIP stack seems to be crashing. I
also don't understand why it's trying to use TCP transport when I specified
TLS transport like in my jitsi sip-communicator.properties file. I also
specified port 5061 but you can see jigasi trying to use TCP port 5060 and
then crashing. I can see in the jigasi logs that my tls and port
preferences are indeed recognized, but they seem to be ignored.

16:46:38.886 INFO: [9] org.jitsi.jigasi.osgi.ConfigPrintActivator.info()
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=5061
16:46:38.899 INFO: [9] org.jitsi.jigasi.osgi.ConfigPrintActivator.info()
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TLS

16:28:57.162 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
16:28:57.443 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122
Error from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
16:28:57.444 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
16:28:57.449 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack

On Tue, Sep 9, 2014 at 5:29 PM, Damian Minkov <damencho@jitsi.org> >>> wrote:

Hi,

the easiest is to run Jitsi, configure the account, make sure it goes
online (registers to server without a problem), then remove you current sip
settings in sip-communicator.properties for jigasi and just paste
those from Jitsi.

Regards
damencho

On Tue, Sep 9, 2014 at 7:14 PM, Peter Villeneuve <petervnv1@gmail.com> >>>> wrote:

Thanks guys. Almost there.

The component now registers as expected, although there are some
errors regarding vcard and carbon copies, but I presume that's due to my
prosody config and so those errors are to be expected but shouldn't have
any impact on the SIP call.
Instead I'm seeing a "failed to specify transport in their offer"
error message and the call thus fails.
Can I specify TLS transport and enable ZRTP for the outbound calls
like in Jitsi? I imagine I'd have to add those properties to the
sip-communicator.properties file, but not sure if that's correct and what
the proper syntax for that is.

Thanks again,

Peter

16:03:35.530 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122
Error from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
16:03:35.530 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
16:03:35.531 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack
net.java.sip.communicator.service.protocol.OperationFailedException:
An unexpected error hapennedwhile initializing the SIP stack
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:255)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.addSipListener(SipStackSharing.java:162)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:329)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
Caused by: java.lang.NullPointerException
at
gov.nist.javax.sip.stack.UDPMessageProcessor.stop(UDPMessageProcessor.java:270)
at
gov.nist.javax.sip.stack.SIPTransactionStack.removeMessageProcessor(SIPTransactionStack.java:2284)
at
gov.nist.javax.sip.SipStackImpl.deleteListeningPoint(SipStackImpl.java:1429)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.createProvider(SipStackSharing.java:383)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.startListening(SipStackSharing.java:243)
... 3 more
16:04:07.702 INFO: [32]
org.jitsi.jigasi.xmpp.CallControlComponent.handleIQSet().162 Got dial
request fromnumber -> 1000@my.domain.com room:
sitchoosewait@conference.meet.domain.com
16:04:07.829 INFO: [32]
org.jitsi.jigasi.JvbConference.setXmppProvider().386
1485b286796@callcontrol.meet.domain.com will use
ProtocolProviderServiceJabberImpl(1485b286796@meet.domain.com
(Jabber))
16:04:08.090 INFO: [33]
impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1288
Chosen TLS protocol and algorithm:
Protocol: TLSv1
Cipher suite: TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
16:04:08.093 INFO: [33]
impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().106
Jingle : ON
16:04:08.093 INFO: [33]
org.jitsi.jigasi.JvbConference.registrationStateChanged().425 XMPP (
1485b286796@callcontrol.meet.domain.com):
RegistrationStateChangeEvent[ oldState=Unregistered;
newState=RegistrationState=Registering; reasonCode=-1; reason=null]
16:04:08.117 SEVERE: [33]
service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().165
An error occurred while executing
RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent)
of
net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@1d7535e2
java.lang.IllegalArgumentException: Connection cannot be anonymous
...............................
...............................
16:04:11.423 INFO: [43]
impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate().810 Failed
to process an incoming session initiate
java.lang.NullPointerException
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.processOffer(CallPeerMediaHandlerJabberImpl.java:1743)
at
net.java.sip.communicator.impl.protocol.jabber.CallPeerJabberImpl.processSessionInitiate(CallPeerJabberImpl.java:787)
at
net.java.sip.communicator.impl.protocol.jabber.CallJabberImpl.processSessionInitiate(CallJabberImpl.java:993)
at
net.java.sip.communicator.impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl$2.run(OperationSetBasicTelephonyJabberImpl.java:1052)
16:04:16.438 SEVERE: [43] util.UtilActivator.uncaughtException().108
An uncaught exception occurred in thread=Thread[Thread-26,5,main] and
message was: The initiator is expected to specify the transport in their
offer.
java.lang.IllegalStateException: The initiator is expected to specify
the transport in their offer.

On Tue, Sep 9, 2014 at 4:36 PM, Paweł Domas <pawel.domas@jitsi.org> >>>>> wrote:

Hi,

On Tue, Sep 9, 2014 at 5:04 PM, Peter Villeneuve <petervnv1@gmail.com> >>>>>> wrote:
> Hi,
>
> I'm experimenting with jigasi and jitmeet.
> After following the instructions, I get some errors when the
component
> starts up
>
> OpenJDK 64-Bit Server VM warning: You have loaded library
> /var/www/jigasi/lib/native/linux/libjnopus.so which might have
disabled
> stack guard. The VM will try to fix the stack guard now.
> It's highly recommended that you fix the library with 'execstack -c
> <libfile>', or link it with '-z noexecstack'.

We have found an error today in jigasi.sh script. If you're running 64
bit java then please modify this line:

libs="$SCRIPT_DIR/lib/native/linux"

to

libs="$SCRIPT_DIR/lib/native/linux-64"

> 14:52:00.311 SEVERE: [9]
> org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
> register custom Renderer
>
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with
> JMF.
> java.lang.IllegalStateException: audioSystem

This one can be ignored.

> and further down:
>
> 14:52:00.405 FINE: [9]
> plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0
already
> installed providers.
> 14:52:00.407 SEVERE: [13]
util.UtilActivator.uncaughtException().108 An
> uncaught exception occurred in thread=Thread[Thread-3,5,main] and
message
> was: null
> java.lang.NullPointerException
> at
>
org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)
>

Ignore this one too.

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#11

Great, thanks.
I appreciate your help.

Peter

···

On Tue, Sep 9, 2014 at 8:19 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

On Tue, Sep 9, 2014 at 6:52 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
> Thanks Damian.
>
> I already did that but I'm still seeing the
> "java.lang.IllegalStateException: The initiator is expected to specify
the
> transport in their offer" error message and the invite never makes it to
my
> SIP proxy.
>
> I see in the jigasi logs that the JAIN-SIP stack seems to be crashing. I
> also don't understand why it's trying to use TCP transport when I
specified
> TLS transport like in my jitsi sip-communicator.properties file. I also
> specified port 5061 but you can see jigasi trying to use TCP port 5060
and
> then crashing. I can see in the jigasi logs that my tls and port
preferences
> are indeed recognized, but they seem to be ignored.

From the stack trace it looks like it's the problem with binding local
socket for SIP which is controller by different properties. I'll find
them tomorrow and let you know.

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#12

Hi,

Here are two properties that control local SIP port numbers:

net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT - the preferred UDP
and TCP port to bind to for clear communications

net.java.sip.communicator.SIP_PREFERRED_SECURE_PORT - the preferred
TLS (TCP) port to bind to for secure communications

···

On Tue, Sep 9, 2014 at 10:08 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Great, thanks.
I appreciate your help.

Peter

On Tue, Sep 9, 2014 at 8:19 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

On Tue, Sep 9, 2014 at 6:52 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:
> Thanks Damian.
>
> I already did that but I'm still seeing the
> "java.lang.IllegalStateException: The initiator is expected to specify
> the
> transport in their offer" error message and the invite never makes it to
> my
> SIP proxy.
>
> I see in the jigasi logs that the JAIN-SIP stack seems to be crashing. I
> also don't understand why it's trying to use TCP transport when I
> specified
> TLS transport like in my jitsi sip-communicator.properties file. I also
> specified port 5061 but you can see jigasi trying to use TCP port 5060
> and
> then crashing. I can see in the jigasi logs that my tls and port
> preferences
> are indeed recognized, but they seem to be ignored.

From the stack trace it looks like it's the problem with binding local
socket for SIP which is controller by different properties. I'll find
them tomorrow and let you know.


#13

Thanks Pawel.

Unfortunately it's still not working.
I added net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT=5060 and
net.java.sip.communicator.SIP_PREFERRED_SECURE_PORT=5061 to the
sip-communicator.properties file and I still get that error starting the
SIP stack.

Are there other properties I have to set anywhere else? I just want the
JAIN-SIP stack to register on localhost, with TLS on port 5061, but I can't
manage to do that.
I installed jigasi from source. Perhaps I should try the debian package
instead to see if that changes anything.

Ideas, thoughts?

Cheers

18:47:15.699 WARNING: [16] impl.protocol.sip.SipLogger.logWarning().174
Warning from the JAIN-SIP stackusing default tls security policy
18:47:15.717 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info from
the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
18:47:15.975 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122 Error
from the JAIN-SIP stack: Invalid argument address = ::0 port = 5060
transport = TCP
18:47:15.976 SEVERE: [25]
impl.protocol.sip.SipStackSharing.startListening().253 An unexpected error
happened while creating theSipProviders and ListeningPoints.
18:47:15.976 SEVERE: [25] org.jitsi.jigasi.RegisterThread.run().42
net.java.sip.communicator.service.protocol.OperationFailedException: An
unexpected error hapennedwhile initializing the SIP stack

···

On Wed, Sep 10, 2014 at 8:10 AM, Paweł Domas <pawel.domas@jitsi.org> wrote:

Hi,

Here are two properties that control local SIP port numbers:

net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT - the preferred UDP
and TCP port to bind to for clear communications

net.java.sip.communicator.SIP_PREFERRED_SECURE_PORT - the preferred
TLS (TCP) port to bind to for secure communications

On Tue, Sep 9, 2014 at 10:08 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
> Great, thanks.
> I appreciate your help.
>
> Peter
>
> On Tue, Sep 9, 2014 at 8:19 PM, Paweł Domas <pawel.domas@jitsi.org> > wrote:
>>
>> On Tue, Sep 9, 2014 at 6:52 PM, Peter Villeneuve <petervnv1@gmail.com> > >> wrote:
>> > Thanks Damian.
>> >
>> > I already did that but I'm still seeing the
>> > "java.lang.IllegalStateException: The initiator is expected to specify
>> > the
>> > transport in their offer" error message and the invite never makes it
to
>> > my
>> > SIP proxy.
>> >
>> > I see in the jigasi logs that the JAIN-SIP stack seems to be
crashing. I
>> > also don't understand why it's trying to use TCP transport when I
>> > specified
>> > TLS transport like in my jitsi sip-communicator.properties file. I
also
>> > specified port 5061 but you can see jigasi trying to use TCP port 5060
>> > and
>> > then crashing. I can see in the jigasi logs that my tls and port
>> > preferences
>> > are indeed recognized, but they seem to be ignored.
>>
>> From the stack trace it looks like it's the problem with binding local
>> socket for SIP which is controller by different properties. I'll find
>> them tomorrow and let you know.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#14

Hi,

···

On Wed, Sep 10, 2014 at 8:53 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Thanks Pawel.

Unfortunately it's still not working.
I added net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT=5060 and
net.java.sip.communicator.SIP_PREFERRED_SECURE_PORT=5061 to the
sip-communicator.properties file and I still get that error starting the SIP
stack.

Are there other properties I have to set anywhere else? I just want the
JAIN-SIP stack to register on localhost, with TLS on port 5061, but I can't
manage to do that.
I installed jigasi from source. Perhaps I should try the debian package
instead to see if that changes anything.

Ideas, thoughts?

Does it run on another machine ? What happens if you specify other
ports than 5060 and 5061 ? Maybe it's a permission problem and Jigasi
is not allowed to bind ?

Regards,
Pawel


#15

Getting closer to finding the source of the problem, I think.
I changed SIP_PREFERRED_CLEAR_PORT=5060 to 5080 and
SIP_PREFERRED_SECURE_PORT=5061
to 5081.
You can see it trying to connect to 5080, but using TCP. But I want it to
connect via TLS to 5061. It seems 5081 did nothing.

Sorry for the long logs, but there maybe a clue there that I missed and you
can spot.

Is there a net.java.sip.communicator.SIP_PROXY_PORT=5061 or something
similar I have to set? How about setting the TLS transport?

And yes, sip proxy and jigasi are on the same server.

Cheers

19:03:51.896 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE CHANGE
ProtocolProviderServiceSipImpl(1010@my.domain.com (SIP)) ->
RegistrationStateChangeEvent[ oldState=Unregistered;
newState=RegistrationState=Registering; reasonCode=-1; reason=null]
19:03:51.936 SEVERE: [25]
impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders().1238
Unable to create a via header for port 5080
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:579)
at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
at
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
at
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
at
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
at
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
at
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
at
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
19:03:51.937 SEVERE: [25]
impl.protocol.sip.SipRegistrarConnection.register().282 Failed to create a
Register request.
net.java.sip.communicator.service.protocol.OperationFailedException: Unable
to create a via header for port 5080
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1242)
at
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
at
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
Caused by: java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:579)
at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
at
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
at
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
at
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
at
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
... 5 more
19:03:51.939 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE CHANGE
ProtocolProviderServiceSipImpl(1010@my.domain.com (SIP)) ->
RegistrationStateChangeEvent[ oldState=Registering;
newState=RegistrationState=Connection Failed; reasonCode=6; reason=Unable
to create a via header for port 5080]
19:03:51.946 INFO: [25] impl.protocol.sip.SipLogger.logInfo().185 Info from
the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
19:03:52.946 INFO: [25] impl.protocol.sip.SipLogger.logInfo().185 Info from
the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
19:03:53.949 SEVERE: [25]
impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress().2607
Cannot send register!
net.java.sip.communicator.service.protocol.OperationFailedException: Unable
to create a via header for port 5080
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1242)
at
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
at
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
Caused by: java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:579)
at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
at
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
at
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
at
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
at
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
... 5 more
19:03:53.950 SEVERE: [25]
impl.protocol.sip.ProtocolProviderServiceSipImpl.register().349 No address
found for ProtocolProviderServiceSipImpl(1010@my.domain.com (SIP))
19:03:53.950 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE CHANGE
ProtocolProviderServiceSipImpl(1010@my.domain.com (SIP)) ->
RegistrationStateChangeEvent[ oldState=Registering;
newState=RegistrationState=Connection Failed; reasonCode=8; reason=Invalid
or inaccessible server address.]

···

On Wed, Sep 10, 2014 at 7:58 PM, Paweł Domas <pawel.domas@jitsi.org> wrote:

Hi,

On Wed, Sep 10, 2014 at 8:53 PM, Peter Villeneuve <petervnv1@gmail.com> > wrote:
> Thanks Pawel.
>
> Unfortunately it's still not working.
> I added net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT=5060 and
> net.java.sip.communicator.SIP_PREFERRED_SECURE_PORT=5061 to the
> sip-communicator.properties file and I still get that error starting the
SIP
> stack.
>
> Are there other properties I have to set anywhere else? I just want the
> JAIN-SIP stack to register on localhost, with TLS on port 5061, but I
can't
> manage to do that.
> I installed jigasi from source. Perhaps I should try the debian package
> instead to see if that changes anything.
>
> Ideas, thoughts?

Does it run on another machine ? What happens if you specify other
ports than 5060 and 5061 ? Maybe it's a permission problem and Jigasi
is not allowed to bind ?

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#16

Hi Pawel,

Me again. Still can't get this to work. I think the problem lies in the
server address that jigasi tries to connect to. I see that changing
the SIP_PREFERRED_SECURE_PORT=5062
works, and my guess that SIP_PREFERRED_TRANSPORT=TLS also seems to work
fine since JAIN-SIP seems to correctly interpret them as you can see below.
Unfortunately it is still not working, probably because of the ipv6 address ::0
it is trying to use. I have set my SIP proxy to listen on 127.0.0.1 and
port 5062 using TLS, but I can't figure out how to force jigasi to register
on 127.0.0.1 instead of ::0. I tried setting
SIP_PREFERRED_SERVER_ADDRESS=127.0.1.1 but that doesn't seem to work either.

Any ideas?

Thanks

16:19:20.304 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122 Error
from the JAIN-SIP stack: Invalid argument address = ::0 port = 5062
transport = TLS
16:19:20.354 SEVERE: [25]
impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress().2607
Cannot send register!

···

On Wed, Sep 10, 2014 at 8:10 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Getting closer to finding the source of the problem, I think.
I changed SIP_PREFERRED_CLEAR_PORT=5060 to 5080 and SIP_PREFERRED_SECURE_PORT=5061
to 5081.
You can see it trying to connect to 5080, but using TCP. But I want it to
connect via TLS to 5061. It seems 5081 did nothing.

Sorry for the long logs, but there maybe a clue there that I missed and
you can spot.

Is there a net.java.sip.communicator.SIP_PROXY_PORT=5061 or something
similar I have to set? How about setting the TLS transport?

And yes, sip proxy and jigasi are on the same server.

Cheers

19:03:51.896 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE CHANGE
ProtocolProviderServiceSipImpl(1010@my.domain.com (SIP)) ->
RegistrationStateChangeEvent[ oldState=Unregistered;
newState=RegistrationState=Registering; reasonCode=-1; reason=null]
19:03:51.936 SEVERE: [25]
impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders().1238
Unable to create a via header for port 5080
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:579)
at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
at
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
at
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
at
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
at
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
at
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
at
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
19:03:51.937 SEVERE: [25]
impl.protocol.sip.SipRegistrarConnection.register().282 Failed to create a
Register request.
net.java.sip.communicator.service.protocol.OperationFailedException:
Unable to create a via header for port 5080
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1242)
at
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
at
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
Caused by: java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:579)
at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
at
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
at
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
at
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
at
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
... 5 more
19:03:51.939 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE CHANGE
ProtocolProviderServiceSipImpl(1010@my.domain.com (SIP)) ->
RegistrationStateChangeEvent[ oldState=Registering;
newState=RegistrationState=Connection Failed; reasonCode=6; reason=Unable
to create a via header for port 5080]
19:03:51.946 INFO: [25] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
19:03:52.946 INFO: [25] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
19:03:53.949 SEVERE: [25]
impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress().2607
Cannot send register!
net.java.sip.communicator.service.protocol.OperationFailedException:
Unable to create a via header for port 5080
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1242)
at
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
at
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
Caused by: java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:579)
at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
at
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
at
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
at
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
at
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
... 5 more
19:03:53.950 SEVERE: [25]
impl.protocol.sip.ProtocolProviderServiceSipImpl.register().349 No address
found for ProtocolProviderServiceSipImpl(1010@my.domain.com (SIP))
19:03:53.950 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE CHANGE
ProtocolProviderServiceSipImpl(1010@my.domain.com (SIP)) ->
RegistrationStateChangeEvent[ oldState=Registering;
newState=RegistrationState=Connection Failed; reasonCode=8; reason=Invalid
or inaccessible server address.]

On Wed, Sep 10, 2014 at 7:58 PM, Paweł Domas <pawel.domas@jitsi.org> > wrote:

Hi,

On Wed, Sep 10, 2014 at 8:53 PM, Peter Villeneuve <petervnv1@gmail.com> >> wrote:
> Thanks Pawel.
>
> Unfortunately it's still not working.
> I added net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT=5060 and
> net.java.sip.communicator.SIP_PREFERRED_SECURE_PORT=5061 to the
> sip-communicator.properties file and I still get that error starting
the SIP
> stack.
>
> Are there other properties I have to set anywhere else? I just want the
> JAIN-SIP stack to register on localhost, with TLS on port 5061, but I
can't
> manage to do that.
> I installed jigasi from source. Perhaps I should try the debian package
> instead to see if that changes anything.
>
> Ideas, thoughts?

Does it run on another machine ? What happens if you specify other
ports than 5060 and 5061 ? Maybe it's a permission problem and Jigasi
is not allowed to bind ?

Regards,
Pawel

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#17

Hi,

Hi Pawel,

Me again. Still can't get this to work. I think the problem lies in the
server address that jigasi tries to connect to. I see that changing the
SIP_PREFERRED_SECURE_PORT=5062 works, and my guess that
SIP_PREFERRED_TRANSPORT=TLS also seems to work fine since JAIN-SIP seems to
correctly interpret them as you can see below. Unfortunately it is still not
working, probably because of the ipv6 address ::0 it is trying to use. I
have set my SIP proxy to listen on 127.0.0.1 and port 5062 using TLS, but I
can't figure out how to force jigasi to register on 127.0.0.1 instead of
::0. I tried setting SIP_PREFERRED_SERVER_ADDRESS=127.0.1.1 but that doesn't
seem to work either.

Any ideas?

There is no such property as SIP_PREFERRED_SERVER_ADDRESS. Currently
Jitsi binds on "any" address which corresponds to ::0 in your case.
You would have to modify
net.java.sip.communicator.impl.protocol.sip.SipStackSharing line 327
to change local address.

Regards,
Pawel

···

On Sat, Sep 13, 2014 at 6:28 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:


#18

Just guessing now but maybe start java with
"-Djava.net.preferIPv4Stack=true" could help.

Cheers,
Markus

···

On 2014-09-13 18:28, Peter Villeneuve wrote:

Hi Pawel,

Me again. Still can't get this to work. I think the problem lies in the
server address that jigasi tries to connect to. I see that changing
the SIP_PREFERRED_SECURE_PORT=5062 works, and my guess
that SIP_PREFERRED_TRANSPORT=TLS also seems to work fine since JAIN-SIP
seems to correctly interpret them as you can see below. Unfortunately it
is still not working, probably because of the ipv6 address ::0 it is
trying to use. I have set my SIP proxy to listen on 127.0.0.1 and port
5062 using TLS, but I can't figure out how to force jigasi to register
on 127.0.0.1 instead of ::0. I tried setting
SIP_PREFERRED_SERVER_ADDRESS=127.0.1.1 but that doesn't seem to work either.

Any ideas?

Thanks

16:19:20.304 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122
Error from the JAIN-SIP stack: Invalid argument address = ::0 port =
5062 transport = TLS
16:19:20.354 SEVERE: [25]
impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress().2607
Cannot send register!

On Wed, Sep 10, 2014 at 8:10 PM, Peter Villeneuve <petervnv1@gmail.com > <mailto:petervnv1@gmail.com>> wrote:

    Getting closer to finding the source of the problem, I think.
    I changed SIP_PREFERRED_CLEAR_PORT=5060 to 5080
    and SIP_PREFERRED_SECURE_PORT=5061 to 5081.
    You can see it trying to connect to 5080, but using TCP. But I want
    it to connect via TLS to 5061. It seems 5081 did nothing.

    Sorry for the long logs, but there maybe a clue there that I missed
    and you can spot.

    Is there a net.java.sip.communicator.SIP_PROXY_PORT=5061 or
    something similar I have to set? How about setting the TLS transport?

    And yes, sip proxy and jigasi are on the same server.

    Cheers

    19:03:51.896 INFO: [25]
    org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE
    CHANGE ProtocolProviderServiceSipImpl(1010@my.domain.com
    <mailto:1010@my.domain.com> (SIP)) -> RegistrationStateChangeEvent[
    oldState=Unregistered; newState=RegistrationState=Registering;
    reasonCode=-1; reason=null]
    19:03:51.936 SEVERE: [25]
    impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders().1238
    Unable to create a via header for port 5080
    java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at
    java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
    at
    java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
    at
    java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
    at java.net.Socket.connect(Socket.java:579)
    at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
    at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
    at
    sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
    at
    net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
    at
    gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
    at
    gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
    at
    net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
    at
    net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
    at
    net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
    at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
    19:03:51.937 SEVERE: [25]
    impl.protocol.sip.SipRegistrarConnection.register().282 Failed to
    create a Register request.
    net.java.sip.communicator.service.protocol.OperationFailedException:
    Unable to create a via header for port 5080
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1242)
    at
    net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
    at
    net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
    at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
    Caused by: java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at
    java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
    at
    java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
    at
    java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
    at java.net.Socket.connect(Socket.java:579)
    at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
    at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
    at
    sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
    at
    net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
    at
    gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
    at
    gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
    at
    net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
    ... 5 more
    19:03:51.939 INFO: [25]
    org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE
    CHANGE ProtocolProviderServiceSipImpl(1010@my.domain.com
    <mailto:1010@my.domain.com> (SIP)) -> RegistrationStateChangeEvent[
    oldState=Registering; newState=RegistrationState=Connection Failed;
    reasonCode=6; reason=Unable to create a via header for port 5080]
    19:03:51.946 INFO: [25] impl.protocol.sip.SipLogger.logInfo().185
    Info from the JAIN-SIP stack: the sip stack timer
    gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
    19:03:52.946 INFO: [25] impl.protocol.sip.SipLogger.logInfo().185
    Info from the JAIN-SIP stack: the sip stack timer
    gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
    19:03:53.949 SEVERE: [25]
    impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress().2607
    Cannot send register!
    net.java.sip.communicator.service.protocol.OperationFailedException:
    Unable to create a via header for port 5080
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1242)
    at
    net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
    at
    net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
    at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
    Caused by: java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at
    java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
    at
    java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
    at
    java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
    at java.net.Socket.connect(Socket.java:579)
    at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
    at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
    at
    sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
    at
    net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
    at
    gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
    at
    gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
    at
    net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
    at
    net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
    ... 5 more
    19:03:53.950 SEVERE: [25]
    impl.protocol.sip.ProtocolProviderServiceSipImpl.register().349 No
    address found for ProtocolProviderServiceSipImpl(1010@my.domain.com
    <mailto:1010@my.domain.com> (SIP))
    19:03:53.950 INFO: [25]
    org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE
    CHANGE ProtocolProviderServiceSipImpl(1010@my.domain.com
    <mailto:1010@my.domain.com> (SIP)) -> RegistrationStateChangeEvent[
    oldState=Registering; newState=RegistrationState=Connection Failed;
    reasonCode=8; reason=Invalid or inaccessible server address.]

    On Wed, Sep 10, 2014 at 7:58 PM, Paweł Domas <pawel.domas@jitsi.org > <mailto:pawel.domas@jitsi.org>> wrote:

        Hi,

        On Wed, Sep 10, 2014 at 8:53 PM, Peter Villeneuve > <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> wrote:
        > Thanks Pawel.
        >
        > Unfortunately it's still not working.
        > I added net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT=5060 and
        > net.java.sip.communicator.SIP_PREFERRED_SECURE_PORT=5061 to the
        > sip-communicator.properties file and I still get that error starting the SIP
        > stack.
        >
        > Are there other properties I have to set anywhere else? I just want the
        > JAIN-SIP stack to register on localhost, with TLS on port 5061, but I can't
        > manage to do that.
        > I installed jigasi from source. Perhaps I should try the debian package
        > instead to see if that changes anything.
        >
        > Ideas, thoughts?

        Does it run on another machine ? What happens if you specify other
        ports than 5060 and 5061 ? Maybe it's a permission problem and
        Jigasi
        is not allowed to bind ?

        Regards,
        Pawel

        _______________________________________________
        dev mailing list
        dev@jitsi.org <mailto:dev@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#19

Thanks for the help guys.

I tried Markus's tip and now it tries to bind using ipv4, however it still
isn't working.

14:39:56.203 WARNING: [16] impl.protocol.sip.SipLogger.logWarning().174
Warning from the JAIN-SIP stackusing default tls security policy
14:39:56.219 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info from
the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
14:39:56.490 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122 Error
from the JAIN-SIP stack: Invalid argument address = 0.0.0.0 port = 5061
transport = TLS
14:39:56.931 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE CHANGE
ProtocolProviderServiceSipImpl(5000@domain.com (SIP)) ->
RegistrationStateChangeEvent[ oldState=Unregistered;
newState=RegistrationState=Registering; reasonCode=-1; reason=null]
14:39:57.944 INFO: [38]
org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE CHANGE
ProtocolProviderServiceSipImpl(5000@domain.com (SIP)) ->
RegistrationStateChangeEvent[ oldState=Registering;
newState=RegistrationState=Registered; reasonCode=-1; reason=null]

I also tried this time to have jigasi register on another remote SIP proxy (
domain.com) to rule out any problems with the SIP proxy on the same host as
jigasi.
I also went back to the defaults from jigasi's git in
sip-communicator.properties and only changed the details to login to the
remote SIP proxy. Still, it isn't working as you can see in the logs.

I noticed in the pcap capture that jigasi does a DNS SRV lookup for the
remote SIP proxy, and gets the proper response back (SIPS only), so it does
seem to recognize my account details, but inexplicably it fails to register.

I'm running jigasi.sh as root, so there shouldn't be any permissions issues.

I'm running out of ideas and things to try. Has anyone else on the list
managed to get jigasi running besides the jitsi devs?

I must be doing something wrong but I cannot understand what. Is there a
specific version of JRE that has been confirmed to work with jigasi and
debian 7? I'm running OpenJDK java version 1.7.0_65 on Debian 7 amd64.

Cheers

···

On Sun, Sep 14, 2014 at 3:55 PM, Markus Kilås <subjunctive.post@gmail.com> wrote:

Just guessing now but maybe start java with
"-Djava.net.preferIPv4Stack=true" could help.

Cheers,
Markus

On 2014-09-13 18:28, Peter Villeneuve wrote:
> Hi Pawel,
>
> Me again. Still can't get this to work. I think the problem lies in the
> server address that jigasi tries to connect to. I see that changing
> the SIP_PREFERRED_SECURE_PORT=5062 works, and my guess
> that SIP_PREFERRED_TRANSPORT=TLS also seems to work fine since JAIN-SIP
> seems to correctly interpret them as you can see below. Unfortunately it
> is still not working, probably because of the ipv6 address ::0 it is
> trying to use. I have set my SIP proxy to listen on 127.0.0.1 and port
> 5062 using TLS, but I can't figure out how to force jigasi to register
> on 127.0.0.1 instead of ::0. I tried setting
> SIP_PREFERRED_SERVER_ADDRESS=127.0.1.1 but that doesn't seem to work
either.
>
> Any ideas?
>
> Thanks
>
>
> 16:19:20.304 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122
> Error from the JAIN-SIP stack: Invalid argument address = ::0 port =
> 5062 transport = TLS
> 16:19:20.354 SEVERE: [25]
>
impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress().2607
> Cannot send register!
>
> On Wed, Sep 10, 2014 at 8:10 PM, Peter Villeneuve <petervnv1@gmail.com > > <mailto:petervnv1@gmail.com>> wrote:
>
> Getting closer to finding the source of the problem, I think.
> I changed SIP_PREFERRED_CLEAR_PORT=5060 to 5080
> and SIP_PREFERRED_SECURE_PORT=5061 to 5081.
> You can see it trying to connect to 5080, but using TCP. But I want
> it to connect via TLS to 5061. It seems 5081 did nothing.
>
> Sorry for the long logs, but there maybe a clue there that I missed
> and you can spot.
>
> Is there a net.java.sip.communicator.SIP_PROXY_PORT=5061 or
> something similar I have to set? How about setting the TLS transport?
>
> And yes, sip proxy and jigasi are on the same server.
>
> Cheers
>
>
> 19:03:51.896 INFO: [25]
> org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE
> CHANGE ProtocolProviderServiceSipImpl(1010@my.domain.com
> <mailto:1010@my.domain.com> (SIP)) -> RegistrationStateChangeEvent[
> oldState=Unregistered; newState=RegistrationState=Registering;
> reasonCode=-1; reason=null]
> 19:03:51.936 SEVERE: [25]
>
impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders().1238
> Unable to create a via header for port 5080
> java.net.ConnectException: Connection refused
> at java.net.PlainSocketImpl.socketConnect(Native Method)
> at
>
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
> at
>
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
> at
>
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
> at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
> at java.net.Socket.connect(Socket.java:579)
> at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
> at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
> at
>
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
> at
>
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
> at
>
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
> at
>
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
> at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
> 19:03:51.937 SEVERE: [25]
> impl.protocol.sip.SipRegistrarConnection.register().282 Failed to
> create a Register request.
> net.java.sip.communicator.service.protocol.OperationFailedException:
> Unable to create a via header for port 5080
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1242)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
> at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
> Caused by: java.net.ConnectException: Connection refused
> at java.net.PlainSocketImpl.socketConnect(Native Method)
> at
>
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
> at
>
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
> at
>
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
> at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
> at java.net.Socket.connect(Socket.java:579)
> at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
> at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
> at
>
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
> at
>
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
> at
>
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
> at
>
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
> ... 5 more
> 19:03:51.939 INFO: [25]
> org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE
> CHANGE ProtocolProviderServiceSipImpl(1010@my.domain.com
> <mailto:1010@my.domain.com> (SIP)) -> RegistrationStateChangeEvent[
> oldState=Registering; newState=RegistrationState=Connection Failed;
> reasonCode=6; reason=Unable to create a via header for port 5080]
> 19:03:51.946 INFO: [25] impl.protocol.sip.SipLogger.logInfo().185
> Info from the JAIN-SIP stack: the sip stack timer
> gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
> 19:03:52.946 INFO: [25] impl.protocol.sip.SipLogger.logInfo().185
> Info from the JAIN-SIP stack: the sip stack timer
> gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
> 19:03:53.949 SEVERE: [25]
>
impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress().2607
> Cannot send register!
> net.java.sip.communicator.service.protocol.OperationFailedException:
> Unable to create a via header for port 5080
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1242)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
> at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
> Caused by: java.net.ConnectException: Connection refused
> at java.net.PlainSocketImpl.socketConnect(Native Method)
> at
>
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
> at
>
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
> at
>
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
> at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
> at java.net.Socket.connect(Socket.java:579)
> at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
> at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
> at
>
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
> at
>
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
> at
>
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
> at
>
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
> ... 5 more
> 19:03:53.950 SEVERE: [25]
> impl.protocol.sip.ProtocolProviderServiceSipImpl.register().349 No
> address found for ProtocolProviderServiceSipImpl(1010@my.domain.com
> <mailto:1010@my.domain.com> (SIP))
> 19:03:53.950 INFO: [25]
> org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE
> CHANGE ProtocolProviderServiceSipImpl(1010@my.domain.com
> <mailto:1010@my.domain.com> (SIP)) -> RegistrationStateChangeEvent[
> oldState=Registering; newState=RegistrationState=Connection Failed;
> reasonCode=8; reason=Invalid or inaccessible server address.]
>
> On Wed, Sep 10, 2014 at 7:58 PM, Paweł Domas <pawel.domas@jitsi.org > > <mailto:pawel.domas@jitsi.org>> wrote:
>
> Hi,
>
> On Wed, Sep 10, 2014 at 8:53 PM, Peter Villeneuve > > <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> wrote:
> > Thanks Pawel.
> >
> > Unfortunately it's still not working.
> > I added
net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT=5060 and
> > net.java.sip.communicator.SIP_PREFERRED_SECURE_PORT=5061 to the
> > sip-communicator.properties file and I still get that error
starting the SIP
> > stack.
> >
> > Are there other properties I have to set anywhere else? I just
want the
> > JAIN-SIP stack to register on localhost, with TLS on port
5061, but I can't
> > manage to do that.
> > I installed jigasi from source. Perhaps I should try the
debian package
> > instead to see if that changes anything.
> >
> > Ideas, thoughts?
>
> Does it run on another machine ? What happens if you specify
other
> ports than 5060 and 5061 ? Maybe it's a permission problem and
> Jigasi
> is not allowed to bind ?
>
> Regards,
> Pawel
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org <mailto:dev@jitsi.org>
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#20

Bump,

Any help?

Thanks

···

On Mon, Sep 15, 2014 at 3:55 PM, Peter Villeneuve <petervnv1@gmail.com> wrote:

Thanks for the help guys.

I tried Markus's tip and now it tries to bind using ipv4, however it still
isn't working.

14:39:56.203 WARNING: [16] impl.protocol.sip.SipLogger.logWarning().174
Warning from the JAIN-SIP stackusing default tls security policy
14:39:56.219 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
14:39:56.490 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122 Error
from the JAIN-SIP stack: Invalid argument address = 0.0.0.0 port = 5061
transport = TLS
14:39:56.931 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE CHANGE
ProtocolProviderServiceSipImpl(5000@domain.com (SIP)) ->
RegistrationStateChangeEvent[ oldState=Unregistered;
newState=RegistrationState=Registering; reasonCode=-1; reason=null]
14:39:57.944 INFO: [38]
org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE CHANGE
ProtocolProviderServiceSipImpl(5000@domain.com (SIP)) ->
RegistrationStateChangeEvent[ oldState=Registering;
newState=RegistrationState=Registered; reasonCode=-1; reason=null]

I also tried this time to have jigasi register on another remote SIP proxy
(domain.com) to rule out any problems with the SIP proxy on the same host
as jigasi.
I also went back to the defaults from jigasi's git in
sip-communicator.properties and only changed the details to login to the
remote SIP proxy. Still, it isn't working as you can see in the logs.

I noticed in the pcap capture that jigasi does a DNS SRV lookup for the
remote SIP proxy, and gets the proper response back (SIPS only), so it does
seem to recognize my account details, but inexplicably it fails to register.

I'm running jigasi.sh as root, so there shouldn't be any permissions
issues.

I'm running out of ideas and things to try. Has anyone else on the list
managed to get jigasi running besides the jitsi devs?

I must be doing something wrong but I cannot understand what. Is there a
specific version of JRE that has been confirmed to work with jigasi and
debian 7? I'm running OpenJDK java version 1.7.0_65 on Debian 7 amd64.

Cheers

On Sun, Sep 14, 2014 at 3:55 PM, Markus Kilås <subjunctive.post@gmail.com> > wrote:

Just guessing now but maybe start java with
"-Djava.net.preferIPv4Stack=true" could help.

Cheers,
Markus

On 2014-09-13 18:28, Peter Villeneuve wrote:
> Hi Pawel,
>
> Me again. Still can't get this to work. I think the problem lies in the
> server address that jigasi tries to connect to. I see that changing
> the SIP_PREFERRED_SECURE_PORT=5062 works, and my guess
> that SIP_PREFERRED_TRANSPORT=TLS also seems to work fine since JAIN-SIP
> seems to correctly interpret them as you can see below. Unfortunately it
> is still not working, probably because of the ipv6 address ::0 it is
> trying to use. I have set my SIP proxy to listen on 127.0.0.1 and port
> 5062 using TLS, but I can't figure out how to force jigasi to register
> on 127.0.0.1 instead of ::0. I tried setting
> SIP_PREFERRED_SERVER_ADDRESS=127.0.1.1 but that doesn't seem to work
either.
>
> Any ideas?
>
> Thanks
>
>
> 16:19:20.304 SEVERE: [25] impl.protocol.sip.SipLogger.logError().122
> Error from the JAIN-SIP stack: Invalid argument address = ::0 port =
> 5062 transport = TLS
> 16:19:20.354 SEVERE: [25]
>
impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress().2607
> Cannot send register!
>
> On Wed, Sep 10, 2014 at 8:10 PM, Peter Villeneuve <petervnv1@gmail.com >> > <mailto:petervnv1@gmail.com>> wrote:
>
> Getting closer to finding the source of the problem, I think.
> I changed SIP_PREFERRED_CLEAR_PORT=5060 to 5080
> and SIP_PREFERRED_SECURE_PORT=5061 to 5081.
> You can see it trying to connect to 5080, but using TCP. But I want
> it to connect via TLS to 5061. It seems 5081 did nothing.
>
> Sorry for the long logs, but there maybe a clue there that I missed
> and you can spot.
>
> Is there a net.java.sip.communicator.SIP_PROXY_PORT=5061 or
> something similar I have to set? How about setting the TLS
transport?
>
> And yes, sip proxy and jigasi are on the same server.
>
> Cheers
>
>
> 19:03:51.896 INFO: [25]
> org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE
> CHANGE ProtocolProviderServiceSipImpl(1010@my.domain.com
> <mailto:1010@my.domain.com> (SIP)) -> RegistrationStateChangeEvent[
> oldState=Unregistered; newState=RegistrationState=Registering;
> reasonCode=-1; reason=null]
> 19:03:51.936 SEVERE: [25]
>
impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders().1238
> Unable to create a via header for port 5080
> java.net.ConnectException: Connection refused
> at java.net.PlainSocketImpl.socketConnect(Native Method)
> at
>
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
> at
>
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
> at
>
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
> at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
> at java.net.Socket.connect(Socket.java:579)
> at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
> at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
> at
>
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
> at
>
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
> at
>
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
> at
>
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
> at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
> 19:03:51.937 SEVERE: [25]
> impl.protocol.sip.SipRegistrarConnection.register().282 Failed to
> create a Register request.
> net.java.sip.communicator.service.protocol.OperationFailedException:
> Unable to create a via header for port 5080
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1242)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
> at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
> Caused by: java.net.ConnectException: Connection refused
> at java.net.PlainSocketImpl.socketConnect(Native Method)
> at
>
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
> at
>
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
> at
>
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
> at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
> at java.net.Socket.connect(Socket.java:579)
> at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
> at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
> at
>
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
> at
>
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
> at
>
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
> at
>
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
> ... 5 more
> 19:03:51.939 INFO: [25]
> org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE
> CHANGE ProtocolProviderServiceSipImpl(1010@my.domain.com
> <mailto:1010@my.domain.com> (SIP)) -> RegistrationStateChangeEvent[
> oldState=Registering; newState=RegistrationState=Connection Failed;
> reasonCode=6; reason=Unable to create a via header for port 5080]
> 19:03:51.946 INFO: [25] impl.protocol.sip.SipLogger.logInfo().185
> Info from the JAIN-SIP stack: the sip stack timer
> gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
> 19:03:52.946 INFO: [25] impl.protocol.sip.SipLogger.logInfo().185
> Info from the JAIN-SIP stack: the sip stack timer
> gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
> 19:03:53.949 SEVERE: [25]
>
impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress().2607
> Cannot send register!
> net.java.sip.communicator.service.protocol.OperationFailedException:
> Unable to create a via header for port 5080
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1242)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipMessageFactory.createRegisterRequest(SipMessageFactory.java:1079)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipRegistrarConnection.register(SipRegistrarConnection.java:257)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.registerUsingNextAddress(ProtocolProviderServiceSipImpl.java:2590)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.register(ProtocolProviderServiceSipImpl.java:347)
> at org.jitsi.jigasi.RegisterThread.run(RegisterThread.java:38)
> Caused by: java.net.ConnectException: Connection refused
> at java.net.PlainSocketImpl.socketConnect(Native Method)
> at
>
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
> at
>
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
> at
>
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
> at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
> at java.net.Socket.connect(Socket.java:579)
> at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
> at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:474)
> at
>
sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:155)
> at
>
net.java.sip.communicator.impl.protocol.sip.net.SslNetworkLayer.createSSLSocket(SslNetworkLayer.java:281)
> at
>
gov.nist.javax.sip.stack.IOHandler.getLocalAddressForTlsDst(IOHandler.java:199)
> at
>
gov.nist.javax.sip.stack.SIPTransactionStack.getLocalAddressForTlsDst(SIPTransactionStack.java:643)
> at
>
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.getLocalAddressForDestination(SipStackSharing.java:1155)
> at
>
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.getLocalViaHeaders(ProtocolProviderServiceSipImpl.java:1195)
> ... 5 more
> 19:03:53.950 SEVERE: [25]
> impl.protocol.sip.ProtocolProviderServiceSipImpl.register().349 No
> address found for ProtocolProviderServiceSipImpl(1010@my.domain.com
> <mailto:1010@my.domain.com> (SIP))
> 19:03:53.950 INFO: [25]
> org.jitsi.jigasi.SipGateway.registrationStateChanged().151 REG STATE
> CHANGE ProtocolProviderServiceSipImpl(1010@my.domain.com
> <mailto:1010@my.domain.com> (SIP)) -> RegistrationStateChangeEvent[
> oldState=Registering; newState=RegistrationState=Connection Failed;
> reasonCode=8; reason=Invalid or inaccessible server address.]
>
> On Wed, Sep 10, 2014 at 7:58 PM, Paweł Domas <pawel.domas@jitsi.org >> > <mailto:pawel.domas@jitsi.org>> wrote:
>
> Hi,
>
> On Wed, Sep 10, 2014 at 8:53 PM, Peter Villeneuve >> > <petervnv1@gmail.com <mailto:petervnv1@gmail.com>> wrote:
> > Thanks Pawel.
> >
> > Unfortunately it's still not working.
> > I added
net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT=5060 and
> > net.java.sip.communicator.SIP_PREFERRED_SECURE_PORT=5061 to
the
> > sip-communicator.properties file and I still get that error
starting the SIP
> > stack.
> >
> > Are there other properties I have to set anywhere else? I
just want the
> > JAIN-SIP stack to register on localhost, with TLS on port
5061, but I can't
> > manage to do that.
> > I installed jigasi from source. Perhaps I should try the
debian package
> > instead to see if that changes anything.
> >
> > Ideas, thoughts?
>
> Does it run on another machine ? What happens if you specify
other
> ports than 5060 and 5061 ? Maybe it's a permission problem and
> Jigasi
> is not allowed to bind ?
>
> Regards,
> Pawel
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org <mailto:dev@jitsi.org>
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev