[jitsi-dev] [jigasi] button not working -> NPE


#1

Hi,

since a few days I have an issue with my jigasi configuration.

My problem is that the button bar get stucked after I clicked on the jigasi button (phone).
I also found the following NPE in the jigasi log but I'm not sure if this is related.

2016-01-15 22:12:19.461 SEVERE: [10] org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to register custom Renderer org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with JMF.
java.lang.IllegalStateException: audioSystem
         at org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:155)
         at org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:135)
         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
         at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
         at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
         at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
         at java.lang.Class.newInstance(Class.java:383)
         at org.jitsi.impl.neomedia.device.DeviceConfiguration.registerCustomRenderers(DeviceConfiguration.java:1046)
         at org.jitsi.impl.neomedia.device.DeviceConfiguration.<init>(DeviceConfiguration.java:365)
         at org.jitsi.impl.neomedia.MediaServiceImpl.<init>(MediaServiceImpl.java:159)
         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
         at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
         at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
         at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
         at java.lang.Class.newInstance(Class.java:383)
         at org.jitsi.impl.libjitsi.LibJitsiImpl.getService(LibJitsiImpl.java:151)
         at org.jitsi.impl.libjitsi.LibJitsiOSGiImpl.getService(LibJitsiOSGiImpl.java:95)
         at org.jitsi.service.libjitsi.LibJitsi.invokeGetServiceOnImpl(LibJitsi.java:172)
         at org.jitsi.service.libjitsi.LibJitsi.getMediaService(LibJitsi.java:124)
         at net.java.sip.communicator.impl.neomedia.NeomediaActivator.start(NeomediaActivator.java:391)
         at org.jitsi.impl.osgi.framework.BundleImpl.start(Unknown Source)
         at org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(Unknown Source)
         at org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(Unknown Source)
         at org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(Unknown Source)
         at org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(Unknown Source)
         at org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(Unknown Source)
2016-01-15 22:12:19.501 INFO: [10] impl.neomedia.NeomediaActivator.start().542 Audio Notifier Service ...[REGISTERED]
2016-01-15 22:12:19.511 INFO: [10] impl.version.VersionActivator.start() Jitsi Version: Jitsi 2.9.0.build.by.SVN
2016-01-15 22:12:19.523 FINE: [10] plugin.reconnectplugin.ReconnectPluginActivator.start().249 Found 0 already installed providers.
2016-01-15 22:12:19.536 SEVERE: [22] util.UtilActivator.uncaughtException().119 An uncaught exception occurred in thread=Thread[Thread-11,5,main] and message was: null
java.lang.NullPointerException
         at org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:276)

Any ideas or something else I need to provide?

Best regards
Christoph


#2

These are normal. You need to check the browser console for some
error. Or if there is nothing, check for anything in jicofo.

···

On Fri, Jan 15, 2016 at 3:21 PM, <jitsi@timmi.org> wrote:

Hi,

since a few days I have an issue with my jigasi configuration.

My problem is that the button bar get stucked after I clicked on the jigasi
button (phone).
I also found the following NPE in the jigasi log but I'm not sure if this is
related.

2016-01-15 22:12:19.461 SEVERE: [10]
org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
register custom Renderer
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with
JMF.
java.lang.IllegalStateException: audioSystem
        at
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:155)
        at
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:135)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
        at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
        at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
        at java.lang.Class.newInstance(Class.java:383)
        at
org.jitsi.impl.neomedia.device.DeviceConfiguration.registerCustomRenderers(DeviceConfiguration.java:1046)
        at
org.jitsi.impl.neomedia.device.DeviceConfiguration.<init>(DeviceConfiguration.java:365)
        at
org.jitsi.impl.neomedia.MediaServiceImpl.<init>(MediaServiceImpl.java:159)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
        at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
        at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
        at java.lang.Class.newInstance(Class.java:383)
        at
org.jitsi.impl.libjitsi.LibJitsiImpl.getService(LibJitsiImpl.java:151)
        at
org.jitsi.impl.libjitsi.LibJitsiOSGiImpl.getService(LibJitsiOSGiImpl.java:95)
        at
org.jitsi.service.libjitsi.LibJitsi.invokeGetServiceOnImpl(LibJitsi.java:172)
        at
org.jitsi.service.libjitsi.LibJitsi.getMediaService(LibJitsi.java:124)
        at
net.java.sip.communicator.impl.neomedia.NeomediaActivator.start(NeomediaActivator.java:391)
        at org.jitsi.impl.osgi.framework.BundleImpl.start(Unknown Source)
        at
org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(Unknown
Source)
        at
org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(Unknown
Source)
        at org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(Unknown
Source)
        at org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(Unknown
Source)
        at org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(Unknown Source)
2016-01-15 22:12:19.501 INFO: [10]
impl.neomedia.NeomediaActivator.start().542 Audio Notifier Service
...[REGISTERED]
2016-01-15 22:12:19.511 INFO: [10] impl.version.VersionActivator.start()
Jitsi Version: Jitsi 2.9.0.build.by.SVN
2016-01-15 22:12:19.523 FINE: [10]
plugin.reconnectplugin.ReconnectPluginActivator.start().249 Found 0 already
installed providers.
2016-01-15 22:12:19.536 SEVERE: [22]
util.UtilActivator.uncaughtException().119 An uncaught exception occurred in
thread=Thread[Thread-11,5,main] and message was: null
java.lang.NullPointerException
        at
org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:276)

Any ideas or something else I need to provide?

Best regards
Christoph

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi Damian,

thank you for the quick reply.
I can't see any issue in the jicofo log.

Firebug is showing the following while clicking on the phone:
TypeError: t.jqib.on(...).on(...).on is not a function ->>> app.bun...s?v=785 (Row 16, Column 19841)

libs/app.bundle.min.js?v=785

Does this help?

Best regards
Chrisotph

···

Am 15.01.2016 um 22:28 schrieb Damian Minkov:

These are normal. You need to check the browser console for some
error. Or if there is nothing, check for anything in jicofo.

On Fri, Jan 15, 2016 at 3:21 PM, <jitsi@timmi.org> wrote:

Hi,

since a few days I have an issue with my jigasi configuration.

My problem is that the button bar get stucked after I clicked on the jigasi
button (phone).
I also found the following NPE in the jigasi log but I'm not sure if this is
related.

2016-01-15 22:12:19.461 SEVERE: [10]
org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
register custom Renderer
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with
JMF.
java.lang.IllegalStateException: audioSystem
         at
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:155)
         at
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:135)
         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
         at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
         at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
         at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
         at java.lang.Class.newInstance(Class.java:383)
         at
org.jitsi.impl.neomedia.device.DeviceConfiguration.registerCustomRenderers(DeviceConfiguration.java:1046)
         at
org.jitsi.impl.neomedia.device.DeviceConfiguration.<init>(DeviceConfiguration.java:365)
         at
org.jitsi.impl.neomedia.MediaServiceImpl.<init>(MediaServiceImpl.java:159)
         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
         at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
         at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
         at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
         at java.lang.Class.newInstance(Class.java:383)
         at
org.jitsi.impl.libjitsi.LibJitsiImpl.getService(LibJitsiImpl.java:151)
         at
org.jitsi.impl.libjitsi.LibJitsiOSGiImpl.getService(LibJitsiOSGiImpl.java:95)
         at
org.jitsi.service.libjitsi.LibJitsi.invokeGetServiceOnImpl(LibJitsi.java:172)
         at
org.jitsi.service.libjitsi.LibJitsi.getMediaService(LibJitsi.java:124)
         at
net.java.sip.communicator.impl.neomedia.NeomediaActivator.start(NeomediaActivator.java:391)
         at org.jitsi.impl.osgi.framework.BundleImpl.start(Unknown Source)
         at
org.jitsi.impl.osgi.framework.launch.FrameworkImpl.startLevelChanged(Unknown
Source)
         at
org.jitsi.impl.osgi.framework.startlevel.FrameworkStartLevelImpl$Command.run(Unknown
Source)
         at org.jitsi.impl.osgi.framework.AsyncExecutor.runInThread(Unknown
Source)
         at org.jitsi.impl.osgi.framework.AsyncExecutor.access$000(Unknown
Source)
         at org.jitsi.impl.osgi.framework.AsyncExecutor$1.run(Unknown Source)
2016-01-15 22:12:19.501 INFO: [10]
impl.neomedia.NeomediaActivator.start().542 Audio Notifier Service
...[REGISTERED]
2016-01-15 22:12:19.511 INFO: [10] impl.version.VersionActivator.start()
Jitsi Version: Jitsi 2.9.0.build.by.SVN
2016-01-15 22:12:19.523 FINE: [10]
plugin.reconnectplugin.ReconnectPluginActivator.start().249 Found 0 already
installed providers.
2016-01-15 22:12:19.536 SEVERE: [22]
util.UtilActivator.uncaughtException().119 An uncaught exception occurred in
thread=Thread[Thread-11,5,main] and message was: null
java.lang.NullPointerException
         at
org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:276)

Any ideas or something else I need to provide?

Best regards
Christoph

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev