[jitsi-dev] Jicofo XMPP interface


#1

Hi all,

I'm developing an application which talks directly with jicofo by the XMPP/bosh interface. This application intends to do exactly the same thing that jitsi-meet. So, I'm implementing the caps, muc, discovery and jingle xmpp extensions.

Now I'm stucked in the following problem: When I send a jingle session-accept, jicofo is returning a service-unavailable msg error. Someone has any idea of what is happening, or what I can do to receive an ack?

Jingle session-accept msg:

<iq xmlns="jabber:client" to="55a7b133f505063475ac5f57@jitsi.example.com/focus" type="set" id="5:sendIQ">

  <jingle xmlns="urn:xmpp:jingle:1" action="session-accept" initiator="55a7b133f505063475ac5f57@jitsi.example.com/focus" responder="f946d0a3-65ed-46b2-885d-c861f7f95734@jitsi.example.com/96094434-2df8-4887-b80e-767efd2c40a3" sid="cbkvrsdh2m90n">

    <group xmlns="urn:xmpp:jingle:apps:grouping:0" semantics="BUNDLE">

      <content name="audio"/>

      <content name="video"/>

      <content name="data"/>

    </group>

    <content creator="responder" name="audio" senders="both">

      <description xmlns="urn:xmpp:jingle:apps:rtp:1" media="audio" ssrc="2322685060">

        <payload-type id="111" name="opus" clockrate="48000" channels="2">

          <parameter name="minptime" value="10"/>

          <parameter name="useinbandfec" value="1"/>

        </payload-type>

        <payload-type id="103" name="ISAC" clockrate="16000" channels="1"/>

        <payload-type id="104" name="ISAC" clockrate="32000" channels="1"/>

        <payload-type id="0" name="PCMU" clockrate="8000" channels="1"/>

        <payload-type id="8" name="PCMA" clockrate="8000" channels="1"/>

        <payload-type id="106" name="CN" clockrate="32000" channels="1"/>

        <payload-type id="105" name="CN" clockrate="16000" channels="1"/>

        <payload-type id="13" name="CN" clockrate="8000" channels="1"/>

        <payload-type id="126" name="telephone-event" clockrate="8000" channels="1"/>

        <source xmlns="urn:xmpp:jingle:apps:rtp:ssma:0" ssrc="2322685060">

          <parameter name="cname" value="c/leQT5QztHIGMMV"/>

          <parameter name="msid" value="xh0cbuxs0sqAJNeIdFZ6QbpZd7q5wIuDzq3i e37f3657-d54c-4292-a835-3a5411b17c6b"/>

          <parameter name="mslabel" value="xh0cbuxs0sqAJNeIdFZ6QbpZd7q5wIuDzq3i"/>

          <parameter name="label" value="e37f3657-d54c-4292-a835-3a5411b17c6b"/>

        </source>

        <rtcp-mux/>

        <rtp-hdrext xmlns="urn:xmpp:jingle:apps:rtp:rtp-hdrext:0" uri="urn:ietf:params:rtp-hdrext:ssrc-audio-level" id="1"/>

      </description>

      <transport xmlns="urn:xmpp:jingle:transports:ice-udp:1" ufrag="/IuQOR9mgPEHMUwW" pwd="oedhudB/EfAGdyfWVEawTUV3">

        <fingerprint xmlns="urn:xmpp:jingle:apps:dtls:0" hash="sha-256" setup="active">DE:C3:45:05:71:F4:37:0C:53:14:00:2E:40:5F:D4:33:C5:EC:76:A1:82:2F:14:55:9E:CA:A8:B2:4C:F5:6B:B0</fingerprint>

      </transport>

    </content>

    <content creator="responder" name="video" senders="both">

      <description xmlns="urn:xmpp:jingle:apps:rtp:1" media="video" ssrc="1929596930">

        <payload-type id="100" name="VP8" clockrate="90000" channels="1">

          <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="ccm" subtype="fir"/>

          <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="nack"/>

          <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="nack" subtype="pli"/>

          <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="goog-remb"/>

        </payload-type>

        <payload-type id="116" name="red" clockrate="90000" channels="1"/>

        <payload-type id="117" name="ulpfec" clockrate="90000" channels="1"/>

        <source xmlns="urn:xmpp:jingle:apps:rtp:ssma:0" ssrc="1929596930">

          <parameter name="cname" value="c/leQT5QztHIGMMV"/>

          <parameter name="msid" value="xh0cbuxs0sqAJNeIdFZ6QbpZd7q5wIuDzq3i a099dc5f-ecd5-4c52-b3fe-faef9e51b6bb"/>

          <parameter name="mslabel" value="xh0cbuxs0sqAJNeIdFZ6QbpZd7q5wIuDzq3i"/>

          <parameter name="label" value="a099dc5f-ecd5-4c52-b3fe-faef9e51b6bb"/>

        </source>

        <rtcp-mux/>

        <rtp-hdrext xmlns="urn:xmpp:jingle:apps:rtp:rtp-hdrext:0" uri="urn:ietf:params:rtp-hdrext:toffset" id="2"/>

        <rtp-hdrext xmlns="urn:xmpp:jingle:apps:rtp:rtp-hdrext:0" uri="http://www.webrtc.org/experiments/rtp-hdrext/abs-send-time" id="3"/>

      </description>

      <transport xmlns="urn:xmpp:jingle:transports:ice-udp:1" ufrag="/IuQOR9mgPEHMUwW" pwd="oedhudB/EfAGdyfWVEawTUV3">

        <fingerprint xmlns="urn:xmpp:jingle:apps:dtls:0" hash="sha-256" setup="active">DE:C3:45:05:71:F4:37:0C:53:14:00:2E:40:5F:D4:33:C5:EC:76:A1:82:2F:14:55:9E:CA:A8:B2:4C:F5:6B:B0</fingerprint>

      </transport>

      <content creator="responder" name="data">

        <transport xmlns="urn:xmpp:jingle:transports:ice-udp:1" ufrag="/IuQOR9mgPEHMUwW" pwd="oedhudB/EfAGdyfWVEawTUV3">

          <sctpmap xmlns="urn:xmpp:jingle:transports:dtls-sctp:1" number="5000" protocol="webrtc-datachannel" streams="1024"/>

          <fingerprint xmlns="urn:xmpp:jingle:apps:dtls:0" hash="sha-256" setup="active">DE:C3:45:05:71:F4:37:0C:53:14:00:2E:40:5F:D4:33:C5:EC:76:A1:82:2F:14:55:9E:CA:A8:B2:4C:F5:6B:B0</fingerprint>

        </transport>

      </content>

    </content>

  </jingle>

</iq>

Jicofo Error:

<body xmlns:stream="http://etherx.jabber.org/streams" xmlns="http://jabber.org/protocol/httpbind" sid="be6ddcc1-6882-4500-8541-b9b776ea61b6">

  <iq xmlns="jabber:client" type="error" to="f946d0a3-65ed-46b2-885d-c861f7f95734@jitsi.example.com/96094434-2df8-4887-b80e-767efd2c40a3" from="55a7b133f505063475ac5f57@jitsi.example.com/focus" id="5:sendIQ">

    <error type="cancel">

      <service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/>

    </error>

  </iq>

</body>

Regards,

Felipe


#2

Hi Pedroni,

You’re sending the IQ to 55a7b133f505063475ac5f57@jitsi.example.com/focus. Are you sure this is correct? This isn’t necessarily wrong, but it is suspicious nonetheless.

Best,
George

···

On 16 Jul 2015, at 9:03, Felipe Pedroni Favoreto wrote:

Hi all,

I'm developing an application which talks directly with jicofo by the XMPP/bosh interface. This application intends to do exactly the same thing that jitsi-meet. So, I'm implementing the caps, muc, discovery and jingle xmpp extensions.

Now I'm stucked in the following problem: When I send a jingle session-accept, jicofo is returning a service-unavailable msg error. Someone has any idea of what is happening, or what I can do to receive an ack?

Jingle session-accept msg:

<iq xmlns="jabber:client" to="55a7b133f505063475ac5f57@jitsi.example.com/focus" type="set" id="5:sendIQ">

<jingle xmlns="urn:xmpp:jingle:1" action="session-accept" initiator="55a7b133f505063475ac5f57@jitsi.example.com/focus" responder="f946d0a3-65ed-46b2-885d-c861f7f95734@jitsi.example.com/96094434-2df8-4887-b80e-767efd2c40a3" sid="cbkvrsdh2m90n">

<group xmlns="urn:xmpp:jingle:apps:grouping:0" semantics="BUNDLE">

   <content name="audio"/>

   <content name="video"/>

   <content name="data"/>

</group>

<content creator="responder" name="audio" senders="both">

   <description xmlns="urn:xmpp:jingle:apps:rtp:1" media="audio" ssrc="2322685060">

     <payload-type id="111" name="opus" clockrate="48000" channels="2">

       <parameter name="minptime" value="10"/>

       <parameter name="useinbandfec" value="1"/>

     </payload-type>

     <payload-type id="103" name="ISAC" clockrate="16000" channels="1"/>

     <payload-type id="104" name="ISAC" clockrate="32000" channels="1"/>

     <payload-type id="0" name="PCMU" clockrate="8000" channels="1"/>

     <payload-type id="8" name="PCMA" clockrate="8000" channels="1"/>

     <payload-type id="106" name="CN" clockrate="32000" channels="1"/>

     <payload-type id="105" name="CN" clockrate="16000" channels="1"/>

     <payload-type id="13" name="CN" clockrate="8000" channels="1"/>

     <payload-type id="126" name="telephone-event" clockrate="8000" channels="1"/>

     <source xmlns="urn:xmpp:jingle:apps:rtp:ssma:0" ssrc="2322685060">

       <parameter name="cname" value="c/leQT5QztHIGMMV"/>

       <parameter name="msid" value="xh0cbuxs0sqAJNeIdFZ6QbpZd7q5wIuDzq3i e37f3657-d54c-4292-a835-3a5411b17c6b"/>

       <parameter name="mslabel" value="xh0cbuxs0sqAJNeIdFZ6QbpZd7q5wIuDzq3i"/>

       <parameter name="label" value="e37f3657-d54c-4292-a835-3a5411b17c6b"/>

     </source>

     <rtcp-mux/>

     <rtp-hdrext xmlns="urn:xmpp:jingle:apps:rtp:rtp-hdrext:0" uri="urn:ietf:params:rtp-hdrext:ssrc-audio-level" id="1"/>

   </description>

   <transport xmlns="urn:xmpp:jingle:transports:ice-udp:1" ufrag="/IuQOR9mgPEHMUwW" pwd="oedhudB/EfAGdyfWVEawTUV3">

     <fingerprint xmlns="urn:xmpp:jingle:apps:dtls:0" hash="sha-256" setup="active">DE:C3:45:05:71:F4:37:0C:53:14:00:2E:40:5F:D4:33:C5:EC:76:A1:82:2F:14:55:9E:CA:A8:B2:4C:F5:6B:B0</fingerprint>

   </transport>

</content>

<content creator="responder" name="video" senders="both">

   <description xmlns="urn:xmpp:jingle:apps:rtp:1" media="video" ssrc="1929596930">

     <payload-type id="100" name="VP8" clockrate="90000" channels="1">

       <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="ccm" subtype="fir"/>

       <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="nack"/>

       <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="nack" subtype="pli"/>

       <rtcp-fb xmlns="urn:xmpp:jingle:apps:rtp:rtcp-fb:0" type="goog-remb"/>

     </payload-type>

     <payload-type id="116" name="red" clockrate="90000" channels="1"/>

     <payload-type id="117" name="ulpfec" clockrate="90000" channels="1"/>

     <source xmlns="urn:xmpp:jingle:apps:rtp:ssma:0" ssrc="1929596930">

       <parameter name="cname" value="c/leQT5QztHIGMMV"/>

       <parameter name="msid" value="xh0cbuxs0sqAJNeIdFZ6QbpZd7q5wIuDzq3i a099dc5f-ecd5-4c52-b3fe-faef9e51b6bb"/>

       <parameter name="mslabel" value="xh0cbuxs0sqAJNeIdFZ6QbpZd7q5wIuDzq3i"/>

       <parameter name="label" value="a099dc5f-ecd5-4c52-b3fe-faef9e51b6bb"/>

     </source>

     <rtcp-mux/>

     <rtp-hdrext xmlns="urn:xmpp:jingle:apps:rtp:rtp-hdrext:0" uri="urn:ietf:params:rtp-hdrext:toffset" id="2"/>

     <rtp-hdrext xmlns="urn:xmpp:jingle:apps:rtp:rtp-hdrext:0" uri="http://www.webrtc.org/experiments/rtp-hdrext/abs-send-time" id="3"/>

   </description>

   <transport xmlns="urn:xmpp:jingle:transports:ice-udp:1" ufrag="/IuQOR9mgPEHMUwW" pwd="oedhudB/EfAGdyfWVEawTUV3">

     <fingerprint xmlns="urn:xmpp:jingle:apps:dtls:0" hash="sha-256" setup="active">DE:C3:45:05:71:F4:37:0C:53:14:00:2E:40:5F:D4:33:C5:EC:76:A1:82:2F:14:55:9E:CA:A8:B2:4C:F5:6B:B0</fingerprint>

   </transport>

   <content creator="responder" name="data">

     <transport xmlns="urn:xmpp:jingle:transports:ice-udp:1" ufrag="/IuQOR9mgPEHMUwW" pwd="oedhudB/EfAGdyfWVEawTUV3">

       <sctpmap xmlns="urn:xmpp:jingle:transports:dtls-sctp:1" number="5000" protocol="webrtc-datachannel" streams="1024"/>

       <fingerprint xmlns="urn:xmpp:jingle:apps:dtls:0" hash="sha-256" setup="active">DE:C3:45:05:71:F4:37:0C:53:14:00:2E:40:5F:D4:33:C5:EC:76:A1:82:2F:14:55:9E:CA:A8:B2:4C:F5:6B:B0</fingerprint>

     </transport>

   </content>

</content>

</jingle>

</iq>

Jicofo Error:

<body xmlns:stream="http://etherx.jabber.org/streams" xmlns="http://jabber.org/protocol/httpbind" sid="be6ddcc1-6882-4500-8541-b9b776ea61b6">

<iq xmlns="jabber:client" type="error" to="f946d0a3-65ed-46b2-885d-c861f7f95734@jitsi.example.com/96094434-2df8-4887-b80e-767efd2c40a3" from="55a7b133f505063475ac5f57@jitsi.example.com/focus" id="5:sendIQ">

<error type="cancel">

   <service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/>

</error>

</iq>

</body>

Regards,

Felipe

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev