[jitsi-dev] Jicofo Ping Time Out


#1

Hi,

What is debug log message from ejabberd when it receives <ping /> request from jicofo?
Also please ensure /etc/ejabberd/ejabberd.yml settings teddy with the settings in /etc/jitsi/jicofo/config:

···

---------
e.g. /etc/ejabberd/ejabberd.yml
  ### jitsi conference service
  -
    port: 5347
    module: ejabberd_service
    access: all
    shaper_rule: fast
    hosts:
      "focus. domain.tld ":
        password: "#1234567!"

--------------
e.g. /etc/jitsi/jicofo/config
# Jitsi Conference Focus settings
# sets the host name of the XMPP server
JICOFO_HOST=localhost

# sets the XMPP domain (default: none)
JICOFO_HOSTNAME domain.tld

# sets the secret used to authenticate as an XMPP component
JICOFO_SECRET=#1234567!

# sets the port to use for the XMPP component connection
JICOFO_PORT=5347

# sets the XMPP domain name to use for XMPP user logins
JICOFO_AUTH_DOMAIN= domain.tld

# sets the username to use for XMPP user logins
JICOFO_AUTH_USER=focus
.....

------------

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of dev-request@jitsi.org
Sent: Tuesday, January 19, 2016 6:58 AM
To: dev@jitsi.org
Subject: dev Digest, Vol 34, Issue 47

Send dev mailing list submissions to
  dev@jitsi.org

To subscribe or unsubscribe via the World Wide Web, visit
  http://lists.jitsi.org/mailman/listinfo/dev
or, via email, send a message with subject or body 'help' to
  dev-request@jitsi.org

You can reach the person managing the list at
  dev-owner@jitsi.org

When replying, please edit your Subject line so it is more specific than "Re: Contents of dev digest..."

Today's Topics:

   1. Jicofo Ping Time Out (cmeng.gm)
   2. Re: Low webcam resolutions selected by default on Google
      Chrome and Firefox (Devin Wilson)
   3. Re: [jitsi-videobridge] Split last n (#122) (lsevans)

----------------------------------------------------------------------

Message: 1
Date: Tue, 19 Jan 2016 00:39:54 +0800
From: "cmeng.gm" <cmeng.gm@gmail.com>
To: <dev@jitsi.org>
Subject: [jitsi-dev] Jicofo Ping Time Out
Message-ID: <004301d1520e$dd6f6560$984e3020$@gmail.com>
Content-Type: text/plain; charset="utf-8"

Hi,

I believe it is the same problem experienced by jitsi-videobridge earlier.

On a Ubuntu machine, try to copy the following java class i.e.
jicoco-1.0-20160109.203023-16.jar
from jitsi-videobridge installed directory /usr/share/jitsi-videobridge/lib

to jicofo installed directory /usr/share/jicofo/lib

and restart jicofo.

Regards,

CM Eng

-------------------------------------------------------

Message: 1

Date: Sun, 17 Jan 2016 12:35:35 +0100

From: Stefan Fuhrmann <stefan@fuhrmann.homedns.org>

To: Jitsi Developers <dev@jitsi.org>

Subject: Re: [jitsi-dev] handleIQError jitsi-videobridge ejabberd ping

                timeout

Message-ID: <1750926.Iuk0iLj3Rz@stefan-ubu>

Content-Type: text/plain; charset="us-ascii"

Hello all,

after last update videobridge its running now.

But jicofo not:

org.jitsi.jicofo.ComponentsDiscovery.discoverServices().264 Feature list changed for: jitsi-videobridge.doamin.tld

2016-01-17 12:30:49.545 SCHWERWIEGEND: [33]

org.jitsi.xmpp.component.ComponentBase.run().415 Ping timeout for ID:
6F03r-15

2016-01-17 12:30:50.026 SCHWERWIEGEND: [33]

org.jitsi.xmpp.component.ComponentBase.run().415 Ping timeout for ID:
6F03r-16

2016-01-17 12:30:54.551 INFORMATION: [58]

org.jitsi.jicofo.xmpp.FocusComponent.handleIQError() (serving component 'Jitsi Meet Focus') IQ stanza of type <tt>error</tt> received:

Can someone help?

tia

Stefan

Am Thursday 14 January 2016, 23:34:52 schrieb Stefan Fuhrmann:

Hello all,

Im trying a new setup with ejabberd, jitsi-videobridge and jicofo.,

Jitsi-meet should run on another machine.

ubuntu server 14.04

java version "1.8.0_66"

Java(TM) SE Runtime Environment (build 1.8.0_66-b17)

followed instructions:

https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd

and getting this in jvb.log when starrting the bridge:

Jan 14, 2016 8:41:24 PM org.jitsi.util.Logger info

INFORMATION: RECV: <iq from="domain.tld" to="jitsi-videobridge.domain.tld"

type="error" id="QiBAF-32"><ping xmlns="urn:xmpp:ping"/><error code="501"

type="cancel"><feature-not-implemented

xmlns="urn:ietf:params:xml:ns:xmpp-

stanzas"/></error></iq>

Jan 14, 2016 8:41:29 PM net.java.sip.communicator.util.Logger error

SCHWERWIEGEND: Ping timeout for ID: QiBAF-32 Jan 14, 2016 8:41:34 PM

org.xmpp.component.AbstractComponent handleIQError

INFORMATION: (serving component 'JitsiVideobridge') IQ stanza of type

<tt>error</tt> received:

ejabberd log shows okay:

[debug] <0.795.0>@ejabberd_receiver:process_data:349 Received XML on

stream = <<"<iq id=\"mh20R-4\" to=\"jitsi-videobridge.domain.tld\"

from=\"jitsi- videobridge.jitsi-videobridge.domain.tld\"

type=\"get\"><ping xmlns= \"urn:xmpp:ping\"></ping></iq>">>

I tried alot around and did searching on the web but can not solve it.

Im having another test machine with prosody. There is no such error.

How can I solve it?

Can someone help?

tia

Stefan

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jitsi.org/pipermail/dev/attachments/20160119/23484354/attachment-0001.html>

------------------------------

Message: 2
Date: Mon, 18 Jan 2016 17:28:54 +0000
From: Devin Wilson <devin.wilson@readytalk.com>
To: "dev@jitsi.org" <dev@jitsi.org>
Subject: Re: [jitsi-dev] Low webcam resolutions selected by default on
  Google Chrome and Firefox
Message-ID:
  <A5ADD11A3CAA544C9A1AA196B7D25588652BC5DF@WYNENT02.readytalk.com>
Content-Type: text/plain; charset="utf-8"

That is the default behavior if you haven’t set config.resolution. See the code in RTCUtils<https://github.com/jitsi/jitsi-meet/blob/75a822be6622342cd96c156a4395682aeb03efe0/modules/RTC/RTCUtils.js#L415>. It will try to get whatever resolution you set (defaults to 640x360) and if that fails, it will continue down the list of resolutions<https://github.com/jitsi/jitsi-meet/blob/75a822be6622342cd96c156a4395682aeb03efe0/service/RTC/Resolutions.js>.

Devin

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Laszlo KERTESZ
Sent: Monday, January 18, 2016 9:20 AM
To: dev@jitsi.org
Subject: [jitsi-dev] Low webcam resolutions selected by default on Google Chrome and Firefox

It seems that on Jitsi Meet Google Chrome always selects 640x360 resolution for desktop webcams even if they support higher resolutions. I tried this with webcams supporting 1280x720, 1920x1080, 1024x768 resolutions. Google Chrome always selected 640x360.

In Firefox 43 with default settings the resolution was 640x480, although i could force other supported resolutions through setting explicit width and height in the (about:config) settings "media.navigator.video.default_width" and "media.navigator.video.default_height".

OS: Debian Stable and Testing, Google Chrome 47.0.2526.111, Firefox 43.04

This email message is for the sole use of the intended recipient(s) and may contain information that is privileged, confidential, and exempt from disclosure under applicable law. Any unauthorized review, use, copying, disclosure or dissemination is prohibited. If you are not the intended recipient, please contact the sender by reply email and destroy all copies of the original message.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jitsi.org/pipermail/dev/attachments/20160118/8058bce7/attachment-0001.html>

------------------------------

Message: 3
Date: Mon, 18 Jan 2016 14:56:40 -0800
From: lsevans <notifications@github.com>
To: jitsi/jitsi-videobridge <jitsi-videobridge@noreply.github.com>
Subject: Re: [jitsi-dev] [jitsi-videobridge] Split last n (#122)
Message-ID: <jitsi/jitsi-videobridge/pull/122/r50053222@github.com>
Content-Type: text/plain; charset="utf-8"

                 {
- this.weakPinnedEndpoint
- = new WeakReference<>(newPinnedEndpoint);
+ if (!pinnedEndpoints.get(i).

I could be misunderstanding, but can pinnedEndpoints.get(i) be null?

In our case, if you pin a stream then unpin the same stream (back to 0 pinnedEndpoints) this method will get called with a singleton list of [null].

It then seems like the resulting NPE here gets swallowed by someone and a Pinned Endpoint property event never fires.

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/122/files#r50053222
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jitsi.org/pipermail/dev/attachments/20160118/63f9a677/attachment.html>

------------------------------

Subject: Digest Footer

_______________________________________________
dev mailing list
dev@jitsi.org
http://lists.jitsi.org/mailman/listinfo/dev

------------------------------

End of dev Digest, Vol 34, Issue 47
***********************************

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus


#2

Ahoi all,

it seems some of the last updates fixed all my issues.

Thanks for your help!

I was looking for a roadmap for all of the jitsi projects. Is there a plan for
stable releases?

tia
Stefan

···

Am Wednesday 20 January 2016, 09:16:17 schrieb cmeng.gm:

Hi,

What is debug log message from ejabberd when it receives <ping /> request
from jicofo? Also please ensure /etc/ejabberd/ejabberd.yml settings teddy
with the settings in /etc/jitsi/jicofo/config:

---------
e.g. /etc/ejabberd/ejabberd.yml
  ### jitsi conference service
  -
    port: 5347
    module: ejabberd_service
    access: all
    shaper_rule: fast
    hosts:
      "focus. domain.tld ":
        password: "#1234567!"

--------------
e.g. /etc/jitsi/jicofo/config
# Jitsi Conference Focus settings
# sets the host name of the XMPP server
JICOFO_HOST=localhost

# sets the XMPP domain (default: none)
JICOFO_HOSTNAME domain.tld

# sets the secret used to authenticate as an XMPP component
JICOFO_SECRET=#1234567!

# sets the port to use for the XMPP component connection
JICOFO_PORT=5347

# sets the XMPP domain name to use for XMPP user logins
JICOFO_AUTH_DOMAIN= domain.tld

# sets the username to use for XMPP user logins
JICOFO_AUTH_USER=focus
.....

------------

-----Original Message-----
From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of dev-request@jitsi.org
Sent: Tuesday, January 19, 2016 6:58 AM
To: dev@jitsi.org
Subject: dev Digest, Vol 34, Issue 47

Send dev mailing list submissions to
  dev@jitsi.org

To subscribe or unsubscribe via the World Wide Web, visit
  http://lists.jitsi.org/mailman/listinfo/dev
or, via email, send a message with subject or body 'help' to
  dev-request@jitsi.org

You can reach the person managing the list at
  dev-owner@jitsi.org

When replying, please edit your Subject line so it is more specific than
"Re: Contents of dev digest..."

Today's Topics:

   1. Jicofo Ping Time Out (cmeng.gm)
   2. Re: Low webcam resolutions selected by default on Google
      Chrome and Firefox (Devin Wilson)
   3. Re: [jitsi-videobridge] Split last n (#122) (lsevans)

----------------------------------------------------------------------

Message: 1
Date: Tue, 19 Jan 2016 00:39:54 +0800
From: "cmeng.gm" <cmeng.gm@gmail.com>
To: <dev@jitsi.org>
Subject: [jitsi-dev] Jicofo Ping Time Out
Message-ID: <004301d1520e$dd6f6560$984e3020$@gmail.com>
Content-Type: text/plain; charset="utf-8"

Hi,

I believe it is the same problem experienced by jitsi-videobridge earlier.

On a Ubuntu machine, try to copy the following java class i.e.
jicoco-1.0-20160109.203023-16.jar
from jitsi-videobridge installed directory /usr/share/jitsi-videobridge/lib

to jicofo installed directory /usr/share/jicofo/lib

and restart jicofo.

Regards,

CM Eng

-------------------------------------------------------

Message: 1

Date: Sun, 17 Jan 2016 12:35:35 +0100

From: Stefan Fuhrmann <stefan@fuhrmann.homedns.org>

To: Jitsi Developers <dev@jitsi.org>

Subject: Re: [jitsi-dev] handleIQError jitsi-videobridge ejabberd ping

                timeout

Message-ID: <1750926.Iuk0iLj3Rz@stefan-ubu>

Content-Type: text/plain; charset="us-ascii"

Hello all,

after last update videobridge its running now.

But jicofo not:

org.jitsi.jicofo.ComponentsDiscovery.discoverServices().264 Feature list
changed for: jitsi-videobridge.doamin.tld

2016-01-17 12:30:49.545 SCHWERWIEGEND: [33]

org.jitsi.xmpp.component.ComponentBase.run().415 Ping timeout for ID:
6F03r-15

2016-01-17 12:30:50.026 SCHWERWIEGEND: [33]

org.jitsi.xmpp.component.ComponentBase.run().415 Ping timeout for ID:
6F03r-16

2016-01-17 12:30:54.551 INFORMATION: [58]

org.jitsi.jicofo.xmpp.FocusComponent.handleIQError() (serving component
'Jitsi Meet Focus') IQ stanza of type <tt>error</tt> received:

Can someone help?

tia

Stefan

Am Thursday 14 January 2016, 23:34:52 schrieb Stefan Fuhrmann:
> Hello all,
>
>
>
> Im trying a new setup with ejabberd, jitsi-videobridge and jicofo.,
>
> Jitsi-meet should run on another machine.
>
> ubuntu server 14.04
>
> java version "1.8.0_66"
>
> Java(TM) SE Runtime Environment (build 1.8.0_66-b17)
>
>
>
> followed instructions:
>
> https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd
>
>
>
> and getting this in jvb.log when starrting the bridge:
>
>
>
> Jan 14, 2016 8:41:24 PM org.jitsi.util.Logger info
>
> INFORMATION: RECV: <iq from="domain.tld" to="jitsi-videobridge.domain.tld"
>
> type="error" id="QiBAF-32"><ping xmlns="urn:xmpp:ping"/><error code="501"
>
> type="cancel"><feature-not-implemented
>
> xmlns="urn:ietf:params:xml:ns:xmpp-
>
> stanzas"/></error></iq>
>
> Jan 14, 2016 8:41:29 PM net.java.sip.communicator.util.Logger error
>
> SCHWERWIEGEND: Ping timeout for ID: QiBAF-32 Jan 14, 2016 8:41:34 PM
>
> org.xmpp.component.AbstractComponent handleIQError
>
> INFORMATION: (serving component 'JitsiVideobridge') IQ stanza of type
>
> <tt>error</tt> received:
>
>
>
> ejabberd log shows okay:
>
> [debug] <0.795.0>@ejabberd_receiver:process_data:349 Received XML on
>
> stream = <<"<iq id=\"mh20R-4\" to=\"jitsi-videobridge.domain.tld\"
>
> from=\"jitsi- videobridge.jitsi-videobridge.domain.tld\"
>
> type=\"get\"><ping xmlns= \"urn:xmpp:ping\"></ping></iq>">>
>
>
>
>
>
> I tried alot around and did searching on the web but can not solve it.
>
>
>
> Im having another test machine with prosody. There is no such error.
>
>
>
> How can I solve it?
>
> Can someone help?
>
>
>
> tia
>
> Stefan

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus
-------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://lists.jitsi.org/pipermail/dev/attachments/20160119/23484354/attachm
ent-0001.html>

------------------------------

Message: 2
Date: Mon, 18 Jan 2016 17:28:54 +0000
From: Devin Wilson <devin.wilson@readytalk.com>
To: "dev@jitsi.org" <dev@jitsi.org>
Subject: Re: [jitsi-dev] Low webcam resolutions selected by default on
  Google Chrome and Firefox
Message-ID:
  <A5ADD11A3CAA544C9A1AA196B7D25588652BC5DF@WYNENT02.readytalk.com>
Content-Type: text/plain; charset="utf-8"

That is the default behavior if you haven’t set config.resolution. See the
code in
RTCUtils<https://github.com/jitsi/jitsi-meet/blob/75a822be6622342cd96c156a4
395682aeb03efe0/modules/RTC/RTCUtils.js#L415>. It will try to get whatever
resolution you set (defaults to 640x360) and if that fails, it will
continue down the list of
resolutions<https://github.com/jitsi/jitsi-meet/blob/75a822be6622342cd96c15
6a4395682aeb03efe0/service/RTC/Resolutions.js>.

Devin

From: dev [mailto:dev-bounces@jitsi.org] On Behalf Of Laszlo KERTESZ
Sent: Monday, January 18, 2016 9:20 AM
To: dev@jitsi.org
Subject: [jitsi-dev] Low webcam resolutions selected by default on Google
Chrome and Firefox

It seems that on Jitsi Meet Google Chrome always selects 640x360 resolution
for desktop webcams even if they support higher resolutions. I tried this
with webcams supporting 1280x720, 1920x1080, 1024x768 resolutions. Google
Chrome always selected 640x360.

In Firefox 43 with default settings the resolution was 640x480, although i
could force other supported resolutions through setting explicit width and
height in the (about:config) settings "media.navigator.video.default_width"
and "media.navigator.video.default_height".

OS: Debian Stable and Testing, Google Chrome 47.0.2526.111, Firefox 43.04

This email message is for the sole use of the intended recipient(s) and may
contain information that is privileged, confidential, and exempt from
disclosure under applicable law. Any unauthorized review, use, copying,
disclosure or dissemination is prohibited. If you are not the intended
recipient, please contact the sender by reply email and destroy all copies
of the original message. -------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://lists.jitsi.org/pipermail/dev/attachments/20160118/8058bce7/attachm
ent-0001.html>

------------------------------

Message: 3
Date: Mon, 18 Jan 2016 14:56:40 -0800
From: lsevans <notifications@github.com>
To: jitsi/jitsi-videobridge <jitsi-videobridge@noreply.github.com>
Subject: Re: [jitsi-dev] [jitsi-videobridge] Split last n (#122)
Message-ID: <jitsi/jitsi-videobridge/pull/122/r50053222@github.com>
Content-Type: text/plain; charset="utf-8"

> {
>
> - this.weakPinnedEndpoint
> - = new WeakReference<>(newPinnedEndpoint);
> + if (!pinnedEndpoints.get(i).

I could be misunderstanding, but can pinnedEndpoints.get(i) be null?

In our case, if you pin a stream then unpin the same stream (back to 0
pinnedEndpoints) this method will get called with a singleton list of
[null].

It then seems like the resulting NPE here gets swallowed by someone and a
Pinned Endpoint property event never fires.

---
Reply to this email directly or view it on GitHub:
https://github.com/jitsi/jitsi-videobridge/pull/122/files#r50053222
-------------- next part --------------
An HTML attachment was scrubbed...
URL:
<http://lists.jitsi.org/pipermail/dev/attachments/20160118/63f9a677/attachm
ent.html>

------------------------------

Subject: Digest Footer

_______________________________________________
dev mailing list
dev@jitsi.org
http://lists.jitsi.org/mailman/listinfo/dev

------------------------------

End of dev Digest, Vol 34, Issue 47
***********************************

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev